Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Desktop (http://www.linux-archive.org/gentoo-desktop/)
-   -   kdnssd-avahi fails to compile. (http://www.linux-archive.org/gentoo-desktop/334373-kdnssd-avahi-fails-compile.html)

"John H. Moe" 03-02-2010 06:06 AM

kdnssd-avahi fails to compile.
 
Dale wrote:

<nothing> <not a durn thing>

Dale, your mail client is acting up again...

John Moe

Dale 03-02-2010 05:03 PM

kdnssd-avahi fails to compile.
 
chrome://messenger/locale/messengercompose/composeMsgs.properties:

Dale wrote:

<nothing> <not a durn thing>

Dale, your mail client is acting up again...

John Moe





Yup, it is. I can reply to a reply tho. Let me try this again.

I read the other day that qt3 is being put to rest. Well, qt3 is not as
dead as the devs want it to be. They buried it in one of those really
old coffins with the bell and string attached. It sounds like qt3 is
ringing that bell like crazy. Anyway, this is the error I get.


>>> Emerging (6 of 37) kde-misc/kdnssd-avahi-0.1.2-r1 from kde-sunset
* kdnssd-avahi_0.1.2.orig.tar.gz RMD160 SHA1 SHA256 size ;-)
... [ ok ]
* kde-admindir-3.5.5.tar.bz2 RMD160 SHA1 SHA256 size ;-)
... [ ok ]
* checking ebuild checksums ;-)
...
[ ok ]
* checking auxfile checksums ;-)
...
[ ok ]
* checking miscfile checksums ;-)
...
[ ok ]

* CPV: kde-misc/kdnssd-avahi-0.1.2-r1
* REPO: kde-sunset
* USE: elibc_glibc kernel_linux userland_GNU x86
* To compile kdnssd-avahi package you need Avahi with DBus and Qt 3.x
support.

* but net-dns/avahi is not built with qt3 and/or dbus USE flags enabled.
* ERROR: kde-misc/kdnssd-avahi-0.1.2-r1 failed:
* Please, rebuild net-dns/avahi with the "qt3" and "dbus" USE flags.
*
* Call stack:
* ebuild.sh, line 48: Called pkg_setup
* kdnssd-avahi-0.1.2-r1.ebuild, line 26: Called die
* The specific snippet of code:
* die "Please, rebuild net-dns/avahi with the "qt3" and
"dbus" USE flags."

*
* If you need support, post the output of 'emerge --info
=kde-misc/kdnssd-avahi-0.1.2-r1',
* the complete build log and the output of 'emerge -pqv
=kde-misc/kdnssd-avahi-0.1.2-r1'.

* This ebuild used the following eclasses from overlays:
* /usr/local/portage/layman/kde-sunset/eclass/kde.eclass
* /usr/local/portage/layman/kde-sunset/eclass/kde-functions.eclass
* This ebuild is from an overlay named 'kde-sunset':
'/usr/local/portage/layman/kde-sunset/'
* The complete build log is located at
'/var/log/portage/elog/kde-misc:kdnssd-avahi-0.1.2-r1:20100302-063035.log'.
* The ebuild environment file is located at
'/var/tmp/portage/kde-misc/kdnssd-avahi-0.1.2-r1/temp/die.env'.
* S:
'/var/tmp/portage/kde-misc/kdnssd-avahi-0.1.2-r1/work/kdnssd-avahi-0.1.2'


>>> Failed to emerge kde-misc/kdnssd-avahi-0.1.2-r1, Log file:

>>>
'/var/log/portage/elog/kde-misc:kdnssd-avahi-0.1.2-r1:20100302-063035.log'


* GNU info directory index is up-to-date.

* IMPORTANT: 1 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


!!! existing preserved libs:
>>> package: net-dns/avahi-0.6.24-r2
* - /usr/lib/libavahi-qt3.so
* - /usr/lib/libavahi-qt3.so.1
* - /usr/lib/libavahi-qt3.so.1.0.2
* used by /usr/kde/3.5/bin/atlantik (kde-base/atlantik-3.5.10)
* used by /usr/kde/3.5/bin/atlantikdesigner
(kde-base/atlantikdesigner-3.5.10)

* used by /usr/kde/3.5/bin/katomic (kde-base/katomic-3.5.10)
* used by 36 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
root@smoker ~ #


So, I thought I would post this here to see if this would help someone
fix it. I'm finally getting KDE 4 to work so I'm not to worried but I
know others still use KDE 3.


Looks like kde-sunset is about to grow.

Dale

:-) :-)

P. S. I'm hoping Seamonkey 2 will fix their email client soon. This
blank mail thing is getting on my nerves.

Paul Hartman 03-02-2010 06:21 PM

kdnssd-avahi fails to compile.
 
On Tue, Mar 2, 2010 at 12:03 PM, Dale <rdalek1967@gmail.com> wrote:
> I read the other day that qt3 is being put to rest. Well, qt3 is not as
> dead as the devs want it to be. They buried it in one of those really old
> coffins with the bell and string attached. It sounds like qt3 is ringing
> that bell like crazy. Anyway, this is the error I get.
>
>>>> Emerging (6 of 37) kde-misc/kdnssd-avahi-0.1.2-r1 from kde-sunset

Of course if you're using deprecated KDE3 stuff it's going to need
deprecated Qt3 stuff as well, since KDE3 is built atop Qt3. Rid
yourself of KDE3 and Qt3 will almost certainly follow it on the way
out. :)

Dale 03-02-2010 06:33 PM

kdnssd-avahi fails to compile.
 
chrome://messenger/locale/messengercompose/composeMsgs.properties:

On Tue, Mar 2, 2010 at 12:03 PM, Dale<rdalek1967@gmail.com> wrote:


I read the other day that qt3 is being put to rest. Well, qt3 is not as
dead as the devs want it to be. They buried it in one of those really old
coffins with the bell and string attached. It sounds like qt3 is ringing
that bell like crazy. Anyway, this is the error I get.



Emerging (6 of 37) kde-misc/kdnssd-avahi-0.1.2-r1 from kde-sunset


Of course if you're using deprecated KDE3 stuff it's going to need
deprecated Qt3 stuff as well, since KDE3 is built atop Qt3. Rid
yourself of KDE3 and Qt3 will almost certainly follow it on the way
out. :)




Well I knew that. Thing is, the kde-sunset maintainers need to know
this is failing because of this. Also, there are quite a few still
using KDE 3. Never assume that just because you have moved on that
every one else has too. KDE 4 has just recently started working well
enough for me to start using. I had to use KDE 3 so that I would have a
working desktop. I'm still not quite ready to get rid of KDE 3 yet.


Dale

:-) :-)

Paul Hartman 03-02-2010 07:35 PM

kdnssd-avahi fails to compile.
 
On Tue, Mar 2, 2010 at 1:33 PM, Dale <rdalek1967@gmail.com> wrote:
> chrome://messenger/locale/messengercompose/composeMsgs.properties:
>>
>> On Tue, Mar 2, 2010 at 12:03 PM, Dale<rdalek1967@gmail.com> wrote:
>>
>>>
>>> I read the other day that qt3 is being put to rest. Well, qt3 is not as
>>> dead as the devs want it to be. They buried it in one of those really
>>> old
>>> coffins with the bell and string attached. It sounds like qt3 is ringing
>>> that bell like crazy. Anyway, this is the error I get.
>>>
>>>
>>>>>>
>>>>>> Emerging (6 of 37) kde-misc/kdnssd-avahi-0.1.2-r1 from kde-sunset
>>>>>>
>>
>> Of course if you're using deprecated KDE3 stuff it's going to need
>> deprecated Qt3 stuff as well, since KDE3 is built atop Qt3. Rid
>> yourself of KDE3 and Qt3 will almost certainly follow it on the way
>> out. :)
>>
>>
>
> Well I knew that. Thing is, the kde-sunset maintainers need to know this is
> failing because of this. Also, there are quite a few still using KDE 3.
> Never assume that just because you have moved on that every one else has
> too. KDE 4 has just recently started working well enough for me to start
> using. I had to use KDE 3 so that I would have a working desktop. I'm
> still not quite ready to get rid of KDE 3 yet.

Sorry, I didn't fully comprehend what you were asking :)

It appears avahi (with requisite qt3 use flag), and Qt3 itself are all
present in the kde-sunset overlay already, and are in the unmask file.
Maybe something is set up wrong on your side. Are you using the sunset
unmask file?

Dale 03-02-2010 08:30 PM

kdnssd-avahi fails to compile.
 
chrome://messenger/locale/messengercompose/composeMsgs.properties:

On Tue, Mar 2, 2010 at 1:33 PM, Dale<rdalek1967@gmail.com> wrote:


chrome://messenger/locale/messengercompose/composeMsgs.properties:


On Tue, Mar 2, 2010 at 12:03 PM, Dale<rdalek1967@gmail.com> wrote:



I read the other day that qt3 is being put to rest. Well, qt3 is not as
dead as the devs want it to be. They buried it in one of those really
old
coffins with the bell and string attached. It sounds like qt3 is ringing
that bell like crazy. Anyway, this is the error I get.




Emerging (6 of 37) kde-misc/kdnssd-avahi-0.1.2-r1 from kde-sunset



Of course if you're using deprecated KDE3 stuff it's going to need
deprecated Qt3 stuff as well, since KDE3 is built atop Qt3. Rid
yourself of KDE3 and Qt3 will almost certainly follow it on the way
out. :)




Well I knew that. Thing is, the kde-sunset maintainers need to know this is
failing because of this. Also, there are quite a few still using KDE 3.
Never assume that just because you have moved on that every one else has
too. KDE 4 has just recently started working well enough for me to start
using. I had to use KDE 3 so that I would have a working desktop. I'm
still not quite ready to get rid of KDE 3 yet.


Sorry, I didn't fully comprehend what you were asking :)

It appears avahi (with requisite qt3 use flag), and Qt3 itself are all
present in the kde-sunset overlay already, and are in the unmask file.
Maybe something is set up wrong on your side. Are you using the sunset
unmask file?





Actually this occurs when doing a preserved-rebuild. It *should* be
rebuilding packages already installed.


I did run autounmask -n kde-base/kde-meta-3.5.10 just to make sure
everything was covered but nothing was changed. As far as I know, the
only thing that has changed is qt3 being removed from portage. I was
thinking maybe qt3 hadn't been moved to the overlay but if it has been
moved, I have no idea why it is failing.


If KDE 4 lasts another week tho, I may be getting rid of KDE 3. I
mostly posted so that the kde-sunset folks would know about the error.
If it was something that could be fixed and needs attention, then they
could work on it.


Me clueless.

Dale

:-) :-)

Paul Hartman 03-02-2010 08:50 PM

kdnssd-avahi fails to compile.
 
On Tue, Mar 2, 2010 at 3:30 PM, Dale <rdalek1967@gmail.com> wrote:
> chrome://messenger/locale/messengercompose/composeMsgs.properties:
>>
>> On Tue, Mar 2, 2010 at 1:33 PM, Dale<rdalek1967@gmail.com> wrote:
>>
>>>
>>> chrome://messenger/locale/messengercompose/composeMsgs.properties:
>>>
>>>>
>>>> On Tue, Mar 2, 2010 at 12:03 PM, Dale<rdalek1967@gmail.com> wrote:
>>>>
>>>>
>>>>>
>>>>> I read the other day that qt3 is being put to rest. Well, qt3 is not
>>>>> as
>>>>> dead as the devs want it to be. They buried it in one of those really
>>>>> old
>>>>> coffins with the bell and string attached. It sounds like qt3 is
>>>>> ringing
>>>>> that bell like crazy. Anyway, this is the error I get.
>>>>>
>>>>>
>>>>>
>>>>>>>>
>>>>>>>> Emerging (6 of 37) kde-misc/kdnssd-avahi-0.1.2-r1 from kde-sunset
>>>>>>>>
>>>>>>>>
>>>>
>>>> Of course if you're using deprecated KDE3 stuff it's going to need
>>>> deprecated Qt3 stuff as well, since KDE3 is built atop Qt3. Rid
>>>> yourself of KDE3 and Qt3 will almost certainly follow it on the way
>>>> out. :)
>>>>
>>>>
>>>>
>>>
>>> Well I knew that. Thing is, the kde-sunset maintainers need to know this
>>> is
>>> failing because of this. Also, there are quite a few still using KDE 3.
>>> Never assume that just because you have moved on that every one else has
>>> too. KDE 4 has just recently started working well enough for me to start
>>> using. I had to use KDE 3 so that I would have a working desktop. I'm
>>> still not quite ready to get rid of KDE 3 yet.
>>>
>>
>> Sorry, I didn't fully comprehend what you were asking :)
>>
>> It appears avahi (with requisite qt3 use flag), and Qt3 itself are all
>> present in the kde-sunset overlay already, and are in the unmask file.
>> Maybe something is set up wrong on your side. Are you using the sunset
>> unmask file?
>>
>>
>>
>
> Actually this occurs when doing a preserved-rebuild. It *should* be
> rebuilding packages already installed.
>
> I did run autounmask -n kde-base/kde-meta-3.5.10 just to make sure
> everything was covered but nothing was changed. As far as I know, the only
> thing that has changed is qt3 being removed from portage. I was thinking
> maybe qt3 hadn't been moved to the overlay but if it has been moved, I have
> no idea why it is failing.
>
> If KDE 4 lasts another week tho, I may be getting rid of KDE 3. I mostly
> posted so that the kde-sunset folks would know about the error. If it was
> something that could be fixed and needs attention, then they could work on
> it.
>
> Me clueless.

Do you have qt3 and dbus USE flags enabled on avahi like it tells you to do?

Dale 03-02-2010 09:25 PM

kdnssd-avahi fails to compile.
 
chrome://messenger/locale/messengercompose/composeMsgs.properties:

Do you have qt3 and dbus USE flags enabled on avahi like it tells you to do?




I still have qt3, qt3support in make.conf. I also checked the files in
package.use and nothing there is disabling it. I would assume that
make.conf should override other settings.


Thoughts?

Dale

:-) :-)

Paul Hartman 03-02-2010 10:03 PM

kdnssd-avahi fails to compile.
 
On Tue, Mar 2, 2010 at 4:25 PM, Dale <rdalek1967@gmail.com> wrote:
> chrome://messenger/locale/messengercompose/composeMsgs.properties:
>>
>> Do you have qt3 and dbus USE flags enabled on avahi like it tells you to
>> do?
>>
>>
>
> I still have qt3, qt3support in make.conf. I also checked the files in
> package.use and nothing there is disabling it. I would assume that
> make.conf should override other settings.
>
> Thoughts?

If you do "emerge -vp avahi" what does it show you? Maybe it's not
using the overlay version of avahi or something.

Dale 03-02-2010 10:11 PM

kdnssd-avahi fails to compile.
 
chrome://messenger/locale/messengercompose/composeMsgs.properties:

emerge -vp avahi


root@smoker ~ # emerge -vp avahi

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] net-dns/avahi-0.6.24-r2 USE="dbus gdbm gtk ipv6
mdnsresponder-compat python qt4 -autoipd -bookmarks -doc -howl-compat
-mono (-qt3) -test" 0 kB [1]


Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage/layman/kde-sunset

* IMPORTANT: 1 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

root@smoker ~ #


I can't help but notice that qt3 is disabled on that. It is turned on
in make.conf so something somewhere is disabling the USE flag. My USE
line from make.conf:


USE="-a52 acl acpi alsa -arts automount avahi -bluetooth -branding bzip2
cddb cdr chroot clucene -crypt curl dbus -doc -dts dvd dvdr -eds esd
exif fdftk -fftw -firefox -gcj gif gimp gkrellm -gnome gnutls gphoto2
gtk hal hbci ipv6 -jabber -jingle java javascript jbig jpeg jpeg2k
justify kde kdeprefix libwww logrotate loop-aes mmx mng mplayer mp3
mdnsresponder-compat -musepack mysql -nls nsplugin ofx offensive opengl
-oss -otr parport pdf ppds ppp qt3 qt3support qt4 sasl seamonkey -sqlite
-sqlite3 sse syslog tcl -theora tiff tk truetype usb -v4l webkit
win32codecs wma wmf X xml yahoo -xulrunner zeroconf 3dnow "



Is make.conf not the last word on things anymore?

Dale

:-) :-)


All times are GMT. The time now is 12:52 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.