FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Desktop

 
 
LinkBack Thread Tools
 
Old 01-21-2009, 04:18 AM
Paul Hartman
 
Default pykde4-4.1.96 won't compile

Hi,

When trying to emerge @kde-4.2 from the kde-testing overlay I ran into
a problem with kde-base/pykde4-4.1.96

>>> Compiling source in /dev/shm/portage/kde-base/pykde4-4.1.96/work/pykde4-4.1.96 ...
make
Scanning dependencies of target compile_python_files


[ 0%] Built target compile_python_files
[ 1%] Generating sip/akonadi/sipakonadipart0.cpp,
sip/akonadi/sipakonadipart1.cpp, sip/akonadi/sipakonadipart2.cpp,
sip/akonadi/sipakonadipart3.cpp, sip/akonadi/sipakonadipart4.cpp,
sip/akonadi/sipakonadipart5.cpp, sip/akonadi/sipakonadipart6.cpp,
sip/akonadi/sipakonadipart7.cpp

sip: Unable to find file "QtGui/QtGuimod.sip"
make[2]: *** [python/pykde4/sip/akonadi/sipakonadipart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all]
Error 2
make: *** [all] Error 2
*
* ERROR: kde-base/pykde4-4.1.96 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 4003: Called kde4-meta_src_compile
* environment, line 2958: Called kde4-base_src_make
* environment, line 2721: Called cmake-utils_src_make
* environment, line 1087: Called die
* The specific snippet of code:
* emake "$@" || die "Make failed!";
* The die message:
* Make failed!
*
* If you need support, post the topmost build error, and the call
stack if relevant.
* A complete build log is located at
'/dev/shm/portage/kde-base/pykde4-4.1.96/temp/build.log'.
* The ebuild environment file is located at
'/dev/shm/portage/kde-base/pykde4-4.1.96/temp/environment'.
* This ebuild is from an overlay named 'kde':
'/usr/local/portage/layman/kde-testing/'
*

I tried some googling but found nothing so far. Anybody know where the
QtGui/QtGuimod.sip file is supposed to come from? Is there a missing
dependency or just something broken on my system?

Thanks,
Paul
 

Thread Tools




All times are GMT. The time now is 01:18 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org