FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Desktop

 
 
LinkBack Thread Tools
 
Old 06-19-2008, 05:28 PM
Lindsay Haisley
 
Default Drag and drop failure

I did (am still in the process of) a substantial upgrade of my desktop
and the apps I use, and somewhere along the way I've lost drag-and-drop
capability in at least a couple of applications, although it still works
on the gnome desktop itself (nautilus, I presume). In particular, in
evolution, I can't drag emails to folders, nor can I drag columns to the
header bar in the index listings using the "Add a Column" dialog. In
firefox (2.0.0.14) I can't drag items to a toolbar from the "Customize
Toolbar" dialog. In all cases, I get the movable ul_angle with the "+"
or arrow in it, and when I move it to the target area on the app, I get
no response from the app. When I release the mouse the cursor/icon
moves back to its original location. This is a royal PITA since I need
to change column headers on a number of indexes in evolution and there's
no way other than dragon drop to do this. Same with setting up toolbars
in firefox!

Any genuine insight or guidance will be appreciated. I'm willing to try
just about anything to keep everything working properly.

--
Lindsay Haisley | "In an open world, | PGP public key
FMP Computer Services | who needs Windows | available at
512-259-1190 | or Gates" | http://pubkeys.fmp.com
http://www.fmp.com | |

--
gentoo-desktop@lists.gentoo.org mailing list
 
Old 06-20-2008, 04:41 AM
Duncan
 
Default Drag and drop failure

Lindsay Haisley <fmouse-gentoo@fmp.com> posted
1213896506.20666.16.camel@vishnu.fmp.com, excerpted below, on Thu, 19 Jun
2008 12:28:26 -0500:

> In all cases, I get the movable ul_angle with the "+" or arrow in it,
> and when I move it to the target area on the app, I get no response from
> the app. When I release the mouse the cursor/icon moves back to its
> original location. This is a royal PITA since I need to change column
> headers on a number of indexes in evolution and there's no way other
> than dragon drop to do this. Same with setting up toolbars in firefox!
>
> Any genuine insight or guidance will be appreciated. I'm willing to try
> just about anything to keep everything working properly.

YMMV on this as I'm a KDE power user and as a result, dislike GNOME's
crippled options with a passion, but I'd suggest checking dbus. It
sounds like the dbus messages aren't getting thru telling the app over
which the mouse is hovering that it's there.

First, assure dbus is running. It may be as simple as it's now failing
to start for some reason. Hopefully it does start manually, at least.
Note that you can start it as a system service if necessary. If you
didn't have it started as a system service already, it may be that the
auto-start is screwed up, but starting it as a system service will still
work.

If it won't start, or it's going, maybe certain apps haven't been rebuilt
after a change somewhere. Try running revdep-rebuild and see if that
helps.

May or may not help, as I said I'm not a GNOME user. It's worth
checking, however, and I do hope it helps.

--
Duncan - List replies preferred. No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master." Richard Stallman

--
gentoo-desktop@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 04:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org