Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Catalyst (http://www.linux-archive.org/gentoo-catalyst/)
-   -   sys-kernel/linux-headers-2.6.33 is blocking net-firewall/iptables-1.4.6 (http://www.linux-archive.org/gentoo-catalyst/529798-sys-kernel-linux-headers-2-6-33-blocking-net-firewall-iptables-1-4-6-a.html)

Daniel van Ham Colchete 05-23-2011 10:19 PM

sys-kernel/linux-headers-2.6.33 is blocking net-firewall/iptables-1.4.6
 
Hey yall,

I have been using Catalyst sucessfully for the past 3+ years managing a Gentoo cluster (about 40 servers). What I do is to build stage1, stage2, stage3 and stage4 based on the same snapshot and them I would create stage4-n as a stage4 based on the prior stage4 generated, but using a newer stage4 this time. My last stage was based on snapshot 20101019 and now I'm upgrading to 20110522. But when doing the system upgrade the catalyst fails with the following message:



Bringing system up to date using profile specific use flags
emerge --quiet --usepkg --buildpkg --newuse -u system

(...)

[ebuild* N*** ] sys-apps/openrc-0.8.2-r1
[ebuild**** U ] sys-apps/util-linux-2.19.1 [2.17.2]


[ebuild**** U ] net-misc/iputils-20100418-r1 [20100418]
[blocks B**** ] >=sys-kernel/linux-headers-2.6.33 (">=sys-kernel/linux-headers-2.6.33" is blocking net-firewall/iptables-1.4.6)

** Error: The above package list contains packages which cannot be


** installed at the same time on the same system.

* ('installed', '/', 'net-firewall/iptables-1.4.6', 'nomerge') pulled in by
*** net-firewall/iptables required by world

* ('ebuild', '/', 'sys-kernel/linux-headers-2.6.36.1', 'merge') pulled in by


*** sys-kernel/linux-headers:0 required by ('ebuild', '/', 'virtual/os-headers-0', 'merge')

I tried putting net-firewall/iptables as ~x86 on a package.keywords file referenced by the portage_confdir config but it didn't considered it. The right package.keyword is right that at /var/tmp/catalyst/tmp/supra10.10/stage4-core2-10.10-02/etc/portage/package.keywords. In a real world system this led to another blocking, so the solution to the blocking problem for catalyst upgrades in general would be better.



Does anyone have any idea to help?

Best,
Daniel

Peter Volkov 05-24-2011 05:53 AM

sys-kernel/linux-headers-2.6.33 is blocking net-firewall/iptables-1.4.6
 
Hi Daniel,

В Пнд, 23/05/2011 в 19:19 -0300, Daniel van Ham Colchete пишет:
> My last stage was based on snapshot 20101019 and now I'm upgrading to
> 20110522. But when doing the system upgrade the catalyst fails with
> the following message:
>
> Bringing system up to date using profile specific use flags
> emerge --quiet --usepkg --buildpkg --newuse -u system
>
> (...)
>
> [ebuild N ] sys-apps/openrc-0.8.2-r1
> [ebuild U ] sys-apps/util-linux-2.19.1 [2.17.2]
> [ebuild U ] net-misc/iputils-20100418-r1 [20100418]
> [blocks B ] >=sys-kernel/linux-headers-2.6.33
> (">=sys-kernel/linux-headers-2.6.33" is blocking
> net-firewall/iptables-1.4.6)

I'm not sure how to do this with catalyst, but you need to update
iptables first. 1.4.10 is stable for long time now.

--
Peter.


All times are GMT. The time now is 10:13 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.