FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Alt

 
 
LinkBack Thread Tools
 
Old 02-24-2012, 01:11 PM
Michael Weiser
 
Default prefix X11 clients hang on Mac OS X 10.6

Hi there,

does anyone else have problems with X11 clients in current prefix on Mac
OS X 10.6? For about a month all my X11 clients hang when trying to
connect to either the Snow Leopard X11.app or current XQuartz. When I
compile against the system's X11 libraries, everything works fine. So I
suspect, the X11 libs in my prefix are either too new or broken somehow.
Is that possible?

I've emerge -ateND world 'ed multiple times to eliminate
versioning/linking inconsistencies or abi incompatibility as culprits.
No change.

Even xset q hangs. top shows it hoging a CPU core at 100%. Attaching to
the process with dtruss shows an endless loop of

select(0x4, 0xBFFFE0C0, 0xBFFFE040, 0x0, 0x0) = 1 0
recvfrom(0x3, 0x801A58, 0x1000) = -1 Err#35

Any help would be greatly appreciated.
--
Thanks,
Micha
 
Old 02-24-2012, 07:28 PM
Johan Hattne
 
Default prefix X11 clients hang on Mac OS X 10.6

On 24 Feb 2012, at 06:11, Michael Weiser wrote:

> does anyone else have problems with X11 clients in current prefix on Mac
> OS X 10.6? For about a month all my X11 clients hang when trying to
> connect to either the Snow Leopard X11.app or current XQuartz. When I
> compile against the system's X11 libraries, everything works fine. So I
> suspect, the X11 libs in my prefix are either too new or broken somehow.
> Is that possible?
>
> I've emerge -ateND world 'ed multiple times to eliminate
> versioning/linking inconsistencies or abi incompatibility as culprits.
> No change.
>
> Even xset q hangs. top shows it hoging a CPU core at 100%. Attaching to
> the process with dtruss shows an endless loop of
>
> select(0x4, 0xBFFFE0C0, 0xBFFFE040, 0x0, 0x0) = 1 0
> recvfrom(0x3, 0x801A58, 0x1000) = -1 Err#35
>
> Any help would be greatly appreciated.

Hi Micha;

Reverting x11-libs/libxcb to version 1.7 makes the problem go away for me. I'll need to do some more digging around to find out what's really going wrong.

// Cheers; Johan
 
Old 02-25-2012, 05:05 PM
Michael Weiser
 
Default prefix X11 clients hang on Mac OS X 10.6

Hi there Johan,

On Fri, Feb 24, 2012 at 12:28:06PM -0800, Johan Hattne wrote:

> > Even xset q hangs. top shows it hoging a CPU core at 100%. Attaching to
> > the process with dtruss shows an endless loop of
> Reverting x11-libs/libxcb to version 1.7 makes the problem go away for
> me. I'll need to do some more digging around to find out what's
> really going wrong.

Yes, that's it. Reverting to 1.7 makes X11 clients work again. Thanks
for your help!

Is there any way in which I could help track down the source of the
problem? Open a bug report, do debug builds and create backtraces? I'd
just need a bit of a pointer, where to start.

Is this problem discussed anywhere else? My search efforts on the web
didn't yield any mention of it. I ask because the problem does not seem
prefix specific to me. So perhaps we should just take this upstream?
--
Thanks again,
Micha
 
Old 02-25-2012, 05:28 PM
Michael Weiser
 
Default prefix X11 clients hang on Mac OS X 10.6

Hello again,

On Sat, Feb 25, 2012 at 07:05:46PM +0100, Michael Weiser wrote:

> Is this problem discussed anywhere else? My search efforts on the web

I was to quick. Should have looked again with the new information in
hand. Now I find https://bugs.freedesktop.org/show_bug.cgi?id=45776.
The patch at
http://anonscm.debian.org/gitweb/?p=collab-maint/libxcb.git;a=commitdiff;h=2b5bc1d3299510e10a1733e5 a3b326232c774b75
reliably fixes the problem (for me) with libxcb-1.8.

So it seems to be in the works already. I can live with that until a 1.9
comes around. Should I still open a bug in Gentoo bugzilla to get the
1.8 patch into the portage tree? There doesn't seem to be one (bug
report, I mean) at the moment.
--
Thanks,
Micha
 
Old 02-25-2012, 08:12 PM
Fabian Groffen
 
Default prefix X11 clients hang on Mac OS X 10.6

On 25-02-2012 19:28:14 +0100, Michael Weiser wrote:
> Hello again,
>
> On Sat, Feb 25, 2012 at 07:05:46PM +0100, Michael Weiser wrote:
>
> > Is this problem discussed anywhere else? My search efforts on the web
>
> I was to quick. Should have looked again with the new information in
> hand. Now I find https://bugs.freedesktop.org/show_bug.cgi?id=45776.
> The patch at
> http://anonscm.debian.org/gitweb/?p=collab-maint/libxcb.git;a=commitdiff;h=2b5bc1d3299510e10a1733e5 a3b326232c774b75
> reliably fixes the problem (for me) with libxcb-1.8.
>
> So it seems to be in the works already. I can live with that until a 1.9
> comes around. Should I still open a bug in Gentoo bugzilla to get the
> 1.8 patch into the portage tree? There doesn't seem to be one (bug
> report, I mean) at the moment.

please do, and thanks

--
Fabian Groffen
Gentoo on a different level
 
Old 02-26-2012, 07:09 PM
Michael Weiser
 
Default prefix X11 clients hang on Mac OS X 10.6

Hello Fabian,

On Sat, Feb 25, 2012 at 10:12:24PM +0100, Fabian Groffen wrote:

> > comes around. Should I still open a bug in Gentoo bugzilla to get the
> > 1.8 patch into the portage tree? There doesn't seem to be one (bug
> please do, and thanks

Done: https://bugs.gentoo.org/show_bug.cgi?id=405951
--
bye,
Micha
 
Old 02-26-2012, 10:28 PM
Johan Hattne
 
Default prefix X11 clients hang on Mac OS X 10.6

On 25 Feb 2012, at 10:28, Michael Weiser wrote:

> On Sat, Feb 25, 2012 at 07:05:46PM +0100, Michael Weiser wrote:
>
>> Is this problem discussed anywhere else? My search efforts on the web
>
> I was to quick. Should have looked again with the new information in
> hand. Now I find https://bugs.freedesktop.org/show_bug.cgi?id=45776.
> The patch at
> http://anonscm.debian.org/gitweb/?p=collab-maint/libxcb.git;a=commitdiff;h=2b5bc1d3299510e10a1733e5 a3b326232c774b75
> reliably fixes the problem (for me) with libxcb-1.8.

Works for me, too. Thanks for all the legwork!

// Cheers; Johan
 

Thread Tools




All times are GMT. The time now is 10:00 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org