Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Alt (http://www.linux-archive.org/gentoo-alt/)
-   -   --with-root-user (http://www.linux-archive.org/gentoo-alt/63264-root-user.html)

"Stefan Hoelldampf" 04-03-2008 06:58 AM

--with-root-user
 
On Wed, April 2, 2008 17:19, Fabian Groffen wrote:
> On 02-04-2008 16:55:30 +0200, Duft Markus wrote:
>> Used a) since i'm messing with environment anyway in the bootstrap
>> script, and i don't know what eprefix i will bootstrap at compile time,
>> so b) isn't possible.
>> Now the right python is found, but i have another problem: there is no
>> rpath hardcoded in python, so it doesn't find python2.5.so...... Need to
>> mess a little more with the environment :)
>
> Then set your LDFLAGS to the appropriate values when you bootstrap
> python.

LDFLAGS not being appropriately set might be the problem, but I had the
same problem on amd64-linux due to the missing /usr/lib -> /usr/lib64
symlink. Emerging baselayout-prefix isn't able to create the symlink due
to the directory /usr/lib created by the bootstrapped portage using
bootstrap-prefix.sh. I've posted a possible patch for bootstrap-prefix.sh
in https://bugs.gentoo.org/show_bug.cgi?id=183874#c9

Regards,
Stefan
--
gentoo-alt@lists.gentoo.org mailing list

Fabian Groffen 04-03-2008 06:59 AM

--with-root-user
 
On 03-04-2008 08:58:38 +0200, Stefan Hoelldampf wrote:
> On Wed, April 2, 2008 17:19, Fabian Groffen wrote:
> > On 02-04-2008 16:55:30 +0200, Duft Markus wrote:
> >> Used a) since i'm messing with environment anyway in the bootstrap
> >> script, and i don't know what eprefix i will bootstrap at compile time,
> >> so b) isn't possible.
> >> Now the right python is found, but i have another problem: there is no
> >> rpath hardcoded in python, so it doesn't find python2.5.so...... Need to
> >> mess a little more with the environment :)
> >
> > Then set your LDFLAGS to the appropriate values when you bootstrap
> > python.
>
> LDFLAGS not being appropriately set might be the problem, but I had the
> same problem on amd64-linux due to the missing /usr/lib -> /usr/lib64
> symlink. Emerging baselayout-prefix isn't able to create the symlink due
> to the directory /usr/lib created by the bootstrapped portage using
> bootstrap-prefix.sh. I've posted a possible patch for bootstrap-prefix.sh
> in https://bugs.gentoo.org/show_bug.cgi?id=183874#c9

Thanks!


--
Fabian Groffen
Gentoo on a different level
--
gentoo-alt@lists.gentoo.org mailing list


All times are GMT. The time now is 01:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.