FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Alt

 
 
LinkBack Thread Tools
 
Old 10-21-2011, 02:01 AM
Nicolas Pinto
 
Default Gentoo Prefix: getting around the "Your OpenSSL headers do not match your library" configure error.

Hello,

I experienced some issues when trying to emerge openssh on a Fedora 12 today:

$ emerge openssh

...
>>> Emerging (1 of 1) net-misc/openssh-5.9_p1-r3
...
checking OpenSSL header version... 1000005f (OpenSSL 1.0.0e 6 Sep 2011)
checking OpenSSL library version... 10000003 (OpenSSL 1.0.0b-fips 16 Nov 2010)
checking whether OpenSSL's headers match the library... no
configure: error: Your OpenSSL headers do not match your
library. Check config.log for details.
...

Investigating the config.log and the linker's search directories
helped identify the problem: the linker preferred the librairies in
/usr/lib64 instead of $EPREFIX/usr/lib, even when forcing
LDFLAGS="-Wl,-L$EPREFIX/usr/lib".

I could not figure out the exact details but found another work around:
$ LDFLAGS="-l:$EPREFIX/usr/lib/libssl.so
-l:$EPREFIX/usr/lib/libcrypto.so" emerge openssh
(basically forcing the linker to use specific files)

Just reporting, in case this helps someone.

Regards,

Nicolas






$ emerge --info =net-misc/openssh-5.9_p1-r3
Portage 2.2.01.19478-prefix (prefix/linux/amd64, gcc-4.2.4,
unavailable, 2.6.32.26-175.fc12.x86_64 x86_64)
================================================== ===============
System Settings
================================================== ===============
System uname: Linux-2.6.32.26-175.fc12.x86_64-x86_64-Intel-R-_Xeon-R-_CPU_W5590_@_3.33GHz-with-fedora-12-Constantine
Timestamp of tree: Fri, 21 Oct 2011 01:09:42 +0000
ccache version 2.4 [disabled]
app-shells/bash: 4.2_p10
dev-lang/python: 2.7.2
dev-util/pkgconfig: 0.25-r2
sys-devel/autoconf: 2.68
sys-devel/automake: 1.11.1
sys-devel/binutils: 2.21.53.0.2
sys-devel/gcc: 4.2.4-r01.4, 4.5.3-r1
sys-devel/gcc-config: 1.4.1-r00.2
sys-devel/libtool: 2.4-r01.1
sys-devel/make: 3.82
Repositories: gentoo_prefix
Installed sets:
ACCEPT_KEYWORDS="~amd64-linux"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf
/etc/portage /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=native -mtune=generic -O2 -pipe"
DISTDIR="/home/ac/npinto/gentoo/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs collision-protect distlocks
ebuild-locks fixlafiles news parallel-fetch preserve-libs
protect-owned sfperms strict unknown-features-warn unmerge-logs
unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j 17"
PKGDIR="/home/ac/npinto/gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/home/ac/npinto/gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
--compress --force --whole-file --delete --stats --timeout=180
--exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/ac/npinto/gentoo/var/tmp"
PORTDIR="/home/ac/npinto/gentoo/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
USE="amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv
ipv6 mmx modules mudflap ncurses nls nptl nptlonly openmp pcre pppd
prefix readline session sse sse2 sse4 ssl sysfs tcpd unicode xorg
zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106
cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0
intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty
extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul
mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon
authn_dbm authn_default authn_file authz_dbm authz_default
authz_groupfile authz_host authz_owner authz_user autoindex cache cgi
cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter
file_cache filter headers include info log_config logio mem_cache mime
mime_magic negotiation rewrite setenvif speling status unique_id
userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan
stage tables krita karbon braindump" CAMERAS="ptp2"
COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18
garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb
ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18"
USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic
nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy
v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset
ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat
logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL,
LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS,
PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
 
Old 10-24-2011, 08:04 AM
Fabian Groffen
 
Default Gentoo Prefix: getting around the "Your OpenSSL headers do not match your library" configure error.

On 20-10-2011 22:01:31 -0400, Nicolas Pinto wrote:
> checking OpenSSL header version... 1000005f (OpenSSL 1.0.0e 6 Sep 2011)
> checking OpenSSL library version... 10000003 (OpenSSL 1.0.0b-fips 16 Nov 2010)
> checking whether OpenSSL's headers match the library... no
> configure: error: Your OpenSSL headers do not match your
> library. Check config.log for details.
> ...
>
> Investigating the config.log and the linker's search directories
> helped identify the problem: the linker preferred the librairies in
> /usr/lib64 instead of $EPREFIX/usr/lib, even when forcing
> LDFLAGS="-Wl,-L$EPREFIX/usr/lib".

Could you please show the gcc/linker call from config.log? It's
important here to see if the linker is making this up, or the flags are
just passed by someone.


--
Fabian Groffen
Gentoo on a different level
 
Old 12-08-2011, 05:04 AM
Nicolas Pinto
 
Default Gentoo Prefix: getting around the "Your OpenSSL headers do not match your library" configure error.

I could not reproduce this issue for a while and I finally traced it
back... gcc compiled with USE=vanilla caused this problem.


On Thu, Oct 20, 2011 at 10:01 PM, Nicolas Pinto <nicolas.pinto@gmail.com> wrote:
> Hello,
>
> I experienced some issues when trying to emerge openssh on a Fedora 12 today:
>
> $ emerge openssh
>
> ...
>>>> Emerging (1 of 1) net-misc/openssh-5.9_p1-r3
> ...
> checking OpenSSL header version... 1000005f (OpenSSL 1.0.0e 6 Sep 2011)
> checking OpenSSL library version... 10000003 (OpenSSL 1.0.0b-fips 16 Nov 2010)
> checking whether OpenSSL's headers match the library... no
> configure: error: Your OpenSSL headers do not match your
> library. Check config.log for details.
> ...
>
> Investigating the config.log and the linker's search directories
> helped identify the problem: the linker preferred the librairies in
> /usr/lib64 instead of $EPREFIX/usr/lib, even when forcing
> LDFLAGS="-Wl,-L$EPREFIX/usr/lib".
>
> I could not figure out the exact details but found another work around:
> $ LDFLAGS="-l:$EPREFIX/usr/lib/libssl.so
> -l:$EPREFIX/usr/lib/libcrypto.so" emerge openssh
> (basically forcing the linker to use specific files)
>
> Just reporting, in case this helps someone.
>
> Regards,
>
> Nicolas
>
>
>
>
>
>
> $ emerge --info =net-misc/openssh-5.9_p1-r3
> Portage 2.2.01.19478-prefix (prefix/linux/amd64, gcc-4.2.4,
> unavailable, 2.6.32.26-175.fc12.x86_64 x86_64)
> ================================================== ===============
> * * * * * * * * * * * *System Settings
> ================================================== ===============
> System uname: Linux-2.6.32.26-175.fc12.x86_64-x86_64-Intel-R-_Xeon-R-_CPU_W5590_@_3.33GHz-with-fedora-12-Constantine
> Timestamp of tree: Fri, 21 Oct 2011 01:09:42 +0000
> ccache version 2.4 [disabled]
> app-shells/bash: * * *4.2_p10
> dev-lang/python: * * *2.7.2
> dev-util/pkgconfig: * 0.25-r2
> sys-devel/autoconf: * 2.68
> sys-devel/automake: * 1.11.1
> sys-devel/binutils: * 2.21.53.0.2
> sys-devel/gcc: * * * *4.2.4-r01.4, 4.5.3-r1
> sys-devel/gcc-config: 1.4.1-r00.2
> sys-devel/libtool: * *2.4-r01.1
> sys-devel/make: * * * 3.82
> Repositories: gentoo_prefix
> Installed sets:
> ACCEPT_KEYWORDS="~amd64-linux"
> ACCEPT_LICENSE="* -@EULA"
> CBUILD="x86_64-pc-linux-gnu"
> CFLAGS="-march=native -mtune=generic -O2 -pipe"
> CHOST="x86_64-pc-linux-gnu"
> CONFIG_PROTECT="/etc"
> CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf
> /etc/portage /etc/revdep-rebuild /etc/terminfo"
> CXXFLAGS="-march=native -mtune=generic -O2 -pipe"
> DISTDIR="/home/ac/npinto/gentoo/usr/portage/distfiles"
> FEATURES="assume-digests binpkg-logs collision-protect distlocks
> ebuild-locks fixlafiles news parallel-fetch preserve-libs
> protect-owned sfperms strict unknown-features-warn unmerge-logs
> unmerge-orphans userfetch"
> FFLAGS=""
> GENTOO_MIRRORS="http://distfiles.gentoo.org"
> LANG="en_US.UTF-8"
> LDFLAGS="-Wl,-O1"
> MAKEOPTS="-j 17"
> PKGDIR="/home/ac/npinto/gentoo/usr/portage/packages"
> PORTAGE_CONFIGROOT="/home/ac/npinto/gentoo/"
> PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times
> --compress --force --whole-file --delete --stats --timeout=180
> --exclude=/distfiles --exclude=/local --exclude=/packages"
> PORTAGE_TMPDIR="/home/ac/npinto/gentoo/var/tmp"
> PORTDIR="/home/ac/npinto/gentoo/usr/portage"
> PORTDIR_OVERLAY=""
> SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
> USE="amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv
> ipv6 mmx modules mudflap ncurses nls nptl nptlonly openmp pcre pppd
> prefix readline session sse sse2 sse4 ssl sysfs tcpd unicode xorg
> zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106
> cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0
> intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
> ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty
> extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul
> mulaw multi null plug rate route share shm softvol"
> APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon
> authn_dbm authn_default authn_file authz_dbm authz_default
> authz_groupfile authz_host authz_owner authz_user autoindex cache cgi
> cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter
> file_cache filter headers include info log_config logio mem_cache mime
> mime_magic negotiation rewrite setenvif speling status unique_id
> userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan
> stage tables krita karbon braindump" CAMERAS="ptp2"
> COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog"
> ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18
> garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
> oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
> tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux"
> LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb
> ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18"
> USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic
> nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy
> v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset
> ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat
> logmark ipmark dhcpmac delude chaos account"
> Unset: *CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL,
> LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS,
> PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



--
Nicolas Pinto
http://web.mit.edu/pinto
 
Old 12-08-2011, 06:51 AM
Fabian Groffen
 
Default Gentoo Prefix: getting around the "Your OpenSSL headers do not match your library" configure error.

On 08-12-2011 01:04:27 -0500, Nicolas Pinto wrote:
> I could not reproduce this issue for a while and I finally traced it
> back... gcc compiled with USE=vanilla caused this problem.

Oh, yes. USE=vanilla should be masked in Prefix, for it makes your gcc
useless. Thanks.


--
Fabian Groffen
Gentoo on a different level
 

Thread Tools




All times are GMT. The time now is 05:16 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org