FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Alt

 
 
LinkBack Thread Tools
 
Old 02-03-2008, 10:14 AM
Dirk Tilger
 
Default Objections to checking-in eclasses into prefix-users?

Hi,

I'm about to checkin a number of ebuilds that bring php into gentoo-alt
land and wanted to double check what the opinions are about overriding
eclasses in prefix-users. The following messages would be generated for
everyone using the prefix-users overlay:

| * Overlay eclasses override eclasses from PORTDIR:
| *
| * '/Gentoo/usr/portage/local/layman/prefix-users/eclass/depend.php.eclass'
| * '/Gentoo/usr/portage/local/layman/prefix-users/eclass/php4_4-sapi.eclass'
| * '/Gentoo/usr/portage/local/layman/prefix-users/eclass/php5_2-sapi.eclass'
| * '/Gentoo/usr/portage/local/layman/prefix-users/eclass/phpconfutils.eclass'
| *
| * It is best to avoid overridding eclasses from PORTDIR because it will
| * trigger invalidation of cached ebuild metadata that is distributed
| * with
| * the portage tree. If you must override eclasses from PORTDIR then you
| * are advised to run `emerge --regen` after each time that you run
| * `emerge
| * --sync`. Set PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if
| * you
| * would like to disable this warning.

Dirk.

--
gentoo-alt@lists.gentoo.org mailing list
 
Old 02-03-2008, 10:38 AM
Dirk Tilger
 
Default Objections to checking-in eclasses into prefix-users?

On 03.02.2008, at 15:22, Fabian Groffen wrote:

On 03-02-2008 11:14:42 +0000, Dirk Tilger wrote:

Hi,

I'm about to checkin a number of ebuilds that bring php into
gentoo-alt
land and wanted to double check what the opinions are about
overriding
eclasses in prefix-users. The following messages would be
generated for

everyone using the prefix-users overlay:


Are those changes with diffs somewhere in a bug?


depend.php.eclass and php5_2-sapi.eclass are in #195765.
phpconfutils.eclass seems unchanged, sorry. B-)

php4_4-sapi.eclass is work in progress. But due to dev-lang/php-4* being
hardmasked (#189172) you might not want it in the overlay tree.

Dirk.
--
gentoo-alt@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 11:51 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org