FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Alt

 
 
LinkBack Thread Tools
 
Old 11-04-2010, 03:01 AM
velociraptor
 
Default Solaris prefix aborting with "invalid shebangs found"

I just did an emerge sync tonight on my Solaris 10 x86 prefix, and so
far all the updates (other than portage itself) have thrown:

* Aborting due to QA concerns: invalid shebangs found
*
* Call stack:
* misc-functions.sh, line 1697: Called install_qa_check
* misc-functions.sh, line 210: Called install_qa_check_prefix
* misc-functions.sh, line 858: Called die
* The specific snippet of code:
* die "Aborting due to QA concerns: invalid shebangs found"

Anyone else seeing this? I've muddled about recently in my prefix and
am considering re-bootstrapping after I apply the latest patch updates
to Solaris.

Thanks--
=Nadine=
 
Old 11-04-2010, 06:30 AM
Fabian Groffen
 
Default Solaris prefix aborting with "invalid shebangs found"

On 03-11-2010 21:01:38 -0700, velociraptor wrote:
> I just did an emerge sync tonight on my Solaris 10 x86 prefix, and so
> far all the updates (other than portage itself) have thrown:
>
> * Aborting due to QA concerns: invalid shebangs found
> *
> * Call stack:
> * misc-functions.sh, line 1697: Called install_qa_check
> * misc-functions.sh, line 210: Called install_qa_check_prefix
> * misc-functions.sh, line 858: Called die
> * The specific snippet of code:
> * die "Aborting due to QA concerns: invalid shebangs found"
>
> Anyone else seeing this? I've muddled about recently in my prefix and
> am considering re-bootstrapping after I apply the latest patch updates
> to Solaris.

Don't! it's most likely just portage.
Do you still have the message that gives the exact reason why it thinks
you have an invalid shebang? It should be somewhere above your paste.


--
Fabian Groffen
Gentoo on a different level
 
Old 11-04-2010, 06:38 AM
Fabian Groffen
 
Default Solaris prefix aborting with "invalid shebangs found"

On 04-11-2010 08:30:40 +0100, Fabian Groffen wrote:
> Don't! it's most likely just portage.
> Do you still have the message that gives the exact reason why it thinks
> you have an invalid shebang? It should be somewhere above your paste.

It IS portage. Please try to downgrade to 2.2.01.17133 if possible. If
not, please give me the output, and I'll help you get through.


--
Fabian Groffen
Gentoo on a different level
 
Old 11-04-2010, 09:09 AM
Konstantin Tokarev
 
Default Solaris prefix aborting with "invalid shebangs found"

04.11.2010, 10:38, "Fabian Groffen" <grobian@gentoo.org>:

> It IS portage. *Please try to downgrade to 2.2.01.17133 if possible. *If
> not, please give me the output, and I'll help you get through.
>

I have similar problem on Mac OS X 10.5. Trying to upgrade from
2.2.01.16711 to 2.2.01.17133

* QA Notice: the following files use invalid (possible non-prefixed) shebangs:
* Users/konstantintokarev/Gentoo/usr/bin/ebuild:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/bin/egencache:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/bin/emerge:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/bin/portageq:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/bin/quickpkg:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/bin/repoman:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/sbin/archive-conf:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/sbin/dispatch-conf:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/sbin/emaint:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/sbin/env-update:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/sbin/fixpackages:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* Users/konstantintokarev/Gentoo/usr/sbin/regenworld:/Volumes/Development/Gentoo/usr/bin/python2.6 (in PATH but target not found)
* ERROR: sys-apps/portage-2.2.01.17133 failed:
* Aborting due to QA concerns: invalid shebangs found
*
* Call stack:
* misc-functions.sh, line 1686: Called install_qa_check
* misc-functions.sh, line 210: Called install_qa_check_prefix
* misc-functions.sh, line 855: Called die
* The specific snippet of code:
* die "Aborting due to QA concerns: invalid shebangs found"


--
Regards,
Konstantin
 
Old 11-07-2010, 04:09 PM
Fabian Groffen
 
Default Solaris prefix aborting with "invalid shebangs found"

On 04-11-2010 13:09:46 +0300, Konstantin Tokarev wrote:
>
> 04.11.2010, 10:38, "Fabian Groffen" <grobian@gentoo.org>:
>
> > It IS portage. *Please try to downgrade to 2.2.01.17133 if possible. *If
> > not, please give me the output, and I'll help you get through.
> >
>
> I have similar problem on Mac OS X 10.5. Trying to upgrade from
> 2.2.01.16711 to 2.2.01.17133

Ok, the only way out of this is to edit the file that causes this
behaviour:

$EPREFIX/usr/lib/portage/bin/misc-functions.sh

The simplest thing to do, is to find the function
install_qa_check_prefix, and just disable it being run entirely, by
simply removing the lines:

# Prefix specific checks
[[ -n ${EPREFIX} ]] && install_qa_check_prefix



--
Fabian Groffen
Gentoo on a different level
 
Old 11-07-2010, 04:33 PM
Konstantin Tokarev
 
Default Solaris prefix aborting with "invalid shebangs found"

07.11.2010, 20:09, "Fabian Groffen" <grobian@gentoo.org>:
> On 04-11-2010 13:09:46 +0300, Konstantin Tokarev wrote:
>
>> *04.11.2010, 10:38, "Fabian Groffen" <grobian@gentoo.org>;:
>>> *It IS portage. *Please try to downgrade to 2.2.01.17133 if possible. *If
>>> *not, please give me the output, and I'll help you get through.
>> *I have similar problem on Mac OS X 10.5. Trying to upgrade from
>> *2.2.01.16711 to 2.2.01.17133
>
> Ok, the only way out of this is to edit the file that causes this
> behaviour:
>
> $EPREFIX/usr/lib/portage/bin/misc-functions.sh
>
> The simplest thing to do, is to find the function
> install_qa_check_prefix, and just disable it being run entirely, by
> simply removing the lines:
>
> ****# Prefix specific checks
> ****[[ -n ${EPREFIX} ]] && install_qa_check_prefix

It works!

--
Regards,
Konstantin
 

Thread Tools




All times are GMT. The time now is 01:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org