FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Alt

 
 
LinkBack Thread Tools
 
Old 09-29-2010, 01:27 PM
Peter Waller
 
Default Upgrade your Portage

It seems dangerous to expect people using prefix to see this email? Can't you do this in a way that people installing the package notice?
On 29 September 2010 15:13, Fabian Groffen <grobian@gentoo.org> wrote:


A word of warning to all Prefix users:



Tomorrow I will commit a long overdue version bump of openssl (1.0.0a).

Recent Portage versions had non-functional preserve-libs functionality,

which causes this upgrade of openssl to severely BREAK YOUR SYSTEM.

(Portage won't work any more)



Make sure you upgrade Portage to version 2.2.01.16706 or above before

you upgrade your openssl, or you'll have to hack some files to get

yourself going again (like I had to when I found out).





--

Fabian Groffen

Gentoo on a different level
 
Old 09-29-2010, 01:29 PM
Jeremy Olexa
 
Default Upgrade your Portage

On Wed, 29 Sep 2010 15:13:15 +0200, Fabian Groffen <grobian@gentoo.org>
wrote:

A word of warning to all Prefix users:

Tomorrow I will commit a long overdue version bump of openssl
(1.0.0a).
Recent Portage versions had non-functional preserve-libs
functionality,

which causes this upgrade of openssl to severely BREAK YOUR SYSTEM.
(Portage won't work any more)

Make sure you upgrade Portage to version 2.2.01.16706 or above before
you upgrade your openssl, or you'll have to hack some files to get
yourself going again (like I had to when I found out).


Can you put a prefix-only depend in openssl for >=portage-2.2.01.16706?
-Jeremy
 
Old 09-29-2010, 01:33 PM
Fabian Groffen
 
Default Upgrade your Portage

On 29-09-2010 15:27:36 +0200, Peter Waller wrote:
> It seems dangerous to expect people using prefix to see this email? Can't
> you do this in a way that people installing the package notice?

not really, since it's a general preserved-libs problem, openssl is just
a bad package to break.


--
Fabian Groffen
Gentoo on a different level
 
Old 09-29-2010, 02:20 PM
Peter Waller
 
Default Upgrade your Portage

On 29 September 2010 15:33, Fabian Groffen <grobian@gentoo.org> wrote:


On 29-09-2010 15:27:36 +0200, Peter Waller wrote:

> It seems dangerous to expect people using prefix to see this email? Can't

> you do this in a way that people installing the package notice?



not really, since it's a general preserved-libs problem, openssl is just

a bad package to break.
This seems like bad practice not to have a way to do this. I don't think you can reasonably expect everyone updating their prefix installation to see posts on this mailing list. You're talking about causing people considerable pain, possibly effectively*irreversible - at least to less experienced users*- unless you publish the details of your hacks required to fix it after it is broken.


I don't see why such breakage should be necessary in the circumstance that someone*innocently*wants to update some packages. Isn't Jeremy's solution possible, for instance?
 
Old 09-29-2010, 06:25 PM
Fabian Groffen
 
Default Upgrade your Portage

On 29-09-2010 16:20:00 +0200, Peter Waller wrote:
> This seems like bad practice not to have a way to do this. I don't think you
> can reasonably expect everyone updating their prefix installation to see
> posts on this mailing list. You're talking about causing people considerable
> pain, possibly effectively*irreversible - at least to less experienced
> users*- unless you publish the details of your hacks required to fix it
> after it is broken.

I can understand your concerns. Gentoo Prefix is still an experiment,
though. While I don't really like to break things, I can't really avoid
it always either.

> I don't see why such breakage should be necessary in the circumstance that
> someone*innocently*wants to update some packages. Isn't Jeremy's solution
> possible, for instance?

I had to mask any flawed portage version, which means most people will
have to downgrade portage now, which I'm not going to force through
openssl or any other random package. It's a very structural problem.

The real problem is an abi update of a package, and Portage's
preserve-libs not working. In our case even worse, because that means
manual means to prevent huge breakage are disabled because Portage is
supposed to handle it.


--
Fabian Groffen
Gentoo on a different level
 
Old 10-02-2010, 10:08 AM
Robert Steinhäußer
 
Default Upgrade your Portage

Hi Fabian,
I'm running prefix on Mac OS X 10.5 on my PowerBook G4 (ppc).

On Wed, Sep 29, 2010 at 03:13:15PM +0200, Fabian Groffen wrote:
> Make sure you upgrade Portage to version 2.2.01.16706 or above before
> you upgrade your openssl, or you'll have to hack some files to get
> yourself going again (like I had to when I found out).

Today the new openssl has become available, but portage downgraded to
2.2.01.15553. Did I miss something?

> $ emerge >=sys-apps/portage-2.2.01.16706
>
> These are the packages that would be merged, in order:
>
> Calculating dependencies... done!
>
> !!! All ebuilds that could satisfy ">=sys-apps/portage-2.2.01.16706" have been masked.
> !!! One of the following masked packages is required to complete your request:
> - sys-apps/portage-2.2.01.16711 (masked by: package.mask)
> /Users/robert/Gentoo/usr/portage/profiles/prefix/package.mask:
> # Fabian Groffen <grobian@gentoo.org> (29 Sep 2010)
> # Unfortunately after master got EROOT support, it's only been horror
> # stories of Portage being broken. Provided snapshots are for the
> # brave, testing is more than appreciated!

73, Robert
 
Old 10-02-2010, 10:13 AM
Fabian Groffen
 
Default Upgrade your Portage

On 02-10-2010 12:08:22 +0200, Robert Steinhäußer wrote:
> Hi Fabian,
> I'm running prefix on Mac OS X 10.5 on my PowerBook G4 (ppc).
>
> On Wed, Sep 29, 2010 at 03:13:15PM +0200, Fabian Groffen wrote:
> > Make sure you upgrade Portage to version 2.2.01.16706 or above before
> > you upgrade your openssl, or you'll have to hack some files to get
> > yourself going again (like I had to when I found out).
>
> Today the new openssl has become available, but portage downgraded to
> 2.2.01.15553. Did I miss something?

not really. It turned out that 2.2.01.16706 was broken too, so to be
sure, I masked all releases >2.2.01.15553. 2.2.01.15553 is a safe
version to use. On a sidenote, 2.2.01.16711 seems to behave very well
at the moment, but if you're not up for some trouble, I'd leave it
alone.


--
Fabian Groffen
Gentoo on a different level
 

Thread Tools




All times are GMT. The time now is 06:31 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org