FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Alt

 
 
LinkBack Thread Tools
 
Old 06-04-2010, 10:27 AM
Daniel Vergien
 
Default Bootstraping on x86-solaris 10

Hi,

following the solaris instruction fails at "emerge --oneshot
pax-utils" because it wants to pull in sys-libs/zlib-1.2.5-r2 which
fails because of missing scanelf.

If I emerge zlib-1.2.3-r01.1 before it works.

Daniel
 
Old 06-04-2010, 10:36 AM
Fabian Groffen
 
Default Bootstraping on x86-solaris 10

On 04-06-2010 12:27:41 +0200, Daniel Vergien wrote:
> Hi,
>
> following the solaris instruction fails at "emerge --oneshot
> pax-utils" because it wants to pull in sys-libs/zlib-1.2.5-r2 which
> fails because of missing scanelf.
> If I emerge zlib-1.2.3-r01.1 before it works.

Ah, I see. That's a nasty workaround, but unavoidable for the moment
indeed. Thanks.


--
Fabian Groffen
Gentoo on a different level
 
Old 06-04-2010, 05:45 PM
Daniel Vergien
 
Default Bootstraping on x86-solaris 10

On 04.06.10 12:36, Fabian Groffen wrote:

On 04-06-2010 12:27:41 +0200, Daniel Vergien wrote:



If I emerge zlib-1.2.3-r01.1 before it works.


Ah, I see. That's a nasty workaround, but unavoidable for the moment
indeed. Thanks.


"it works" was a bit to early. After doing "emerge -u system". The
"zlib solaris issue" appeared. But after doing the fix in your mail,
every try to emerge something fails with:

checking for i386-pc-solaris2.10-gcc... i386-pc-solaris2.10-gcc
checking for C compiler default output file name... configure: error:
C compiler cannot create executables


The config.log is attached.

Daniel
 
Old 06-11-2010, 08:39 PM
Fabian Groffen
 
Default Bootstraping on x86-solaris 10

On 04-06-2010 19:45:02 +0200, Daniel Vergien wrote:
> On 04.06.10 12:36, Fabian Groffen wrote:
> > On 04-06-2010 12:27:41 +0200, Daniel Vergien wrote:
>
> >> If I emerge zlib-1.2.3-r01.1 before it works.
> >
> > Ah, I see. That's a nasty workaround, but unavoidable for the moment
> > indeed. Thanks.
>
> "it works" was a bit to early. After doing "emerge -u system". The
> "zlib solaris issue" appeared. But after doing the fix in your mail,
> every try to emerge something fails with:
> checking for i386-pc-solaris2.10-gcc... i386-pc-solaris2.10-gcc
> checking for C compiler default output file name... configure: error:
> C compiler cannot create executables

I think this is http://bugs.gentoo.org/show_bug.cgi?id=318679.

> configure:3810: i386-pc-solaris2.10-gcc -c conftest.c >&5
> ld.so.1: as: fatal: libz.so.1: version `SUNW_1.1' not found (required by file /nilfisk/gentoo/usr/lib/binutils/i386-pc-solaris2.10/2.20.51.0.4/libbfd-2.20.51.0.4.20091214.so)

The wrong zlib.so.1 is being loaded, I think. Is the symlink still
around? I guess not, is it?


--
Fabian Groffen
Gentoo on a different level
 

Thread Tools




All times are GMT. The time now is 04:55 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org