FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 05-27-2008, 04:12 PM
James Pifer
 
Default OT: SSI with httpd

I'm trying to get server side includes working with httpd. I have this
in the conf file:

LoadModule include_module modules/mod_include.so

#
# This should be changed to whatever you set DocumentRoot to.
#
Directory /var/www/html>
Options Indexes FollowSymLinks Includes
AllowOverride None
Order allow,deny
Allow from all
</Directory>

I've restarted httpd and it restarts fine. When I try to add an SSI to a
page it doesn't work. If I look at the page source I can see the include
in the source, which I read means that the httpd server is not properly
setup for SSI.

Here's a simple page I'm trying:

<html>
<head>
<title>Welcome</title>
</head>
<body>
<!--#include FILE="include.inc" -->
This would be a Welcome page.

<!--#config timefmt="%A %B %d, %Y" -->
Today is<!--#echo var="DATE_LOCAL" -->
</body>
</html>


include.inc exists in the same directory as this file. Can anyone tell
me what I might be missing here?

Thanks,
James

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 03:10 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org