FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 05-25-2008, 09:01 PM
dexter
 
Default F9 KDE4 - CMake Error: Error in cmake code at

I'm getting this error:

+ /usr/bin/cmake -DCMAKE_SKIP_RPATH:BOOL=ON -DCMAKE_BUILD_TYPE=FEDORA -DCMAKE_INSTALL_PREFIX=/usr -DSYSCONF_INSTALL_DIR=/etc -DINCLUDE_INSTALL_DIR=/usr/include/kde4 -DLIB_INSTALL_DIR=/usr/lib -DLIBEXEC_INSTALL_DIR=/usr/libexec/kde4 -DDATA_INSTALL_DIR=/usr/share/kde4/apps
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Check size of void*
-- Check size of void* - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
CMake Error: Error in cmake code at
/home/dexter/rpmbuild/BUILD/ksystemlog/src/CMakeLists.txt:41:
Unknown CMake command "kde4_add_ui_files".
-- Configuring done
error: Bad exit status from /var/tmp/rpm-tmp.52261 (%build)

Anybody know which package "kde4_add_ui_files" macros are defined?

...dex

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 05-26-2008, 03:53 AM
Kevin Kofler
 
Default F9 KDE4 - CMake Error: Error in cmake code at

dexter <dex.mbox <at> googlemail.com> writes:
> Anybody know which package "kde4_add_ui_files" macros are defined?

You're probably trying to build a program which requires KDE 4.1 against KDE
4.0. What are you trying to compile?

Kevin Kofler

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 05-26-2008, 10:28 AM
dexter
 
Default F9 KDE4 - CMake Error: Error in cmake code at

On Mon May 26 2008 04:53:11 Kevin Kofler wrote:
> dexter <dex.mbox <at> googlemail.com> writes:
> > Anybody know which package "kde4_add_ui_files" macros are defined?
>
> You're probably trying to build a program which requires KDE 4.1 against
> KDE 4.0. What are you trying to compile?

KSystemLog @ http://ksystemlog.forum-software.org/
svn co svn://anonsvn.kde.org/home/kde/trunk/KDE/kdeadmin/ksystemlog

I've been building it in F7 since kde 3.9x, I see now from F7 these macros are
part of kdelibs4-devel and kdelibs-devel in F9 but cmake is'nt finding them?

...dex

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 05-27-2008, 05:30 AM
Kevin Kofler
 
Default F9 KDE4 - CMake Error: Error in cmake code at

dexter <dex.mbox <at> googlemail.com> writes:
> KSystemLog @ http://ksystemlog.forum-software.org/
> svn co svn://anonsvn.kde.org/home/kde/trunk/KDE/kdeadmin/ksystemlog

That's part of KDE 4.1, and presumably requires KDE 4.1 to build now. Try an
older version for now.

It's likely that KDE 4.1 will be pushed to F9 as an update once it's released,
then ksystemlog will be included in kdeadmin.

Kevin Kofler

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 05-27-2008, 07:11 PM
dexter
 
Default F9 KDE4 - CMake Error: Error in cmake code at

On Tue May 27 2008 06:30:21 Kevin Kofler wrote:
> That's part of KDE 4.1, and presumably requires KDE 4.1 to build now. Try
> an older version for now.

A kde development environment that looks backwards is useless to me YMMV.

> It's likely that KDE 4.1 will be pushed to F9 as an update once it's
> released, then ksystemlog will be included in kdeadmin.

Well consider if you dont push it F9 will be in some sort of kde4 development
limbo with one gear => reverse, which is were I'm now.

<rant>
F9 its been a pos
unfinished X underneath unfinished kde thats not bleeding edge thats a
haemorrhage. I'll stop there and be back for kde 4.5 & F13.
</rant>

...dex

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 05-28-2008, 05:17 PM
Kevin Kofler
 
Default F9 KDE4 - CMake Error: Error in cmake code at

dexter <dex.mbox <at> googlemail.com> writes:
> On Tue May 27 2008 06:30:21 Kevin Kofler wrote:
> > That's part of KDE 4.1, and presumably requires KDE 4.1 to build now. Try
> > an older version for now.
>
> A kde development environment that looks backwards is useless to me YMMV.

We're shipping the latest stable version of KDE, KDE 4.0.4. Of course we aren't
shipping unstable betas or even alphas of KDE in a stable release! KDE 4.1 is
not released yet.

Kevin Kofler

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 05-28-2008, 11:48 PM
dexter
 
Default F9 KDE4 - CMake Error: Error in cmake code at

On Wed May 28 2008 18:17:03 Kevin Kofler wrote:
> We're shipping the latest stable version of KDE, KDE 4.0.4. Of course we
> aren't shipping unstable betas or even alphas of KDE in a stable release!
> KDE 4.1 is not released yet.

Don't panic I'm building my own now as 4.0.4 was old before it hit the mirrors
& if you think 4.1 will be any less stable than 4.0.4(which isn't stable btw)
maybe I have more faith in kde development than you.


...dex

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 09:41 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org