Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   Problem with wpa_supplicant (http://www.linux-archive.org/fedora-user/709749-problem-wpa_supplicant.html)

"R. G. Newbury" 10-05-2012 01:00 AM

Problem with wpa_supplicant
 
Has anyone else noticed a problem with wireless authentication using
wpa_supplicant? Following a router change and consequent messing with
passphrases, my Thinkpad with iwl4965 chipset has ceased to
authenticate. It can easily connect with the wireless router if the
router is 'open' but fails on WEP, WPA and WPA2. The household's mac
airbook, ipad, iphone and android phone have no difficulty.


I have tried deleting all /etc/sysconfig/network* files, as well as
those in wicd and wpa_supplicant and recreating but no joy.


Interestingly, the psk reported by a 'iwlist wlan0 scan' for my router
is nothing like the psk produced by 'wpa_passphrase essid
mysecretpassphrase'


scan: 1382882a0e39633131ca70df0db2a9bff9a8f142d47cdde921 740e27aea26c77
wpa_passphrase:
f389062374809e11f7c30b39b6e34f221b311a963dcb866a31 8bcee1e4ce0337


Anyone have any idea what's going on?
Fedora 17 on 3.5.5.-1, wpa_supplicant, wpa_supplicant-1.0-1.fc17.x86_64


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org

JD 10-05-2012 01:23 AM

Problem with wpa_supplicant
 
On 10/04/2012 07:00 PM, R. G. Newbury wrote:
Has anyone else noticed a problem with wireless authentication using
wpa_supplicant? Following a router change and consequent messing with
passphrases, my Thinkpad with iwl4965 chipset has ceased to
authenticate. It can easily connect with the wireless router if the
router is 'open' but fails on WEP, WPA and WPA2. The household's mac
airbook, ipad, iphone and android phone have no difficulty.


I have tried deleting all /etc/sysconfig/network* files, as well as
those in wicd and wpa_supplicant and recreating but no joy.


Interestingly, the psk reported by a 'iwlist wlan0 scan' for my router
is nothing like the psk produced by 'wpa_passphrase essid
mysecretpassphrase'


scan: 1382882a0e39633131ca70df0db2a9bff9a8f142d47cdde921 740e27aea26c77
wpa_passphrase:
f389062374809e11f7c30b39b6e34f221b311a963dcb866a31 8bcee1e4ce0337


Anyone have any idea what's going on?
Fedora 17 on 3.5.5.-1, wpa_supplicant, wpa_supplicant-1.0-1.fc17.x86_64



I hope the psk and the passphrase you posted are not your REAL
psk and passphrase values.

What tool did you use to configure your wlan0, and did you (in that
tool) provide the ESSID name, AP MAC address, security mode (WPA2-xxx...
etc) and ascii passphrase? Also how did you "Activate" the interface?
Did you provide a static IP or selected DHCP?




--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org


All times are GMT. The time now is 10:36 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.