FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 07-15-2012, 03:13 PM
Jeffrey Ross
 
Default F16 - Install Wine - dependency problem?

I tried to install wine with a simple "yum -y install wine" and of
course I got a whole list of dependencies that needed to be installed as
well, however the installation failed with this dependency requirement:


--> Processing Dependency: libsqlite3.so.0 for package:
nss-softokn-3.13.4-1.fc16.i686

---> Package pixman.i686 0:0.24.4-1.fc16 will be installed
--> Running transaction check
---> Package sqlite.i686 0:3.7.7.1-1.fc16 will be installed
--> Processing Dependency: libreadline.so.6 for package:
sqlite-3.7.7.1-1.fc16.i686

--> Running transaction check
---> Package readline.i686 0:6.2-2.fc16 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: sqlite-3.7.7.1-1.fc16.i686 !=
sqlite-3.7.9-1.fc17.x86_64



system is x86_64

How can I either tell yum that 3.7.7.1-1 is ok (which is currently on
the system) or upgrade to 3.7.9-1.fc17?


Thanks, Jeff
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-15-2012, 03:35 PM
Michael Schwendt
 
Default F16 - Install Wine - dependency problem?

On Sun, 15 Jul 2012 11:13:37 -0400, Jeffrey Ross wrote:

> I tried to install wine with a simple "yum -y install wine" and of
> course I got a whole list of dependencies that needed to be installed as
> well, however the installation failed with this dependency requirement:
>
> --> Processing Dependency: libsqlite3.so.0 for package:
> nss-softokn-3.13.4-1.fc16.i686
> ---> Package pixman.i686 0:0.24.4-1.fc16 will be installed
> --> Running transaction check
> ---> Package sqlite.i686 0:3.7.7.1-1.fc16 will be installed
> --> Processing Dependency: libreadline.so.6 for package:
> sqlite-3.7.7.1-1.fc16.i686
> --> Running transaction check
> ---> Package readline.i686 0:6.2-2.fc16 will be installed
> --> Finished Dependency Resolution
> Error: Protected multilib versions: sqlite-3.7.7.1-1.fc16.i686 !=
> sqlite-3.7.9-1.fc17.x86_64

fc16 and fc17 -> why?
What is it? Fedora 16 or Fedora 17?

> system is x86_64
>
> How can I either tell yum that 3.7.7.1-1 is ok (which is currently on
> the system) or upgrade to 3.7.9-1.fc17?
>
> Thanks, Jeff

What do you get for "yum list sqlite"? Multilib packages typically are
published for x86_64 *and* i686 at the same time, so one would need to
examine they don't match for you.

# yum list sqlite
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Installed Packages
sqlite.x86_64 3.7.11-3.fc17 installed
Available Packages
sqlite.i686 3.7.11-3.fc17 updates
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-15-2012, 03:37 PM
Michael Schwendt
 
Default F16 - Install Wine - dependency problem?

On Sun, 15 Jul 2012 11:13:37 -0400, Jeffrey Ross wrote:

> Error: Protected multilib versions: sqlite-3.7.7.1-1.fc16.i686 !=
> sqlite-3.7.9-1.fc17.x86_64

Without knowing why you've got this fc17 package, try

yum distro-sync

before trying to install anything else.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-15-2012, 03:47 PM
Jeffrey Ross
 
Default F16 - Install Wine - dependency problem?

On 07/15/2012 11:37 AM, Michael Schwendt wrote:

On Sun, 15 Jul 2012 11:13:37 -0400, Jeffrey Ross wrote:


Error: Protected multilib versions: sqlite-3.7.7.1-1.fc16.i686 !=
sqlite-3.7.9-1.fc17.x86_64

Without knowing why you've got this fc17 package, try

yum distro-sync

before trying to install anything else.
system is definitely running F16, ran distro-sync and that seemed to
solve it, no idea why the FC17 package got there...


Thanks, Jeff

$ sudo yum distro-sync
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package sqlite.x86_64 0:3.7.7.1-1.fc16 will be a downgrade
---> Package sqlite.x86_64 0:3.7.9-1.fc17 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ================================
Package Arch Version Repository Size
================================================== ================================
Downgrading:
sqlite x86_64 3.7.7.1-1.fc16 fedora 331 k

Transaction Summary
================================================== ================================
Downgrade 1 Package

Total download size: 331 k
Is this ok [y/N]: y
Downloading Packages:
sqlite-3.7.7.1-1.fc16.x86_64.rpm | 331 kB
00:00

Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing :
sqlite-3.7.7.1-1.fc16.x86_64 1/2
Cleanup :
sqlite-3.7.9-1.fc17.x86_64 2/2
Verifying :
sqlite-3.7.7.1-1.fc16.x86_64 1/2
Verifying :
sqlite-3.7.9-1.fc17.x86_64 2/2


Removed:
sqlite.x86_64 0:3.7.9-1.fc17

Installed:
sqlite.x86_64 0:3.7.7.1-1.fc16

Complete!


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 

Thread Tools




All times are GMT. The time now is 12:20 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org