FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 07-10-2012, 12:25 PM
Timothy Murphy
 
Default TeXlive 2012 problem

I am running Fedora-17/KDE on my laptop,
and have been trying to update TeXlive.
I've enabled the fedora-updates-testing repo, as was suggested,
but still get the error:
-----------------------------
[tim@blanche ~]$ sudo yum update texlive*
...
Error: Package: 1:texlive-preview-11.86.svn17118-1.noarch (@texlive)
Requires: texlive-kpathsea
Removing: 1:texlive-kpathsea-svn26691-1.noarch (@texlive)
texlive-kpathsea = 1:svn26691-1
Obsoleted By: 1:tex-kpathsea-svn26691-1.noarch (texlive)
Not found
-----------------------------
Any suggestions or enlightenment gratefully received.

--
Timothy Murphy
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-10-2012, 03:53 PM
"Germán A. Racca"
 
Default TeXlive 2012 problem

On 07/10/2012 09:25 AM, Timothy Murphy wrote:

I am running Fedora-17/KDE on my laptop,
and have been trying to update TeXlive.
I've enabled the fedora-updates-testing repo, as was suggested,
but still get the error:
-----------------------------
[tim@blanche ~]$ sudo yum update texlive*
...
Error: Package: 1:texlive-preview-11.86.svn17118-1.noarch (@texlive)
Requires: texlive-kpathsea
Removing: 1:texlive-kpathsea-svn26691-1.noarch (@texlive)
texlive-kpathsea = 1:svn26691-1
Obsoleted By: 1:tex-kpathsea-svn26691-1.noarch (texlive)
Not found
-----------------------------
Any suggestions or enlightenment gratefully received.


Hi Timothy:

I have F17 and texlive repo installed, but not updates-testing enabled.
My TeXLive 2012 works fine, and I don't have any texlive-preview package
in my repos:


$ yum --enablerepo=updates-testing search texlive-preview
Warning: No matches found for: texlive-preview
No Matches found

So where do your texlive-preview package comes from?

Maybe you should disable updates-testing repo, it's not a good thing to
keep it enabled.


HTH,
Germán.

--
Germán A. Racca
Fedora Package Maintainer
https://fedoraproject.org/wiki/User:Skytux


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-10-2012, 06:46 PM
Matthew Saltzman
 
Default TeXlive 2012 problem

On Tue, 2012-07-10 at 08:25 -0400, Timothy Murphy wrote:
> I am running Fedora-17/KDE on my laptop,
> and have been trying to update TeXlive.
> I've enabled the fedora-updates-testing repo, as was suggested,
> but still get the error:
> -----------------------------
> [tim@blanche ~]$ sudo yum update texlive*
> ...
> Error: Package: 1:texlive-preview-11.86.svn17118-1.noarch (@texlive)
> Requires: texlive-kpathsea
> Removing: 1:texlive-kpathsea-svn26691-1.noarch (@texlive)
> texlive-kpathsea = 1:svn26691-1
> Obsoleted By: 1:tex-kpathsea-svn26691-1.noarch (texlive)
> Not found
> -----------------------------
> Any suggestions or enlightenment gratefully received.
>

I think the solution is to remove texlive-preview and install
tex-preview from the Fedora 17 repo. The texlive repo no longer lists
texlive-preview or tex-preview as a package.

--
Matthew Saltzman
Clemson University Math Sciences
mjs AT clemson DOT edu

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-10-2012, 10:35 PM
Timothy Murphy
 
Default TeXlive 2012 problem

Matthew Saltzman wrote:

> I think the solution is to remove texlive-preview and install
> tex-preview from the Fedora 17 repo. The texlive repo no longer lists
> texlive-preview or tex-preview as a package.

Thanks for your response.
That did the trick.

Unfortunately when I try to LaTeX (or pdfLaTeX) a file I get the error
--------------------------
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
restricted write18 enabled.

kpathsea: Running mktexfmt latex.fmt
I can't find the format file `latex.fmt'!
[tim@blanche Problems]$ pdflatex Problems-08
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
restricted write18 enabled.

kpathsea: Running mktexfmt pdflatex.fmt
I can't find the format file `pdflatex.fmt'!

[tim@blanche Problems]$ sudo yum install tex-latex
Loaded plugins: langpacks, presto, refresh-packagekit
Package 1:tex-latex-svn23639-1.noarch already installed and latest version
Nothing to do
--------------------------

Should these .fmt files be part of the latest Fedora TeXlive distribution?

--
Timothy Murphy
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-10-2012, 11:04 PM
Ranjan Maitra
 
Default TeXlive 2012 problem

How about for the following?

Error: Package: R-core-2.15.0-1.fc17.x86_64 (@fedora)
Requires: texlive-latex
Removing: texlive-latex-2007-70.fc17.x86_64 (@fedora)
texlive-latex = 2007-70.fc17
Obsoleted By: 1:tex-latex-svn23639-1.noarch (texlive)
Not found
Error: Package: R-core-2.15.0-1.fc17.x86_64 (@fedora)
Requires: texlive-dvips
Removing: texlive-dvips-2007-70.fc17.x86_64 (@fedora)
texlive-dvips = 2007-70.fc17
Obsoleted By: 1:tex-dvips-svn26765-1.noarch (texlive)
Not found

Tried everything I could think of, nothing has worked so far....

Ranjan



On Tue, 10 Jul 2012 14:46:45 -0400 Matthew Saltzman <mjs@clemson.edu>
wrote:

> On Tue, 2012-07-10 at 08:25 -0400, Timothy Murphy wrote:
> > I am running Fedora-17/KDE on my laptop,
> > and have been trying to update TeXlive.
> > I've enabled the fedora-updates-testing repo, as was suggested,
> > but still get the error:
> > -----------------------------
> > [tim@blanche ~]$ sudo yum update texlive*
> > ...
> > Error: Package: 1:texlive-preview-11.86.svn17118-1.noarch (@texlive)
> > Requires: texlive-kpathsea
> > Removing: 1:texlive-kpathsea-svn26691-1.noarch (@texlive)
> > texlive-kpathsea = 1:svn26691-1
> > Obsoleted By: 1:tex-kpathsea-svn26691-1.noarch (texlive)
> > Not found
> > -----------------------------
> > Any suggestions or enlightenment gratefully received.
> >
>
> I think the solution is to remove texlive-preview and install
> tex-preview from the Fedora 17 repo. The texlive repo no longer lists
> texlive-preview or tex-preview as a package.
>
> --
> Matthew Saltzman
> Clemson University Math Sciences
> mjs AT clemson DOT edu
>
> --
> users mailing list
> users@lists.fedoraproject.org
> To unsubscribe or change subscription options:
> https://admin.fedoraproject.org/mailman/listinfo/users
> Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
> Have a question? Ask away: http://ask.fedoraproject.org
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-10-2012, 11:12 PM
Ranjan Maitra
 
Default TeXlive 2012 problem

Sorry to answer my own post, but cleaning up the cache took care of
this problem.

Should have thought about that before sending it out!

Ranjan

On Tue, 10 Jul 2012 18:04:35 -0500 Ranjan Maitra <maitra@iastate.edu>
wrote:

> How about for the following?
>
> Error: Package: R-core-2.15.0-1.fc17.x86_64 (@fedora)
> Requires: texlive-latex
> Removing: texlive-latex-2007-70.fc17.x86_64 (@fedora)
> texlive-latex = 2007-70.fc17
> Obsoleted By: 1:tex-latex-svn23639-1.noarch (texlive)
> Not found
> Error: Package: R-core-2.15.0-1.fc17.x86_64 (@fedora)
> Requires: texlive-dvips
> Removing: texlive-dvips-2007-70.fc17.x86_64 (@fedora)
> texlive-dvips = 2007-70.fc17
> Obsoleted By: 1:tex-dvips-svn26765-1.noarch (texlive)
> Not found
>
> Tried everything I could think of, nothing has worked so far....
>
> Ranjan
>
>
>
> On Tue, 10 Jul 2012 14:46:45 -0400 Matthew Saltzman <mjs@clemson.edu>
> wrote:
>
> > On Tue, 2012-07-10 at 08:25 -0400, Timothy Murphy wrote:
> > > I am running Fedora-17/KDE on my laptop,
> > > and have been trying to update TeXlive.
> > > I've enabled the fedora-updates-testing repo, as was suggested,
> > > but still get the error:
> > > -----------------------------
> > > [tim@blanche ~]$ sudo yum update texlive*
> > > ...
> > > Error: Package: 1:texlive-preview-11.86.svn17118-1.noarch (@texlive)
> > > Requires: texlive-kpathsea
> > > Removing: 1:texlive-kpathsea-svn26691-1.noarch (@texlive)
> > > texlive-kpathsea = 1:svn26691-1
> > > Obsoleted By: 1:tex-kpathsea-svn26691-1.noarch (texlive)
> > > Not found
> > > -----------------------------
> > > Any suggestions or enlightenment gratefully received.
> > >
> >
> > I think the solution is to remove texlive-preview and install
> > tex-preview from the Fedora 17 repo. The texlive repo no longer lists
> > texlive-preview or tex-preview as a package.
> >
> > --
> > Matthew Saltzman
> > Clemson University Math Sciences
> > mjs AT clemson DOT edu
> >
> > --
> > users mailing list
> > users@lists.fedoraproject.org
> > To unsubscribe or change subscription options:
> > https://admin.fedoraproject.org/mailman/listinfo/users
> > Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
> > Have a question? Ask away: http://ask.fedoraproject.org
> --
> users mailing list
> users@lists.fedoraproject.org
> To unsubscribe or change subscription options:
> https://admin.fedoraproject.org/mailman/listinfo/users
> Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
> Have a question? Ask away: http://ask.fedoraproject.org
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-10-2012, 11:52 PM
"Germán A. Racca"
 
Default TeXlive 2012 problem

On 07/10/2012 07:35 PM, Timothy Murphy wrote:

Matthew Saltzman wrote:


I think the solution is to remove texlive-preview and install
tex-preview from the Fedora 17 repo. The texlive repo no longer lists
texlive-preview or tex-preview as a package.


Thanks for your response.
That did the trick.

Unfortunately when I try to LaTeX (or pdfLaTeX) a file I get the error
--------------------------
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
restricted write18 enabled.

kpathsea: Running mktexfmt latex.fmt
I can't find the format file `latex.fmt'!
[tim@blanche Problems]$ pdflatex Problems-08
This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
restricted write18 enabled.

kpathsea: Running mktexfmt pdflatex.fmt
I can't find the format file `pdflatex.fmt'!

[tim@blanche Problems]$ sudo yum install tex-latex
Loaded plugins: langpacks, presto, refresh-packagekit
Package 1:tex-latex-svn23639-1.noarch already installed and latest version
Nothing to do
--------------------------

Should these .fmt files be part of the latest Fedora TeXlive distribution?


I solved this issue with "yum reinstall tex-*".

HTH,
Germán.

--
Germán A. Racca
Fedora Package Maintainer
https://fedoraproject.org/wiki/User:Skytux


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-11-2012, 12:13 AM
Matthew Saltzman
 
Default TeXlive 2012 problem

On Tue, 2012-07-10 at 19:04 -0400, Ranjan Maitra wrote:
> How about for the following?
>
> Error: Package: R-core-2.15.0-1.fc17.x86_64 (@fedora)
> Requires: texlive-latex
> Removing: texlive-latex-2007-70.fc17.x86_64 (@fedora)
> texlive-latex = 2007-70.fc17
> Obsoleted By: 1:tex-latex-svn23639-1.noarch (texlive)
> Not found
> Error: Package: R-core-2.15.0-1.fc17.x86_64 (@fedora)
> Requires: texlive-dvips
> Removing: texlive-dvips-2007-70.fc17.x86_64 (@fedora)
> texlive-dvips = 2007-70.fc17
> Obsoleted By: 1:tex-dvips-svn26765-1.noarch (texlive)
> Not found
>
> Tried everything I could think of, nothing has worked so far....

New R packages have just been pushed to F17 stable for this problem.

>
> Ranjan
>
>
>
> On Tue, 10 Jul 2012 14:46:45 -0400 Matthew Saltzman <mjs@clemson.edu>
> wrote:
>
> > On Tue, 2012-07-10 at 08:25 -0400, Timothy Murphy wrote:
> > > I am running Fedora-17/KDE on my laptop,
> > > and have been trying to update TeXlive.
> > > I've enabled the fedora-updates-testing repo, as was suggested,
> > > but still get the error:
> > > -----------------------------
> > > [tim@blanche ~]$ sudo yum update texlive*
> > > ...
> > > Error: Package: 1:texlive-preview-11.86.svn17118-1.noarch (@texlive)
> > > Requires: texlive-kpathsea
> > > Removing: 1:texlive-kpathsea-svn26691-1.noarch (@texlive)
> > > texlive-kpathsea = 1:svn26691-1
> > > Obsoleted By: 1:tex-kpathsea-svn26691-1.noarch (texlive)
> > > Not found
> > > -----------------------------
> > > Any suggestions or enlightenment gratefully received.
> > >
> >
> > I think the solution is to remove texlive-preview and install
> > tex-preview from the Fedora 17 repo. The texlive repo no longer lists
> > texlive-preview or tex-preview as a package.
> >
> > --
> > Matthew Saltzman
> > Clemson University Math Sciences
> > mjs AT clemson DOT edu
> >
> > --
> > users mailing list
> > users@lists.fedoraproject.org
> > To unsubscribe or change subscription options:
> > https://admin.fedoraproject.org/mailman/listinfo/users
> > Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
> > Have a question? Ask away: http://ask.fedoraproject.org
>

--
Matthew Saltzman
Clemson University Math Sciences
mjs AT clemson DOT edu

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-11-2012, 12:14 AM
Matthew Saltzman
 
Default TeXlive 2012 problem

On Tue, 2012-07-10 at 18:35 -0400, Timothy Murphy wrote:
> Matthew Saltzman wrote:
>
> > I think the solution is to remove texlive-preview and install
> > tex-preview from the Fedora 17 repo. The texlive repo no longer lists
> > texlive-preview or tex-preview as a package.
>
> Thanks for your response.
> That did the trick.
>
> Unfortunately when I try to LaTeX (or pdfLaTeX) a file I get the error
> --------------------------
> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
> restricted write18 enabled.
>
> kpathsea: Running mktexfmt latex.fmt
> I can't find the format file `latex.fmt'!
> [tim@blanche Problems]$ pdflatex Problems-08
> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
> restricted write18 enabled.
>
> kpathsea: Running mktexfmt pdflatex.fmt
> I can't find the format file `pdflatex.fmt'!
>
> [tim@blanche Problems]$ sudo yum install tex-latex
> Loaded plugins: langpacks, presto, refresh-packagekit
> Package 1:tex-latex-svn23639-1.noarch already installed and latest version
> Nothing to do
> --------------------------
>
> Should these .fmt files be part of the latest Fedora TeXlive distribution?
>

They are built on installation. I think yum reinstall tex-* texlive-*
will fix this.

--
Matthew Saltzman
Clemson University Math Sciences
mjs AT clemson DOT edu

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 07-11-2012, 10:20 PM
Timothy Murphy
 
Default TeXlive 2012 problem

Matthew Saltzman wrote:


>> --------------------------
>> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
>> restricted write18 enabled.
>>
>> kpathsea: Running mktexfmt latex.fmt
>> I can't find the format file `latex.fmt'!
>> [tim@blanche Problems]$ pdflatex Problems-08
>> This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
>> restricted write18 enabled.
>>
>> kpathsea: Running mktexfmt pdflatex.fmt
>> I can't find the format file `pdflatex.fmt'!
>>
>> [tim@blanche Problems]$ sudo yum install tex-latex
>> Loaded plugins: langpacks, presto, refresh-packagekit
>> Package 1:tex-latex-svn23639-1.noarch already installed and latest
>> version Nothing to do
>> --------------------------

> They are built on installation. I think yum reinstall tex-* texlive-*
> will fix this.

Thanks very much.
That did indeed solve the problem.

--
Timothy Murphy
e-mail: gayleard /at/ eircom.net
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College Dublin


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 

Thread Tools




All times are GMT. The time now is 06:59 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org