FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 05-09-2012, 05:11 AM
JD
 
Default No Audio from media players

I can get audio when I play videos on firefox (youtube, ...etc).
But vlc and mplayer issue this message into ~/.xsession-error

Failed to open VDPAU backend libvdpau_r300.so: cannot open shared object
file:

No such file or directory
Running DIL (3.6.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
ALSA lib pulse.c:243pulse_connect) PulseAudio: Unable to connect:
Connection

refused

Also, there is no pulseaudio daemon running.
Tried to start it but got:
$ pulseaudio --start
E: main.c: Daemon startup failed.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 05:27 AM
Ed Greshko
 
Default No Audio from media players

On 05/09/2012 01:11 PM, JD wrote:
> I can get audio when I play videos on firefox (youtube, ...etc).
> But vlc and mplayer issue this message into ~/.xsession-error
>
> Failed to open VDPAU backend libvdpau_r300.so: cannot open shared object file:
> No such file or directory
> Running DIL (3.6.0) Version
> DtsDeviceOpen: Opening HW in mode 0
> DtsDeviceOpen: Create File Failed
> ALSA lib pulse.c:243pulse_connect) PulseAudio: Unable to connect: Connection
> refused
>
> Also, there is no pulseaudio daemon running.
> Tried to start it but got:
> $ pulseaudio --start
> E: main.c: Daemon startup failed.
>

You are running Fedora ??

Well, there is no libvdpau_r300.so on my system and "yum whatprovides
*/libvdpau_r300.so" returns nothing.....

What do you get when you "ldd /usr/bin/mplayer | grep libvdpau" ?

I don't get any reference to libvdpau_r300.so. Only....

libvdpau.so.1 => /usr/lib/libvdpau.so.1 (0x4b827000)


--
Never be afraid to laugh at yourself, after all, you could be missing out on the joke
of the century. -- Dame Edna Everage
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 05:33 AM
Ed Greshko
 
Default No Audio from media players

On 05/09/2012 01:27 PM, Ed Greshko wrote:
> On 05/09/2012 01:11 PM, JD wrote:
>> I can get audio when I play videos on firefox (youtube, ...etc).
>> But vlc and mplayer issue this message into ~/.xsession-error
>>
>> Failed to open VDPAU backend libvdpau_r300.so: cannot open shared object file:
>> No such file or directory
>> Running DIL (3.6.0) Version
>> DtsDeviceOpen: Opening HW in mode 0
>> DtsDeviceOpen: Create File Failed
>> ALSA lib pulse.c:243pulse_connect) PulseAudio: Unable to connect: Connection
>> refused
>>
>> Also, there is no pulseaudio daemon running.
>> Tried to start it but got:
>> $ pulseaudio --start
>> E: main.c: Daemon startup failed.
>>
> You are running Fedora ??
>
> Well, there is no libvdpau_r300.so on my system and "yum whatprovides
> */libvdpau_r300.so" returns nothing.....
>
> What do you get when you "ldd /usr/bin/mplayer | grep libvdpau" ?
>
> I don't get any reference to libvdpau_r300.so. Only....
>
> libvdpau.so.1 => /usr/lib/libvdpau.so.1 (0x4b827000)
>

Also, I believe, libvdpau is for "video" anyway....

libvdpau-0.4.1-4.fc15.i686 : Wrapper library for the Video Decode and Presentation
: API
Repo : @fedora
Matched from:
Filename : /usr/lib/libvdpau.so.1

--
Never be afraid to laugh at yourself, after all, you could be missing out on the joke
of the century. -- Dame Edna Everage
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 06:09 AM
Ed Greshko
 
Default No Audio from media players

On 05/09/2012 01:11 PM, JD wrote:
> $ pulseaudio --start
> E: main.c: Daemon startup failed.

Also, pulseaudio should throw entries in /var/log/messages which may clue you in....

--
Never be afraid to laugh at yourself, after all, you could be missing out on the joke
of the century. -- Dame Edna Everage
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 11:20 AM
Ankur Sinha
 
Default No Audio from media players

On Tue, 2012-05-08 at 23:11 -0600, JD wrote:
> $ pulseaudio --start
> E: main.c: Daemon startup failed.

Try starting it with verbose on:

$ pulseaudio --start --log-level=10

etc. and see if you get anything meaningful on the failure?
--
Thanks,
Regards,
Ankur: "FranciscoD"

http://fedoraproject.org/wiki/User:Ankursinha
http://dodoincfedora.wordpress.com/

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 02:23 PM
JD
 
Default No Audio from media players

On 05/08/2012 11:27 PM, Ed Greshko wrote:

On 05/09/2012 01:11 PM, JD wrote:

I can get audio when I play videos on firefox (youtube, ...etc).
But vlc and mplayer issue this message into ~/.xsession-error

Failed to open VDPAU backend libvdpau_r300.so: cannot open shared object file:
No such file or directory
Running DIL (3.6.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
ALSA lib pulse.c:243pulse_connect) PulseAudio: Unable to connect: Connection
refused

Also, there is no pulseaudio daemon running.
Tried to start it but got:
$ pulseaudio --start
E: main.c: Daemon startup failed.


You are running Fedora ??

Well, there is no libvdpau_r300.so on my system and "yum whatprovides
*/libvdpau_r300.so" returns nothing.....

What do you get when you "ldd /usr/bin/mplayer | grep libvdpau" ?

I don't get any reference to libvdpau_r300.so. Only....

libvdpau.so.1 => /usr/lib/libvdpau.so.1 (0x4b827000)



I am running fc16
uname -r
3.3.4-3.fc16.i686

Just as in your case,

ldd /usr/bin/mplayer | grep libvdpau

returns nothing.

Ditto for vlc.

Libvdpau_r300 comes from Mesa, which is not available on fedora reppos.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 02:33 PM
JD
 
Default No Audio from media players

On 05/09/2012 12:09 AM, Ed Greshko wrote:

On 05/09/2012 01:11 PM, JD wrote:

$ pulseaudio --start
E: main.c: Daemon startup failed.


Also, pulseaudio should throw entries in /var/log/messages which may clue you in....


The errors are:
May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread
31173 of process 31173 (/usr/bin/pulseaudio) owned by '1008' high
priority at nice level -11.
May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread
31174 of process 31173 (/usr/bin/pulseaudio) owned by '1008' RT at
priority 5.
May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread
31175 of process 31173 (/usr/bin/pulseaudio) owned by '1008' RT at
priority 5.
May 8 22:07:44 localhost pulseaudio[31173]: bluetooth-util.c: Error
from ListAdapters reply: org.freedesktop.systemd1.LoadFailed
May 8 22:07:44 localhost pulseaudio[31173]: module-ladspa-sink.c:
Master sink not found
May 8 22:07:44 localhost pulseaudio[31173]: module.c: Failed to load
module "module-ladspa-sink" (argument:
"sink_name=ladspa_output.mbeq_1197.mbeq
master=alsa_output.pci-0000_00_02.7.analog-surround-51 plugin=mbeq_1197
label=mbeq control=-11.6,-5.4,0,0,0,0,0,0,0,0,0,0,0,0,0"):
initialization failed.


Yet yum does not think anything is wrong.
Doing update does not bring in any missing deps.
I use both Fedora and Rpmfusion repos.

May 8 22:07:44 localhost pulseaudio[31173]: main.c: Module load failed.
May 8 22:07:44 localhost pulseaudio[31173]: main.c: Failed to
initialize daemon.


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 02:45 PM
Ed Greshko
 
Default No Audio from media players

On 05/09/2012 10:33 PM, JD wrote:
> The errors are:
> May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread 31173 of
> process 31173 (/usr/bin/pulseaudio) owned by '1008' high priority at nice level -11.
> May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread 31174 of
> process 31173 (/usr/bin/pulseaudio) owned by '1008' RT at priority 5.
> May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread 31175 of
> process 31173 (/usr/bin/pulseaudio) owned by '1008' RT at priority 5.
> May 8 22:07:44 localhost pulseaudio[31173]: bluetooth-util.c: Error from
> ListAdapters reply: org.freedesktop.systemd1.LoadFailed
> May 8 22:07:44 localhost pulseaudio[31173]: module-ladspa-sink.c: Master sink not
> found
> May 8 22:07:44 localhost pulseaudio[31173]: module.c: Failed to load module
> "module-ladspa-sink" (argument: "sink_name=ladspa_output.mbeq_1197.mbeq
> master=alsa_output.pci-0000_00_02.7.analog-surround-51 plugin=mbeq_1197 label=mbeq
> control=-11.6,-5.4,0,0,0,0,0,0,0,0,0,0,0,0,0"): initialization failed.
>
> Yet yum does not think anything is wrong.
> Doing update does not bring in any missing deps.
> I use both Fedora and Rpmfusion repos.
>
> May 8 22:07:44 localhost pulseaudio[31173]: main.c: Module load failed.
> May 8 22:07:44 localhost pulseaudio[31173]: main.c: Failed to initialize daemon.

What type of HW do you have? Do you have a bluetooth adapter of sorts? Can you
disable it?

If you don't have any bluetooth devices, you can try

yum erase pulseaudio-module-bluetooth

It will also remove other bluetooth stuff which you wouldn't need.

--
Never be afraid to laugh at yourself, after all, you could be missing out on the joke
of the century. -- Dame Edna Everage
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 02:52 PM
"Bryn M. Reeves"
 
Default No Audio from media players

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 05/09/2012 03:33 PM, JD wrote:
> May 8 22:07:44 localhost pulseaudio[31173]: bluetooth-util.c:
> Error from ListAdapters reply: org.freedesktop.systemd1.LoadFailed
> May 8 22:07:44 localhost pulseaudio[31173]: module-ladspa-sink.c:
> Master sink not found May 8 22:07:44 localhost pulseaudio[31173]:
> module.c: Failed to load module "module-ladspa-sink" (argument:
> "sink_name=ladspa_output.mbeq_1197.mbeq
> master=alsa_output.pci-0000_00_02.7.analog-surround-51
> plugin=mbeq_1197 label=mbeq
> control=-11.6,-5.4,0,0,0,0,0,0,0,0,0,0,0,0,0"): initialization
> failed.

Those messages refer to the LADSPA sink for pulseaudio. This is the
"Linux Audio DSP Architecture", a framework for chainable audio
effects plugins (similar to Steinberg VST in some ways).

Do you use any LADSPA plugins or effects on this system?

Pulse is attempting to load a graph with a LADSPA multiband equalizer
configuration defined:

sink_name=ladspa_output.mbeq_1197.mbeq
master=alsa_output.pci-0000_00_02.7.analog-surround-51 plugin=mbeq_1197
label=mbeq control=-11.6,-5.4,0,0,0,0,0,0,0,0,0,0,0,0,0"

The master sink it references doesn't appear to exist so it fails the
module load and gives up.

If you have configured any kind of EQ on the system then you might
want to try unconfiguring it.

Regards,
Bryn.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk+qhMAACgkQ6YSQoMYUY95b8wCeJ7kOLnGm+5 mJxRSw4kUIg9M0
D1AAn1zkP3T2cmPN1u2L8TC5k80tbtoN
=TOuR
-----END PGP SIGNATURE-----
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 05-09-2012, 03:23 PM
JD
 
Default No Audio from media players

On 05/09/2012 08:45 AM, Ed Greshko wrote:

On 05/09/2012 10:33 PM, JD wrote:

The errors are:
May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread 31173 of
process 31173 (/usr/bin/pulseaudio) owned by '1008' high priority at nice level -11.
May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread 31174 of
process 31173 (/usr/bin/pulseaudio) owned by '1008' RT at priority 5.
May 8 22:07:44 localhost rtkit-daemon[1520]: Successfully made thread 31175 of
process 31173 (/usr/bin/pulseaudio) owned by '1008' RT at priority 5.
May 8 22:07:44 localhost pulseaudio[31173]: bluetooth-util.c: Error from
ListAdapters reply: org.freedesktop.systemd1.LoadFailed
May 8 22:07:44 localhost pulseaudio[31173]: module-ladspa-sink.c: Master sink not
found
May 8 22:07:44 localhost pulseaudio[31173]: module.c: Failed to load module
"module-ladspa-sink" (argument: "sink_name=ladspa_output.mbeq_1197.mbeq
master=alsa_output.pci-0000_00_02.7.analog-surround-51 plugin=mbeq_1197 label=mbeq
control=-11.6,-5.4,0,0,0,0,0,0,0,0,0,0,0,0,0"): initialization failed.

Yet yum does not think anything is wrong.
Doing update does not bring in any missing deps.
I use both Fedora and Rpmfusion repos.

May 8 22:07:44 localhost pulseaudio[31173]: main.c: Module load failed.
May 8 22:07:44 localhost pulseaudio[31173]: main.c: Failed to initialize daemon.

What type of HW do you have? Do you have a bluetooth adapter of sorts? Can you
disable it?

If you don't have any bluetooth devices, you can try

yum erase pulseaudio-module-bluetooth

It will also remove other bluetooth stuff which you wouldn't need.


My laptop has no BT chip or usb dongle at all. Have had it since 2004.
The audio chipset is:
Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
Multimedia audio controller: Silicon Integrated Systems [SiS] C-Media
AC'97 Sound Controller (rev a0)


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 

Thread Tools




All times are GMT. The time now is 10:25 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org