FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 02-15-2012, 10:21 AM
Patrick Dupre
 
Default startx fails with new kernel

Hello,

With te new kernel 3.2.5-3.fc16.x86_64
I cannot start the graphics mode!

X.Org X Server 1.11.4
Release Date: 2012-01-27
[ 161.446] X Protocol Version 11, Revision 0
[ 161.446] Build Operating System: x86-01 2.6.32-220.4.1.el6.x86_64
[ 161.446] Current Operating System: Linux Homere 3.2.5-3.fc16.x86_64 #1
SMP Thu Feb 9 01:24:38 UTC 2012 x86_64
[ 161.446] Kernel command line:
BOOT_IMAGE=/boot/vmlinuz-3.2.5-3.fc16.x86_64
root=UUID=e0d44568-5e7b-4c91-921f-ab1130406253 ro rd.md=0 rd.lvm=0 rd.dm=0
KEYTABLE=us SYSFONT=latarcyrheb-sun16 rd.luks=0 LANG=en_US.UTF-8

[ 161.446] Build Date: 08 February 2012 10:54:57PM
[ 161.446] Build ID: xorg-x11-server 1.11.4-1.fc16
[ 161.447] Current version of pixman: 0.22.2
[ 161.447] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 161.447] Markers: (--) probed, (**) from config file, (==) default
setting,

(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 161.448] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 15
12:13:46 2012

[ 161.449] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 161.449] (==) Using system config directory
"/usr/share/X11/xorg.conf.d"

[ 161.449] (==) No Layout section. Using the first Screen section.
[ 161.449] (**) |-->Screen "Default Screen" (0)
[ 161.449] (**) | |-->Monitor "VGA-1"
[ 161.449] (==) Automatically adding devices
[ 161.449] (==) Automatically enabling devices
[ 161.449] (==) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
[ 161.449] (**) ModulePath set to
"/usr/lib64/xorg/modules/extensions/nvidia,/usr/lib64/xorg/modules"
[ 161.449] (II) The server relies on udev to provide the list of input
devices.
If no devices become available, reconfigure udev or disable
AutoAddDevices.

[ 161.449] (II) Loader magic: 0x7caac0
[ 161.449] (II) Module ABI versions:
[ 161.449] X.Org ANSI C Emulation: 0.4
[ 161.449] X.Org Video Driver: 11.0
[ 161.449] X.Org XInput driver : 13.0
[ 161.449] X.Org Server Extension : 6.0
[ 161.450] (--) PCI:*(0:1:0:0) 10de:0a65:0000:0000 rev 162, Mem @
0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @
0x0000d800/128, BIOS @ 0x????????/524288

[ 161.450] (II) LoadModule: "extmod"
[ 161.450] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[ 161.451] (II) Module extmod: vendor="X.Org Foundation"
[ 161.451] compiled for 1.11.4, module version = 1.0.0
[ 161.451] Module class: X.Org Server Extension
[ 161.451] ABI class: X.Org Server Extension, version 6.0
[ 161.451] (II) Loading extension SELinux
[ 161.451] (II) Loading extension MIT-SCREEN-SAVER
[ 161.451] (II) Loading extension XFree86-VidModeExtension
[ 161.451] (II) Loading extension XFree86-DGA
[ 161.451] (II) Loading extension DPMS
[ 161.451] (II) Loading extension XVideo
[ 161.451] (II) Loading extension XVideo-MotionCompensation
[ 161.451] (II) Loading extension X-Resource
[ 161.451] (II) LoadModule: "dbe"
[ 161.451] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[ 161.451] (II) Module dbe: vendor="X.Org Foundation"
[ 161.451] compiled for 1.11.4, module version = 1.0.0
[ 161.451] Module class: X.Org Server Extension
[ 161.451] ABI class: X.Org Server Extension, version 6.0
[ 161.451] (II) Loading extension DOUBLE-BUFFER
[ 161.451] (II) LoadModule: "glx"
[ 161.451] (II) Loading
/usr/lib64/xorg/modules/extensions/nvidia/libglx.so

[ 161.454] (II) Module glx: vendor="NVIDIA Corporation"
[ 161.454] compiled for 4.0.2, module version = 1.0.0
[ 161.454] Module class: X.Org Server Extension
[ 161.454] (II) NVIDIA GLX Module 290.10 Wed Nov 16 18:01:24 PST 2011
[ 161.454] (II) Loading extension GLX
[ 161.454] (II) LoadModule: "record"
[ 161.455] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[ 161.455] (II) Module record: vendor="X.Org Foundation"
[ 161.455] compiled for 1.11.4, module version = 1.13.0
[ 161.455] Module class: X.Org Server Extension
[ 161.455] ABI class: X.Org Server Extension, version 6.0
[ 161.455] (II) Loading extension RECORD
[ 161.455] (II) LoadModule: "dri"
[ 161.455] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[ 161.455] (II) Module dri: vendor="X.Org Foundation"
[ 161.455] compiled for 1.11.4, module version = 1.0.0
[ 161.455] ABI class: X.Org Server Extension, version 6.0
[ 161.455] (II) Loading extension XFree86-DRI
[ 161.455] (II) LoadModule: "dri2"
[ 161.455] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 161.455] (II) Module dri2: vendor="X.Org Foundation"
[ 161.456] compiled for 1.11.4, module version = 1.2.0
[ 161.456] ABI class: X.Org Server Extension, version 6.0
[ 161.456] (II) Loading extension DRI2
[ 161.456] (==) Matched nouveau as autoconfigured driver 0
[ 161.456] (==) Matched vesa as autoconfigured driver 1
[ 161.456] (==) Matched fbdev as autoconfigured driver 2
[ 161.456] (==) Assigned the driver to the xf86ConfigLayout
[ 161.456] (II) LoadModule: "nouveau"
[ 161.456] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[ 161.456] (II) Module nouveau: vendor="X.Org Foundation"
[ 161.456] compiled for 1.10.99.902, module version = 0.0.16
[ 161.456] Module class: X.Org Video Driver
[ 161.456] ABI class: X.Org Video Driver, version 11.0
[ 161.456] (II) LoadModule: "vesa"
[ 161.456] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 161.456] (II) Module vesa: vendor="X.Org Foundation"
[ 161.456] compiled for 1.10.99.902, module version = 2.3.0
[ 161.456] Module class: X.Org Video Driver
[ 161.456] ABI class: X.Org Video Driver, version 11.0
[ 161.456] (II) LoadModule: "fbdev"
[ 161.456] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 161.456] (II) Module fbdev: vendor="X.Org Foundation"
[ 161.456] compiled for 1.10.99.902, module version = 0.4.2
[ 161.456] ABI class: X.Org Video Driver, version 11.0
[ 161.456] (II) NOUVEAU driver
[ 161.456] (II) NOUVEAU driver for NVIDIA chipset families :
[ 161.456] RIVA TNT (NV04)
[ 161.456] RIVA TNT2 (NV05)
[ 161.456] GeForce 256 (NV10)
[ 161.456] GeForce 2 (NV11, NV15)
[ 161.456] GeForce 4MX (NV17, NV18)
[ 161.456] GeForce 3 (NV20)
[ 161.456] GeForce 4Ti (NV25, NV28)
[ 161.456] GeForce FX (NV3x)
[ 161.456] GeForce 6 (NV4x)
[ 161.456] GeForce 7 (G7x)
[ 161.456] GeForce 8 (G8x)
[ 161.456] GeForce GTX 200 (NVA0)
[ 161.456] GeForce GTX 400 (NVC0)
[ 161.456] (II) VESA: driver for VESA chipsets: vesa
[ 161.457] (II) FBDEV: driver for framebuffer: fbdev
[ 161.457] (--) using VT number 2

[ 161.460] drmOpenDevice: node name is /dev/dri/card0
[ 161.470] drmOpenByBusid: Searching for BusID pci:0000:01:00.0
[ 161.470] drmOpenDevice: node name is /dev/dri/card0
[ 161.476] drmOpenByBusid: drmOpenMinor returns -1
[ 161.476] drmOpenDevice: node name is /dev/dri/card1
[ 161.482] drmOpenByBusid: drmOpenMinor returns -1
[ 161.482] drmOpenDevice: node name is /dev/dri/card2
[ 161.488] drmOpenByBusid: drmOpenMinor returns -1
[ 161.488] drmOpenDevice: node name is /dev/dri/card3
[ 161.495] drmOpenByBusid: drmOpenMinor returns -1
[ 161.495] drmOpenDevice: node name is /dev/dri/card4
[ 161.501] drmOpenByBusid: drmOpenMinor returns -1
[ 161.501] drmOpenDevice: node name is /dev/dri/card5
[ 161.507] drmOpenByBusid: drmOpenMinor returns -1
[ 161.507] drmOpenDevice: node name is /dev/dri/card6
[ 161.513] drmOpenByBusid: drmOpenMinor returns -1
[ 161.513] drmOpenDevice: node name is /dev/dri/card7
[ 161.519] drmOpenByBusid: drmOpenMinor returns -1
[ 161.519] drmOpenDevice: node name is /dev/dri/card8
[ 161.525] drmOpenByBusid: drmOpenMinor returns -1
[ 161.525] drmOpenDevice: node name is /dev/dri/card9
[ 161.532] drmOpenByBusid: drmOpenMinor returns -1
[ 161.532] drmOpenDevice: node name is /dev/dri/card10
[ 161.538] drmOpenByBusid: drmOpenMinor returns -1
[ 161.538] drmOpenDevice: node name is /dev/dri/card11
[ 161.544] drmOpenByBusid: drmOpenMinor returns -1
[ 161.544] drmOpenDevice: node name is /dev/dri/card12
[ 161.550] drmOpenByBusid: drmOpenMinor returns -1
[ 161.551] drmOpenDevice: node name is /dev/dri/card13
[ 161.557] drmOpenByBusid: drmOpenMinor returns -1
[ 161.557] drmOpenDevice: node name is /dev/dri/card14
[ 161.563] drmOpenByBusid: drmOpenMinor returns -1
[ 161.563] drmOpenDevice: node name is /dev/dri/card15
[ 161.569] drmOpenByBusid: drmOpenMinor returns -1
[ 161.569] drmOpenDevice: node name is /dev/dri/card0
[ 161.580] drmOpenDevice: node name is /dev/dri/card0
[ 161.586] drmOpenDevice: node name is /dev/dri/card1
[ 161.593] drmOpenDevice: node name is /dev/dri/card2
[ 161.599] drmOpenDevice: node name is /dev/dri/card3
[ 161.605] drmOpenDevice: node name is /dev/dri/card4
[ 161.611] drmOpenDevice: node name is /dev/dri/card5
[ 161.617] drmOpenDevice: node name is /dev/dri/card6
[ 161.624] drmOpenDevice: node name is /dev/dri/card7
[ 161.630] drmOpenDevice: node name is /dev/dri/card8
[ 161.636] drmOpenDevice: node name is /dev/dri/card9
[ 161.642] drmOpenDevice: node name is /dev/dri/card10
[ 161.648] drmOpenDevice: node name is /dev/dri/card11
[ 161.655] drmOpenDevice: node name is /dev/dri/card12
[ 161.661] drmOpenDevice: node name is /dev/dri/card13
[ 161.667] drmOpenDevice: node name is /dev/dri/card14
[ 161.673] drmOpenDevice: node name is /dev/dri/card15
[ 161.680] (EE) [drm] failed to open device
[ 161.680] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 161.680] Refusing to touch device with a bound kernel driver
[ 161.680] (WW) Falling back to old probe method for vesa
[ 161.680] (II) Loading sub module "fbdevhw"
[ 161.680] (II) LoadModule: "fbdevhw"
[ 161.681] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 161.681] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 161.681] compiled for 1.11.4, module version = 0.0.2
[ 161.681] ABI class: X.Org Video Driver, version 11.0
[ 161.681] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 161.681] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 161.692] (EE) open /dev/fb0: No such device
[ 161.692] (WW) Falling back to old probe method for fbdev
[ 161.692] (II) UnloadModule: "vesa"
[ 161.692] (II) Unloading vesa
[ 161.692] (II) UnloadModule: "fbdev"
[ 161.692] (II) Unloading fbdev
[ 161.692] (II) UnloadModule: "fbdevhw"
[ 161.692] (II) Unloading fbdevhw
[ 161.692] (EE) Screen(s) found, but none have a usable configuration.
[ 161.692]
Fatal server error:
[ 161.692] no screens found
[ 161.692]
Please consult the Fedora Project support
at http://wiki.x.org
for help.
[ 161.692] Please also check the log file at "/var/log/Xorg.0.log" for
additional information.

[ 161.692]
[ 161.694] Server terminated with error (1). Closing log file.


--
---
================================================== ========================
Patrick DUPRÉ | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: patrick.dupre@york.ac.uk
================================================== ========================--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 10:39 AM
John Pilkington
 
Default startx fails with new kernel

On 15/02/12 11:21, Patrick Dupre wrote:

Hello,

With te new kernel 3.2.5-3.fc16.x86_64
I cannot start the graphics mode!


You have a mix of nVidia and nouveau drivers, and probably need a nVidia
kmod that matches your new kernel.


See recent posts about 'no more nvidia' for hints.

John P
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 05:59 PM
Marko Vojinovic
 
Default startx fails with new kernel

On Wednesday 15 February 2012 11:21:49 Patrick Dupre wrote:
> Hello,
>
> With te new kernel 3.2.5-3.fc16.x86_64
> I cannot start the graphics mode!
>
> [ 161.451] (II) LoadModule: "glx"
> [ 161.451] (II) Loading
> /usr/lib64/xorg/modules/extensions/nvidia/libglx.so
> [ 161.454] (II) Module glx: vendor="NVIDIA Corporation"
> [ 161.454] (II) NVIDIA GLX Module 290.10 Wed Nov 16 18:01:24 PST 2011
[snip]
> [ 161.456] (II) LoadModule: "nouveau"
> [ 161.456] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
> [ 161.456] (II) Module nouveau: vendor="X.Org Foundation"

You have both nVidia binary blob driver and Nouveau driver installed at the
same time. This is well-known to Not Work. Either remove the binary blob and
let Nouveau drive your hardware, or remove nouveau and let the binary blob
drive your hardware. The world is too small for both of them... ;-)

HTH, :-)
Marko


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 07:08 PM
Patrick Dupre
 
Default startx fails with new kernel

Thank for your email.

But could you tell me exactly what I should do?

I removed xorg-x11-drv-nouveau (and xorg-x11-drivers), but I did
not get any improvements (see below)

Then I even cannot get back with the 1920x1080 resolution even with
the previous kernel. So reinstalled the removed packages.

X.Org X Server 1.11.4
Release Date: 2012-01-27
[ 30.939] X Protocol Version 11, Revision 0
[ 30.939] Build Operating System: x86-01 2.6.32-220.4.1.el6.x86_64
[ 30.939] Current Operating System: Linux Homere 3.2.5-3.fc16.x86_64 #1
SMP Thu Feb 9 01:24:38 UTC 2012 x86_64
[ 30.939] Kernel command line:
BOOT_IMAGE=/boot/vmlinuz-3.2.5-3.fc16.x86_64
root=UUID=e0d44568-5e7b-4c91-921f-ab1130406253 ro rd.md=0 rd.lvm=0 rd.dm=0
KEYTABLE=us SYSFONT=latarcyrheb-sun16 rd.luks=0 LANG=en_US.UTF-8

[ 30.940] Build Date: 08 February 2012 10:54:57PM
[ 30.940] Build ID: xorg-x11-server 1.11.4-1.fc16
[ 30.940] Current version of pixman: 0.22.2
[ 30.940] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 30.941] Markers: (--) probed, (**) from config file, (==) default
setting,

(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 30.942] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 15
20:17:36 2012

[ 31.007] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 31.007] (==) Using system config directory
"/usr/share/X11/xorg.conf.d"

[ 31.048] (==) No Layout section. Using the first Screen section.
[ 31.048] (**) |-->Screen "Default Screen" (0)
[ 31.048] (**) | |-->Monitor "VGA-1"
[ 31.048] (==) Automatically adding devices
[ 31.048] (==) Automatically enabling devices
[ 31.056] (==) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
[ 31.056] (**) ModulePath set to
"/usr/lib64/xorg/modules/extensions/nvidia,/usr/lib64/xorg/modules"
[ 31.056] (II) The server relies on udev to provide the list of input
devices.
If no devices become available, reconfigure udev or disable
AutoAddDevices.

[ 31.056] (II) Loader magic: 0x7caac0
[ 31.056] (II) Module ABI versions:
[ 31.056] X.Org ANSI C Emulation: 0.4
[ 31.056] X.Org Video Driver: 11.0
[ 31.056] X.Org XInput driver : 13.0
[ 31.056] X.Org Server Extension : 6.0
[ 31.058] (--) PCI:*(0:1:0:0) 10de:0a65:0000:0000 rev 162, Mem @
0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @
0x0000d800/128, BIOS @ 0x????????/524288

[ 31.058] (II) LoadModule: "extmod"
[ 31.072] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[ 31.082] (II) Module extmod: vendor="X.Org Foundation"
[ 31.082] compiled for 1.11.4, module version = 1.0.0
[ 31.082] Module class: X.Org Server Extension
[ 31.082] ABI class: X.Org Server Extension, version 6.0
[ 31.082] (II) Loading extension SELinux
[ 31.082] (II) Loading extension MIT-SCREEN-SAVER
[ 31.082] (II) Loading extension XFree86-VidModeExtension
[ 31.082] (II) Loading extension XFree86-DGA
[ 31.082] (II) Loading extension DPMS
[ 31.082] (II) Loading extension XVideo
[ 31.082] (II) Loading extension XVideo-MotionCompensation
[ 31.082] (II) Loading extension X-Resource
[ 31.082] (II) LoadModule: "dbe"
[ 31.083] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[ 31.084] (II) Module dbe: vendor="X.Org Foundation"
[ 31.084] compiled for 1.11.4, module version = 1.0.0
[ 31.084] Module class: X.Org Server Extension
[ 31.084] ABI class: X.Org Server Extension, version 6.0
[ 31.084] (II) Loading extension DOUBLE-BUFFER
[ 31.084] (II) LoadModule: "glx"
[ 31.084] (II) Loading
/usr/lib64/xorg/modules/extensions/nvidia/libglx.so

[ 31.391] (II) Module glx: vendor="NVIDIA Corporation"
[ 31.403] compiled for 4.0.2, module version = 1.0.0
[ 31.403] Module class: X.Org Server Extension
[ 31.403] (II) NVIDIA GLX Module 290.10 Wed Nov 16 18:01:24 PST 2011
[ 31.403] (II) Loading extension GLX
[ 31.403] (II) LoadModule: "record"
[ 31.404] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[ 31.410] (II) Module record: vendor="X.Org Foundation"
[ 31.410] compiled for 1.11.4, module version = 1.13.0
[ 31.410] Module class: X.Org Server Extension
[ 31.410] ABI class: X.Org Server Extension, version 6.0
[ 31.410] (II) Loading extension RECORD
[ 31.410] (II) LoadModule: "dri"
[ 31.411] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[ 31.437] (II) Module dri: vendor="X.Org Foundation"
[ 31.437] compiled for 1.11.4, module version = 1.0.0
[ 31.437] ABI class: X.Org Server Extension, version 6.0
[ 31.437] (II) Loading extension XFree86-DRI
[ 31.437] (II) LoadModule: "dri2"
[ 31.438] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[ 31.445] (II) Module dri2: vendor="X.Org Foundation"
[ 31.445] compiled for 1.11.4, module version = 1.2.0
[ 31.445] ABI class: X.Org Server Extension, version 6.0
[ 31.445] (II) Loading extension DRI2
[ 31.445] (==) Matched nouveau as autoconfigured driver 0
[ 31.445] (==) Matched vesa as autoconfigured driver 1
[ 31.445] (==) Matched fbdev as autoconfigured driver 2
[ 31.445] (==) Assigned the driver to the xf86ConfigLayout
[ 31.445] (II) LoadModule: "nouveau"
[ 31.447] (WW) Warning, couldn't open module nouveau
[ 31.447] (II) UnloadModule: "nouveau"
[ 31.447] (II) Unloading nouveau
[ 31.447] (EE) Failed to load module "nouveau" (module does not exist,
0)

[ 31.447] (II) LoadModule: "vesa"
[ 31.448] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 31.455] (II) Module vesa: vendor="X.Org Foundation"
[ 31.455] compiled for 1.10.99.902, module version = 2.3.0
[ 31.455] Module class: X.Org Video Driver
[ 31.455] ABI class: X.Org Video Driver, version 11.0
[ 31.455] (II) LoadModule: "fbdev"
[ 31.456] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 31.466] (II) Module fbdev: vendor="X.Org Foundation"
[ 31.466] compiled for 1.10.99.902, module version = 0.4.2
[ 31.466] ABI class: X.Org Video Driver, version 11.0
[ 31.466] (II) VESA: driver for VESA chipsets: vesa
[ 31.466] (II) FBDEV: driver for framebuffer: fbdev
[ 31.466] (--) using VT number 2

[ 31.471] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[ 31.471] Refusing to touch device with a bound kernel driver
[ 31.471] (WW) Falling back to old probe method for vesa
[ 31.471] (II) Loading sub module "fbdevhw"
[ 31.471] (II) LoadModule: "fbdevhw"
[ 31.472] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 31.482] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 31.482] compiled for 1.11.4, module version = 0.0.2
[ 31.482] ABI class: X.Org Video Driver, version 11.0
[ 31.482] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[ 31.482] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[ 31.487] (EE) open /dev/fb0: No such device
[ 31.487] (WW) Falling back to old probe method for fbdev
[ 31.487] (II) UnloadModule: "vesa"
[ 31.487] (II) Unloading vesa
[ 31.487] (II) UnloadModule: "fbdev"
[ 31.487] (II) Unloading fbdev
[ 31.487] (II) UnloadModule: "fbdevhw"
[ 31.487] (II) Unloading fbdevhw
[ 31.487] (EE) Screen(s) found, but none have a usable configuration.
[ 31.487]
Fatal server error:
[ 31.487] no screens found
[ 31.487]
Please consult the Fedora Project support
at http://wiki.x.org
for help.
[ 31.487] Please also check the log file at "/var/log/Xorg.0.log" for
additional information.

[ 31.487]
[ 31.499] Server terminated with error (1). Closing log file.




On Wednesday 15 February 2012 11:21:49 Patrick Dupre wrote:
Hello,

With te new kernel 3.2.5-3.fc16.x86_64
I cannot start the graphics mode!

[ 161.451] (II) LoadModule: "glx"
[ 161.451] (II) Loading
/usr/lib64/xorg/modules/extensions/nvidia/libglx.so
[ 161.454] (II) Module glx: vendor="NVIDIA Corporation"
[ 161.454] (II) NVIDIA GLX Module 290.10 Wed Nov 16 18:01:24 PST 2011

[snip]

[ 161.456] (II) LoadModule: "nouveau"
[ 161.456] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[ 161.456] (II) Module nouveau: vendor="X.Org Foundation"


You have both nVidia binary blob driver and Nouveau driver installed at the
same time. This is well-known to Not Work. Either remove the binary blob and
let Nouveau drive your hardware, or remove nouveau and let the binary blob
drive your hardware. The world is too small for both of them... ;-)


HTH, :-)
Marko


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org

--
---
================================================== ========================
Patrick DUPRÉ | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: patrick.dupre@york.ac.uk
================================================== ========================--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 07:38 PM
Marko Vojinovic
 
Default startx fails with new kernel

On Wednesday 15 February 2012 20:08:22 Patrick Dupre wrote:
> But could you tell me exactly what I should do?
>
> I removed xorg-x11-drv-nouveau (and xorg-x11-drivers), but I did
> not get any improvements (see below)
>
> Then I even cannot get back with the 1920x1080 resolution even with
> the previous kernel. So reinstalled the removed packages.

If you want to use nVidia's binary blob, then in general you should:

(a) enable rpmfusion repositories (you probably have done that already), and
(b) do a "yum install akmod-nvidia".

The latter will blacklist nouveau driver, rebuild your initrd image so that
nouveau doesn't get loaded on reboot, build the nVidia binary blob against
your running kernel (preferably the latest one), and set up xorg.conf
appropriately for nVidia driver to work. After that you must reboot for the
whole thing to take effect.

Note, though, that this is generic advice. Since it appears you have been
removing/installing packages randomly, something else might be broken as well.
If the above procedure doesn't give you expected results, post the latest
/var/log/Xorg.0.log again so that we can troubleshoot it further.

HTH, :-)
Marko


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 07:54 PM
Joe Zeff
 
Default startx fails with new kernel

On 02/15/2012 12:38 PM, Marko Vojinovic wrote:

(b) do a "yum install akmod-nvidia".


Back when I installed akmod-nvidia, it needed either kernel-devel or
kernel-headers, if not both. (It's been several years, so my memory's a
tad fuzzy.) However, for whatever reason, it didn't list them as
dependencies, which meant that you just had to know about them to get it
working right. Is that still true, or has that been corrected?

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 09:37 PM
Marko Vojinovic
 
Default startx fails with new kernel

On Wednesday 15 February 2012 12:54:30 Joe Zeff wrote:
> On 02/15/2012 12:38 PM, Marko Vojinovic wrote:
> > (b) do a "yum install akmod-nvidia".
>
> Back when I installed akmod-nvidia, it needed either kernel-devel or
> kernel-headers, if not both. (It's been several years, so my memory's a
> tad fuzzy.) However, for whatever reason, it didn't list them as
> dependencies, which meant that you just had to know about them to get it
> working right. Is that still true, or has that been corrected?

I don't know, but I assume yum will pull in any and all dependencies required
to make it work, including the kernel header packages and the development
toolchain for compilation.

On all machines where I had akmod-nvidia installed, I usually also had all
that other stuff already installed beforehand, so I am not sure if akmod would
drag it in if it weren't already there.

But even if it doesn't work automatically, the OP can always do it like this:

yum install kernel-headers kernel-devel
yum groupinstall "Development Tools"
yum install akmod-nvidia

That would probably cover all cases. :-) Also, IIRC, the OP had already
installed the nVidia's .run package which also needs all that stuff, so it's
likely he already has it all installed.

Best, :-)
Marko



--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 09:39 PM
Ian Malone
 
Default startx fails with new kernel

On 15 February 2012 22:37, Marko Vojinovic <vvmarko@gmail.com> wrote:
> On Wednesday 15 February 2012 12:54:30 Joe Zeff wrote:
>> On 02/15/2012 12:38 PM, Marko Vojinovic wrote:
>> > (b) do a "yum install akmod-nvidia".
>>
>> Back when I installed akmod-nvidia, it needed either kernel-devel or
>> kernel-headers, if not both. *(It's been several years, so my memory's a
>> tad fuzzy.) *However, for whatever reason, it didn't list them as
>> dependencies, which meant that you just had to know about them to get it
>> working right. *Is that still true, or has that been corrected?
>
> I don't know, but I assume yum will pull in any and all dependencies required
> to make it work, including the kernel header packages and the development
> toolchain for compilation.
>
> On all machines where I had akmod-nvidia installed, I usually also had all
> that other stuff already installed beforehand, so I am not sure if akmod would
> drag it in if it weren't already there.
>
> But even if it doesn't work automatically, the OP can always do it like this:
>
> yum install kernel-headers kernel-devel
> yum groupinstall "Development Tools"
> yum install akmod-nvidia
>
> That would probably cover all cases. :-) Also, IIRC, the OP had already
> installed the nVidia's .run package which also needs all that stuff, so it's
> likely he already has it all installed.
>

$ rpm -qR akmods|grep devel
kernel-devel

...so yes it's listed as a dependency and should get pulled in by yum.

--
imalone
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 09:57 PM
Joe Zeff
 
Default startx fails with new kernel

On 02/15/2012 02:37 PM, Marko Vojinovic wrote:

I don't know, but I assume yum will pull in any and all dependencies required
to make it work, including the kernel header packages and the development
toolchain for compilation.


That's true if and only if they're properly listed. Back when I
installed them, they weren't, so yum had no way of knowing that they
were needed.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 02-15-2012, 09:58 PM
Joe Zeff
 
Default startx fails with new kernel

On 02/15/2012 02:39 PM, Ian Malone wrote:

$ rpm -qR akmods|grep devel
kernel-devel

...so yes it's listed as a dependency and should get pulled in by yum.


...and that also answers my question.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 

Thread Tools




All times are GMT. The time now is 05:37 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org