Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   iptables? issue (http://www.linux-archive.org/fedora-user/632487-iptables-issue.html)

02-13-2012 06:34 PM

iptables? issue
 
Hi,

*

I'm hoping that you can point out what i'm missing here. I have a server (router0) with a public ip 41.123.234.74/29 that's using an internet modem 41.123.234.73/29 as a gateway. the server (router0) also has a second card used for lan comms where it has ip address 10.0.0.1/8. addresses are broadcast via dhcp along with DNS and gateway settings and everything works perfectly when i MASQUERADE the local ips to the wan address with iptables.*

*

The issue is this: i'm trying to set up another server (db0) behind router0 on the lan side and want to have it's packets go the my router0 gateway and be forwarded to the internet side and vice versa. db0 has an address 41.123.234.75/29 with .74 set as the gateway. if i set up my addressing on db0 using lan addresses and 10.0.0.1 my db0 server can connect and everything but if i use the wan address i can't connect even to the 41.123.234.74/29 router0 address. i had inserted the following rule to my tables forward chain:*

iptables -I FORWARD -s 41.123.234.72/29 -j ACCEPT*

to allow public packets from either side to be forwarded to both sides but i can't seem to get the boxes to through to each other.

*

Can anyone tell me were i'm getting it wrong?

*

Thanks in advance

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org

gary artim 02-13-2012 07:14 PM

iptables? issue
 
if you own both address you need to alias your nic with the other address.

ifcfg-eth0:0

add in /etc/sysconfig/network-scripts


On Mon, Feb 13, 2012 at 11:34 AM, <nullv@gmx.com> wrote:
> Hi,
>
> I'm hoping that you can point out what i'm missing here. I have a server
> (router0) with a public ip 41.123.234.74/29 that's using an internet modem
> 41.123.234.73/29 as a gateway. the server (router0) also has a second card
> used for lan comms where it has ip address 10.0.0.1/8. addresses are
> broadcast via dhcp along with DNS and gateway settings and everything works
> perfectly when i MASQUERADE the local ips to the wan address with iptables.
>
> The issue is this: i'm trying to set up another server (db0) behind router0
> on the lan side and want to have it's packets go the my router0 gateway and
> be forwarded to the internet side and vice versa. db0 has an address
> 41.123.234.75/29 with .74 set as the gateway. if i set up my addressing on
> db0 using lan addresses and 10.0.0.1 my db0 server can connect and
> everything but if i use the wan address i can't connect even to the
> 41.123.234.74/29 router0 address. i had inserted the following rule to my
> tables forward chain:
> iptables -I FORWARD -s 41.123.234.72/29 -j ACCEPT
> to allow public packets from either side to be forwarded to both sides but i
> can't seem to get the boxes to through to each other.
>
> Can anyone tell me were i'm getting it wrong?
>
> Thanks in advance
>
> --
> users mailing list
> users@lists.fedoraproject.org
> To unsubscribe or change subscription options:
> https://admin.fedoraproject.org/mailman/listinfo/users
> Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
> Have a question? Ask away: http://ask.fedoraproject.org
>
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org


All times are GMT. The time now is 07:18 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.