Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   gphoto2 (http://www.linux-archive.org/fedora-user/629310-gphoto2.html)

Patrick Dupre 02-05-2012 09:28 PM

gphoto2
 
Hello,

With the version 16, as a user,

gphoto2 -l

gives:


*** Error ***
An error occurred in the io-library ('I/O problem'): Could not open USB
device (Permission denied).

*** Error (-7: 'I/O problem') ***

For debugging messages, please use the --debug option.
Debugging messages may help finding a solution to your problem.
If you intend to send any error or debug messages to the gphoto
developer mailing list <gphoto-devel@lists.sourceforge.net>, please run
gphoto2 as follows:

env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt -l

Please make sure there is sufficient quoting around the arguments.

while as root:

There is 1 folder in folder '/'.
- store_00010001
There are 0 folders in folder '/store_00010001'.


lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 413c:a005 Dell Computer Corp. Internal 2.0 Hub
Bus 004 Device 002: ID 046d:c047 Logitech, Inc. Laser Mouse
Bus 001 Device 004: ID 152d:2338 JMicron Technology Corp. / JMicron USA
Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo Bridge

Bus 001 Device 013: ID 054c:004e Sony Corp. DSC-xxx (ptp)


It looks like that there is a right issue.

running selinux in permissive mode does not help.

How can I fix this issue?
Thank.

Regards.


--
---
================================================== ========================
Patrick DUPRÉ | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: patrick.dupre@york.ac.uk
================================================== ========================--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org

Rockinghorse Winner 02-08-2012 05:09 AM

gphoto2
 
On Sun, Feb 05, 2012 at 10:28:25PM +0000, Patrick Dupre wrote:
> Hello,
>
> With the version 16, as a user,
>
> gphoto2 -l
>
> gives:
>
>
> *** Error ***
> An error occurred in the io-library ('I/O problem'): Could not open
> USB device (Permission denied).
> *** Error (-7: 'I/O problem') ***
>
> For debugging messages, please use the --debug option.
> Debugging messages may help finding a solution to your problem.
> If you intend to send any error or debug messages to the gphoto
> developer mailing list <gphoto-devel@lists.sourceforge.net>, please run
> gphoto2 as follows:
>
> env LANG=C gphoto2 --debug --debug-logfile=my-logfile.txt -l
>
> Please make sure there is sufficient quoting around the arguments.
>
> while as root:
>
> There is 1 folder in folder '/'.
> - store_00010001
> There are 0 folders in folder '/store_00010001'.
>
>
> lsusb
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 002: ID 413c:a005 Dell Computer Corp. Internal 2.0 Hub
> Bus 004 Device 002: ID 046d:c047 Logitech, Inc. Laser Mouse
> Bus 001 Device 004: ID 152d:2338 JMicron Technology Corp. / JMicron
> USA Technology Corp. JM20337 Hi-Speed USB to SATA & PATA Combo
> Bridge
> Bus 001 Device 013: ID 054c:004e Sony Corp. DSC-xxx (ptp)
>
>
> It looks like that there is a right issue.
>
> running selinux in permissive mode does not help.
>
> How can I fix this issue?
> Thank.
>
> Regards.
>
>
> --
> ---
> ================================================== ========================
> Patrick DUPRÉ | |
> Department of Chemistry | | Phone: (44)-(0)-1904-434384
> The University of York | | Fax: (44)-(0)-1904-432516
> Heslington | |
> York YO10 5DD United Kingdom | | email: patrick.dupre@york.ac.uk
> ================================================== ========================


I don't know if this would help or not; I recently had a similar issue with
xsane - would not find my printer which was on a USB port. So I used lsusb
to find which bus/device the printer was on, then changed the permission to
a+w for the /dev/bus/usb/ device in question. Then, I was able to run xsane
as a normal user. HTH.

Terry
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org


All times are GMT. The time now is 08:35 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.