FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 03-31-2008, 08:49 AM
Boris Glawe
 
Default ndiswrapper with 2.6.24 kernels

Hi,

has anybody successfully installed the freshrpm's dkms-ndiswrapper package?

The installation itself is not the problem, but the kernel module
compilation fails.


The kernel modules was usually compiled and properly installed with the
execution of "/etc/init.d/dkms start". This command still does not show
any error messages, but after returning after some seconds of operation,
there's no kernel module in /lib/modules/`uname -r` which is confirmed
by modprobe : "FATAL: Module ndiswrapper not found."


Nobody's reporting any problems?! How are you using ndiswrapper WLAN
adapters with F8 and 2.6.24.x kernels?


Thanks and greets
Boris

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 03-31-2008, 11:58 AM
"Mark Haney"
 
Default ndiswrapper with 2.6.24 kernels

Boris Glawe wrote:

Hi,

has anybody successfully installed the freshrpm's dkms-ndiswrapper package?

The installation itself is not the problem, but the kernel module
compilation fails.


The kernel modules was usually compiled and properly installed with the
execution of "/etc/init.d/dkms start". This command still does not show
any error messages, but after returning after some seconds of operation,
there's no kernel module in /lib/modules/`uname -r` which is confirmed
by modprobe : "FATAL: Module ndiswrapper not found."


Nobody's reporting any problems?! How are you using ndiswrapper WLAN
adapters with F8 and 2.6.24.x kernels?


Thanks and greets
Boris




IIRC (and I've been on vacation, so my brain hasn't caught up yet),
Linus himself got involved with the NDISwrapper code being GPL'd. He
put the kibosh on exporting the symbols needed to load it since in his
mind it CAN'T be GPL if it loads non-GPL binaries. IANAL, so take that
how you will. The thread was on Slashdot a couple weeks ago. It's my
understanding that ndiswrapper is broken in the .24 kernels and hasn't
been fixed yet.


Granted, it's also my understanding the new WIFI stack is supposed to
have much better support for cards in .24, but I can't say for certain yet.



--
Libenter homines id quod volunt credunt -- Caius Julius Caesar


Mark Haney
Sr. Systems Administrator
ERC Broadband
(828) 350-2415

Call (866) ERC-7110 for after hours support

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 03-31-2008, 05:43 PM
Rick Bilonick
 
Default ndiswrapper with 2.6.24 kernels

On Mon, 2008-03-31 at 07:58 -0400, Mark Haney wrote:
> Boris Glawe wrote:
> > Hi,
> >
> > has anybody successfully installed the freshrpm's dkms-ndiswrapper package?
> >
> > The installation itself is not the problem, but the kernel module
> > compilation fails.
> >
> > The kernel modules was usually compiled and properly installed with the
> > execution of "/etc/init.d/dkms start". This command still does not show
> > any error messages, but after returning after some seconds of operation,
> > there's no kernel module in /lib/modules/`uname -r` which is confirmed
> > by modprobe : "FATAL: Module ndiswrapper not found."
> >
> > Nobody's reporting any problems?! How are you using ndiswrapper WLAN
> > adapters with F8 and 2.6.24.x kernels?
> >
> > Thanks and greets
> > Boris
> >
>
>
> IIRC (and I've been on vacation, so my brain hasn't caught up yet),
> Linus himself got involved with the NDISwrapper code being GPL'd. He
> put the kibosh on exporting the symbols needed to load it since in his
> mind it CAN'T be GPL if it loads non-GPL binaries. IANAL, so take that
> how you will. The thread was on Slashdot a couple weeks ago. It's my
> understanding that ndiswrapper is broken in the .24 kernels and hasn't
> been fixed yet.
>
> Granted, it's also my understanding the new WIFI stack is supposed to
> have much better support for cards in .24, but I can't say for certain yet.
>
>
> --
> Libenter homines id quod volunt credunt -- Caius Julius Caesar
>
>
> Mark Haney
> Sr. Systems Administrator
> ERC Broadband
> (828) 350-2415
>
> Call (866) ERC-7110 for after hours support
>

I'm using ndiswrapper with this kernel:

[chippy@localhost ~]$ uname -r
2.6.24.3-50.fc8

But I'm using Livna's packages.

Rick B.

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 03-31-2008, 05:54 PM
Arch Willingham
 
Default ndiswrapper with 2.6.24 kernels

Ndiswrapper works for me too...current versions of FC8 and FC9.

Arch

-----Original Message-----
From: fedora-list-bounces@redhat.com [mailto:fedora-list-bounces@redhat.com] On Behalf Of Rick Bilonick
Sent: Monday, March 31, 2008 1:44 PM
To: For users of Fedora
Subject: Re: ndiswrapper with 2.6.24 kernels


On Mon, 2008-03-31 at 07:58 -0400, Mark Haney wrote:
> Boris Glawe wrote:
> > Hi,
> >
> > has anybody successfully installed the freshrpm's dkms-ndiswrapper package?
> >
> > The installation itself is not the problem, but the kernel module
> > compilation fails.
> >
> > The kernel modules was usually compiled and properly installed with the
> > execution of "/etc/init.d/dkms start". This command still does not show
> > any error messages, but after returning after some seconds of operation,
> > there's no kernel module in /lib/modules/`uname -r` which is confirmed
> > by modprobe : "FATAL: Module ndiswrapper not found."
> >
> > Nobody's reporting any problems?! How are you using ndiswrapper WLAN
> > adapters with F8 and 2.6.24.x kernels?
> >
> > Thanks and greets
> > Boris
> >
>
>
> IIRC (and I've been on vacation, so my brain hasn't caught up yet),
> Linus himself got involved with the NDISwrapper code being GPL'd. He
> put the kibosh on exporting the symbols needed to load it since in his
> mind it CAN'T be GPL if it loads non-GPL binaries. IANAL, so take that
> how you will. The thread was on Slashdot a couple weeks ago. It's my
> understanding that ndiswrapper is broken in the .24 kernels and hasn't
> been fixed yet.
>
> Granted, it's also my understanding the new WIFI stack is supposed to
> have much better support for cards in .24, but I can't say for certain yet.
>
>
> --
> Libenter homines id quod volunt credunt -- Caius Julius Caesar
>
>
> Mark Haney
> Sr. Systems Administrator
> ERC Broadband
> (828) 350-2415
>
> Call (866) ERC-7110 for after hours support
>

I'm using ndiswrapper with this kernel:

[chippy@localhost ~]$ uname -r
2.6.24.3-50.fc8

But I'm using Livna's packages.

Rick B.

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 04-01-2008, 02:39 PM
Boris Glawe
 
Default ndiswrapper with 2.6.24 kernels

ed, it's also my understanding the new WIFI stack is supArch Willingham
schrieb:

Ndiswrapper works for me too...current versions of FC8 and FC9.

Arch



Which packages do you use? Freshrpms's or livna's?

I've successfully compiled the source packages, that are provided by the
ndiswrapper project, but the compiled module coud not be loaded.
Unfortunately, I cannot remember the exact error message. It was a very
general message, though. I'll retry it, when I find some time!


Thanks and greets
Boris

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 03:53 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org