FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 03-29-2008, 05:26 PM
Gene Heskett
 
Default Error: API mismatch: the NVIDIA kernel module has version 169.12,

On Saturday 29 March 2008, François Patte wrote:
>Bonjour,
>
>I have an Nvidia graphic card and use dkms_autoinstaller to
>install/compile the driver from freshrpms.
>
>I get this message:
>
>Error: API mismatch: the NVIDIA kernel module has version 169.12,
>but this NVIDIA driver component has version 169.07. Please make
>sure that the kernel module and all NVIDIA driver components
>have the same version.
>NVIDIA: Direct rendering failed; attempting indirect rendering.
>Error: API mismatch: the NVIDIA kernel module has version 169.12,
>but this NVIDIA driver component has version 169.07. Please make
>sure that the kernel module and all NVIDIA driver components
>have the same version.
>NVIDIA: Direct rendering failed; attempting indirect rendering.
>
>How can I correct this?
>
I have my own installer routine, but you need to do the sh ./NVIDIA*.run once
at the beginning of using a new version as that will rebuild all the
libraries and such with the proper versioning. I suspect that this dkms
thingy does it like my script in that it only builds the kernel module, and
if the libraries don't match, it will error out with messages resembling
those.

>thanks.
>--
>François Patte
>UFR de mathématiques et informatique
>Université Paris Descartes
>45, rue des Saints Pères
>F-75270 Paris Cedex 06
>Tél. +33 (0)1 44 55 35 61
>http://www.math-info.univ-paris5.fr/~patte



--
Cheers, Gene
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
> Tut mir Leid, Jost, aber Du bist ein unertraeglicher Troll.
Was soll das? Du *beleidigst* die Trolle!
-- de.comp.os.unix.linux.misc

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 04:02 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org