FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 11-30-2011, 07:23 PM
Lucélio Gomes de Freitas
 
Default Help with "sudo yum update"

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi everybody,

I've never seen an error like this. Anybody helps?
================================================== ===============
[Lucelio@MAQ02 ~]$ uname -r
3.1.2-1.fc16.x86_64
[Lucelio@MAQ02 ~]$ sudo yum update
Plugins carregados: refresh-packagekit
Configurando o processo de atualização
Resolvendo dependências
- --> Executando verificação da transação
- ---> Package gtk2.i686 0:2.24.7-3.fc16 will be atualizado
- ---> Package gtk2.i686 0:2.24.8-2.fc16 will be an update
- ---> Package preupgrade.noarch 0:1.1.9-1.fc16 will be atualizado
- ---> Package preupgrade.noarch 0:1.1.10-1.fc16 will be an update
- --> Resolução de dependências finalizada
Error: Protected multilib versions: gtk2-2.24.8-2.fc16.i686 !=
gtk2-2.24.7-3.fc16.x86_64
[Lucelio@MAQ02 ~]$
================================================== ===============
So I can't update the system.

Thanks in advance.

- --
Lucélio Gomes de Freitas
ETFCSF-> U.G.F.-> P.U.C.(RJ)
Engº, Analista Suporte(Free Mind).
Email: aa.lucelio@gmail.com
Tel: 55 0XX 21 85964911
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iF4EAREIAAYFAk7WkLcACgkQENqGaHfBA/eC9gD9HEDn7ph5Km6BtnLouoriv3eW
NxOkqhVa9Jq68GnhnN4A/RuT2oabrYBkzyXoMbzBjFtvyuUAS/KM+PX4+0Ys+U0s
=0wn3
-----END PGP SIGNATURE-----

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 07:39 PM
Joe Zeff
 
Default Help with "sudo yum update"

On 11/30/2011 12:23 PM, Lucélio Gomes de Freitas wrote:
> So I can't update the system.

Sure you can:

su -c 'yum update --skip-broken'

will do the job just fine. HTH, HAND.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:09 PM
Lucélio Gomes de Freitas
 
Default Help with "sudo yum update"

Joe,

Did't work.
================================================== ===============
[Lucelio@MAQ02 ~]$ su -c 'yum update --skip-broken'
Senha:
Plugins carregados: refresh-packagekit
Configurando o processo de atualização
Resolvendo dependências
--> Executando verificação da transação
---> Package gtk2.i686 0:2.24.7-3.fc16 will be atualizado
---> Package gtk2.i686 0:2.24.8-2.fc16 will be an update
---> Package preupgrade.noarch 0:1.1.9-1.fc16 will be atualizado
---> Package preupgrade.noarch 0:1.1.10-1.fc16 will be an update
--> Resolução de dependências finalizada
Error: Protected multilib versions: gtk2-2.24.8-2.fc16.i686 !=
gtk2-2.24.7-3.fc16.x86_64
[Lucelio@MAQ02 ~]$
================================================== ===============

Any other try?

Thx,

Em 30-11-2011 18:39, Joe Zeff escreveu:
> On 11/30/2011 12:23 PM, Lucélio Gomes de Freitas wrote:
>> So I can't update the system.
> Sure you can:
>
> su -c 'yum update --skip-broken'
>
> will do the job just fine. HTH, HAND.

--
Lucélio Gomes de Freitas
ETFCSF-> U.G.F.-> P.U.C.(RJ)
Engº, Analista Suporte(Free Mind).
Email: aa.lucelio@gmail.com
Tel: 55 0XX 21 85964911

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:21 PM
Joe Zeff
 
Default Help with "sudo yum update"

On 11/30/2011 01:09 PM, Lucélio Gomes de Freitas wrote:
> ---> Package gtk2.i686 0:2.24.7-3.fc16 will be atualizado
> ---> Package gtk2.i686 0:2.24.8-2.fc16 will be an update
> ---> Package preupgrade.noarch 0:1.1.9-1.fc16 will be atualizado
> ---> Package preupgrade.noarch 0:1.1.10-1.fc16 will be an update
> --> Resolução de dependências finalizada
> Error: Protected multilib versions: gtk2-2.24.8-2.fc16.i686 !=
> gtk2-2.24.7-3.fc16.x86_64
> [Lucelio@MAQ02 ~]$
> ================================================== ===============
>
> Any other try?

I note two things. First every package that's being updated is either
.i686 or .noarch but the error message complains about a file not being
equal to an .x86_64 file. If your system's not 64 bit, you shouldn't be
needing any .x86_64 programs/libs installed. Second, the first of the
two files in the error message is a newer version than the other, which
is a tad odd.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:27 PM
Dennis Kaptain
 
Default Help with "sudo yum update"

>________________________________
> De: Lucélio Gomes de Freitas <aa.lucelio@gmail.com>
>Para: Community support for Fedora users <users@lists.fedoraproject.org>
>Enviado: Miércoles, 30 de noviembre, 2011 14:23:19
>Asunto: Help with "sudo yum update"
>
>
>-----BEGIN PGP SIGNED MESSAGE-----
>Hash: SHA256
>
>Hi everybody,
>
>I've never seen an error like this.* Anybody helps?
>================================================= ================
>[Lucelio@MAQ02 ~]$ uname -r
>3.1.2-1.fc16.x86_64
>[Lucelio@MAQ02 ~]$ sudo yum update
>Plugins carregados: refresh-packagekit
>Configurando o processo de atualização
>Resolvendo dependências
>- --> Executando verificação da transação
>- ---> Package gtk2.i686 0:2.24.7-3.fc16 will be atualizado
>- ---> Package gtk2.i686 0:2.24.8-2.fc16 will be an update
>- ---> Package preupgrade.noarch 0:1.1.9-1.fc16 will be atualizado
>- ---> Package preupgrade.noarch 0:1.1.10-1.fc16 will be an update
>- --> Resolução de dependências finalizada
>Error: Protected multilib versions: gtk2-2.24.8-2.fc16.i686 !=
>gtk2-2.24.7-3.fc16.x86_64
>[Lucelio@MAQ02 ~]$
>================================================= ================
>So I can't update the system.
>
>Thanks in advance.
>
>- --
>Lucélio Gomes de Freitas
>ETFCSF-> U.G.F.-> P.U.C.(RJ)
>Engº, Analista Suporte(Free Mind).
>Email: aa.lucelio@gmail.com
>Tel: 55 0XX 21 85964911
>-----BEGIN PGP SIGNATURE-----
>Version: GnuPG v1.4.11 (GNU/Linux)
>Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>
>iF4EAREIAAYFAk7WkLcACgkQENqGaHfBA/eC9gD9HEDn7ph5Km6BtnLouoriv3eW
>NxOkqhVa9Jq68GnhnN4A/RuT2oabrYBkzyXoMbzBjFtvyuUAS/KM+PX4+0Ys+U0s
>=0wn3
>-----END PGP SIGNATURE-----
>
>--
>users mailing list
>users@lists.fedoraproject.org
>To unsubscribe or change subscription options:
>https://admin.fedoraproject.org/mailman/listinfo/users
>Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
>Have a question? Ask away: http://ask.fedoraproject.org
>
>


A partial workaround is
sudo yum --skip-broken update

You will still not get the update for gtk2 but at least the others will work.

DK
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:34 PM
"T.C. Hollingsworth"
 
Default Help with "sudo yum update"

2011/11/30 Lucélio Gomes de Freitas <aa.lucelio@gmail.com>:
> Hi everybody,
>
> I've never seen an error like this. *Anybody helps?
> ================================================== ===============
> [Lucelio@MAQ02 ~]$ uname -r
> 3.1.2-1.fc16.x86_64
> [Lucelio@MAQ02 ~]$ sudo yum update
> Plugins carregados: refresh-packagekit
> Configurando o processo de atualização
> Resolvendo dependências
> - --> Executando verificação da transação
> - ---> Package gtk2.i686 0:2.24.7-3.fc16 will be atualizado
> - ---> Package gtk2.i686 0:2.24.8-2.fc16 will be an update
> - ---> Package preupgrade.noarch 0:1.1.9-1.fc16 will be atualizado
> - ---> Package preupgrade.noarch 0:1.1.10-1.fc16 will be an update
> - --> Resolução de dependências finalizada
> Error: Protected multilib versions: gtk2-2.24.8-2.fc16.i686 !=
> gtk2-2.24.7-3.fc16.x86_64
> [Lucelio@MAQ02 ~]$
> ================================================== ===============
> So I can't update the system.

Hmm, for some reason YUM finds an update for i686 gtk2 but not x86_64
gtk2. AFAICT, gtk2-2.24.8-2.fc16 is in the updates repo for both
arches.

Run "yum clean all" and try again. If it still fails, provide the
output of "yum info gtk2".

-T.C.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:39 PM
Lucélio Gomes de Freitas
 
Default Help with "sudo yum update"

Joe,

I don't know what .i686 is doing there. I use always .x86_64 since the
beginnig of Fedora10.
My be because of Skype? What do you think?

The last "sudo yum update" ran last saturday, without any problem.
I didn't install anythig. Why "Error: Protected multilib ...."?

Em 30-11-2011 19:21, Joe Zeff escreveu:
> On 11/30/2011 01:09 PM, Lucélio Gomes de Freitas wrote:
>> ---> Package gtk2.i686 0:2.24.7-3.fc16 will be atualizado
>> ---> Package gtk2.i686 0:2.24.8-2.fc16 will be an update
>> ---> Package preupgrade.noarch 0:1.1.9-1.fc16 will be atualizado
>> ---> Package preupgrade.noarch 0:1.1.10-1.fc16 will be an update
>> --> Resolução de dependências finalizada
>> Error: Protected multilib versions: gtk2-2.24.8-2.fc16.i686 !=
>> gtk2-2.24.7-3.fc16.x86_64
>> [Lucelio@MAQ02 ~]$
>> ================================================== ===============
>>
>> Any other try?
> I note two things. First every package that's being updated is either
> .i686 or .noarch but the error message complains about a file not being
> equal to an .x86_64 file. If your system's not 64 bit, you shouldn't be
> needing any .x86_64 programs/libs installed. Second, the first of the
> two files in the error message is a newer version than the other, which
> is a tad odd.

--
Lucélio Gomes de Freitas
ETFCSF-> U.G.F.-> P.U.C.(RJ)
Engº, Analista Suporte(Free Mind).
Email: aa.lucelio@gmail.com
Tel: 55 0XX 21 85964911

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:43 PM
"T.C. Hollingsworth"
 
Default Help with "sudo yum update"

2011/11/30 Lucélio Gomes de Freitas <aa.lucelio@gmail.com>:
> Joe,
>
> I don't know what .i686 is doing there. *I use always .x86_64 since the
> beginnig of Fedora10.
> My be because of Skype? *What do you think?

Yeah, Skype requires a bunch of 32-bit libraries. It's usually
harmless, although you seem to have run into a glitch.

> The last "sudo yum update" ran last saturday, without any problem.
> I didn't install anythig. *Why "Error: Protected multilib ...."?

YUM ensures that when you have x86_64 and i686 libraries installed,
they both stay at the same version. (Things can get screwed up pretty
badly if their versions differ.) For some reason, YUM found an update
for the i686 version, but not the x86_64 version, so it failed out
rather than install it and potentially screw up your system.

From here I can see that the new gtk2 is present for both x86_64 and
i686, so likely your YUM metadata is outdated/incorrect. "yum clean
all" will erase it and force it to redownload on the next update.

-T.C.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:48 PM
Joe Zeff
 
Default Help with "sudo yum update"

On 11/30/2011 01:39 PM, Lucélio Gomes de Freitas wrote:
> I don't know what .i686 is doing there. I use always .x86_64 since the
> beginnig of Fedora10.
> My be because of Skype? What do you think?

To be honest, I've no idea. I've never needed to use the 64 bit
version. However, I'm sure there's somebody out there on this list who
can help. If nothing else, I've helped you eliminate one possibility
and may have pointed somebody in the right direction.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 
Old 11-30-2011, 08:54 PM
Lucélio Gomes de Freitas
 
Default Help with "sudo yum update"

T.C.,



Sorry for the big E-mail.** Same thing:

================================================== ===============

[Lucelio@MAQ02 ~]$ sudo yum clean all

Plugins carregados: refresh-packagekit

Limpando tudo

[Lucelio@MAQ02 ~]$ sudo yum update

Plugins carregados: refresh-packagekit

Webmin******************************************** ********* |* 951
B**** 00:00** *

Webmin/primary**************************************** |* 12 kB****
00:00** *

Webmin******************************************** *********************************
95/95

adobe-linux-i386**************************************** |* 951
B**** 00:00** *

adobe-linux-i386/primary*************************** |* 11 kB****
00:00** *

adobe-linux-i386********************************************** *******************
17/17

fedora******************************************** ************ | 4.2
kB**** 00:00** *

fedora/primary_db************************************* |* 14 MB****
00:07** *

google-talkplugin**************************************** |* 951
B**** 00:00** *

google-talkplugin/primary*************************** | 1.6 kB****
00:00** *

google-talkplugin**************************************** *************************
1/1

kde*********************************************** ************** |
2.1 kB**** 00:00** *

kde/primary_db**************************************** ** | 199
kB**** 00:01** *

kde-all*********************************************** ********** |
1.9 kB**** 00:00** *

kde-all/primary_db************************************** |* 81
kB**** 00:00** *

rpmfusion-free******************************************* | 2.7
kB**** 00:00** *

rpmfusion-free/primary_db************************* | 373 kB****
00:06** *

rpmfusion-free-updates****************************** | 3.3 kB****
00:00** *

rpmfusion-free-updates/primary_db*********** |* 28 kB**** 00:00** *

rpmfusion-nonfree************************************* | 2.7 kB****
00:00** *

rpmfusion-nonfree/primary_db****************** | 111 kB**** 00:01**
*

rpmfusion-nonfree-updates*********************** | 3.3 kB****
00:00** *

rpmfusion-nonfree-updates/primary_db***** |* 28 kB**** 00:00** *

updates/metalink**************************************** |* 44
kB**** 00:00** *

updates******************************************* *********** | 4.7
kB**** 00:00** *

updates/primary_db*********************************** | 2.5 MB****
00:01** *

virtualbox**************************************** *********** |* 951
B**** 00:00** *

virtualbox/primary************************************** | 1.8
kB**** 00:00** *

virtualbox**************************************** *************************************
1/1

Configurando o processo de atualização

Resolvendo dependências

--> Executando verificação da transação

---> Package gtk2.i686 0:2.24.7-3.fc16 will be atualizado

---> Package gtk2.i686 0:2.24.8-2.fc16 will be an update

---> Package preupgrade.noarch 0:1.1.9-1.fc16 will be atualizado

---> Package preupgrade.noarch 0:1.1.10-1.fc16 will be an update

--> Resolução de dependências finalizada

Error: Protected multilib versions: gtk2-2.24.8-2.fc16.i686 !=
gtk2-2.24.7-3.fc16.x86_64

[Lucelio@MAQ02 ~]$ sudo yum info gtk2

Plugins carregados: refresh-packagekit

Pacotes instalados

Nome******* : gtk2

Arquitetura******* : i686

Versão**** : 2.24.7

Lançamento**** : 3.fc16

Tamanho******* : 13 M

Repo******* : installed

Do repositório** : anaconda-0

Sumário**** : GIMP ToolKit (GTK+), uma biblioteca para criar GUIs
para o X.

URL******** : http://www.gtk.org

Licença**** : LGPLv2+

Descrição : O GTK+ é uma ferramenta multi-plataforma para criar
interfaces gráficas para o

********* : usuário. Ao oferecer um conjunto completo de ítens
gráficos, o GTK+ é

********* : adequado para os projetos que vão de pequenas
ferramentas a pacotes

********* : de aplicações completos.



Nome******* : gtk2

Arquitetura******* : x86_64

Versão**** : 2.24.7

Lançamento**** : 3.fc16

Tamanho******* : 13 M

Repo******* : installed

Do repositório** : anaconda-0

Sumário**** : GIMP ToolKit (GTK+), uma biblioteca para criar GUIs
para o X.

URL******** : http://www.gtk.org

Licença**** : LGPLv2+

Descrição : O GTK+ é uma ferramenta multi-plataforma para criar
interfaces gráficas para o

********* : usuário. Ao oferecer um conjunto completo de ítens
gráficos, o GTK+ é

********* : adequado para os projetos que vão de pequenas
ferramentas a pacotes

********* : de aplicações completos.



Nome******* : gtk2

Arquitetura******* : x86_64

Versão**** : 2.24.8

Lançamento**** : 2.fc16

Tamanho******* : 13 M

Repo******* : installed

Sumário**** : GIMP ToolKit (GTK+), uma biblioteca para criar GUIs
para o X.

URL******** : http://www.gtk.org

Licença**** : LGPLv2+

Descrição : O GTK+ é uma ferramenta multi-plataforma para criar
interfaces gráficas para o

********* : usuário. Ao oferecer um conjunto completo de ítens
gráficos, o GTK+ é

********* : adequado para os projetos que vão de pequenas
ferramentas a pacotes

********* : de aplicações completos.



Pacotes disponíveis

Nome******* : gtk2

Arquitetura******* : i686

Versão**** : 2.24.8

Lançamento**** : 2.fc16

Tamanho******* : 3.2 M

Repo******* : updates

Sumário**** : GIMP ToolKit (GTK+), uma biblioteca para criar GUIs
para o X.

URL******** : http://www.gtk.org

Licença**** : LGPLv2+

Descrição : O GTK+ é uma ferramenta multi-plataforma para criar
interfaces gráficas para o

********* : usuário. Ao oferecer um conjunto completo de ítens
gráficos, o GTK+ é

********* : adequado para os projetos que vão de pequenas
ferramentas a pacotes

********* : de aplicações completos.



[Lucelio@MAQ02 ~]$

================================================== ===============



Em 30-11-2011 19:34, T.C. Hollingsworth escreveu:

> 2011/11/30 Lucélio Gomes de
Freitas <aa.lucelio@gmail.com>:

>> Hi everybody,

>>

>> I've never seen an error like this. Anybody helps?

>>
================================================== ===============

>> [Lucelio@MAQ02 ~]$ uname -r

>> 3.1.2-1.fc16.x86_64

>> [Lucelio@MAQ02 ~]$ sudo yum update

>> Plugins carregados: refresh-packagekit

>> Configurando o processo de atualização

>> Resolvendo dependências

>> - --> Executando verificação da transação

>> - ---> Package gtk2.i686 0:2.24.7-3.fc16 will be
atualizado

>> - ---> Package gtk2.i686 0:2.24.8-2.fc16 will be an
update

>> - ---> Package preupgrade.noarch 0:1.1.9-1.fc16 will
be atualizado

>> - ---> Package preupgrade.noarch 0:1.1.10-1.fc16 will
be an update

>> - --> Resolução de dependências finalizada

>> Error: Protected multilib versions:
gtk2-2.24.8-2.fc16.i686 !=

>> gtk2-2.24.7-3.fc16.x86_64

>> [Lucelio@MAQ02 ~]$

>>
================================================== ===============

>> So I can't update the system.

>

> Hmm, for some reason YUM finds an update for i686 gtk2 but
not x86_64

> gtk2. AFAICT, gtk2-2.24.8-2.fc16 is in the updates repo for
both

> arches.

>

> Run "yum clean all" and try again. If it still fails, provide
the

> output of "yum info gtk2".

>

> -T.C.



--

Lucélio Gomes de Freitas

ETFCSF-> U.G.F.-> P.U.C.(RJ)

Engº, Analista Suporte(Free Mind).

Email: aa.lucelio@gmail.com

Tel: 55 0XX 21 85964911





--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org
 

Thread Tools




All times are GMT. The time now is 02:43 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org