FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 11-22-2011, 08:04 PM
Paul Smith
 
Default Cannot play MP3 files on Totem

Dear All,

When trying to play MP3 files on F16 with Totem, I get the following error:

"The playback of this movie requires a ID3 tag demuxer plugin which is
not installed."

Any ideas?

Thanks in advance,

Paul
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-22-2011, 08:28 PM
Terry Polzin
 
Default Cannot play MP3 files on Totem

On Tue, 2011-11-22 at 21:04 +0000, Paul Smith wrote:
> Dear All,
>
> When trying to play MP3 files on F16 with Totem, I get the following error:
>
> "The playback of this movie requires a ID3 tag demuxer plugin which is
> not installed."
>
> Any ideas?
>
> Thanks in advance,
>
> Paul

MP3 is a proprietary file format codex for it are not included in
Fedora.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-22-2011, 08:33 PM
Paul Smith
 
Default Cannot play MP3 files on Totem

On Tue, Nov 22, 2011 at 9:28 PM, Terry Polzin <foxec208@wowway.com> wrote:
>> When trying to play MP3 files on F16 with Totem, I get the following error:
>>
>> "The playback of this movie requires a ID3 tag demuxer plugin which is
>> not installed."
>>
>> Any ideas?
>
> MP3 is a proprietary file format codex for it are not included in
> Fedora.

Thanks, Terry, but what plugin do I need? I do have rpmfusion
repository installed, but I do not know what plugin to install.

Paul
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-22-2011, 08:52 PM
Bryce Hardy
 
Default Cannot play MP3 files on Totem

On Tue, Nov 22, 2011 at 1:33 PM, Paul Smith <phhs80@gmail.com> wrote:

>I do have rpmfusion
> repository installed, but I do not know what plugin to install.

yum search gstreamer

Install all of the packages listed that have good, bad, ugly and
ffmpeg in their names that are correct for your architecture and
barring the devel packages. Alternatively you can install easylife or
autoplus to do all of this for you. Hope this helps.

--
Bryce Hardy
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-22-2011, 08:58 PM
Richard Shaw
 
Default Cannot play MP3 files on Totem

On Tue, Nov 22, 2011 at 3:33 PM, Paul Smith <phhs80@gmail.com> wrote:
> On Tue, Nov 22, 2011 at 9:28 PM, Terry Polzin <foxec208@wowway.com> wrote:
>>> When trying to play MP3 files on F16 with Totem, I get the following error:
>>>
>>> "The playback of this movie requires a ID3 tag demuxer plugin which is
>>> not installed."
>>>
>>> Any ideas?
>>
>> MP3 is a proprietary file format codex for it are not included in
>> Fedora.
>
> Thanks, Terry, but what plugin do I need? I do have rpmfusion
> repository installed, but I do not know what plugin to install.

Strange. As long as you have rpmfusion properly installed Totem should
figure out which packages need to be installed and offer to install
them. At least that's how it usually works for me.

The other strange thing is the error. It didn't say MP3 demuxer, but
rather an ID3 tag demuxer...

Richard
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Y��}��^���au��.�Ǭ�+-�&#x1DD8B6;������I�)z��ib� ���7����y;��h�m5��m4E� &m�-�����������m=����� ��h
 
Old 11-23-2011, 11:34 AM
Paul Smith
 
Default Cannot play MP3 files on Totem

On Tue, Nov 22, 2011 at 9:58 PM, Richard Shaw <hobbes1069@gmail.com> wrote:
>>>> When trying to play MP3 files on F16 with Totem, I get the following error:
>>>>
>>>> "The playback of this movie requires a ID3 tag demuxer plugin which is
>>>> not installed."
>>>>
>>>> Any ideas?
>>>
>>> MP3 is a proprietary file format codex for it are not included in
>>> Fedora.
>>
>> Thanks, Terry, but what plugin do I need? I do have rpmfusion
>> repository installed, but I do not know what plugin to install.
>
> Strange. As long as you have rpmfusion properly installed Totem should
> figure out which packages need to be installed and offer to install
> them. At least that's how it usually works for me.
>
> The other strange thing is the error. It didn't say MP3 demuxer, but
> rather an ID3 tag demuxer...

Fedora tries to find the appropriate plugin, but no appropriate plugin is found:

I do have the repository rpmfusion non-free installed.

Any further ideas?

Paul
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-23-2011, 11:42 AM
Frank Murphy
 
Default Cannot play MP3 files on Totem

On 22/11/11 21:58, Richard Shaw wrote:

>
> Strange. As long as you have rpmfusion properly installed Totem should
> figure out which packages need to be installed and offer to install
> them. At least that's how it usually works for me.

Only work if you have the correct PackageKit* rpm installed.


--
Regards,

Frank Murphy
UTF_8 Encoded
Friend of fedoraproject.org
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-23-2011, 01:12 PM
Richard Shaw
 
Default Cannot play MP3 files on Totem

On Wed, Nov 23, 2011 at 6:42 AM, Frank Murphy <frankly3d@gmail.com> wrote:
> On 22/11/11 21:58, Richard Shaw wrote:
>> Strange. As long as you have rpmfusion properly installed Totem should
>> figure out which packages need to be installed and offer to install
>> them. At least that's how it usually works for me.
>
> Only work if you have the correct PackageKit* rpm installed.

Do you mean "PackageKit-gstreamer-plugin"?

Interesting, I've never installed that specifically, it must have been
pulled in by something else.

Paul,

Can you check to make sure you have that installed?

Richard
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-23-2011, 01:21 PM
Paul Smith
 
Default Cannot play MP3 files on Totem

On Wed, Nov 23, 2011 at 2:12 PM, Richard Shaw <hobbes1069@gmail.com> wrote:
>>> Strange. As long as you have rpmfusion properly installed Totem should
>>> figure out which packages need to be installed and offer to install
>>> them. At least that's how it usually works for me.
>>
>> Only work if you have the correct PackageKit* rpm installed.
>
> Do you mean "PackageKit-gstreamer-plugin"?
>
> Interesting, I've never installed that specifically, it must have been
> pulled in by something else.
>
> Paul,
>
> Can you check to make sure you have that installed?

Yes, I have:

$ rpm -q PackageKit-gstreamer-plugin
PackageKit-gstreamer-plugin-0.6.20-1.fc16.x86_64
$

Paul
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-23-2011, 01:28 PM
Richard Shaw
 
Default Cannot play MP3 files on Totem

Ok, I did a quick search for id3 and found two likely packages:

id3lib
libid3tag

I have both installed so I don't know which Totem uses. Since it's not
a hard dependency I don't think repoquery can help here.

# repoquery --whatrequires id3lib
easytag-0:2.1.6-6.fc15.x86_64
gmediaserver-0:0.13.0-7.fc15.x86_64
grip-1:3.2.0-30.fc15.x86_64
id3lib-devel-0:3.8.3-25.fc15.i686
id3lib-devel-0:3.8.3-25.fc15.x86_64
id3v2-0:0.1.12-2.fc15.x86_64
kid3-0:1.6-3.fc15.x86_64
kid3-qt-0:1.6-3.fc15.x86_64
liblicense-modules-0:0.8.1-5.x86_64
tagtool-0:0.12.3-9.fc15.x86_64
tagtool-0:0.12.3-10.fc15.x86_64

# repoquery --whatrequires libid3tag
audacity-0:1.3.12-0.7.beta.fc15.x86_64
audacity-0:1.3.13-0.4.beta.fc15.x86_64
audacity-freeworld-0:1.3.13-0.4.beta.fc15.x86_64
easytag-0:2.1.6-6.fc15.x86_64
gnomad2-0:2.9.4-8.fc15.x86_64
gnomad2-0:2.9.6-1.fc15.x86_64
gstreamer-plugins-ugly-0:0.10.18-1.fc15.i686
gstreamer-plugins-ugly-0:0.10.18-1.fc15.x86_64
gstreamer-plugins-ugly-0:0.10.18-1.fc15.1.i686
gstreamer-plugins-ugly-0:0.10.18-1.fc15.1.x86_64
gtkpod-0:1.0.0-3.fc15.x86_64
gtkpod-0:2.1.0-1.fc15.i686
gtkpod-0:2.1.0-1.fc15.x86_64
imlib2-id3tag-loader-0:1.4.4-2.fc15.x86_64
libid3tag-devel-0:0.15.1b-11.fc15.i686
libid3tag-devel-0:0.15.1b-11.fc15.x86_64
madplay-0:0.15.2b-6.fc11.x86_64
mixxx-0:1.9.0-2.fc15.x86_64
mixxx-0:1.9.2-1.fc15.x86_64
mpd-0:0.15.13-1.fc15.x86_64
mpg321-0:0.2.12-2.fc15.x86_64
mt-daapd-1:0.2.4.2-8.fc15.x86_64
vdr-mp3-0:0.10.1-7.fc11.x86_64

Seeing that libid3tag is required by gstreamer-plugins-ugly, I would
guess that's the one.

Richard
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 11:36 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org