FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 11-17-2011, 08:59 PM
Brian Ericson
 
Default gnome-terminal "paint" issues?

I'm having "one-off" issues with gnome-terminal on my laptop. At the
bottom of the terminal, the results of a command typically (but not
always) don't display until I hit "enter" a second time and PgUp/PgDown
in man pages or vim oftentimes don't do anything (then, when the key is
hit again, the result will be 2x rather than 1x).

Anyone know what might cause this?
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-17-2011, 10:22 PM
Deron Meranda
 
Default gnome-terminal "paint" issues?

On Thu, Nov 17, 2011 at 4:59 PM, Brian Ericson <bericson@ptc.com> wrote:
> I'm having "one-off" issues with gnome-terminal on my laptop. *At the
> bottom of the terminal, the results of a command typically (but not
> always) don't display until I hit "enter" a second time and PgUp/PgDown
> in man pages or vim oftentimes don't do anything (then, when the key is
> hit again, the result will be 2x rather than 1x).
>
> Anyone know what might cause this?

I don't know, but here's a few things that may give you or others here a clue:

Also, are you only logged into the local machine just using a plain
bash shell, or are you say ssh'ed into another? Or using the
"screen(1)" command? Or using a keyboard KVM switch?

Look at your terminal profile preferences, and in particular under
scrolling see if "scroll on keystrokes" is checked.

Check your $TERM environment variable.

If you resize the terminal window (and press enter), do the values for
the environment variables $COLUMNS and $LINES change?

What are your terminal device settings? Run: stty -a

Are you using any Gnome universal access features, or have perhaps
changed your Compose key binding or other keyboard layout settings?

You can also try using the on-screen keyboard and see if it behaves
differently than your real keyboard (pull down the Gnome Universal
Access menu from the gnome bar at the top right and choose "Screen
Keyboard").

--
Deron Meranda
http://deron.meranda.us/
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-18-2011, 01:51 PM
Brian Ericson
 
Default gnome-terminal "paint" issues?

Thanks for the reply! I should mention I'm on f16. Interestingly, this
seems to happen more frequently the larger the terminal window is. It's
easily reproduced doing repeated "ls -d .??*"s and I've also noticed
that if I wait long enough (upwards of two minutes), it'll repaint on
its own, but it always repaints instantly if I hit enter again.

I'm using a plain bash shell with a default .bash_profile and an
uninspiring .bashrc. The shell is to the local machine. The profile
settings for gnome-terminal are unaltered (the "Default" profile) save
that I don't display the menu bar (not that this changes anything).

TERM is set to xterm (same as on other machines I have f16 on that don't
exhibit this issue) and both COLUMNS & LINES change when the window is
resized. stty -a settings are unaltered from the default (and match the
other machines' settings). This particular machine uses the English
(Dvorak) layout which it inherits from the system as I pass
KEYTABLE=dvorak to the kernel (my other machines have Dvorak keyboards
and, consequently, are set to English (US)).

I went so far as to create a new user to see if the user would exhibit
the same issues (and set that user's layout to English (US)), and the
new user has the same issues. As an aside, did you know that if you
create or delete user using the "Users and Groups" application, it logs
you out of your session?!

The onscreen keyboard (funnily in QWERTY), doesn't appear to have this
issue, if that helps.

On 11/17/2011 05:22 PM, Deron Meranda wrote:
> On Thu, Nov 17, 2011 at 4:59 PM, Brian Ericson<bericson@ptc.com> wrote:
>> I'm having "one-off" issues with gnome-terminal on my laptop. At the
>> bottom of the terminal, the results of a command typically (but not
>> always) don't display until I hit "enter" a second time and PgUp/PgDown
>> in man pages or vim oftentimes don't do anything (then, when the key is
>> hit again, the result will be 2x rather than 1x).
>>
>> Anyone know what might cause this?
> I don't know, but here's a few things that may give you or others here a clue:
>
> Also, are you only logged into the local machine just using a plain
> bash shell, or are you say ssh'ed into another? Or using the
> "screen(1)" command? Or using a keyboard KVM switch?
>
> Look at your terminal profile preferences, and in particular under
> scrolling see if "scroll on keystrokes" is checked.
>
> Check your $TERM environment variable.
>
> If you resize the terminal window (and press enter), do the values for
> the environment variables $COLUMNS and $LINES change?
>
> What are your terminal device settings? Run: stty -a
>
> Are you using any Gnome universal access features, or have perhaps
> changed your Compose key binding or other keyboard layout settings?
>
> You can also try using the on-screen keyboard and see if it behaves
> differently than your real keyboard (pull down the Gnome Universal
> Access menu from the gnome bar at the top right and choose "Screen
> Keyboard").
>
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-18-2011, 06:36 PM
Deron Meranda
 
Default gnome-terminal "paint" issues?

So you have other F16 systems that do not exhibit this bahavior, and
from what you can tell all the settings are the same between both?
That is strange.

By chance, are you seeing any repainting issues in any other applications?

You might try a different terminal program and see if it has a similar
issue. You may need to install a terminal program with yum. There's
always the old trusty "xterm", but you may also like "lilyterm" as it
is more like gnome-terminal (UTF-8, multiple tabs, etc.).

--
Deron Meranda
http://deron.meranda.us/
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 02:50 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org