FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 11-16-2011, 03:26 AM
Deron Meranda
 
Default Yum update fails after upgrade from F15 to F16 while doing a transaction check

I had a Fedora 15 (x86_64) system that I successfully upgraded to
Fedora 16, using the DVD image.

Now, however, when I attempt to run "yum update" on the new F16
system, yum fails during the transaction check. I did make sure that
everything was fully updated in F15 just prior to the upgrade, and I
have not performed any other yum/rpm operations after upgrading to F16
prior to this failed yum update.

It appears as if the following packages have a dependency issue:

* mesa-dri-drivers-7.11-8.fc16.i686
* libmtp-hal-1.0.6-5.fc15.x86_64

Also there are hundreds of what I assume are minor issues with the yum
database that follow. What should I do about those, and is there a way
to clean those up?

And a third question: yum seems to have saved the transaction for
later "playback". Can I ignore that, or should I somehow cleanup or
delete the saved transaction before doing anything else?

Thanks for any help.


Below is the snippet from yum update....

...
Install 17 Packages
Upgrade 502 Packages

Total size: 835 M
Is this ok [y/N]: y
Downloading Packages:
...
Running Transaction Check
ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-7.11-8.fc16.i686
libmtp = 1.0.6-5.fc15 is needed by (installed) libmtp-hal-1.0.6-5.fc15.x86_64
Please report this error in http://yum.baseurl.org/report

** Found 171 pre-existing rpmdb problem(s), 'yum check' output follows:
GConf2-gtk-2.32.3-1.fc15.x86_64 has missing requires of GConf2 = ('0',
'2.32.3', '1.fc15')
ImageMagick-c++-6.6.5.10-19.fc15.x86_64 has missing requires of
ImageMagick = ('0', '6.6.5.10', '19.fc15')
ImageMagick-perl-6.6.5.10-19.fc15.x86_64 has missing requires of
ImageMagick = ('0', '6.6.5.10', '19.fc15')
ImageMagick-perl-6.6.5.10-19.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.3)
agg-devel-2.5-10.fc15.x86_64 has missing requires of agg = ('0',
'2.5', '10.fc15')
atk-2.2.0-2.fc16.x86_64 is a duplicate with atk-2.0.0-1.fc15.i686
audit-libs-2.1.3-4.fc16.x86_64 is a duplicate with audit-libs-2.1.3-1.fc15.i686
avahi-libs-0.6.30-4.fc16.x86_64 is a duplicate with
avahi-libs-0.6.30-3.fc15.i686
avahi-ui-0.6.30-3.fc15.x86_64 has missing requires of avahi = ('0',
'0.6.30', '3.fc15')
awn-extras-applets-0.4.2-0.1.bzr1523.fc15.x86_64 has missing requires
of libgnome-menu.so.2()(64bit)
cairo-1.10.2-4.fc16.x86_64 is a duplicate with cairo-1.10.2-3.fc15.i686
cegui-0.7.5-8.fc15.x86_64 has missing requires of libGLEW.so.1.5()(64bit)
chess-1.0-37.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)
compiz-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc 15.x86_64
has missing requires of libboost_serialization-mt.so.1.46.0()(64bit)
compiz-gtk-0.9.5.92.1-0.1.gite676f1b12eb8db3a76978eed5bfc7c2cf9a0b6ce.fc 15.x86_64
has missing requires of libboost_serialization-mt.so.1.46.0()(64bit)
compiz-plugins-main-0.9.5.92-1.fc15.x86_64 has missing requires of
libboost_serialization-mt.so.1.46.0()(64bit)
1:cups-libs-1.5.0-16.fc16.x86_64 is a duplicate with
1:cups-libs-1.4.8-5.fc15.i686
1:dbus-libs-1.4.10-3.fc16.x86_64 is a duplicate with
1:dbus-libs-1.4.6-5.fc15.i686
dconf-editor-0.7.5-1.x86_64 has missing requires of dconf = ('0', '0.7.5', '1')
device-mapper-multipath-0.4.9-15.fc15.x86_64 has missing requires of
kpartx = ('0', '0.4.9', '15.fc15')
12:dhcp-4.2.1-11.P1.fc15.x86_64 has missing requires of dhcp-common =
('12', '4.2.1', '11.P1.fc15')
12:dhcp-4.2.1-11.P1.fc15.x86_64 has missing requires of dhcp-libs =
('12', '4.2.1', '11.P1.fc15')
dnssec-tools-1.11-1.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.4)
1:emacs-nox-23.2-19.fc15.x86_64 has missing requires of emacs-common =
('1', '23.2', '19.fc15')
exiv2-0.21.1-3.fc15.x86_64 has missing requires of exiv2-libs(x86-64)
= ('0', '0.21.1', '3.fc15')
file-devel-5.07-4.fc15.x86_64 has missing requires of file = ('0',
'5.07', '4.fc15')
fontconfig-2.8.0-4.fc16.x86_64 is a duplicate with fontconfig-2.8.0-3.fc15.i686
freetype-2.4.6-3.fc16.x86_64 is a duplicate with freetype-2.4.4-6.fc15.i686
fuse-encfs-1.7.4-1.fc15.x86_64 has missing requires of
libboost_filesystem-mt.so.1.46.0()(64bit)
fuse-encfs-1.7.4-1.fc15.x86_64 has missing requires of
libboost_serialization-mt.so.1.46.0()(64bit)
fuse-encfs-1.7.4-1.fc15.x86_64 has missing requires of
libboost_system-mt.so.1.46.0()(64bit)
gamin-0.1.10-10.fc16.x86_64 is a duplicate with gamin-0.1.10-9.fc15.i686
gdk-pixbuf2-2.24.0-1.fc16.x86_64 is a duplicate with
gdk-pixbuf2-2.23.3-2.fc15.i686
glabels-3.0.0-1.fc15.x86_64 has missing requires of libcamel-1.2.so.23()(64bit)
glabels-3.0.0-1.fc15.x86_64 has missing requires of libebook-1.2.so.10()(64bit)
glabels-3.0.0-1.fc15.x86_64 has missing requires of
libedataserver-1.2.so.14()(64bit)
1:glade3-libgladeui-devel-3.10.0-2.fc15.x86_64 has missing requires of
glade3-libgladeui = ('1', '3.10.0', '2.fc15')
glew-1.5.8-4.fc15.x86_64 has missing requires of libGLEW.so.1.5()(64bit)
glib2-2.30.1-1.fc16.x86_64 is a duplicate with glib2-2.28.8-1.fc15.i686
glibc-2.14-5.i686 has missing requires of glibc-common = ('0', '2.14', '5')
glibc-2.14.90-14.x86_64 is a duplicate with glibc-2.14-5.i686
gnome-python2-bonobo-2.28.1-4.fc15.x86_64 has missing requires of
gnome-python2 = ('0', '2.28.1', '4.fc15')
gnome-python2-gnomedesktop-2.32.0-4.fc15.x86_64 has missing requires
of gnome-python2-desktop = ('0', '2.32.0', '4.fc15')
gnome-python2-libgtop2-2.32.0-4.fc15.x86_64 has missing requires of
gnome-python2-desktop = ('0', '2.32.0', '4.fc15')
gnutls-2.12.7-2.fc16.x86_64 is a duplicate with gnutls-2.10.5-1.fc15.i686
gparted-0.9.1-1.fc15.x86_64 has missing requires of libparted.so.0()(64bit)
groff-perl-1.21-3.fc15.x86_64 has missing requires of groff = ('0',
'1.21', '3.fc15')
gtk2-2.24.7-2.fc16.x86_64 is a duplicate with gtk2-2.24.7-1.fc15.i686
hugin-2010.4.0-4.fc15.x86_64 has missing requires of hugin-base =
('0', '2010.4.0', '4.fc15')
hugin-2010.4.0-4.fc15.x86_64 has missing requires of libGLEW.so.1.5()(64bit)
hugin-2010.4.0-4.fc15.x86_64 has missing requires of
libboost_date_time-mt.so.1.46.0()(64bit)
hugin-2010.4.0-4.fc15.x86_64 has missing requires of
libboost_filesystem-mt.so.1.46.0()(64bit)
hugin-2010.4.0-4.fc15.x86_64 has missing requires of
libboost_iostreams-mt.so.1.46.0()(64bit)
hugin-2010.4.0-4.fc15.x86_64 has missing requires of
libboost_regex-mt.so.1.46.0()(64bit)
hugin-2010.4.0-4.fc15.x86_64 has missing requires of
libboost_signals-mt.so.1.46.0()(64bit)
hugin-2010.4.0-4.fc15.x86_64 has missing requires of
libboost_system-mt.so.1.46.0()(64bit)
hugin-2010.4.0-4.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)
initscripts-9.33-1.fc16.x86_64 has installed conflicts libselinux <
('0', '2.1.0', None): libselinux-2.0.99-4.fc15.i686
inkscape-0.48.1-4.fc15.x86_64 has missing requires of libpoppler.so.13()(64bit)
inkscape-0.48.1-4.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.3)
inkscape-view-0.48.1-4.fc15.x86_64 has missing requires of
libpoppler.so.13()(64bit)
inkscape-view-0.48.1-4.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.3)
keyutils-libs-1.5.2-1.fc16.x86_64 is a duplicate with
keyutils-libs-1.2-7.fc15.i686
krb5-libs-1.9.1-18.fc16.x86_64 is a duplicate with krb5-libs-1.9.1-5.fc15.i686
libICE-1.0.7-1.fc16.x86_64 is a duplicate with libICE-1.0.6-3.fc15.i686
libX11-1.4.3-1.fc15.i686 has missing requires of libX11-common = ('0',
'1.4.3', '1.fc15')
libX11-1.4.3-1.fc16.x86_64 is a duplicate with libX11-1.4.3-1.fc15.i686
libXfixes-5.0-1.fc16.x86_64 is a duplicate with libXfixes-5.0-1.fc15.i686
libXi-1.4.3-3.fc16.x86_64 is a duplicate with libXi-1.4.3-2.fc15.i686
libXt-1.1.1-1.fc16.x86_64 is a duplicate with libXt-1.1.0-1.fc15.i686
libcompizconfig-0.9.5.92-1.fc15.x86_64 has missing requires of
libboost_serialization-mt.so.1.46.0()(64bit)
libdrm-2.4.26-3.fc16.x86_64 is a duplicate with libdrm-2.4.26-2.fc15.i686
libffi-3.0.10-1.fc16.x86_64 is a duplicate with libffi-3.0.10-1.fc15.i686
libgcc-4.6.2-1.fc16.x86_64 is a duplicate with libgcc-4.6.1-9.fc15.i686
libgcrypt-1.5.0-2.fc16.x86_64 is a duplicate with libgcrypt-1.4.6-1.fc15.i686
libgpg-error-1.10-1.fc16.x86_64 is a duplicate with libgpg-error-1.9-2.fc15.i686
libidn-1.22-3.fc16.x86_64 is a duplicate with libidn-1.19-2.fc15.i686
libjpeg-turbo-1.1.1-1.fc16.x86_64 is a duplicate with
libjpeg-turbo-1.1.1-1.fc15.i686
libjpeg-turbo-utils-1.1.1-1.fc15.x86_64 has missing requires of
libjpeg-turbo(x86-64) = ('0', '1.1.1', '1.fc15')
libmongodb-1.8.0-6.fc15.x86_64 has missing requires of
libboost_filesystem-mt.so.1.46.0()(64bit)
libmongodb-1.8.0-6.fc15.x86_64 has missing requires of
libboost_system-mt.so.1.46.0()(64bit)
libmongodb-1.8.0-6.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)
libmtp-hal-1.0.6-5.fc15.x86_64 has missing requires of libmtp = ('0',
'1.0.6', '5.fc15')
libnih-1.0.2-4.fc15.x86_64 has missing requires of
libc.so.6(GLIBC_PRIVATE)(64bit)
2:libpng-1.2.46-1.fc16.x86_64 is a duplicate with 2:libpng-1.2.46-1.fc15.i686
libselinux-2.1.5-5.1.fc16.x86_64 is a duplicate with
libselinux-2.0.99-4.fc15.i686
libstdc++-4.6.2-1.fc16.x86_64 is a duplicate with libstdc++-4.6.1-9.fc15.i686
libtalloc-2.0.6-1.fc16.x86_64 is a duplicate with libtalloc-2.0.6-1.fc15.i686
libtiff-3.9.5-1.fc16.x86_64 is a duplicate with libtiff-3.9.5-1.fc15.i686
libuuid-2.20.1-2.fc16.x86_64 is a duplicate with libuuid-2.19.1-1.4.fc15.i686
libxcb-1.7-3.fc16.x86_64 is a duplicate with libxcb-1.7-2.fc15.i686
libxfce4ui-devel-4.8.0-4.fc15.x86_64 has missing requires of
libxfce4ui = ('0', '4.8.0', '4.fc15')
libxfce4util-devel-4.8.2-1.fc15.x86_64 has missing requires of
libxfce4util = ('0', '4.8.2', '1.fc15')
libxml2-2.7.8-6.fc16.x86_64 is a duplicate with libxml2-2.7.8-6.fc15.i686
libxslt-python-1.1.26-8.fc15.x86_64 has missing requires of libxslt =
('0', '1.1.26', '8.fc15')
llvm-libs-2.9-4.fc16.x86_64 is a duplicate with llvm-libs-2.8-12.fc15.i686
mesa-dri-drivers-7.11-1.fc15.i686 has missing requires of
mesa-dri-filesystem(x86-32)
mesa-dri-drivers-7.11-8.fc16.x86_64 is a duplicate with
mesa-dri-drivers-7.11-1.fc15.i686
mesa-dri-llvmcore-7.11-0.11.20110525.0.fc15.i686 has missing requires
of mesa-dri-filesystem(x86-32)
mesa-libGL-7.11-8.fc16.x86_64 is a duplicate with mesa-libGL-7.11-1.fc15.i686
mesa-libGLU-7.11-8.fc16.x86_64 is a duplicate with mesa-libGLU-7.11-1.fc15.i686
mod_dav_svn-1.6.17-1.fc15.x86_64 has missing requires of
subversion-libs(x86-64) = ('0', '1.6.17', '1.fc15')
mongodb-1.8.0-6.fc15.x86_64 has missing requires of
libboost_filesystem-mt.so.1.46.0()(64bit)
mongodb-1.8.0-6.fc15.x86_64 has missing requires of
libboost_program_options-mt.so.1.46.0()(64bit)
mongodb-1.8.0-6.fc15.x86_64 has missing requires of
libboost_system-mt.so.1.46.0()(64bit)
mongodb-1.8.0-6.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)
mongodb-server-1.8.0-6.fc15.x86_64 has missing requires of
libboost_filesystem-mt.so.1.46.0()(64bit)
mongodb-server-1.8.0-6.fc15.x86_64 has missing requires of
libboost_program_options-mt.so.1.46.0()(64bit)
mongodb-server-1.8.0-6.fc15.x86_64 has missing requires of
libboost_system-mt.so.1.46.0()(64bit)
mongodb-server-1.8.0-6.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)
netpbm-progs-10.47.26-2.fc15.x86_64 has missing requires of netpbm =
('0', '10.47.26', '2.fc15')
nscd-2.14-5.x86_64 has missing requires of libc.so.6(GLIBC_PRIVATE)(64bit)
nss-softokn-freebl-3.12.10-4.fc16.x86_64 is a duplicate with
nss-softokn-freebl-3.12.10-2.fc15.i686
ogre-1.7.3-1.fc15.x86_64 has missing requires of
libboost_date_time-mt.so.1.46.0()(64bit)
ogre-1.7.3-1.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)
pango-1.29.4-1.fc16.x86_64 is a duplicate with pango-1.28.4-1.fc15.i686
perl-Cairo-1.060-6.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Chart-2.4.2-3.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Crypt-OpenSSL-DSA-0.13-18.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Date-Manip-6.25-1.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.4)
perl-DateTime-TimeZone-1.41-1.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.4)
perl-Digest-BubbleBabble-0.02-1.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-GD-2.44-6.fc15.x86_64 has missing requires of perl(:MODULE_COMPAT_5.12.3)
perl-Getopt-GUI-Long-0.91-6.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Gtk2-1.224-2.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.4)
perl-MIME-Base32-1.02a-3.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Net-DNS-SEC-0.16-6.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Pango-1.221-2.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Parse-Yapp-1.05-44.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-QWizard-3.15-8.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Text-CSV-1.21-1.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-Tk-804.028-12.fc14.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.0)
perl-XML-Simple-2.18-9.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-XML-XQL-0.68-12.fc15.noarch has missing requires of
perl(:MODULE_COMPAT_5.12.3)
perl-YAML-Syck-1.17-2.fc15.x86_64 has missing requires of
perl(:MODULE_COMPAT_5.12.3)
php-devel-5.3.8-3.fc15.x86_64 has missing requires of php(x86-64) =
('0', '5.3.8', '3.fc15')
php-gd-5.3.8-3.fc15.x86_64 has missing requires of php-common(x86-64)
= ('0', '5.3.8', '3.fc15')
php-mbstring-5.3.8-3.fc15.x86_64 has missing requires of
php-common(x86-64) = ('0', '5.3.8', '3.fc15')
php-pgsql-5.3.8-3.fc15.x86_64 has missing requires of php-pdo(x86-64)
= ('0', '5.3.8', '3.fc15')
php-xml-5.3.8-3.fc15.x86_64 has missing requires of php-common(x86-64)
= ('0', '5.3.8', '3.fc15')
pixman-0.22.2-1.fc16.x86_64 is a duplicate with pixman-0.20.2-2.fc15.i686
policycoreutils-gui-2.0.86-7.fc15.x86_64 has missing requires of
policycoreutils-python = ('0', '2.0.86', '7.fc15')
policycoreutils-newrole-2.0.86-7.fc15.x86_64 has missing requires of
policycoreutils = ('0', '2.0.86', '7.fc15')
postgresql-docs-9.0.5-1.fc15.x86_64 has missing requires of
postgresql(x86-64) = ('0', '9.0.5', '1.fc15')
postgresql-plpython-9.0.5-1.fc15.x86_64 has missing requires of
postgresql-server(x86-64) = ('0', '9.0.5', '1.fc15')
python3-3.2-1.fc15.x86_64 has missing requires of python3-libs(x86-64)
= ('0', '3.2', '1.fc15')
2:qemu-user-0.14.0-8.fc15.x86_64 has missing requires of qemu-common =
('2', '0.14.0', '8.fc15')
1:qt-assistant-4.7.4-6.fc15.x86_64 has missing requires of
qt-sqlite(x86-64) = ('1', '4.7.4', '6.fc15')
1:qt-assistant-4.7.4-6.fc15.x86_64 has missing requires of
qt-x11(x86-64) = ('1', '4.7.4', '6.fc15')
1:qt-demos-4.7.4-6.fc15.x86_64 has missing requires of qt = ('1',
'4.7.4', '6.fc15')
1:qt-doc-4.7.4-6.fc15.noarch has missing requires of qt = ('1',
'4.7.4', '6.fc15')
1:qt-examples-4.7.4-6.fc15.x86_64 has missing requires of qt(x86-64) =
('1', '4.7.4', '6.fc15')
raptor2-2.0.4-2.fc16.x86_64 has installed conflicts raptor < ('0',
'1.4.21', '10'): raptor-1.4.21-2.fc15.x86_64
report-plugin-ftp-0.22-0.fc15.x86_64 has missing requires of report =
('0', '0.22', '0.fc15')
report-plugin-scp-0.22-0.fc15.x86_64 has missing requires of report =
('0', '0.22', '0.fc15')
ruby-1.8.7.352-1.fc15.x86_64 has missing requires of ruby-libs(x86-64)
= ('0', '1.8.7.352', '1.fc15')
ruby-devel-1.8.7.352-1.fc15.x86_64 has missing requires of
ruby-libs(x86-64) = ('0', '1.8.7.352', '1.fc15')
selinux-policy-doc-3.9.16-44.fc15.noarch has missing requires of
selinux-policy = ('0', '3.9.16', '44.fc15')
selinux-policy-mls-3.9.16-44.fc15.noarch has missing requires of
selinux-policy = ('0', '3.9.16', '44.fc15')
selinux-policy-mls-3.9.16-44.fc15.noarch has missing requires of
selinux-policy = ('0', '3.9.16', '44.fc15')
setools-console-3.3.7-12.fc15.x86_64 has missing requires of
setools-libs = ('0', '3.3.7', '12.fc15')
shared-color-profiles-extra-0.1.4-1.fc15.noarch has missing requires
of shared-color-profiles = ('0', '0.1.4', '1.fc15')
system-config-network-1.6.2-2.fc15.noarch has missing requires of
system-config-network-tui = ('0', '1.6.2', '2.fc15')
texlive-2007-62.fc15.x86_64 has missing requires of libpoppler.so.13()(64bit)
xapian-bindings-ruby-1.2.7-1.fc15.x86_64 has missing requires of
xapian-bindings = ('0', '1.2.7', '1.fc15')
xapian-core-1.2.7-1.fc15.x86_64 has missing requires of
xapian-core-libs = ('0', '1.2.7', '1.fc15')
xapian-core-devel-1.2.7-1.fc15.x86_64 has missing requires of
xapian-core-libs = ('0', '1.2.7', '1.fc15')
xfce4-panel-devel-4.8.6-1.fc15.x86_64 has missing requires of
xfce4-panel = ('0', '4.8.6', '1.fc15')
xfconf-devel-4.8.0-2.fc15.x86_64 has missing requires of xfconf =
('0', '4.8.0', '2.fc15')
xz-lzma-compat-5.0.3-1.fc15.x86_64 has missing requires of xz = ('0',
'5.0.3', '1.fc15')
zlib-1.2.5-4.fc16.x86_64 is a duplicate with zlib-1.2.5-3.fc15.i686
Your transaction was saved, rerun it with: yum load-transaction
/tmp/yum_save_tx-2011-11-15-21-12BPNeNR.yumtx

*END OF SNIPPET*

--
Deron Meranda
http://deron.meranda.us/
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-16-2011, 04:28 AM
"T.C. Hollingsworth"
 
Default Yum update fails after upgrade from F15 to F16 while doing a transaction check

On Tue, Nov 15, 2011 at 9:26 PM, Deron Meranda <deron.meranda@gmail.com> wrote:
> I had a Fedora 15 (x86_64) system that I successfully upgraded to
> Fedora 16, using the DVD image.
>
> Now, however, when I attempt to run "yum update" on the new F16
> system, yum fails during the transaction check. *I did make sure that
> everything was fully updated in F15 just prior to the upgrade, and I
> have not performed any other yum/rpm operations after upgrading to F16
> prior to this failed yum update.
>
> It appears as if the following packages have a dependency issue:
>
> * mesa-dri-drivers-7.11-8.fc16.i686
> * libmtp-hal-1.0.6-5.fc15.x86_64
>
> Also there are hundreds of what I assume are minor issues with the yum
> database that follow. What should I do about those, and is there a way
> to clean those up?

"package-cleanup --cleandupes" will take care of the duplicates.
After that, "yum distro-sync" should sort out the remaining errors.

-T.C.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-16-2011, 05:58 AM
Deron Meranda
 
Default Yum update fails after upgrade from F15 to F16 while doing a transaction check

I'm getting closer, but am still having problems...

I manually and selectively ran yum updates to all those packages that
didn't cause errors, and so I have now successfully updated most
things. Only the following packages still needing updated are
*stuck* where I can't proceed:

libmtp.x86_64 1.1.1-1.fc16
llvm-libs.i686 2.9-4.fc16
mesa-dri-drivers.i686 7.11-8.fc16

Those won't update because of the following unresolvable dependencies:

libmtp = 1.0.6-5.fc15 is needed by (installed) libmtp-hal-1.0.6-5.fc15.x86_64
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-7.11-8.fc16.i686


And "yum check" is now down to just these items:

chess-1.0-37.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)
libmtp-hal-1.0.6-5.fc15.x86_64 has missing requires of libmtp = ('0',
'1.0.6', '5.fc15')
libnih-1.0.2-4.fc15.x86_64 has missing requires of
libc.so.6(GLIBC_PRIVATE)(64bit)
llvm-libs-2.9-4.fc16.x86_64 is a duplicate with llvm-libs-2.8-12.fc15.i686
mesa-dri-drivers-7.11-1.fc15.i686 has missing requires of
mesa-dri-filesystem(x86-32)
mesa-dri-drivers-7.11-8.fc16.x86_64 is a duplicate with
mesa-dri-drivers-7.11-1.fc15.i686
mesa-dri-llvmcore-7.11-0.11.20110525.0.fc15.i686 has missing requires
of mesa-dri-filesystem(x86-32)


The suggestion to run "package-cleanup --cleandupes" now does nothing,
because there are no duplicates.

The "yum distro-sync" fails because of the libmtp-hal dependency.


I don't really know what those packages are or what to do about them.
Thanks again,
--
Deron Meranda
http://deron.meranda.us/
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-16-2011, 06:21 AM
"T.C. Hollingsworth"
 
Default Yum update fails after upgrade from F15 to F16 while doing a transaction check

On Tue, Nov 15, 2011 at 11:58 PM, Deron Meranda <deron.meranda@gmail.com> wrote:
> I'm getting closer, but am still having problems...
>
> I manually and selectively ran yum updates to all those packages that
> didn't cause errors, and so I have now successfully updated most
> things. *Only the following *packages still needing updated are
> *stuck* where I can't proceed:
>
> libmtp.x86_64 * * * * * * * * * * * * 1.1.1-1.fc16
> llvm-libs.i686 * * * * * * * * * * * * *2.9-4.fc16
> mesa-dri-drivers.i686 * * * * * * 7.11-8.fc16
>
> Those won't update because of the following unresolvable dependencies:
>
> libmtp = 1.0.6-5.fc15 is needed by (installed) libmtp-hal-1.0.6-5.fc15.x86_64
> mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-7.11-8.fc16.i686
>
>
> And "yum check" is now down to just these items:
>

[rearranged according to which I'm talking about]

> libmtp-hal-1.0.6-5.fc15.x86_64 has missing requires of libmtp = ('0',
> '1.0.6', '5.fc15')
> libnih-1.0.2-4.fc15.x86_64 has missing requires of
> libc.so.6(GLIBC_PRIVATE)(64bit)

libmtp-hal can die, HAL is gone as of F16. "repoquery" tells me the
only thing that requires libnih is Upstart, which has also been
replaced. So you can safely remove these. Try "rpm -ev libmtp-hal
libnih".

> llvm-libs-2.9-4.fc16.x86_64 is a duplicate with llvm-libs-2.8-12.fc15.i686
> mesa-dri-drivers-7.11-1.fc15.i686 has missing requires of
> mesa-dri-filesystem(x86-32)
> mesa-dri-drivers-7.11-8.fc16.x86_64 is a duplicate with
> mesa-dri-drivers-7.11-1.fc15.i686
> mesa-dri-llvmcore-7.11-0.11.20110525.0.fc15.i686 has missing requires
> of mesa-dri-filesystem(x86-32)

Do you have wine installed or any other 32-bit applications? (Wine
installs 32-bit libraries so it can run 32-bit Windows apps. Skype is
the only other commonly used thing that uses 32-bit libs AFAIK. "rpm
-qa | grep i686" will indicate all installed 32-bit packages.)

If not, you can also "rpm -ev > mesa-dri-drivers-7.11-1.fc15.i686
mesa-dri-llvmcore-7.11-0.11.20110525.0.fc15.i686
llvm-libs-2.8-12.fc15.i686". If you do need 32-bit libs, try forcing
an update: "yum install mesa-dri-drivers.i686 mesa-dri-llvmcore.i686
mesa-dri-filesystem.i686 llvm-libs.i686" If that doesn't work, the
easiest solution might be to uninstall Wine, uninstall those libs, get
everything updated, and install it again.

-T.C.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-16-2011, 06:49 AM
Deron Meranda
 
Default Yum update fails after upgrade from F15 to F16 while doing a transaction check

I'll try removing the packages you mentioned and report back.


As far as 32-bit, yes, unfortunately. Thank Adobe for that I
needed Acrobat reader because of some PDF file which the open source
alternatives just couldn't handle. But Adobe is infamous for only
delivering 32-bit apps for Linux, when they do at all. So that
required installing a bunch of 32-bit packages (though I don't
remember what ones it eventually installed).

If I need to I can try blowing away Adobe reader and then uninstall
whatever 32-bit packages I need to.

Thanks
--
Deron Meranda
http://deron.meranda.us/
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-16-2011, 07:03 AM
Deron Meranda
 
Default Yum update fails after upgrade from F15 to F16 while doing a transaction check

I just removed the i686 packages with

rpm -ev mesa-dri-drivers-7.11-1.fc15.i686
mesa-dri-llvmcore-7.11-0.11.20110525.0.fc15.i686
llvm-libs-2.8-12.fc15.i686

then yum update could proceed, and now all my packages are up to date.


Then "yum check" only reported one remaining problem:

chess-1.0-37.fc15.x86_64 has missing requires of
libboost_thread-mt.so.1.46.0()(64bit)

The "chess" package doesn't appear to be in F16 at all -- perhaps
that's what is now called "gnuchess" ?
I just removed the chess package with "rpm -ev chess"


So as of now, everything looks updated and clean. (I'll deal with
Acrobat reader later, if I ever need it to work again)

Thanks again for your help.
--
Deron Meranda
http://deron.meranda.us/
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 12:16 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org