FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 11-11-2011, 11:29 PM
Kevin Fenzi
 
Default fedora repo error with yum

On Fri, 11 Nov 2011 16:41:40 -0700
Peter Gueckel <pgueckel@gmail.com> wrote:

> For 36 hours I have been getting this error and am unable to update:
>
> Error: Cannot retrieve repository metadata (repomd.xml) for
> repository: fedora. Please verify its path and try again
>
> I have run yum clean all countless times, but the error keeps
> reappearing. What is wrong?

Hard to say without more info.

Try doing:

URLGRABBER_DEBUG=1 yum update

and see if that provides any better info on where it's running into
problems?

One thing I have seen a few people run into: make sure the date on your
machine is appox close. If it's set too far into the past, it won't
accept the fedora ssl cert as valid.

kevin
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 01:10 AM
Peter Gueckel
 
Default fedora repo error with yum

Kevin Fenzi wrote:

> Try doing:
>
> URLGRABBER_DEBUG=1 yum update

This is what I get (edited to exclude rpmfusion):

2011-11-11 19:03:36,668 attempt 1/10:
https://mirrors.fedoraproject.org/metalink?repo=updates-released-
f16&arch=x86_64
INFO:urlgrabber:attempt 1/10:
https://mirrors.fedoraproject.org/metalink?repo=updates-released-
f16&arch=x86_64
2011-11-11 19:03:36,668 opening local file
"/var/cache/yum/x86_64/16/updates/metalink.xml.tmp" with mode wb
INFO:urlgrabberpening local file
"/var/cache/yum/x86_64/16/updates/metalink.xml.tmp" with mode wb
* About to connect() to mirrors.fedoraproject.org port 443 (#0)
* Trying 140.211.169.197... * connected
* Connected to mirrors.fedoraproject.org (140.211.169.197) port 443 (#0)
* warning: ignoring unsupported value (1) of ssl.verifyhost
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* Certificate is signed by an untrusted issuer: 'CN=GeoTrust SSL
CA,O="GeoTrust, Inc.",C=US'
* NSS error -8172
* Closing connection #0
* Peer certificate cannot be authenticated with given CA certificates
2011-11-11 19:03:36,920 exception: [Errno 14] Peer cert cannot be verified or
peer cert invalid
INFO:urlgrabber:exception: [Errno 14] Peer cert cannot be verified or peer cert
invalid
2011-11-11 19:03:36,920 retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-
raising
INFO:urlgrabber:retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
adobe-linux-x86_64
2/2
2011-11-11 19:03:37,336 combined options: {
'text' : 'fedora/metalink',
'delegate' : {
'bandwidth' : 0,
'cache_openers': True,
'checkfunc' : None,
'close_connection': 0,
'copy_local' : 0,
'data' : None,
'delegate' : None,
'failure_callback': None,
'ftp_headers' : None,
'http_headers' : (),
'interrupt_callback': None,
'ip_resolve' : None,
'keepalive' : True,
'max_header_size': 2097152,
'opener' : None,
'password' : None,
'prefix' : None,
'progress_obj' : <output.YumTextMeter instance at 0x2a78d88>,
'proxies' : None,
'quote' : None,
'range' : None,
'reget' : None,
'retry' : 10,
'retrycodes' : [-1, 2, 4, 5, 6, 7],
'size' : None,
'ssl_ca_cert' : None,
'ssl_cert' : None,
'ssl_cert_type': 'PEM',
'ssl_context' : None,
'ssl_key' : None,
'ssl_key_pass' : None,
'ssl_key_type' : 'PEM',
'ssl_verify_host': True,
'ssl_verify_peer': True,
'text' : None,
'throttle' : 0,
'timeout' : 30.0,
'urlparser' : <urlgrabber.grabber.URLParser instance at 0x2b149e0>,
'user_agent' : 'urlgrabber/3.9.1 yum/3.4.3',
'username' : None,
}
}
DEBUG:urlgrabber:combined options: {
'text' : 'fedora/metalink',
'delegate' : {
'bandwidth' : 0,
'cache_openers': True,
'checkfunc' : None,
'close_connection': 0,
'copy_local' : 0,
'data' : None,
'delegate' : None,
'failure_callback': None,
'ftp_headers' : None,
'http_headers' : (),
'interrupt_callback': None,
'ip_resolve' : None,
'keepalive' : True,
'max_header_size': 2097152,
'opener' : None,
'password' : None,
'prefix' : None,
'progress_obj' : <output.YumTextMeter instance at 0x2a78d88>,
'proxies' : None,
'quote' : None,
'range' : None,
'reget' : None,
'retry' : 10,
'retrycodes' : [-1, 2, 4, 5, 6, 7],
'size' : None,
'ssl_ca_cert' : None,
'ssl_cert' : None,
'ssl_cert_type': 'PEM',
'ssl_context' : None,
'ssl_key' : None,
'ssl_key_pass' : None,
'ssl_key_type' : 'PEM',
'ssl_verify_host': True,
'ssl_verify_peer': True,
'text' : None,
'throttle' : 0,
'timeout' : 30.0,
'urlparser' : <urlgrabber.grabber.URLParser instance at 0x2b149e0>,
'user_agent' : 'urlgrabber/3.9.1 yum/3.4.3',
'username' : None,
}
}
2011-11-11 19:03:37,337 attempt 1/10:
https://mirrors.fedoraproject.org/metalink?repo=fedora-16&arch=x86_64
INFO:urlgrabber:attempt 1/10:
https://mirrors.fedoraproject.org/metalink?repo=fedora-16&arch=x86_64
2011-11-11 19:03:37,338 opening local file
"/var/cache/yum/x86_64/16/fedora/metalink.xml.tmp" with mode wb
INFO:urlgrabberpening local file
"/var/cache/yum/x86_64/16/fedora/metalink.xml.tmp" with mode wb
* About to connect() to mirrors.fedoraproject.org port 443 (#0)
* Trying 140.211.169.197... * connected
* Connected to mirrors.fedoraproject.org (140.211.169.197) port 443 (#0)
* warning: ignoring unsupported value (1) of ssl.verifyhost
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* Certificate is signed by an untrusted issuer: 'CN=GeoTrust SSL
CA,O="GeoTrust, Inc.",C=US'
* NSS error -8172
* Closing connection #0
* Peer certificate cannot be authenticated with given CA certificates
2011-11-11 19:03:37,589 exception: [Errno 14] Peer cert cannot be verified or
peer cert invalid
INFO:urlgrabber:exception: [Errno 14] Peer cert cannot be verified or peer cert
invalid
2011-11-11 19:03:37,589 retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-
raising
INFO:urlgrabber:retrycode (14) not in list [-1, 2, 4, 5, 6, 7], re-raising
Error: Cannot retrieve repository metadata (repomd.xml) for repository: fedora.
Please verify its path and try again

*

I don't understand all this stuff, but it appears that the Canadian mirrors are
using untrusted certificates. Am I correct?

How can I use a different mirror?

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 01:27 AM
Peter Gueckel
 
Default fedora repo error with yum

Kevin Fenzi wrote:

> Hard to say without more info.

I edited the fedora.repo, fedora-updates.repo and fedora-updates-testing.repo
files by uncommenting the baseurl line and commenting out the mirrors line and
now everything works... but why don't the mirrorlists work?

I should add that I am using updates-testing, also.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 03:50 AM
Kevin Fenzi
 
Default fedora repo error with yum

On Fri, 11 Nov 2011 19:27:39 -0700
Peter Gueckel <pgueckel@gmail.com> wrote:

> Kevin Fenzi wrote:
>
> > Hard to say without more info.
>
> I edited the fedora.repo, fedora-updates.repo and
> fedora-updates-testing.repo files by uncommenting the baseurl line
> and commenting out the mirrors line and now everything works... but
> why don't the mirrorlists work?
>
> I should add that I am using updates-testing, also.

Well, the problem seems to be that your machine is not accepting the
ssl cert for the fedoraproject web server:

* warning: ignoring unsupported value (1) of ssl.verifyhost
* CAfile: /etc/pki/tls/certs/ca-bundle.crt
CApath: none
* Certificate is signed by an untrusted issuer: 'CN=GeoTrust SSL
CA,O="GeoTrust, Inc.",C=US'
* NSS error -8172

It should out of the box, so something is weird here.

What does:

rpm -q ca-certificates
rpm -V ca-certificates

output?
What fedora version is this?

kevin
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 04:18 AM
Peter Gueckel
 
Default fedora repo error with yum

Kevin Fenzi wrote:

> What does:
>
> rpm -q ca-certificates
ca-certificates-2011.78-1.fc16.noarch

> rpm -V ca-certificates
{no output}

> What fedora version is this?
cat /etc/fedora-release
Fedora release 16 (Verne)

I am using these repos:

updates
updates-testing
kde-testing
kde-unstable
rpmfusion-(non)free
rpmfusion-(non)free-updates


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 04:33 AM
Peter Gueckel
 
Default fedora repo error with yum

Kevin Fenzi wrote:

> It should out of the box, so something is weird here.

I think it started after yesterday morning's (November 10, 2011 10:52:36)
testing updates. See anything suspect here?

Coin2-2.5.0-11.fc16
NetworkManager-openconnect-0.9.0-3.fc16
OpenImageIO-0.10.3-2.fc16
PackageKit-0.6.20-1.fc16
PyKDE4-4.7.3-1.fc16
apron-0.9.10-4.fc16
authconfig-6.1.16-2.fc16
banshee-2.0.1-3.fc16
barry-0.17.1-4.fc16
blinken-4.7.3-1.fc16
bucardo-4.4.7-1.fc16
cantor-4.7.3-1.fc16
chmsee-1.99-0.4.5.git7fb12b8.fc16
cups-1.5.0-21.fc16
darktable-0.9.3-1.fc16
davfs2-1.4.6-1.fc16
deltacloud-core-0.4.1-4.fc16
deltacloud-core-0.4.1-5.fc16
digikam-2.3.0-2.fc16
drupal7-diff-2.0-1.fc16
drupal7-login_destination-1.0-1.fc16
drupal7-theme-ninesixty-1.0-1.fc16
e00compr-1.0.1-4.fc16
eclipse-3.7.1-1.fc16
eclipse-fedorapackager-0.2.2-3.fc16
emacs-spice-mode-1.2.25-6.fc16
empathy-3.2.1.2-1.fc16
etckeeper-0.57-1.fc16
evolution-data-server-3.2.1-2.fc16
evolution-ews-3.2.1-1.fc16
evolution-rss-0.2.90-31.20111108git.fc16
fflas-ffpack-1.4.3-1.fc16
firefox-8.0-1.fc16
fluxbox-1.3.2-2.fc16
gdb-7.3.50.20110722-10.fc16
gdesklets-goodweather-0.31-7.fc16
ghc-regex-pcre-0.94.2-2.fc16
ghostscript-9.04-7.fc16
givaro-3.5.0-1.fc16
gnome-shell-extension-remove-accessibility-icon-20111008-1.fc16
grantlee-0.2.0-1.fc16
gwenview-4.7.3-1.fc16
ikiwiki-3.20111106-1.fc16
iw-3.2-1.fc16
kalgebra-4.7.3-1.fc16
kalzium-4.7.3-1.fc16
kamera-4.7.3-1.fc16
kanagram-4.7.3-1.fc16
kate-4.7.3-1.fc16
kbruch-4.7.3-1.fc16
kcolorchooser-4.7.3-1.fc16
kde-l10n-4.7.3-1.fc16
kde-wallpapers-4.7.3-5.fc16
kdeaccessibility-4.7.3-1.fc16
kdeadmin-4.7.3-1.fc16
kdeartwork-4.7.3-1.fc16
kdebase-4.7.3-1.fc16
kdebase-runtime-4.7.3-10.fc16
kdebase-workspace-4.7.3-6.fc16
kdeedu-4.7.3-1.fc16
kdegames-4.7.3-1.fc16
kdegraphics-4.7.3-1.fc16
kdegraphics-strigi-analyzer-4.7.3-1.fc16
kdegraphics-thumbnailers-4.7.3-1.fc16
kdelibs-4.7.3-2.fc16
kdemultimedia-4.7.3-1.fc16
kdenetwork-4.7.3-1.fc16
kdepim-4.7.3-1.fc16
kdepim-runtime-4.7.3-1.fc16
kdepimlibs-4.7.3-1.fc16
kdeplasma-addons-4.7.3-1.fc16
kdesdk-4.7.3-1.fc16
kdetoys-4.7.3-1.fc16
kdeutils-4.7.3-1.fc16
kgamma-4.7.3-1.fc16
kgeography-4.7.3-1.fc16
khangman-4.7.3-1.fc16
kig-4.7.3-1.fc16
kiten-4.7.3-1.fc16
klettres-4.7.3-1.fc16
kmplot-4.7.3-1.fc16
kolourpaint-4.7.3-1.fc16
konsole-4.7.3-1.fc16
kross-interpreters-4.7.3-1.fc16
kruler-4.7.3-1.fc16
ksaneplugin-4.7.3-1.fc16
ksnapshot-4.7.3-1.fc16
kstars-4.7.3-1.fc16
ktouch-4.7.3-1.fc16
kturtle-4.7.3-1.fc16
kwordquiz-4.7.3-1.fc16
libdrm-2.4.27-1.fc16
libkactivities-6.1-2.fc16
libkdcraw-4.7.3-1.fc16
libkdeedu-4.7.3-1.fc16
libkexiv2-4.7.3-1.fc16
libkipi-4.7.3-1.fc16
libksane-4.7.3-1.fc16
libmsn-4.2-1.fc16
libmtp-1.1.1-2.fc16
libnih-1.0.2-5.fc16
libpgf-6.11.42-1.fc16
libpinyin-0.2.99.3-1.fc16
libqzeitgeist-0.8.0-3.fc16
libsvm-3.11-1.fc16
linbox-1.2.2-1.fc16
liveusb-creator-3.11.6-1.fc16
mailman-2.1.14-10.fc16
marble-4.7.3-1.fc16
memcached-1.4.10-1.fc16
mod_perl-2.0.5-6.fc16
mozvoikko-1.9.0-10.fc16
mspdebug-0.18-1.fc16
mumble-1.2.3-5.fc16
newlisp-10.3.3-2.fc16
nomnom-0.3.1-1.fc16
nspr-4.8.9-2.fc16
nss-3.13.1-2.fc16
nss-util-3.13.1-1.fc16
okular-4.7.3-1.fc16
openCOLLADA-0-8.svn863.fc16
openfst-1.2.8-1.fc16
opus-0.9.8-1.fc16
oxygen-icon-theme-4.7.3-1.fc16
pacemaker-cloud-0.5.0-1.fc16
pam_yubico-2.8-1.fc16
parley-4.7.3-1.fc16
perl-DateTime-TimeZone-1.42-1.fc16
perl-DateTime-TimeZone-SystemV-0.005-1.fc16
perl-Env-Path-0.18-1.fc16
perl-IO-Socket-SSL-1.49-1.fc16
perl-JSON-RPC-0.96-10.fc16
perl-MooseX-Has-Sugar-0.05070419-2.fc16
perl-Net-Lite-FTP-0.61-3.fc16
phonon-4.5.57-3.20111031.fc16
phonon-backend-gstreamer-4.5.90-3.fc16
postfix-2.8.7-1.fc16
python-asyncmongo-1.1.1-1.fc16
python-postman-0.6.0-1.fc16
python-tornado-2.1.1-1.fc16
rabbitmq-server-2.6.1-1.fc16
ristretto-0.3.0-2.fc16
rocs-4.7.3-1.fc16
samba-3.6.1-75.fc16
setroubleshoot-plugins-3.0.17-1.fc16
smokegen-4.7.3-1.fc16
smokekde-4.7.3-1.fc16
smokeqt-4.7.3-1.fc16
spyder-2.1.1-1.fc16
stellarium-0.11.1-1.fc16
step-4.7.3-1.fc16
svgpart-4.7.3-1.fc16
telepathy-mission-control-5.10.1-1.fc16
telepathy-qt4-0.7.3-1.fc16
texlive-texmf-2007-40.fc16
thunderbird-8.0-1.fc16
thunderbird-lightning-1.0-0.52.rc2.fc16
timidity++-2.13.2-25.fc16
xca-0.9.1-1.fc16
xinput_calibrator-0.7.5-2.fc16
xorg-x11-server-1.11.2-2.fc16
xulrunner-8.0-1.fc16
ykclient-2.6-1.fc16
yubikey-val-2.10-1.fc16
zyGrib-5.0.6-4.fc16

I had all of the kde-4.7.3 stuff already (from kde-testing), so it can't be
that.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 06:03 AM
Kevin Fenzi
 
Default fedora repo error with yum

On Fri, 11 Nov 2011 22:18:24 -0700
Peter Gueckel <pgueckel@gmail.com> wrote:

> Kevin Fenzi wrote:
>
> > What does:
> >
> > rpm -q ca-certificates
> ca-certificates-2011.78-1.fc16.noarch
>
> > rpm -V ca-certificates
> {no output}
>
> > What fedora version is this?
> cat /etc/fedora-release
> Fedora release 16 (Verne)

How about:

rpm -q nss

?

Might be this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=750376

seems possibly similar error codes. Not sure why no one else is seeing
it however if that was the case. ;(

kevin
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 08:30 AM
Michael Schwendt
 
Default fedora repo error with yum

On Sat, 12 Nov 2011 00:03:40 -0700, KF (Kevin) wrote:

> On Fri, 11 Nov 2011 22:18:24 -0700
> Peter Gueckel <pgueckel@gmail.com> wrote:
>
> > Kevin Fenzi wrote:
> >
> > > What does:
> > >
> > > rpm -q ca-certificates
> > ca-certificates-2011.78-1.fc16.noarch
> >
> > > rpm -V ca-certificates
> > {no output}
> >
> > > What fedora version is this?
> > cat /etc/fedora-release
> > Fedora release 16 (Verne)
>
> How about:
>
> rpm -q nss
>
> ?
>
> Might be this bug:
>
> https://bugzilla.redhat.com/show_bug.cgi?id=750376
>
> seems possibly similar error codes. Not sure why no one else is seeing
> it however if that was the case. ;(

That repo error is due to the bad "nss, nss-util, nspr critical path
security update" in updates-testing:

https://admin.fedoraproject.org/updates/FEDORA-2011-15612

It has been withdrawn already, but some mirrors offer it much longer than
what is displayed in bodhi.

Work-around is to downgrade the packages.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 03:48 PM
Peter Gueckel
 
Default fedora repo error with yum

Michael Schwendt wrote:

> On Sat, 12 Nov 2011 00:03:40 -0700, KF (Kevin) wrote:
>
>> How about:
>>
>> rpm -q nss
>>
>> ?
nss-3.13.1-2.fc16.x86_64

>> Might be this bug:
>>
>> https://bugzilla.redhat.com/show_bug.cgi?id=750376

> That repo error is due to the bad "nss, nss-util, nspr critical path
> security update" in updates-testing:
>
> https://admin.fedoraproject.org/updates/FEDORA-2011-15612
>
> It has been withdrawn already, but some mirrors offer it much longer than
> what is displayed in bodhi.
>
> Work-around is to downgrade the packages.

Okay. I will try that.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-12-2011, 04:04 PM
Peter Gueckel
 
Default fedora repo error with yum

Michael Schwendt wrote:

> Work-around is to downgrade the packages.

That worked. I have been able to revert the repo files to using the mirrorlist
and all works again. Thanks.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 04:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org