FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 10-25-2011, 07:40 PM
J B
 
Default F14 - PackageKit vice yum update discrepancy

Hi,

This is F14.

I tried an update:
menu: System-Administration-Software Update (which is PackageKit)
...
Transaction error:
could not add package update for
sane-backends-libs-1.0.22-5.fc14(i686)updates:
sane-backends-libs-1.0.22-5.fc14.i686

which means the update process was interrupted and canceled.

# yum list sane-backends-libs
...
Installed Packages
sane-backends-libs.i686 1.0.22-3.fc14 @updates
Available Packages
sane-backends-libs.i686 1.0.22-5.fc14 updates
#

Next I tried update with yum:
# yum update
...
---> Package sane-backends.i686 0:1.0.22-5.fc14 set to be installed
--> Processing Dependency: sane-backends-libs(x86-32) = 1.0.22-5.fc14
for package: sane-backends-1.0.22-5.fc14.i686
...
--> Running transaction check
---> Package sane-backends-libs.i686 0:1.0.22-5.fc14 set to be updated
--> Finished Dependency Resolution
...
Installing:
...
replacing sane-backends.i686 1.0.22-3.fc14
replacing sane-backends-libs.i686 1.0.22-3.fc14
...
Updating for dependencies:
sane-backends-libs i686 1.0.22-5.fc14 updates 77 k
...
Total download size: 205 M
Is this ok [y/N]: y
Downloading Packages:
...
Presto reduced the update size by 90% (from 182 M to 19 M).
Package(s) data still to download: 23 M
...
(10/16): sane-backends-1.0.22-5.fc14.i686.rpm | 1.0 MB 00:04
(11/16): sane-backends-drivers-cameras-1.0.22-5.fc14.i68 | 40 kB 00:00
(12/16): sane-backends-drivers-scanners-1.0.22-5.fc14.i6 | 2.1 MB 00:08
(13/16): sane-backends-libs-1.0.22-5.fc14.i686.rpm | 77 kB 00:00
...
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
...
Installing : sane-backends-drivers-cameras-1.0.22-5.fc14.i686 10/182
Updating : sane-backends-libs-1.0.22-5.fc14.i686 11/182
Installing : sane-backends-1.0.22-5.fc14.i686
12/182 ...
Dependency Updated:
sane-backends-libs.i686 0:1.0.22-5.fc14

Replaced:
...
sane-backends.i686 0:1.0.22-3.fc14
sane-backends-libs.i686 0:1.0.22-3.fc14
sane-backends-libs-gphoto2.i686 0:1.0.22-3.fc14

Complete!
[root@localhost jb]#

Why the difference ? Perhaps there is an error in one of the update packages ?

JB
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 05:10 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org