FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 03-18-2008, 04:26 PM
Robin Laing
 
Default OT? Help to compile program - ac_nonexitent.h

Hello,

I am trying to compile a program that there is no RPM for. I hope to
use this experience to learn how to make RPM's as well.


I am starting to use Atmel AVR's and I want to try this program.
http://savannah.nongnu.org/projects/simulavr/

(The latest tar file is dated 2008-03-16)
http://download.savannah.nongnu.org/releases/simulavr/

I am looking at other options as well.

While trying to compile the program, I have installed most of the devel
and libs so I only get three or four error messages when running ./configure


One of them that I cannot find any answers to is where do I find
ac_nonexitent.h. I have searched Google (31,800 hits) and I see that
this is a common question for many users but I never see an answer. Two
days of looking and I am no closer to an answer. I did solve the issue
with vfork.h (use unistd.h) this morning.


As others have asked in my searches, I have errors when compiling and
trying to fix all the ./configure issues first.


Is there someone on this list that can at least point me in the right
direction on this question, even to what this header is supposed to do?


I have either F7 or F8 to work with.


--
Robin Laing

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 03-18-2008, 04:26 PM
Robin Laing
 
Default OT? Help to compile program - ac_nonexitent.h

Hello,

I am trying to compile a program that there is no RPM for. I hope to
use this experience to learn how to make RPM's as well.


I am starting to use Atmel AVR's and I want to try this program.
http://savannah.nongnu.org/projects/simulavr/

(The latest tar file is dated 2008-03-16)
http://download.savannah.nongnu.org/releases/simulavr/

I am looking at other options as well.

While trying to compile the program, I have installed most of the devel
and libs so I only get three or four error messages when running ./configure


One of them that I cannot find any answers to is where do I find
ac_nonexitent.h. I have searched Google (31,800 hits) and I see that
this is a common question for many users but I never see an answer. Two
days of looking and I am no closer to an answer. I did solve the issue
with vfork.h (use unistd.h) this morning.


As others have asked in my searches, I have errors when compiling and
trying to fix all the ./configure issues first.


Is there someone on this list that can at least point me in the right
direction on this question, even to what this header is supposed to do?


I have either F7 or F8 to work with.


--
Robin Laing

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 03-18-2008, 05:32 PM
Todd Zullinger
 
Default OT? Help to compile program - ac_nonexitent.h

Robin Laing wrote:
> I am trying to compile a program that there is no RPM for. I hope
> to use this experience to learn how to make RPM's as well.



> I am starting to use Atmel AVR's and I want to try this program.
> http://savannah.nongnu.org/projects/simulavr/
>
> (The latest tar file is dated 2008-03-16)
> http://download.savannah.nongnu.org/releases/simulavr/
>
> I am looking at other options as well.
>
> While trying to compile the program, I have installed most of the
> devel and libs so I only get three or four error messages when
> running ./configure
>
> One of them that I cannot find any answers to is where do I find
> ac_nonexitent.h. I have searched Google (31,800 hits) and I see
^ an 's' is missing, isn't it?
> that this is a common question for many users but I never see an
> answer. Two days of looking and I am no closer to an answer. I did
> solve the issue with vfork.h (use unistd.h) this morning.
>
> As others have asked in my searches, I have errors when compiling
> and trying to fix all the ./configure issues first.

Does configure exit cleanly or does it throw an error when this
happens? I *think* that ac_nonexistent.h is something autoconf uses
to test and isn't supposed to exist. (But I've not found that
documented ATM.) I can tell you that a similar message is found in
the config.log of some software I successfully build all the time.

What errors are you getting from make? It might be worth posting a
link to the output from ./configure && make (and perhaps also the
config.log file).

--
Todd OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~
The power of accurate observation is frequently called cynicism by
those who don't have it.
-- George Bernard Shaw

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 03-18-2008, 05:32 PM
Todd Zullinger
 
Default OT? Help to compile program - ac_nonexitent.h

Robin Laing wrote:
> I am trying to compile a program that there is no RPM for. I hope
> to use this experience to learn how to make RPM's as well.



> I am starting to use Atmel AVR's and I want to try this program.
> http://savannah.nongnu.org/projects/simulavr/
>
> (The latest tar file is dated 2008-03-16)
> http://download.savannah.nongnu.org/releases/simulavr/
>
> I am looking at other options as well.
>
> While trying to compile the program, I have installed most of the
> devel and libs so I only get three or four error messages when
> running ./configure
>
> One of them that I cannot find any answers to is where do I find
> ac_nonexitent.h. I have searched Google (31,800 hits) and I see
^ an 's' is missing, isn't it?
> that this is a common question for many users but I never see an
> answer. Two days of looking and I am no closer to an answer. I did
> solve the issue with vfork.h (use unistd.h) this morning.
>
> As others have asked in my searches, I have errors when compiling
> and trying to fix all the ./configure issues first.

Does configure exit cleanly or does it throw an error when this
happens? I *think* that ac_nonexistent.h is something autoconf uses
to test and isn't supposed to exist. (But I've not found that
documented ATM.) I can tell you that a similar message is found in
the config.log of some software I successfully build all the time.

What errors are you getting from make? It might be worth posting a
link to the output from ./configure && make (and perhaps also the
config.log file).

--
Todd OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~
The power of accurate observation is frequently called cynicism by
those who don't have it.
-- George Bernard Shaw

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 03-18-2008, 06:19 PM
Robin Laing
 
Default OT? Help to compile program - ac_nonexitent.h

Todd Zullinger wrote:

Robin Laing wrote:

I am trying to compile a program that there is no RPM for. I hope
to use this experience to learn how to make RPM's as well.





I am starting to use Atmel AVR's and I want to try this program.
http://savannah.nongnu.org/projects/simulavr/

(The latest tar file is dated 2008-03-16)
http://download.savannah.nongnu.org/releases/simulavr/

I am looking at other options as well.

While trying to compile the program, I have installed most of the
devel and libs so I only get three or four error messages when
running ./configure

One of them that I cannot find any answers to is where do I find
ac_nonexitent.h. I have searched Google (31,800 hits) and I see

^ an 's' is missing, isn't it?

that this is a common question for many users but I never see an
answer. Two days of looking and I am no closer to an answer. I did
solve the issue with vfork.h (use unistd.h) this morning.

As others have asked in my searches, I have errors when compiling
and trying to fix all the ./configure issues first.


Does configure exit cleanly or does it throw an error when this
happens? I *think* that ac_nonexistent.h is something autoconf uses
to test and isn't supposed to exist. (But I've not found that
documented ATM.) I can tell you that a similar message is found in
the config.log of some software I successfully build all the time.

What errors are you getting from make? It might be worth posting a
link to the output from ./configure && make (and perhaps also the
config.log file).




I am doing this at home so I cannot remember the last error message. I
spent most of last night getting rid of all but four error messages in
the config.log file. I was missing many headers at first as well as
other things like bison and yacc. Some simple things as well.


The last two times I tried to run, it stopped with error messages but
that was before I got rid of even more missing items in the log.


Hopefully tonight I will be able to get an answer. I am expecting an
error related to vfork as it is may be looking for the wrong header. I
will have to check the config file (another new experience).



--
Robin Laing

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 01:21 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org