FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 07-23-2011, 08:19 PM
james tate
 
Default Linking shared lib.

FC15

I'm trying to install from the fedora repos honeyd package and it
requires a dependency package libevent-1.4.so.2 which does not exist.

I did a ln -s libevent-2.0.so.5 libevent-1.4.so.2 in /usr/lib .

So i now have in /usr/lib libevent-1.4.so.2 > libevent-2.0.so.5 >
libevent-2.0.so.5.0.1 . But when i try to install honeyd I still
get the error it needs libevent-1.4.so.2 .

What do I do ?
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 07-23-2011, 08:36 PM
Alan Cox
 
Default Linking shared lib.

On Sat, 23 Jul 2011 16:19:46 -0400
james tate <binarynut@comcast.net> wrote:

> FC15
>
> I'm trying to install from the fedora repos honeyd package and it
> requires a dependency package libevent-1.4.so.2 which does not exist.
>
> I did a ln -s libevent-2.0.so.5 libevent-1.4.so.2 in /usr/lib .

The first digit on a library is the major version and indicates an API
version, so you can't just do that.

> So i now have in /usr/lib libevent-1.4.so.2 > libevent-2.0.so.5 >
> libevent-2.0.so.5.0.1 . But when i try to install honeyd I still
> get the error it needs libevent-1.4.so.2 .
>
> What do I do ?

Ask yum

yum resolvedep libevent-1.4.so.2
Loaded plugins: refresh-packagekit
0:libevent-1.4.14b-1.fc14.i686


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 07-23-2011, 08:43 PM
Andre Robatino
 
Default Linking shared lib.

james tate <binarynut <at> comcast.net> writes:

> I'm trying to install from the fedora repos honeyd package and it
> requires a dependency package libevent-1.4.so.2 which does not exist.

Problem exists on both F15 and Rawhide, reported already:

https://bugzilla.redhat.com/show_bug.cgi?id=706658
https://bugzilla.redhat.com/show_bug.cgi?id=712446

I set the Severity on these to Urgent since it makes honeyd uninstallable.



--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 03:41 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org