FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 06-16-2011, 08:08 PM
Mike Wright
 
Default glibc-devel missing gnu/stubs-32.h

Hi all,

I'm trying to compile xen-4.1.1 on f14 and it is failing saying
"/usr/include/gnu/stubs-32.h" no such file.

yum whatprovides stubs-32.h: glibc-devel (installed but doesn't have
that file).

Is this a packaging error in glibc-devel?

It's sure a show-stopper for me.

After much googling I see that this is a very common problem.

Anybody have a copy of it? It's probably about 700 bytes and not to big
to "inline" in a reply :/

Thanks,
Mike Wright
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-16-2011, 08:12 PM
Jakub Jelinek
 
Default glibc-devel missing gnu/stubs-32.h

On Thu, Jun 16, 2011 at 01:08:36PM -0700, Mike Wright wrote:
> I'm trying to compile xen-4.1.1 on f14 and it is failing saying
> "/usr/include/gnu/stubs-32.h" no such file.
>
> yum whatprovides stubs-32.h: glibc-devel (installed but doesn't have
> that file).
>
> Is this a packaging error in glibc-devel?
>

No, user error. You should look more carefully on what provides it,
glibc-devel.i686, rather than glibc-devel.x86_64 you have probably
installed.

So, just
yum install glibc-devel.i686 # and libgcc.i686 probably too

if you want to compile/link 32-bit stuff on x86-64.

Jakub
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-17-2011, 12:51 AM
Rick Stevens
 
Default glibc-devel missing gnu/stubs-32.h

On 06/16/2011 01:12 PM, Jakub Jelinek wrote:
> On Thu, Jun 16, 2011 at 01:08:36PM -0700, Mike Wright wrote:
>> I'm trying to compile xen-4.1.1 on f14 and it is failing saying
>> "/usr/include/gnu/stubs-32.h" no such file.
>>
>> yum whatprovides stubs-32.h: glibc-devel (installed but doesn't have
>> that file).
>>
>> Is this a packaging error in glibc-devel?
>>
>
> No, user error. You should look more carefully on what provides it,
> glibc-devel.i686, rather than glibc-devel.x86_64 you have probably
> installed.
>
> So, just
> yum install glibc-devel.i686 # and libgcc.i686 probably too
>
> if you want to compile/link 32-bit stuff on x86-64.

Just to confirm what Jakub said:

[root@prophead ~]# rpm --qf %{NAME}-%{ARCH}
-qf
/usr/include/gnu/stubs-64.h
glibc-devel-x86_64
[root@prophead ~]# rpm --qf %{NAME}-%{ARCH}
-qf
/usr/include/gnu/stubs-32.h
glibc-devel-i686

----------------------------------------------------------------------
- Rick Stevens, Systems Engineer, C2 Hosting ricks@nerd.com -
- AIM/Skype: therps2 ICQ: 22643734 Yahoo: origrps2 -
- -
- The light at the end of the tunnel is really an oncoming train. -
----------------------------------------------------------------------
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 01:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org