FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 06-03-2011, 11:01 AM
Javier Perez
 
Default CUPS service not starting after upgrade to F15

Hi

How do I solve this?
Cups was working perfectly on F14. I upgrade to F15 and now Cups does not start

[root@bloody cups]# systemctl status cups.service
cups.service - LSB: The CUPS scheduler
********* Loaded: loaded (/etc/rc.d/init.d/cups)

********* Active: failed since Fri, 03 Jun 2011 05:52:30 -0500; 10s ago
******** Process: 1394 ExecStart=/etc/rc.d/init.d/cups start (code=exited, status=1/FAILURE)
********* CGroup: name=systemd:/system/cups.service


All I get on /var/log/messages is the following
Jun* 3 05:52:30 bloody systemd[1]: cups.service: control process exited, code=exited status=1
Jun* 3 05:52:30 bloody systemd[1]: Unit cups.service entered failed state.



How do I trace what is the problem? Have anyone seen this before?

--
------------------------------
*/\_/**
*|O O|* pepebuho@gmail.com
*~~~~ * * Javier Perez

*~~~~* * * * * While the night runs
*~~~~* * * * * toward the day...
* m m** * * Pepebuho watches
* * * * * ** ** from his high perch.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-03-2011, 11:27 AM
Tim Waugh
 
Default CUPS service not starting after upgrade to F15

On Fri, 2011-06-03 at 06:01 -0500, Javier Perez wrote:
> How do I trace what is the problem? Have anyone seen this before?

Take a look in /var/log/cups/error_log.

Tim.
*/

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-03-2011, 11:55 AM
Javier Perez
 
Default CUPS service not starting after upgrade to F15

ok
I erased error_log and started cupsd in the foreground ( cupsd -f)

I got this on error_log:

[root@bloody cups]# cat error_log
I [03/Jun/2011:06:50:25 -0500] Listening to ::1:631 (IPv6)
I [03/Jun/2011:06:50:25 -0500] Listening to 127.0.0.1:631 (IPv4)

I [03/Jun/2011:06:50:25 -0500] Listening to /var/run/cups/cups.sock (Domain)
I [03/Jun/2011:06:50:25 -0500] Remote access is disabled.
D [03/Jun/2011:06:50:25 -0500] Added auto ServerAlias bloody.pphm
D [03/Jun/2011:06:50:25 -0500] Added auto ServerAlias bloody

I [03/Jun/2011:06:50:25 -0500] Loaded configuration file "/etc/cups/cupsd.conf"
I [03/Jun/2011:06:50:25 -0500] Using default TempDir of /var/spool/cups/tmp...
I [03/Jun/2011:06:50:25 -0500] Configured for up to 100 clients.

I [03/Jun/2011:06:50:25 -0500] Allowing up to 100 client connections per host.
I [03/Jun/2011:06:50:25 -0500] Using policy "default" as the default!
I [03/Jun/2011:06:50:25 -0500] Full reload is required.

I [03/Jun/2011:06:50:25 -0500] Loaded MIME database from "/usr/share/cups/mime" and "/etc/cups": 35 types, 45 filters...
D [03/Jun/2011:06:50:25 -0500] Loading printer Canon_IP3000...
D [03/Jun/2011:06:50:25 -0500] load_ppd: Loading /var/cache/cups/Canon_IP3000.ipp4...

D [03/Jun/2011:06:50:25 -0500] Calling DeleteDevice(cups-Canon_IP3000)

Additionally, cupsd -f failed with the following error:

[root@bloody ~]# cupsd -f
process 1461: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 3524.

This is normally a bug in some application using the D-Bus library.
* D-Bus not built with -rdynamic so unable to print a backtrace
Aborted

=======================

I hope it means something to someone, it does not tell me much

It looks like some problem with D-Bus

JP


On Fri, Jun 3, 2011 at 6:27 AM, Tim Waugh <twaugh@redhat.com> wrote:

On Fri, 2011-06-03 at 06:01 -0500, Javier Perez wrote:

> How do I trace what is the problem? Have anyone seen this before?



Take a look in /var/log/cups/error_log.



Tim.

*/




--

users mailing list

users@lists.fedoraproject.org

To unsubscribe or change subscription options:

https://admin.fedoraproject.org/mailman/listinfo/users

Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines




--
------------------------------
*/\_/**
*|O O|* pepebuho@gmail.com
*~~~~ * * Javier Perez
*~~~~* * * * * While the night runs

*~~~~* * * * * toward the day...
* m m** * * Pepebuho watches
* * * * * ** ** from his high perch.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-03-2011, 02:36 PM
Tim Waugh
 
Default CUPS service not starting after upgrade to F15

On Fri, 2011-06-03 at 06:55 -0500, Javier Perez wrote:
> process 1461: arguments to dbus_connection_send_with_reply_and_block()
> were incorrect, assertion "connection != NULL" failed in file
> dbus-connection.c line 3524.

I think that should be fixed by this build:
http://koji.fedoraproject.org/koji/buildinfo?buildID=246196

The fix will be in an official signed update in the next few weeks I
expect.

Tim.
*/

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-03-2011, 03:09 PM
"Clyde E. Kunkel"
 
Default CUPS service not starting after upgrade to F15

On 06/03/2011 10:36 AM, Tim Waugh wrote:
> On Fri, 2011-06-03 at 06:55 -0500, Javier Perez wrote:
>> process 1461: arguments to dbus_connection_send_with_reply_and_block()
>> were incorrect, assertion "connection != NULL" failed in file
>> dbus-connection.c line 3524.
>
> I think that should be fixed by this build:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=246196
>
> The fix will be in an official signed update in the next few weeks I
> expect.
>
> Tim.
> */
>
>

Just tried it and still failing. Should something else be updated
besides cups?

$ rpm -q cups
cups-1.4.6-19.fc15.x86_64

$ systemctl status cups.service
cups.service - LSB: The CUPS scheduler
Loaded: loaded (/etc/rc.d/init.d/cups)
Active: failed since Fri, 03 Jun 2011 10:55:37 -0400; 3min 49s ago
Process: 1669 ExecStart=/etc/rc.d/init.d/cups start (code=exited,
status=1/FAILURE)
CGroup: name=systemd:/system/cups.service

$ sudo systemctl start cups.service
$ systemctl status cups.service
cups.service - LSB: The CUPS scheduler
Loaded: loaded (/etc/rc.d/init.d/cups)
Active: active (running) since Fri, 03 Jun 2011 10:59:46 -0400; 5s ago
Process: 2841 ExecStart=/etc/rc.d/init.d/cups start (code=exited,
status=0/SUCCESS)
Main PID: 2848 (cupsd)
CGroup: name=systemd:/system/cups.service
└ 2848 cupsd -C /etc/cups/cupsd.conf



--
Regards,
OldFart

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-03-2011, 03:50 PM
Tim Waugh
 
Default CUPS service not starting after upgrade to F15

On Fri, 2011-06-03 at 11:09 -0400, Clyde E. Kunkel wrote:
> Just tried it and still failing. Should something else be updated
> besides cups?

What output do you get if you first stop cups, then run "cupsd -f" as
root from the command line?

Tim.
*/

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-03-2011, 05:40 PM
Richard Hughes
 
Default CUPS service not starting after upgrade to F15

On 3 June 2011 12:55, Javier Perez <pepebuho@gmail.com> wrote:
> D [03/Jun/2011:06:50:25 -0500] Loading printer Canon_IP3000...
> D [03/Jun/2011:06:50:25 -0500] load_ppd: Loading
> /var/cache/cups/Canon_IP3000.ipp4...
> D [03/Jun/2011:06:50:25 -0500] Calling DeleteDevice(cups-Canon_IP3000)

So it's deleting the colord device before it adds the device. I've
never seen that before. Can you please open a bug report for cups and
cc me please. Thanks.

Richard.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-04-2011, 03:35 AM
Javier Perez
 
Default CUPS service not starting after upgrade to F15

Hi, Richard. Done. https://bugzilla.redhat.com/show_bug.cgi?id=710689
I am sorry I do not know how to add someone to the cc list of the bug, but I guess you could add yourself.


On Fri, Jun 3, 2011 at 12:40 PM, Richard Hughes <hughsient@gmail.com> wrote:

On 3 June 2011 12:55, Javier Perez <pepebuho@gmail.com> wrote:

> D [03/Jun/2011:06:50:25 -0500] Loading printer Canon_IP3000...

> D [03/Jun/2011:06:50:25 -0500] load_ppd: Loading

> /var/cache/cups/Canon_IP3000.ipp4...

> D [03/Jun/2011:06:50:25 -0500] Calling DeleteDevice(cups-Canon_IP3000)



So it's deleting the colord device before it adds the device. I've

never seen that before. Can you please open a bug report for cups and

cc me please. Thanks.



Richard.

--

users mailing list

users@lists.fedoraproject.org

To unsubscribe or change subscription options:

https://admin.fedoraproject.org/mailman/listinfo/users

Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines



--
------------------------------
*/\_/**
*|O O|* pepebuho@gmail.com
*~~~~ * * Javier Perez
*~~~~* * * * * While the night runs

*~~~~* * * * * toward the day...
* m m** * * Pepebuho watches
* * * * * ** ** from his high perch.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-04-2011, 05:31 AM
Javier Perez
 
Default CUPS service not starting after upgrade to F15

Hi
I solved the problem.
I used the build pointed out by Tim (http://koji.fedoraproject.org/koji/buildinfo?buildID=246196) and it solved the problem.

cups work normally, the test page looks ok and cups starts normally.

I applied the i686 version

Hope that helps any other with a similar problem

Thanks Tim, Richard.

JP


On Fri, Jun 3, 2011 at 10:35 PM, Javier Perez <pepebuho@gmail.com> wrote:

Hi, Richard. Done. https://bugzilla.redhat.com/show_bug.cgi?id=710689
I am sorry I do not know how to add someone to the cc list of the bug, but I guess you could add yourself.



On Fri, Jun 3, 2011 at 12:40 PM, Richard Hughes <hughsient@gmail.com> wrote:


On 3 June 2011 12:55, Javier Perez <pepebuho@gmail.com> wrote:

> D [03/Jun/2011:06:50:25 -0500] Loading printer Canon_IP3000...

> D [03/Jun/2011:06:50:25 -0500] load_ppd: Loading

> /var/cache/cups/Canon_IP3000.ipp4...

> D [03/Jun/2011:06:50:25 -0500] Calling DeleteDevice(cups-Canon_IP3000)



So it's deleting the colord device before it adds the device. I've

never seen that before. Can you please open a bug report for cups and

cc me please. Thanks.



Richard.

--

users mailing list

users@lists.fedoraproject.org

To unsubscribe or change subscription options:

https://admin.fedoraproject.org/mailman/listinfo/users

Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines



--
------------------------------
*/\_/**
*|O O|* pepebuho@gmail.com

*~~~~ * * Javier Perez
*~~~~* * * * * While the night runs

*~~~~* * * * * toward the day...
* m m** * * Pepebuho watches
* * * * * ** ** from his high perch.



--
------------------------------
*/\_/**
*|O O|* pepebuho@gmail.com
*~~~~ * * Javier Perez
*~~~~* * * * * While the night runs

*~~~~* * * * * toward the day...
* m m** * * Pepebuho watches
* * * * * ** ** from his high perch.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 06-04-2011, 11:42 AM
"Clyde E. Kunkel"
 
Default CUPS service not starting after upgrade to F15

On 06/03/2011 11:50 AM, Tim Waugh wrote:
> On Fri, 2011-06-03 at 11:09 -0400, Clyde E. Kunkel wrote:
>> Just tried it and still failing. Should something else be updated
>> besides cups?
>
> What output do you get if you first stop cups, then run "cupsd -f" as
> root from the command line?
>
> Tim.
> */
>
>

cupsd -f just hangs. Have to ctrl-c out. Can start with systemctl start
cups.service

[kunkelc@P5K-EWIFI ~]$ uname -r
2.6.38.7-30.fc15.x86_64
[kunkelc@P5K-EWIFI ~]$ dmesg | grep -i fail
[ 3.757734] failed to evaluate ATIF got AE_BAD_PARAMETER
[ 39.544143] dbus[1447]: [system] Activation via systemd failed for
unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service failed to
load: No such file or directory. See system logs and 'systemctl status'
for details.
[kunkelc@P5K-EWIFI ~]$ systemctl status cups.service
cups.service - LSB: The CUPS scheduler
Loaded: loaded (/etc/rc.d/init.d/cups)
Active: failed since Sat, 04 Jun 2011 07:17:37 -0400; 1min 27s ago
Process: 1650 ExecStart=/etc/rc.d/init.d/cups start (code=exited,
status=1/FAILURE)
CGroup: name=systemd:/system/cups.service
[kunkelc@P5K-EWIFI ~]$ sudo systemctl stop cups.service
[kunkelc@P5K-EWIFI ~]$ sudo cupsd -f
^C
[kunkelc@P5K-EWIFI ~]$ su -
Password:
[root@P5K-EWIFI ~]# cupsd -f
^C
[root@P5K-EWIFI ~]# systemctl start cups.service
[root@P5K-EWIFI ~]# systemctl status cups.service
cups.service - LSB: The CUPS scheduler
Loaded: loaded (/etc/rc.d/init.d/cups)
Active: active (running) since Sat, 04 Jun 2011 07:37:52 -0400; 14s ago
Process: 2886 ExecStart=/etc/rc.d/init.d/cups start (code=exited,
status=0/SUCCESS)
Main PID: 2893 (cupsd)
CGroup: name=systemd:/system/cups.service
└ 2893 cupsd -C /etc/cups/cupsd.conf
[root@P5K-EWIFI ~]# rpm -q cups
cups-1.4.6-19.fc15.x86_64




--
Regards,
OldFart

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 10:05 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org