FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 11-04-2010, 01:45 PM
Colin Paul Adams
 
Default emacs not working on GNOME in fedora 14

The error is Glin-GIO:Error:gdbusconnection.c:2270:inittable
init:assertion failed etc.

Googling showed that this occured in RC1. the tester got round it by
unset -ing DBUS_SESSION_BUS_ADDRESS.

This work-around works for me too. I guess I will have to put it in my
.bash_profile, or whatever one is supposed to use. But shouldn't there
be a fix by now?
--
Colin Adams
Preston Lancashire
() ascii ribbon campaign - against html e-mail
/ www.asciiribbon.org - against proprietary attachments
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-04-2010, 01:55 PM
Tom Horsley
 
Default emacs not working on GNOME in fedora 14

On Thu, 04 Nov 2010 14:45:21 +0000
Colin Paul Adams wrote:

> Googling showed that this occured in RC1. the tester got round it by
> unset -ing DBUS_SESSION_BUS_ADDRESS.

You don't want to do that for everything, or basically nothing
will work, but emacs works fine for me (I have it heavily
customized though - perhaps I've disabled whatever bit is
having the problem).
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-04-2010, 02:44 PM
Michael Schwendt
 
Default emacs not working on GNOME in fedora 14

On Thu, 04 Nov 2010 14:45:21 +0000, Colin wrote:

> The error is Glin-GIO:Error:gdbusconnection.c:2270:inittable
> init:assertion failed etc.
>
> Googling showed that this occured in RC1. the tester got round it by
> unset -ing DBUS_SESSION_BUS_ADDRESS.
>
> This work-around works for me too. I guess I will have to put it in my
> .bash_profile, or whatever one is supposed to use. But shouldn't there
> be a fix by now?

Please, append a question mark to mail subject lines like this.
Emacs works for me in F14 and has not failed in several weaks.
What is the bugzilla ticket number for the problem you refer to?
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-04-2010, 03:05 PM
Colin Paul Adams
 
Default emacs not working on GNOME in fedora 14

>>>>> "Michael" == Michael Schwendt <mschwendt@gmail.com> writes:

Michael> On Thu, 04 Nov 2010 14:45:21 +0000, Colin wrote:
>> The error is Glin-GIO:Error:gdbusconnection.c:2270:inittable
>> init:assertion failed etc.
>>
>> Googling showed that this occured in RC1. the tester got round it
>> by unset -ing DBUS_SESSION_BUS_ADDRESS.
>>
>> This work-around works for me too. I guess I will have to put it
>> in my .bash_profile, or whatever one is supposed to use. But
>> shouldn't there be a fix by now?

Michael> Please, append a question mark to mail subject lines like
Michael> this. Emacs works for me in F14 and has not failed in
Michael> several weaks. What is the bugzilla ticket number for the
Michael> problem you refer to?

I don't know.

I just found this:

http://forums.fedoraforum.org/showthread.php?p=1409936
--
Colin Adams
Preston Lancashire
() ascii ribbon campaign - against html e-mail
/ www.asciiribbon.org - against proprietary attachments
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-04-2010, 06:07 PM
Michael Schwendt
 
Default emacs not working on GNOME in fedora 14

On Thu, 04 Nov 2010 16:05:54 +0000, Colin wrote:

> I just found this:
>
> http://forums.fedoraforum.org/showthread.php?p=1409936

Cannot confirm that. Running Emacs as root after logging into GNOME as an
ordinary user also works for me.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-04-2010, 06:22 PM
"Paul W. Frields"
 
Default emacs not working on GNOME in fedora 14

On Thu, Nov 04, 2010 at 08:07:02PM +0100, Michael Schwendt wrote:
> On Thu, 04 Nov 2010 16:05:54 +0000, Colin wrote:
>
> > I just found this:
> >
> > http://forums.fedoraforum.org/showthread.php?p=1409936
>
> Cannot confirm that. Running Emacs as root after logging into GNOME as an
> ordinary user also works for me.

Emacs under GNOME in F14 is working fine for me on several different
stations. One was a fresh installation, the other a F13->F14
preupgraded station.

--
Paul W. Frields http://paul.frields.org/
gpg fingerprint: 3DA6 A0AC 6D58 FEC4 0233 5906 ACDB C937 BD11 3717
http://redhat.com/ - - - - http://pfrields.fedorapeople.org/
Where open source multiplies: http://opensource.com
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-04-2010, 06:50 PM
Tom Horsley
 
Default emacs not working on GNOME in fedora 14

On Thu, 4 Nov 2010 20:07:02 +0100
Michael Schwendt wrote:

> > http://forums.fedoraforum.org/showthread.php?p=1409936
>
> Cannot confirm that. Running Emacs as root after logging into GNOME as an
> ordinary user also works for me.

Works for me as well, but if I start emacs from a root xterm, I do
see lots of errors spewed on stderr, however none of them seem to
prevent emacs from working.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 11-04-2010, 07:42 PM
"Wolfgang S. Rupprecht"
 
Default emacs not working on GNOME in fedora 14

Tom Horsley <horsley1953@gmail.com> writes:
> On Thu, 4 Nov 2010 20:07:02 +0100
> Michael Schwendt wrote:
>
>> > http://forums.fedoraforum.org/showthread.php?p=1409936
>>
>> Cannot confirm that. Running Emacs as root after logging into GNOME as an
>> ordinary user also works for me.
>
> Works for me as well, but if I start emacs from a root xterm, I do
> see lots of errors spewed on stderr, however none of them seem to
> prevent emacs from working.

# emacs
**
GLib-GIO:ERROR:gdbusconnection.c:2270:initable_init: assertion failed: (connection->initialization_error == NULL)
Fatal error (6)Aborted (core dumped)

Hmm. A plain "emacs<cr>" run under an su-to-root bash shell seems to
fail for me too. Running "emacs -nw" works fine. At first glance it
looks like something in the X11 initialization is screwing up.

-wolfgang

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 11:29 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org