FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 08-14-2010, 05:05 PM
JD
 
Default Xlib: extension "XFree86-Misc" missing on display ":0.0".

$ xset r rate 3 30
Xlib: extension "XFree86-Misc" missing on display ":0.0".

.
.
.
Section "Module"
Load "record"
Load "extmod"
Load "dri2"
Load "dbe"
Load "glx"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbRules" "xfree86"
EndSection

So, what am I missing?

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 08-15-2010, 01:01 AM
James McKenzie
 
Default Xlib: extension "XFree86-Misc" missing on display ":0.0".

JD wrote:
> $ xset r rate 3 30
> Xlib: extension "XFree86-Misc" missing on display ":0.0".
>
This is saying that your display settings are missing. Reading the
below, it does look like they are.
> .
> .
> .
> Section "Module"
> Load "record"
> Load "extmod"
> Load "dri2"
> Load "dbe"
> Load "glx"
> Load "dri"
> EndSection
>
> Section "InputDevice"
> Identifier "Keyboard0"
> Driver "kbd"
> Option "Protocol" "Standard"
> Option "XkbLayout" "us"
> Option "XkbRules" "xfree86"
> EndSection
>
> So, what am I missing?
>
>
This is for your keyboard. Are there any sections that say Monitor0?

James McKenzie

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 08-15-2010, 01:48 AM
JD
 
Default Xlib: extension "XFree86-Misc" missing on display ":0.0".

On 08/14/2010 06:01 PM, James McKenzie wrote:
> JD wrote:
>> $ xset r rate 3 30
>> Xlib: extension "XFree86-Misc" missing on display ":0.0".
>>
> This is saying that your display settings are missing. Reading the
> below, it does look like they are.
>> .
>> .
>> .
>> Section "Module"
>> Load "record"
>> Load "extmod"
>> Load "dri2"
>> Load "dbe"
>> Load "glx"
>> Load "dri"
>> EndSection
>>
>> Section "InputDevice"
>> Identifier "Keyboard0"
>> Driver "kbd"
>> Option "Protocol" "Standard"
>> Option "XkbLayout" "us"
>> Option "XkbRules" "xfree86"
>> EndSection
>>
>> So, what am I missing?
>>
>>
> This is for your keyboard. Are there any sections that say Monitor0?
>
> James McKenzie
>

Here's the whole xorg.conf

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "catalogue:/etc/X11/fontpath.d"
FontPath "built-ins"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "dri2"
Load "dbe"
Load "glx"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 24.0 - 85.0
VertRefresh 48.0 - 76.0
EndSection

Section "Device"
Identifier "Card0"
Driver "radeon"
VendorName "ATI Technologies Inc"
BoardName "RV350 [Mobility Radeon 9600 M10]"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 08-15-2010, 08:38 PM
JD
 
Default Xlib: extension "XFree86-Misc" missing on display ":0.0".

On 08/14/2010 10:05 AM, JD wrote:
> $ xset r rate 3 30
> Xlib: extension "XFree86-Misc" missing on display ":0.0".
I tracked down the original bug against xset bailing out with
this error:
https://bugs.freedesktop.org/show_bug.cgi?id=2258

A patch was issued, but apparently never integrated, or
perhaps never accepted by the mainline devs.

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 08-15-2010, 08:57 PM
JD
 
Default Xlib: extension "XFree86-Misc" missing on display ":0.0".

On 08/15/2010 01:38 PM, JD wrote:
> On 08/14/2010 10:05 AM, JD wrote:
>> $ xset r rate 3 30
>> Xlib: extension "XFree86-Misc" missing on display ":0.0".
> I tracked down the original bug against xset bailing out with
> this error:
> https://bugs.freedesktop.org/show_bug.cgi?id=2258
>
> A patch was issued, but apparently never integrated, or
> perhaps never accepted by the mainline devs.
>

Though I am still unable to get
xset r rate N M (where N=delay, M=rate)
to work, I decided to look at the defaults.

Do these default values look reasonable?

$ xset q
Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
auto repeat delay: 985 repeat rate: 111
auto repeating keys: 00ffffffdffffbbf
fadfffefffedffff
9fffffffffffffff
fff7ffffffffffff

I never set the value of the autorepeating keys.
How are they being set like this by default?

As you can see the delay is almost a full second,
but in practice, it is more like 1.20 seconds.

If on your fedora xset r rate N M
works without giving you the error message,
could you please share your xorg.conf and the
version of these packages:
xorg-x11-server-utils
xorg-x11-server-common
xorg-x11-server-Xorg

Thanx.

JD
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 03:24 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org