FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 07-29-2010, 08:22 PM
Richard Shaw
 
Default HELP! Installed some rawhide packages and now system will not boot!

Well I installed parted/libparted from rawhide to get version 2.3 as I
was bitten by the resize bug and some other issues with the current
version in Fedora 12/13. It pulled in a few dependencies and one of
them broke my system, I'm thinking it was dev-mapper.

On reboot LVM was able to find all 4 of my logical volumes but then
the boot process fails and I get a message that I need to run e2fsck.
The actual problem is that for some reason only two of my four LVs are
showing in /dev/mapper... I booted System Rescue CD and it was able to
mount the LVs fine and they all checked out clean.

I have the following LVM layout:

VG: vg-hobbes
LVs: lv-root, lv-var, lv-swap

VG: vg-home (whole disk VG, no dos partition)
LV: lv-home

Only lv-home and lv-var are showing up in /dev/mapper

My plan at this point is to boot a Fedora LiveCD, mount my LVs and
chroot to it. I'm hoping rpm and yum will work properly from a
chroot'ed environment.

Any ideas would be greatly appreciated.

Richard
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 05:01 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org