FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 02-19-2010, 09:26 PM
"Peter J. Stieber"
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

I had an initial attempt at preupgrade that failed, but I followed the
Method 2 instructions at

http://fedoraproject.org/wiki/How_to_use_PreUpgrade#Not_enough_space_in_.2Fboot

and successfully upgraded.

After upgrading I ran...

# package-cleanup --orphans
alsa-lib-1.0.22-3.fc11.x86_64
alsa-lib-devel-1.0.22-3.fc11.x86_64

So I removed alsa-lib-devel-1.0.22-3.fc11.x86_64...

yum erase alsa-lib-devel
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package alsa-lib-devel.x86_64 0:1.0.22-3.fc11 set to be erased
--> Processing Dependency: alsa-lib-devel for package:
xulrunner-devel-1.9.1.6-2.fc12.x86_64
--> Processing Dependency: alsa-lib-devel for package:
SDL-devel-1.2.13-10.fc12.x86_64
--> Running transaction check
---> Package SDL-devel.x86_64 0:1.2.13-10.fc12 set to be erased
---> Package xulrunner-devel.x86_64 0:1.9.1.6-2.fc12 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===============
Package Arch Version Repository Size
================================================== ===============
Removing:
alsa-lib-devel x86_64 1.0.22-3.fc11 installed 13 M
Removing for dependencies:
SDL-devel x86_64 1.2.13-10.fc12 installed 1.4 M
xulrunner-devel x86_64 1.9.1.6-2.fc12 installed 21 M

Transaction Summary
================================================== ===============
Remove 3 Package(s)
Reinstall 0 Package(s)
Downgrade 0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : alsa-lib-devel-1.0.22-3.fc11.x86_64 1/3
Erasing : SDL-devel-1.2.13-10.fc12.x86_64 2/3
Erasing : xulrunner-devel-1.9.1.6-2.fc12.x86_64 3/3

Removed:
alsa-lib-devel.x86_64 0:1.0.22-3.fc11

Dependency Removed:
SDL-devel.x86_64 0:1.2.13-10.fc12 xulrunner-devel.x86_64
0:1.9.1.6-2.fc12

Complete!

If I try to erase alsa-lib-1.0.22-3.fc11.x86_64, there are a ton of
dependent packages that will be erased. I don't want to do that.

If I try to reinstall SDL-devel, an i686 version of the alsa-lib package
wants to be installed. I'm running an x86_64 kernel...

yum install SDL-devel
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package SDL-devel.x86_64 0:1.2.13-10.fc12 set to be updated
--> Processing Dependency: alsa-lib-devel for package:
SDL-devel-1.2.13-10.fc12.x86_64
--> Running transaction check
---> Package alsa-lib-devel.x86_64 0:1.0.22-2.fc12 set to be updated
--> Processing Dependency: alsa-lib = 1.0.22-2.fc12 for package:
alsa-lib-devel-1.0.22-2.fc12.x86_64
--> Running transaction check
---> Package alsa-lib.i686 0:1.0.22-2.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== =====================
Package Arch Version Repository Size
================================================== =====================
Installing:
SDL-devel x86_64 1.2.13-10.fc12 fedora 327 k
Installing for dependencies:
alsa-lib i686 1.0.22-2.fc12 updates 367 k
alsa-lib-devel x86_64 1.0.22-2.fc12 updates 1.0 M


What should I do to resolve this (i.e. get ALSA updated to the latest
Fedora 12 x86_64 versions)?

TIA,
Pete
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 02-23-2010, 03:46 PM
"Peter J. Stieber"
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

Making another attempt to explain my problem...

After the F11 -> F12 preupgrade process, I have an orphaned ALSA lib
package...

# package-cleanup --orphans
Loaded plugins: dellsysidplugin2, refresh-packagekit
alsa-lib-1.0.22-3.fc11.x86_64

When I try to update...

# yum update alsa-lib
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Update Process
No Packages marked for Update

When I try to install...

# yum install alsa-lib
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Install Process
Package matching alsa-lib-1.0.22-2.fc12.x86_64 already installed.
Checking for update.
Nothing to do

If I try to remove the version that was reported as installed...

# yum erase alsa-lib-1.0.22-2.fc12.x86_64
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Remove Process
No Match for argument: alsa-lib-1.0.22-2.fc12.x86_64
Package(s) alsa-lib-1.0.22-2.fc12.x86_64 available, but not installed.
No Packages marked for removal

If I try to remove alsa-lib (the old F11 version) over 100 other
packages will be removed due to dependencies.

How can I upgrade alsa-lib to the Fedora 12 version without having to
remember the other > 100 packages I would have to reinstall?

Pete
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 02-23-2010, 08:46 PM
Tony Nelson
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

On 10-02-23 11:46:51, Peter J. Stieber wrote:
> Making another attempt to explain my problem...
>
> After the F11 -> F12 preupgrade process, I have an orphaned ALSA lib
> package...
...
> alsa-lib-1.0.22-3.fc11.x86_64
...
> Package matching alsa-lib-1.0.22-2.fc12.x86_64 already installed.
...

Note this is a lower version.

> How can I upgrade alsa-lib to the Fedora 12 version without having to
> remember the other > 100 packages I would have to reinstall?

1) Wait. You already have a newer version.

2) Downgrade the package. See `man yum` for caveats.

3) Download the package with yumdownloader and install it with RPM (see
--oldpackage).

--
__________________________________________________ __________________
TonyN.:' <mailto:tonynelson@georgeanelson.com>
' <http://www.georgeanelson.com/>
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 02-23-2010, 11:11 PM
"Peter J. Stieber"
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

On 10-02-23 11:46:51, PS = Pete Stieber wrote:
PS>> Making another attempt to explain my problem...
PS>>
PS>> After the F11 -> F12 preupgrade process, I have an
PS>> orphaned ALSA lib package...
PS>> ...
PS>> alsa-lib-1.0.22-3.fc11.x86_64
PS>> ...
PS>> Package matching alsa-lib-1.0.22-2.fc12.x86_64
PS>> already installed.
PS>> ...

On 2/23/2010 1:46 PM, TN = Tony Nelson wrote:
TN> Note this is a lower version.

Thanks Tony. I completely ignored this and was hung-up on the fc11 vs.
fc12 portion of the version.

PS>> How can I upgrade alsa-lib to the Fedora 12
PS>> version without having to remember the other
PS>> 100 packages I would have to reinstall?

TN> 1) Wait. You already have a newer version.

But I was hoping to use the non-orphaned fc12 version.

TN> 2) Downgrade the package. See `man yum` for
TN> caveats.

This worked. Thank you. And fortunately

yum update

does *not* update to the higher numbered fc11 version.

TN> 3) Download the package with yumdownloader
TN> and install it with RPM (see --oldpackage).

I didn't need to do this.

Thanks again.

BTW, It would be "I Dream of Jeannie freaky" if you were ever a Major in
the U.S. Air Force, but I'm sure you have heard that before ;-)

Pete

--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 02-23-2010, 11:48 PM
Tony Nelson
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

On 10-02-23 19:11:18, Peter J. Stieber wrote:
> On 10-02-23 11:46:51, PS = Pete Stieber wrote:
> PS>> Making another attempt to explain my problem...
> PS>>
> PS>> After the F11 -> F12 preupgrade process, I have an
> PS>> orphaned ALSA lib package...
> PS>> ...
> PS>> alsa-lib-1.0.22-3.fc11.x86_64
> PS>> ...
> PS>> Package matching alsa-lib-1.0.22-2.fc12.x86_64
> PS>> already installed.
> PS>> ...
>
> On 2/23/2010 1:46 PM, TN = Tony Nelson wrote:
> TN> Note this is a lower version.
>
> Thanks Tony. I completely ignored this and was hung-up on the fc11
> vs. fc12 portion of the version.

That's the least important part of the version scheme.

...
> TN> 1) Wait. You already have a newer version.
>
> But I was hoping to use the non-orphaned fc12 version.

The difference between alsa-lib-1.0.22-3.fc11.x86_64 and a hypothetical
alsa-lib-1.0.22-3.fc12.x86_64 is the environment they were compiled in,
as they start from the same source code. An update to alsa-lib in F12
would have a higher version and would replace the one you had.


> TN> 2) Downgrade the package. See `man yum` for
> TN> caveats.
>
> This worked. Thank you. And fortunately
>
> yum update
>
> does *not* update to the higher numbered fc11 version.
...

That would only happen if the F11 repos were active, but in that case,
the package would not have been an orphan.


> BTW, It would be "I Dream of Jeannie freaky" if you were ever a Major
> in the U.S. Air Force, but I'm sure you have heard that before ;-)

I was USNavy Enlisted.

--
__________________________________________________ __________________
TonyN.:' <mailto:tonynelson@georgeanelson.com>
' <http://www.georgeanelson.com/>
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 02-23-2010, 11:56 PM
Don Quixote de la Mancha
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

>> BTW, It would be "I Dream of Jeannie freaky" if you were ever a Major
>> in the U.S. Air Force, but I'm sure you have heard that before ;-)
>
> I was USNavy Enlisted.

For fifteen years now, I have been getting adoring fan mail from women
who apparently suffer from poor reading comprehension. I'm pretty
sure most of them would have had my baby, had I but asked.

One women asked me to sing at her daughter's wedding. When I said
that I only knew how to play piano, and could not sing, she asked me
to sing anyway.

Michael Crawford
--
Don Quixote de la Mancha
quixote@dulcineatech.com
http://www.dulcineatech.com

Dulcinea Technologies Corporation: Software of Elegance and Beauty.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 02-24-2010, 12:28 AM
Konstantin Svist
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

On 02/23/2010 04:56 PM, Don Quixote de la Mancha wrote:
> For fifteen years now, I have been getting adoring fan mail from women
> who apparently suffer from poor reading comprehension. I'm pretty
> sure most of them would have had my baby, had I but asked.
>
> One women asked me to sing at her daughter's wedding. When I said
> that I only knew how to play piano, and could not sing, she asked me
> to sing anyway.
>

Uhh.. how does "preupgrade problem..." turn to THIS?
Or should I instead ask, why does this always happen on this list?


--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 
Old 02-24-2010, 01:33 AM
Tim
 
Default F11 -> F12 preupgrade problem resulted in odd alsa loaded

On Tue, 2010-02-23 at 17:28 -0800, Konstantin Svist wrote:
> Uhh.. how does "preupgrade problem..." turn to THIS?

It's the "community" aspect of Fedora. ;-)

I don't mind an *occasional* *small* tangental slip, probably most
people don't care, either.

--
[tim@localhost ~]$ uname -r
2.6.27.25-78.2.56.fc9.i686

Don't send private replies to my address, the mailbox is ignored. I
read messages from the public lists.



--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
 

Thread Tools




All times are GMT. The time now is 07:22 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org