FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 02-10-2010, 11:37 AM
"Robert P. J. Day"
 
Default setting up the android SDK on fedora

i mentioned this before, but i plan on documenting how to get the
android SDK up and running on fedora, and i've started documenting the
process here:

http://www.crashcourse.ca/wiki/index.php/Android_on_64-bit_Fedora_12

so far, only the first two links are reasonably fleshed out, so if
one wants to follow along just to run the emulator, feel free, and
email me anything you think needs to be added to that page. i've
already been given some advice on how to install additional sound
packages to get around the sound issue.

so, for now, the emulator page is fairly skeletal and you can email
me any other cool things that would be useful there as i work on the
later topics.

rday
--

================================================== ======================
Robert P. J. Day Waterloo, Ontario, CANADA

Linux Consulting, Training and Kernel Pedantry.

Web page: http://crashcourse.ca
Twitter: http://twitter.com/rpjday
================================================== ======================
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
 
Old 02-11-2010, 12:00 PM
Don Quixote de la Mancha
 
Default setting up the android SDK on fedora

Robert,

On Wed, Feb 10, 2010 at 4:37 AM, Robert P. J. Day <rpjday@crashcourse.ca> wrote:
> *i mentioned this before, but i plan on documenting how to get the
> android SDK up and running on fedora, and i've started documenting the
> process here:
>
> http://www.crashcourse.ca/wiki/index.php/Android_on_64-bit_Fedora_12

Android wants the 1.5 JDK; it's incompatible with Java 1.6.

That gets to be a really annoying problem, because there is lots of
software that wants to suck Java 1.6 in as a dependency.

I haven't actually tried it, but it ought to be possible to install
both Java 1.5 and Java 1.6, then set up some environment variables so
that Android only sees 1.5 while everything else sees 1.6.

Android is also incompatible with every version of gcj, the GNU Java compiler.

Best,

Don Quixote
--
Don Quixote de la Mancha
quixote@dulcineatech.com
http://www.dulcineatech.com

Dulcinea Technologies Corporation: Software of Elegance and Beauty.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
 
Old 02-11-2010, 12:00 PM
Don Quixote de la Mancha
 
Default setting up the android SDK on fedora

Robert,

On Wed, Feb 10, 2010 at 4:37 AM, Robert P. J. Day <rpjday@crashcourse.ca> wrote:
> *i mentioned this before, but i plan on documenting how to get the
> android SDK up and running on fedora, and i've started documenting the
> process here:
>
> http://www.crashcourse.ca/wiki/index.php/Android_on_64-bit_Fedora_12

Android wants the 1.5 JDK; it's incompatible with Java 1.6.

That gets to be a really annoying problem, because there is lots of
software that wants to suck Java 1.6 in as a dependency.

I haven't actually tried it, but it ought to be possible to install
both Java 1.5 and Java 1.6, then set up some environment variables so
that Android only sees 1.5 while everything else sees 1.6.

Android is also incompatible with every version of gcj, the GNU Java compiler.

Best,

Don Quixote
--
Don Quixote de la Mancha
quixote@dulcineatech.com
http://www.dulcineatech.com

Dulcinea Technologies Corporation: Software of Elegance and Beauty.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
 
Old 02-12-2010, 10:44 AM
"Robert P. J. Day"
 
Default setting up the android SDK on fedora

On Thu, 11 Feb 2010, Don Quixote de la Mancha wrote:

> Robert,
>
> On Wed, Feb 10, 2010 at 4:37 AM, Robert P. J. Day <rpjday@crashcourse.ca> wrote:
> > *i mentioned this before, but i plan on documenting how to get the
> > android SDK up and running on fedora, and i've started documenting
> > the process here:
> >
> > http://www.crashcourse.ca/wiki/index.php/Android_on_64-bit_Fedora_12
>
> Android wants the 1.5 JDK; it's incompatible with Java 1.6.

seriously? even running the emulator? because i can do *that* with
openjdk 1.6.

rday
--

================================================== ======================
Robert P. J. Day Waterloo, Ontario, CANADA

Linux Consulting, Training and Kernel Pedantry.

Web page: http://crashcourse.ca
Twitter: http://twitter.com/rpjday
================================================== ======================--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
 
Old 02-12-2010, 10:44 AM
"Robert P. J. Day"
 
Default setting up the android SDK on fedora

On Thu, 11 Feb 2010, Don Quixote de la Mancha wrote:

> Robert,
>
> On Wed, Feb 10, 2010 at 4:37 AM, Robert P. J. Day <rpjday@crashcourse.ca> wrote:
> > *i mentioned this before, but i plan on documenting how to get the
> > android SDK up and running on fedora, and i've started documenting
> > the process here:
> >
> > http://www.crashcourse.ca/wiki/index.php/Android_on_64-bit_Fedora_12
>
> Android wants the 1.5 JDK; it's incompatible with Java 1.6.

seriously? even running the emulator? because i can do *that* with
openjdk 1.6.

rday
--

================================================== ======================
Robert P. J. Day Waterloo, Ontario, CANADA

Linux Consulting, Training and Kernel Pedantry.

Web page: http://crashcourse.ca
Twitter: http://twitter.com/rpjday
================================================== ======================--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
 
Old 02-12-2010, 11:11 AM
Don Quixote de la Mancha
 
Default setting up the android SDK on fedora

On Fri, Feb 12, 2010 at 3:44 AM, Robert P. J. Day <rpjday@crashcourse.ca> wrote:
>> Android wants the 1.5 JDK; it's incompatible with Java 1.6.
>
> *seriously? *even running the emulator? *because i can do *that* with
> openjdk 1.6.

The Android.com website says somewhere that JDK 1.6 is incompatible
with some construction used by Android's Java. I think it may be a
Google-specific extension to the Java language.

On my own box, I find that despite my best efforts, I am unable to
prevent 1.6 from getting installed. All I have to do is sneeze, and
then Yum wants to install the 1.6 JDK because it is a dependency of
the tissue with which I wipe my nose.

So what I'm going to have to do, is have both the 1.5 and 1.6 JDKs
installed, but hide the 1.6 from all the Android tools.

Don Quixote.
--
Don Quixote de la Mancha
quixote@dulcineatech.com
http://www.dulcineatech.com

Dulcinea Technologies Corporation: Software of Elegance and Beauty.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
 
Old 02-12-2010, 11:11 AM
Don Quixote de la Mancha
 
Default setting up the android SDK on fedora

On Fri, Feb 12, 2010 at 3:44 AM, Robert P. J. Day <rpjday@crashcourse.ca> wrote:
>> Android wants the 1.5 JDK; it's incompatible with Java 1.6.
>
> *seriously? *even running the emulator? *because i can do *that* with
> openjdk 1.6.

The Android.com website says somewhere that JDK 1.6 is incompatible
with some construction used by Android's Java. I think it may be a
Google-specific extension to the Java language.

On my own box, I find that despite my best efforts, I am unable to
prevent 1.6 from getting installed. All I have to do is sneeze, and
then Yum wants to install the 1.6 JDK because it is a dependency of
the tissue with which I wipe my nose.

So what I'm going to have to do, is have both the 1.5 and 1.6 JDKs
installed, but hide the 1.6 from all the Android tools.

Don Quixote.
--
Don Quixote de la Mancha
quixote@dulcineatech.com
http://www.dulcineatech.com

Dulcinea Technologies Corporation: Software of Elegance and Beauty.
--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
 

Thread Tools




All times are GMT. The time now is 09:41 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org