Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   Gnome failing on first login (http://www.linux-archive.org/fedora-user/320308-gnome-failing-first-login.html)

"Andrew Commons" 02-03-2010 09:59 PM

Gnome failing on first login
 
Hi,

I am setting up authentication using LDAP (using the 389 server). I create a
new user in the directory and then try and login. The home directory is
created but Gnome will not start and examining the home directory shows that
most (all?) Gnome related directories and files are missing.

My workaround, at present, is as follows:

(1) Create the user normally on the system.
(2) Login to the user and immediately log out.
(3) Remove the user from the system making sure I do not remove the home and
mail directories.
(4) Add the user into LDAP using the same username, UID and GID as the
temporary system user.

The login now works.

Is there a better way than this ugly kludge?

As an aside, I logged into the user for the first time using Switch User,
when I logged out and logged back into the original user I could not remove
the new user because there were still processes owned by the user running.
I'm not sure if this is a timing issue or something else. I logged out
completely and logged in again and all was OK. Any ideas on that as well?

Cheers,
Andrew



--
users mailing list
users@lists.fedoraproject.org
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines


All times are GMT. The time now is 11:38 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.