FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 02-01-2012, 07:37 PM
P Nikolic
 
Default Google earth

On Wednesday 01 Feb 2012 19:48:08 P Nikolic wrote:
> Well
>
> Kmail seems to be a little better behaved now thanks for the help .
>
> Now got Google earth installed (loads of 32 bit stuff added from multilib)
> now it starts up then bombs out after a few seconds with an error report
> as
>
> Major Version 6
> Minor Version 2
> Build Number 0000
> Build Date Jan 23 2012
> Build Time 17:11:07
> OS Type 3
> OS Major Version 3
> OS Minor Version 2
> OS Build Version 2
> OS Patch Version 0
> Crash Signal 11
> Crash Time 1328125391
> Up Time 5.39584
>
> Stacktrace from glibc:
> ./libgoogleearth_free.so(+0xc0af3)[0xf7681af3]
> ./libgoogleearth_free.so(+0xc0c73)[0xf7681c73]
> [0xf7707400]
>
> anyone got this working right up to date on kernel KDE ect ect
> uname -a
> Linux 7-of-9 3.2.2-1-ARCH #1 SMP PREEMPT Thu Jan 26 08:40:20 CET 2012 x86_64
> AMD Phenom(tm) 9600B Quad-Core Processor AuthenticAMD GNU/Linux
> 7-of-9:/ #
>
>
> Cheers Pete .

Quick thought .

I am running the nouveau driver not the Nvidia i have tried to install
lib32-nvidia-utils but got the report below do i take it that i need to
install the full Nvidia binary ( i do not mind installing it BTW) but thought
i would give the nouveau a try out as the last time i tried it Opensuse it
was horrible



7-of-9:/ # pacman -S lib32-nvidia-utils
resolving dependencies...
looking for inter-conflicts...
:: nvidia-utils and libgl are in conflict. Remove libgl? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-utils and libgl are in conflict


Pete
 
Old 02-01-2012, 07:47 PM
Jesse Juhani Jaara
 
Default Google earth

keskiviikko, 1. helmikuuta 2012 20:37:36 P Nikolic kirjoitti:
> I am running the nouveau driver not the Nvidia i have tried to install
> lib32-nvidia-utils but got the report below do i take it that i need to
> install the full Nvidia binary ( i do not mind installing it BTW) but
> thought i would give the nouveau a try out as the last time i tried it
> Opensuse it was horrible
You can't have 2 differend drivers in use (unless they use differend
kernel module..) at the same time. Its eather nouveau in 64bit and
in 32bit apps too, or nvidia blob on both archs...
 
Old 02-01-2012, 07:55 PM
P Nikolic
 
Default Google earth

On Wednesday 01 Feb 2012 22:47:47 Jesse Juhani Jaara wrote:
> keskiviikko, 1. helmikuuta 2012 20:37:36 P Nikolic kirjoitti:
> > I am running the nouveau driver not the Nvidia i have tried to
> > install
> > lib32-nvidia-utils but got the report below do i take it that i need to
> > install the full Nvidia binary ( i do not mind installing it BTW) but
> > thought i would give the nouveau a try out as the last time i tried it
> > Opensuse it was horrible
>
> You can't have 2 differend drivers in use (unless they use differend
> kernel module..) at the same time. Its eather nouveau in 64bit and
> in 32bit apps too, or nvidia blob on both archs...
Hi
Yes iam fully aware of that but basically my question was i am at the moment
running the nouveau do i need to switch to the Nvidia Binary driver to get
Google earth to behave or can i tell pacman to deinstall the libgl and
install the nvidia-utils (or are the nvidia-utils for the Nvidia binary
driver in which casse the answer is pre determined)


Pete .
 
Old 02-01-2012, 08:03 PM
Jesse Juhani Jaara
 
Default Google earth

keskiviikko, 1. helmikuuta 2012 20:55:36 P Nikolic kirjoitti:
> driver to get Google earth to behave or can i tell pacman to deinstall the
> libgl and install the nvidia-utils (or are the nvidia-utils for the Nvidia
> binary driver in which casse the answer is pre determined)

nvidia-utils is the user space part of Nvidia's binary blob
nvidia pkg provides the kernel module....
 
Old 02-01-2012, 08:11 PM
P Nikolic
 
Default Google earth

On Wednesday 01 Feb 2012 23:03:04 Jesse Juhani Jaara wrote:
> keskiviikko, 1. helmikuuta 2012 20:55:36 P Nikolic kirjoitti:
> > driver to get Google earth to behave or can i tell pacman to deinstall
> > the
> > libgl and install the nvidia-utils (or are the nvidia-utils for the
> > Nvidia
> > binary driver in which casse the answer is pre determined)
>
> nvidia-utils is the user space part of Nvidia's binary blob
> nvidia pkg provides the kernel module....

Ok ..

So all i got to do now is determine whether i need to switch to the Nvidia
binary or stay with the nouveau to get google earth working

Pete .
 
Old 02-01-2012, 08:17 PM
Ionut Biru
 
Default Google earth

On 02/01/2012 11:11 PM, P Nikolic wrote:
> On Wednesday 01 Feb 2012 23:03:04 Jesse Juhani Jaara wrote:
>> keskiviikko, 1. helmikuuta 2012 20:55:36 P Nikolic kirjoitti:
>>> driver to get Google earth to behave or can i tell pacman to deinstall
>>> the
>>> libgl and install the nvidia-utils (or are the nvidia-utils for the
>>> Nvidia
>>> binary driver in which casse the answer is pre determined)
>>
>> nvidia-utils is the user space part of Nvidia's binary blob
>> nvidia pkg provides the kernel module....
>
> Ok ..
>
> So all i got to do now is determine whether i need to switch to the Nvidia
> binary or stay with the nouveau to get google earth working
>
> Pete .
>

install lib32-nouveau-dri then

--
IonuČ›
 
Old 02-01-2012, 08:35 PM
"David C. Rankin"
 
Default Google earth

On 02/01/2012 03:17 PM, Ionut Biru wrote:

Ok ..
>
> So all i got to do now is determine whether i need to switch to the Nvidia
> binary or stay with the nouveau to get google earth working
>
> Pete .
>

install lib32-nouveau-dri then



Pete,

If that doesn't fix it, then install the binaries:

# pacman -Sy nvidia nvidia-utils

(if you installed the LTS kernel, the also install 'nvidia-lts')

I've run the binaries for a couple of years without issue Biru also
packages opencl-nvidia for development.



--
David C. Rankin, J.D.,P.E.
 
Old 02-01-2012, 09:26 PM
P Nikolic
 
Default Google earth

On Wednesday 01 Feb 2012 23:17:27 Ionut Biru wrote:
> On 02/01/2012 11:11 PM, P Nikolic wrote:
> > On Wednesday 01 Feb 2012 23:03:04 Jesse Juhani Jaara wrote:
> >> keskiviikko, 1. helmikuuta 2012 20:55:36 P Nikolic kirjoitti:
> >>> driver to get Google earth to behave or can i tell pacman to deinstall
> >>> the
> >>> libgl and install the nvidia-utils (or are the nvidia-utils for the
> >>> Nvidia
> >>> binary driver in which casse the answer is pre determined)
> >>
> >> nvidia-utils is the user space part of Nvidia's binary blob
> >> nvidia pkg provides the kernel module....
> >
> > Ok ..
> >
> > So all i got to do now is determine whether i need to switch to the Nvidia
> > binary or stay with the nouveau to get google earth working
> >
> > Pete .
>
> install lib32-nouveau-dri then

Thanks muchly thats the one fixed

cheers Pete
 

Thread Tools




All times are GMT. The time now is 11:32 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org