FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 01-28-2012, 01:24 PM
Kwpolska
 
Default Google earth

On Sat, Jan 28, 2012 at 3:05 PM, Peter G Nikolic
<p.nikolic1@btinternet.com> wrote:
> On Saturday 28 Jan 2012 14:24:19 Karol Blazewicz wrote:
>> On Sat, Jan 28, 2012 at 2:14 PM, Peter G Nikolic
>>
>> <p.nikolic1@btinternet.com> wrote:
>> > Hi
>> >
>> > Does anyone have a method of getting google earth to work i HAVE tried
>> > the stuff in AUR it fails completely the packages it complains about
>> > are all out of date and have so many deps that are also out of date *it
>> > is like chasing your own tail up your own backside
>>
>> archstuff unofficial user repo has google-earth 5.2.1.1588-1
>> Have you tried the updated
>> https://aur.archlinux.org/packages.php?ID=15270 ? Does it fail too?
>
>
> Yep exactly the same failure word for word
>
> ==> Making package: google-earth 6.2.0.5905-1 (Sat Jan 28 14:03:26 GMT 2012)
> ==> Checking runtime dependencies...
> ==> Missing Dependencies:
> *-> lib32-fontconfig
> *-> ld-lsb
> *-> lib32-libgl
> *-> lib32-libsm
> *-> lib32-libxi
> *-> lib32-libxrender
> *-> lib32-pcre
> ==> Checking buildtime dependencies...
> ==> ERROR: Could not resolve all dependencies.
>
> so then for each of the deps i get *..
>
> :/ # pacman -S lib32-fontconfig
> error: target not found: lib32-fontconfig
>
>
> Pete
>
>
> --
> Powered by *Kernel: 3.2.2-1-ARCH
> KDE Development Platform: 4.7.4 (4.7.4)
> *14:03:57 up 21:13, *5 users, *load average: 0.13, 0.09, 0.06
>

First of, you need the [multilib] repo, add it to your pacman.conf.
Second of, you need to get the ld-lsb package from the AUR.
Third of, you should run makepkg with `-si' options.

--
Kwpolska <http://kwpolska.tk>
stop html mail * * *| always bottom-post
www.asciiribbon.org | www.netmeister.org/news/learn2quote.html
GPG KEY: 5EAAEA16 * | Arch Linux x86_64, zsh, mutt, vim.
# vim:set textwidth=70:
 
Old 01-28-2012, 01:49 PM
Peter G Nikolic
 
Default Google earth

On Saturday 28 Jan 2012 15:24:42 Kwpolska wrote:
> On Sat, Jan 28, 2012 at 3:05 PM, Peter G Nikolic
>
> <p.nikolic1@btinternet.com> wrote:
> > On Saturday 28 Jan 2012 14:24:19 Karol Blazewicz wrote:
> >> On Sat, Jan 28, 2012 at 2:14 PM, Peter G Nikolic
> >>
> >> <p.nikolic1@btinternet.com> wrote:
> >> > Hi
> >> >
> >> > Does anyone have a method of getting google earth to work i HAVE
> >> > tried
> >> > the stuff in AUR it fails completely the packages it complains
> >> > about
> >> > are all out of date and have so many deps that are also out of
> >> > date it is like chasing your own tail up your own backside
> >>
> >> archstuff unofficial user repo has google-earth 5.2.1.1588-1
> >> Have you tried the updated
> >> https://aur.archlinux.org/packages.php?ID=15270 ? Does it fail too?
> >
> > Yep exactly the same failure word for word
> >
> > ==> Making package: google-earth 6.2.0.5905-1 (Sat Jan 28 14:03:26 GMT
> > 2012) ==> Checking runtime dependencies...
> > ==> Missing Dependencies:
> > -> lib32-fontconfig
> > -> ld-lsb
> > -> lib32-libgl
> > -> lib32-libsm
> > -> lib32-libxi
> > -> lib32-libxrender
> > -> lib32-pcre
> > ==> Checking buildtime dependencies...
> > ==> ERROR: Could not resolve all dependencies.
> >
> > so then for each of the deps i get ..
> >
> > :/ # pacman -S lib32-fontconfig
> >
> > error: target not found: lib32-fontconfig
> >
> >
> > Pete
> >
> >
> > --
> > Powered by Kernel: 3.2.2-1-ARCH
> > KDE Development Platform: 4.7.4 (4.7.4)
> > 14:03:57 up 21:13, 5 users, load average: 0.13, 0.09, 0.06
>
> First of, you need the [multilib] repo, add it to your pacman.conf.
> Second of, you need to get the ld-lsb package from the AUR.
> Third of, you should run makepkg with `-si' options.

Ok on the multi lib that done now if i try makepkg -si it asks for the
password but i am unable to enter a password it will not accept entry from
the keyboard

Pete .

--
Powered by Kernel: 3.2.2-1-ARCH
KDE Development Platform: 4.7.4 (4.7.4)
14:47:19 up 21:56, 5 users, load average: 0.03, 0.04, 0.05
 
Old 01-28-2012, 01:51 PM
"G. Schlisio"
 
Default Google earth

Am 28.01.2012 15:49, schrieb Peter G Nikolic:

On Saturday 28 Jan 2012 15:24:42 Kwpolska wrote:

On Sat, Jan 28, 2012 at 3:05 PM, Peter G Nikolic

<p.nikolic1@btinternet.com> wrote:

On Saturday 28 Jan 2012 14:24:19 Karol Blazewicz wrote:

On Sat, Jan 28, 2012 at 2:14 PM, Peter G Nikolic

<p.nikolic1@btinternet.com> wrote:

Hi

Does anyone have a method of getting google earth to work i HAVE
tried
the stuff in AUR it fails completely the packages it complains
about
are all out of date and have so many deps that are also out of
date it is like chasing your own tail up your own backside

archstuff unofficial user repo has google-earth 5.2.1.1588-1
Have you tried the updated
https://aur.archlinux.org/packages.php?ID=15270 ? Does it fail too?

Yep exactly the same failure word for word

==> Making package: google-earth 6.2.0.5905-1 (Sat Jan 28 14:03:26 GMT
2012) ==> Checking runtime dependencies...
==> Missing Dependencies:
-> lib32-fontconfig
-> ld-lsb
-> lib32-libgl
-> lib32-libsm
-> lib32-libxi
-> lib32-libxrender
-> lib32-pcre
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

so then for each of the deps i get ..

:/ # pacman -S lib32-fontconfig

error: target not found: lib32-fontconfig


Pete


--
Powered by Kernel: 3.2.2-1-ARCH
KDE Development Platform: 4.7.4 (4.7.4)
14:03:57 up 21:13, 5 users, load average: 0.13, 0.09, 0.06

First of, you need the [multilib] repo, add it to your pacman.conf.
Second of, you need to get the ld-lsb package from the AUR.
Third of, you should run makepkg with `-si' options.

Ok on the multi lib that done now if i try makepkg -si it asks for the
password but i am unable to enter a password it will not accept entry from
the keyboard

Pete .

you can also just build the package, an then use
# pacman -U /path/to/packet.tar.gz
 
Old 01-28-2012, 01:52 PM
Jesse Jaara
 
Default Google earth

2012/1/28 Peter G Nikolic <p.nikolic1@btinternet.com>:
> Ok on the multi lib * that done now * if i try makepkg -si *it asks for the
> password but i am unable to enter a password it will not accept entry *from
> the keyboard

In linux entering your password on the console doesn't display **** chars
instead the it just simply stays black, but the password is there. Just
type it and press enter and magic happens. D


--
(\_ /) copy the bunny to your profile
(0.o ) to help him achieve world domination.
(> <) come join the dark side.
/_|_ (we have cookies.)
 
Old 01-28-2012, 02:37 PM
Ralf Mardorf
 
Default Google earth

Hi

I also haven't set up sudo, anyway, the dependencies are listed at the
AUR page.
It was build here, but it doesn't run.

> >> https://aur.archlinux.org/packages.php?ID=15270

> First of, you need the [multilib] repo, add it to your pacman.conf.
> Second of, you need to get the ld-lsb package from the AUR.
> Third of, you should run makepkg with `-si' options.

[spinymouse@archlinux src]$ uname -rm
3.2.2-1-ARCH x86_64
[spinymouse@archlinux src]$ pacman -Qs lib32-fontconfig
local/lib32-fontconfig 2.8.0-3
A library for configuring and customizing font access (32-bit)
[spinymouse@archlinux src]$ pacman -Qs ld-lsb
[spinymouse@archlinux src]$ wget
http://aur.archlinux.org/packages/ld/ld-lsb/ld-lsb.tar.gz
[spinymouse@archlinux src]$ wget
https://aur.archlinux.org/packages/go/google-earth/google-earth.tar.gz
[spinymouse@archlinux src]$ tar xzf google-earth.tar.gz
[spinymouse@archlinux src]$ tar xzf ld-lsb.tar.gz
[spinymouse@archlinux src]$ cd ld-lsb
[spinymouse@archlinux ld-lsb]$ makepkg -s
[spinymouse@archlinux ld-lsb]$ su -c "pacman -U
ld-lsb-3-3-any.pkg.tar.xz"
[spinymouse@archlinux ld-lsb]$ cd ../google-earth
[spinymouse@archlinux google-earth]$ makepkg -s
==> Making package: google-earth 6.2.0.5905-1 (Sat Jan 28 16:15:47 CET
2012)
==> Checking runtime dependencies...
==> Installing missing dependencies...
Password:
Sorry, try again.
Password:
sudo: 1 incorrect password attempt

==> ERROR: Aborted by user! Exiting...
[spinymouse@archlinux google-earth]$ su -c "pacman -S desktop-file-utils
fontconfig ld-lsb libgl libsm libxi libxrender pcre shared-mime-info"
Password:
warning: desktop-file-utils-0.19-1 is up to date -- reinstalling
warning: fontconfig-2.8.0-1 is up to date -- reinstalling
error: target not found: ld-lsb
[spinymouse@archlinux google-earth]$ su -c "pacman -S desktop-file-utils
fontconfig libgl libsm libxi libxrender pcre shared-mime-info"
Password:
warning: desktop-file-utils-0.19-1 is up to date -- reinstalling
warning: fontconfig-2.8.0-1 is up to date -- reinstalling
warning: libsm-1.2.0-1 is up to date -- reinstalling
warning: libxi-1.4.5-1 is up to date -- reinstalling
warning: libxrender-0.9.6-1 is up to date -- reinstalling
warning: pcre-8.21-1 is up to date -- reinstalling
warning: shared-mime-info-0.91-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...
:: libgl and nvidia-utils are in conflict. Remove nvidia-utils? [y/N] N
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: libgl and nvidia-utils are in conflict
[spinymouse@archlinux google-earth]$ su -c "pacman -S desktop-file-utils
fontconfig libsm libxi libxrender pcre shared-mime-info"
[now it's ok here]
[spinymouse@archlinux google-earth]$ makepkg
==> Making package: google-earth 6.2.0.5905-1 (Sat Jan 28 16:23:22 CET
2012)
==> Checking runtime dependencies...
==> Missing Dependencies:
-> lib32-pcre
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.
[spinymouse@archlinux google-earth]$ su -c "pacman -S lib32-pcre"
[spinymouse@archlinux google-earth]$ makepkg
[snip]
==> Finished making: google-earth 6.2.0.5905-1 (Sat Jan 28 16:28:10 CET
2012)
[spinymouse@archlinux google-earth]$ su
Password:
[root@archlinux google-earth]# pacman -U
google-earth-6.2.0.5905-1-x86_64.pkg.tar.xz
Optional dependencies for google-earth
lib32-catalyst-utils: 3D support for ATI/AMD cards
lib32-gtk2: SCIM support
lib32-nss-mdns: In case the application fails to contact the servers
lib32-nvidia-utils: 3D support for Nvidia cards
qt: For changing the font size with qtconfig
ttf-ms-fonts: Fonts
[root@archlinux google-earth]# exit
[spinymouse@archlinux google-earth]$ pacman -Qi google-earth
Name : google-earth
Version : 6.2.0.5905-1

Menu > Internet > Google Earth = only the splash screen appears.

[spinymouse@archlinux google-earth]$ google-earth
Google Earth has caught signal 11.



We apologize for the inconvenience, but Google Earth has crashed.
This is a bug in the program, and should never happen under normal
circumstances. A bug report and debugging data have been written
to this text file:

/home/spinymouse/.googleearth/crashlogs/crashlog-4f2415fa.txt

Please include this file if you submit a bug report to Google.

- Ralf
 
Old 01-28-2012, 02:42 PM
Ralf Mardorf
 
Default Google earth

[spinymouse@archlinux ~]$
cat .googleearth/crashlogs/crashlog-4f2415fa.txt
Major Version 6
Minor Version 2
Build Number 0000
Build Date Jan 23 2012
Build Time 17:11:07
OS Type 3
OS Major Version 3
OS Minor Version 2
OS Build Version 2
OS Patch Version 0
Crash Signal 11
Crash Time 1327764986
Up Time 1.13404

Stacktrace from glibc:
./libgoogleearth_free.so(+0xc0af3)[0xf7757af3]
./libgoogleearth_free.so(+0xc0c73)[0xf7757c73]
[0xf77db400]
 
Old 01-28-2012, 03:20 PM
Jesse Jaara
 
Default Google earth

Did you remeber to install
lib32-nvidia-utils ???
--
(\_ /) copy the bunny to your profile
(0.o ) to help him achieve world domination.
(> <) come join the dark side.
/_|_ (we have cookies.)
 
Old 01-28-2012, 05:12 PM
Ralf Mardorf
 
Default Google earth

On Sat, 2012-01-28 at 18:20 +0200, Jesse Jaara wrote:
> Did you remeber to install
> lib32-nvidia-utils ???

Thank you, no I didn't install lib32-nvidia-utils. I need to reboot
and will try again.

- Ralf
 
Old 01-28-2012, 07:34 PM
Ralf Mardorf
 
Default Google earth

On Sat, 2012-01-28 at 18:20 +0200, Jesse Jaara wrote:
> Did you remeber to install
> lib32-nvidia-utils ???

Works like a charm! Only when I closed it, there was much output "[snip]
Another crash happened while handling crash!" During usage there where
no messages.

I suspect for the OP, the problem is related to the dependencies. No
sudo.

- Ralf

--
# pacman -S lib32-nvidia-utils
resolving dependencies...
looking for inter-conflicts...
:: lib32-nvidia-utils and lib32-libgl are in conflict. Remove
lib32-libgl? [y/N] y
[snip]
$ tar xzf google-earth.tar.gz
[snip]
$ makepkg
==> Finished making: google-earth 6.2.0.5905-1 (Sat Jan 28 21:25:10 CET
2012)
[snip]
# pacman -U google-earth-6.2.0.5905-1-x86_64.pkg.tar.xz
[snip]
NOTE: The binary is called 'google-earth'

[root@archlinux google-earth]# exit
[spinymouse@archlinux google-earth]$ google-earth
 
Old 02-01-2012, 06:48 PM
P Nikolic
 
Default Google earth

Well

Kmail seems to be a little better behaved now thanks for the help .

Now got Google earth installed (loads of 32 bit stuff added from multilib)
now it starts up then bombs out after a few seconds with an error report as

Major Version 6
Minor Version 2
Build Number 0000
Build Date Jan 23 2012
Build Time 17:11:07
OS Type 3
OS Major Version 3
OS Minor Version 2
OS Build Version 2
OS Patch Version 0
Crash Signal 11
Crash Time 1328125391
Up Time 5.39584

Stacktrace from glibc:
./libgoogleearth_free.so(+0xc0af3)[0xf7681af3]
./libgoogleearth_free.so(+0xc0c73)[0xf7681c73]
[0xf7707400]

anyone got this working right up to date on kernel KDE ect ect
uname -a
Linux 7-of-9 3.2.2-1-ARCH #1 SMP PREEMPT Thu Jan 26 08:40:20 CET 2012 x86_64
AMD Phenom(tm) 9600B Quad-Core Processor AuthenticAMD GNU/Linux
7-of-9:/ #


Cheers Pete .
 

Thread Tools




All times are GMT. The time now is 01:45 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org