FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 12-25-2007, 04:12 AM
"Jesus Jr M Salvo"
 
Default Unable to upgrade firefox in F7 (needs gecko-libs = 1.8.1.3, this is not available.)

Had this problem for a while but was just ignoring it. yum is
complaining of not being able to find gecko-libs, which does not seem
to be available on the default repos:


# yum update --changelog firefox
Loading "changelog" plugin
Loading "fastestmirror" plugin
Loading "allowdowngrade" plugin
Loading "skip-broken" plugin
Loading mirror speeds from cached hostfile
* livna: rpm.livna.org
* fedora: mirror.optus.net
* updates: mirror.optus.net
* freshrpms: ayo.ie.freshrpms.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package firefox.i386 0:2.0.0.10-2.fc7 set to be updated
---> Package firefox.x86_64 0:2.0.0.10-2.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.5-1.fc7 for package: firefox-devel
--> Running transaction check
---> Package firefox-devel.x86_64 0:2.0.0.10-2.fc7 set to be updated
--> Finished Dependency Resolution

Changes in packages about to be updated:

firefox-devel - 2.0.0.10-2.fc7.x86_64, firefox - 2.0.0.10-2.fc7.i386,
firefox - 2.0.0.10-2.fc7.x86_64
* Thu Nov 29 09:00:00 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.10-2
- Make Canvas.drawImage work again

* Tue Nov 27 09:00:00 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.10-1
- Update to 2.0.0.10

* Tue Nov 6 09:00:00 2007 Martin Stransky <stransky@redhat.com> - 2.0.0.9-1
- Update to 2.0.0.9

* Sat Oct 20 08:00:00 2007 Christopher Aillon <caillon@redhat.com> - 2.0.0.8-1
- Update to 2.0.0.8

* Wed Oct 17 08:00:00 2007 Martin Stransky <stransky@redhat.com>
- added fix for #246248 - firefox crashes when searching


Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
firefox i386 2.0.0.10-2.fc7 updates 21 M
firefox x86_64 2.0.0.10-2.fc7 updates 20 M
Updating for dependencies:
firefox-devel x86_64 2.0.0.10-2.fc7 updates 3.5 M

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 3 Package(s)
Remove 0 Package(s)

Total download size: 45 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): firefox-2.0.0.10-2 100% |=========================| 20 MB 00:17
(2/3): firefox-2.0.0.10-2 100% |=========================| 21 MB 00:18
(3/3): firefox-devel-2.0. 100% |=========================| 3.5 MB 00:02
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package yelp needs gecko-libs = 1.8.1.3, this is not available.
Package devhelp needs gecko-libs = 1.8.1.3, this is not available.
Package devhelp needs gecko-libs = 1.8.1.3, this is not available.
Package yelp needs gecko-libs = 1.8.1.3, this is not available.
Package devhelp needs gecko-libs = 1.8.1.3, this is not available.
Package devhelp needs gecko-libs = 1.8.1.3, this is not available.
Complete!

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-27-2007, 07:36 AM
"Jesus Jr M Salvo"
 
Default Unable to upgrade firefox in F7 (needs gecko-libs = 1.8.1.3, this is not available.)

On 25/12/2007, garys@email.com <garys@email.com> wrote:
>
> Looks like you upgraded to fc7 and you have a bunch of fc6 packages still
> floating around. Try "yum remove yelp devhelp gecko-libs"
> ............gary
>

No. This was a fresh install of F7 about a year ago on a new laptop.
OTOH, I decided to remove the packages yelp and devhelp, since no
other packages depend on these two ... and was finally able to upgrade
firefox ... which begs the question, why did the upgrade for firefox
required gecko-libs ?

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-27-2007, 11:54 AM
"Michael Schwendt"
 
Default Unable to upgrade firefox in F7 (needs gecko-libs = 1.8.1.3, this is not available.)

On 27/12/2007, Jesus Jr M Salvo <jesus.m.salvo@gmail.com> wrote:
> On 25/12/2007, garys@email.com <garys@email.com> wrote:
> >
> > Looks like you upgraded to fc7 and you have a bunch of fc6 packages still
> > floating around. Try "yum remove yelp devhelp gecko-libs"
> > ............gary
> >
>
> No. This was a fresh install of F7 about a year ago on a new laptop.
> OTOH, I decided to remove the packages yelp and devhelp, since no
> other packages depend on these two ... and was finally able to upgrade
> firefox ... which begs the question, why did the upgrade for firefox
> required gecko-libs ?

Because it is included within the firefox package. It is a virtual
package. Examine "rpm --query --provides firefox | grep gecko". Other
packages (not limited to yelp and devhelp) depend on a specific
version of the Gecko Runtime Environment because often they access the
libraries in a specific path which contains the Gecko version.
Therefore they require a specific version of either the firefox
package or its virtual gecko-libs package. You can only upgrade all at
once.

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 01:21 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org