Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   dependency problem installing Bacula from SRPM (http://www.linux-archive.org/fedora-user/150804-dependency-problem-installing-bacula-srpm.html)

Gary Stainburn 08-29-2008 10:53 AM

dependency problem installing Bacula from SRPM
 
Hi folks.

I've just built the 2.4.2.2 rpms for FC9 using:

rpmbuild --rebuild
--define "build_fc9 1"
--define "build_postgresql 1"
bacula-2.4.2-2.src.rpm

and after sorting some dependancies they built fine.

I then tried

rpm -ivh
bacula-debuginfo-2.4.2-2.i386.rpm
bacula-gconsole-2.4.2-2.i386.rpm
bacula-mtx-2.4.2-2.i386.rpm
bacula-postgresql-2.4.2-2.i386.rpm
bacula-updatedb-2.4.2-2.i386.rpm

and got:

error: Failed dependencies:
libtermcap is needed by bacula-postgresql-2.4.2-2.i386

To me, this means I need ncurses-devel, so I tried to install that. However, I
then got:

[root@curly ~]# yum install ncurses-devel
[snip]
Package ncurses-devel-5.6-18.20080628.fc9.i386 already installed and latest
version
Nothing to do
[root@curly ~]# cd /usr/src/redhat/RPMS/i386/
[root@curly i386]# rpm -ivh bacula-*
error: Failed dependencies:
libtermcap is needed by bacula-postgresql-2.4.2-2.i386
[root@curly i386]#

I've tried:

rpm -vv --rebuilddb

just in case, but that made no difference.

Anyone got a clue what I do next?

--
Gary Stainburn

This email does not contain private or confidential material as it
may be snooped on by interested government parties for unknown
and undisclosed purposes - Regulation of Investigatory Powers Act, 2000

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

Michael Schwendt 08-29-2008 11:22 AM

dependency problem installing Bacula from SRPM
 
On Fri, 29 Aug 2008 11:53:44 +0100, Gary Stainburn wrote:

> Hi folks.
>
> I've just built the 2.4.2.2 rpms for FC9 using:
>
> rpmbuild --rebuild
> --define "build_fc9 1"
> --define "build_postgresql 1"
> bacula-2.4.2-2.src.rpm
>
> and after sorting some dependancies they built fine.
>
> I then tried
>
> rpm -ivh
> bacula-debuginfo-2.4.2-2.i386.rpm
> bacula-gconsole-2.4.2-2.i386.rpm
> bacula-mtx-2.4.2-2.i386.rpm
> bacula-postgresql-2.4.2-2.i386.rpm
> bacula-updatedb-2.4.2-2.i386.rpm
>
> and got:
>
> error: Failed dependencies:
> libtermcap is needed by bacula-postgresql-2.4.2-2.i386
>
> To me, this means I need ncurses-devel, so I tried to install that. However, I
> then got:

??

Run "yum whatprovides libtermcap" or "repoquery --whatprovides libtermcap".
It here points to package "libtermcap".

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

Gary Stainburn 08-29-2008 11:46 AM

dependency problem installing Bacula from SRPM
 
On Friday 29 August 2008 12:22, Michael Schwendt wrote:
>
> ??
>
> Run "yum whatprovides libtermcap" or "repoquery --whatprovides libtermcap".
> It here points to package "libtermcap".

Am I having a blonde moment or just missing something - it has been a VERY
long week.

[root@curly ~]# yum whatprovides libtermcap
Loaded plugins: refresh-packagekit
livna | 2.1 kB 00:00
fedora | 2.4 kB 00:00
adobe-linux-i386 | 951 B 00:00
updates | 2.3 kB 00:00
Warning: 3.0.x versions of yum would erronously match against filenames.
You can use "*/libtermcap" and/or "*bin/libtermcap" to get that behaviour
No Matches found
[root@curly ~]# yum install libtermcap
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package libtermcap available.
Nothing to do
[root@curly ~]# repoquery --whatprovides libtermcap
[root@curly ~]# yum install libtermcap
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package libtermcap available.
Nothing to do
[root@curly ~]#

--
Gary Stainburn

This email does not contain private or confidential material as it
may be snooped on by interested government parties for unknown
and undisclosed purposes - Regulation of Investigatory Powers Act, 2000

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

Michael Schwendt 08-29-2008 12:07 PM

dependency problem installing Bacula from SRPM
 
On Fri, 29 Aug 2008 12:46:13 +0100, Gary Stainburn wrote:

> On Friday 29 August 2008 12:22, Michael Schwendt wrote:
> >
> > ??
> >
> > Run "yum whatprovides libtermcap" or "repoquery --whatprovides libtermcap".
> > It here points to package "libtermcap".
>
> Am I having a blonde moment or just missing something - it has been a VERY
> long week.

You don't understand the purpose of the tools I've pointed you to.
If nothing in your repos provides "libtermcap", you're lost, and you need
to fix the bacula src.rpm package (and probably drop the explicit "Requires:
libtermcap" which should not have been added to the package, because for
shared libraries we rely on automatic dependencies on library SONAMEs).
Here with F8, there still is a libtermcap package. But Fedora pkg cvs says
it's obsolete since F9.

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines


All times are GMT. The time now is 04:36 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.