FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 08-20-2008, 10:01 PM
Patrick Dupre
 
Default Hp P1005

Hello,

I am trying to install a new HP LaserJet P1005 on my FC7 machine,
but it just do not work and I am lost !!!

It looks like that I need hplip.

So originally, I hade the version for fc7 (1.7.4a-6).
Then I installed the 2.8.7 version from the tar file.
I was able to do hp-toolbox, hp-setup, etc... but it always fails in
detectting properly the printer even it is was here more or less.
So I though that it may be a conflict between the 1.7.4 version and the
new 2.8.7 (which is coming with the new distribution).
So I deinstalled the 1.7.4, expecting that I would have the same
functionalities from the 2.8.7. So I even reinstall the 2.8.7 after all.
But I list all the fonctionnality, like the hp-toolbox, etc....
I looks like that 2.8.7 and 1.7.4 do not install the same think at all !!!
There is not much documentation about this.

Anyway, if some botdy has some experience with a printer HP P1005 and
FC7, maybe he could tell me.

Regards

--
---
================================================== ========================
Patrick DUPRÉ | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: pd520@york.ac.uk
================================================== ========================--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-20-2008, 10:12 PM
g
 
Default Hp P1005

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


Patrick Dupre wrote:
<snip>
> It looks like that I need hplip.

if question? yes. hplip is needed with hp laser printers.



- --
tc,hago.

g
.

in a free world without fences, who needs gates.

learn linux:
'Rute User's Tutorial and Exposition' http://rute.2038bug.com/index.html.gz
'The Linux Documentation Project' http://www.tldp.org/
'HowtoForge' http://howtoforge.com/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with Red Hat - http://enigmail.mozdev.org

iD8DBQFIrJbd+C4Bj9Rkw/wRAr9nAKCwnoJANdRQHkRCwIDNAh88eFnFqQCfQgjf
eageff1rWLmhg3qRtNzCxiw=
=fEGG
-----END PGP SIGNATURE-----

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-21-2008, 08:42 AM
Zoltan Boszormenyi
 
Default Hp P1005

Hi,

Patrick Dupre írta:
> Hello,
>
> I am trying to install a new HP LaserJet P1005 on my FC7 machine,
> but it just do not work and I am lost !!!
>
> It looks like that I need hplip.

Not only that, install hplip-gui, too. Then run hp-setup from a terminal.
It will detect your printer and download the extra library and firmware
needed for this printer. I installed an 1005 during the weekend on Fedora 9.
It works nicely.

> So originally, I hade the version for fc7 (1.7.4a-6).
> Then I installed the 2.8.7 version from the tar file.
> I was able to do hp-toolbox, hp-setup, etc... but it always fails in
> detectting properly the printer even it is was here more or less.
> So I though that it may be a conflict between the 1.7.4 version and the
> new 2.8.7 (which is coming with the new distribution).
> So I deinstalled the 1.7.4, expecting that I would have the same
> functionalities from the 2.8.7. So I even reinstall the 2.8.7 after all.
> But I list all the fonctionnality, like the hp-toolbox, etc....
> I looks like that 2.8.7 and 1.7.4 do not install the same think at all
> !!!
> There is not much documentation about this.
>
> Anyway, if some botdy has some experience with a printer HP P1005 and
> FC7, maybe he could tell me.
>
> Regards
>

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-21-2008, 09:12 AM
Patrick Dupre
 
Default Hp P1005

On Thu, 21 Aug 2008, Zoltan Boszormenyi wrote:


Hi,

Patrick Dupre írta:

Hello,

I am trying to install a new HP LaserJet P1005 on my FC7 machine,
but it just do not work and I am lost !!!

It looks like that I need hplip.


Not only that, install hplip-gui, too. Then run hp-setup from a terminal.

I did all that stuff, but fails
hp-setup does not recognize the printer

HP Linux Imaging and Printing System (ver. 1.7.4a)
Printer/Fax Setup Utility ver. 4.5

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: No devices found.Please make sure your printer is properly
connected and powered-on.


But it is here:
Bus 007 Device 006: ID 03f0:3d17 Hewlett-Packard



It will detect your printer and download the extra library and firmware
needed for this printer. I installed an 1005 during the weekend on Fedora 9.
It works nicely.


So originally, I hade the version for fc7 (1.7.4a-6).
Then I installed the 2.8.7 version from the tar file.
I was able to do hp-toolbox, hp-setup, etc... but it always fails in
detectting properly the printer even it is was here more or less.
So I though that it may be a conflict between the 1.7.4 version and the
new 2.8.7 (which is coming with the new distribution).
So I deinstalled the 1.7.4, expecting that I would have the same
functionalities from the 2.8.7. So I even reinstall the 2.8.7 after all.
But I list all the fonctionnality, like the hp-toolbox, etc....
I looks like that 2.8.7 and 1.7.4 do not install the same think at all
!!!
There is not much documentation about this.

Anyway, if some botdy has some experience with a printer HP P1005 and
FC7, maybe he could tell me.

Regards






--
---
================================================== ========================
Patrick DUPRÉ | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: pd520@york.ac.uk
================================================== ========================--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-21-2008, 02:17 PM
"Patrick O'Callaghan"
 
Default Hp P1005

On Thu, 2008-08-21 at 10:12 +0100, Patrick Dupre wrote:
> hp-setup does not recognize the printer
>
> HP Linux Imaging and Printing System (ver. 1.7.4a)
> Printer/Fax Setup Utility ver. 4.5
>
> Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
> This software comes with ABSOLUTELY NO WARRANTY.
> This is free software, and you are welcome to distribute it
> under certain conditions. See COPYING file for more details.
>
> error: No devices found.Please make sure your printer is properly
> connected and powered-on.
>
> But it is here:
> Bus 007 Device 006: ID 03f0:3d17 Hewlett-Packard

Are you using the GUI? Did you tell it to look for USB printers (hplip
supports parallel and network printers as well). Sorry for the stupid
questions but the docs say the 1007 is supported.

Of course it could be a problem with F7.

poc

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-21-2008, 02:54 PM
Patrick Dupre
 
Default Hp P1005

On Thu, 21 Aug 2008, Patrick O'Callaghan wrote:


On Thu, 2008-08-21 at 10:12 +0100, Patrick Dupre wrote:

hp-setup does not recognize the printer

HP Linux Imaging and Printing System (ver. 1.7.4a)
Printer/Fax Setup Utility ver. 4.5

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: No devices found.Please make sure your printer is properly
connected and powered-on.

But it is here:
Bus 007 Device 006: ID 03f0:3d17 Hewlett-Packard


Are you using the GUI? Did you tell it to look for USB printers (hplip
supports parallel and network printers as well). Sorry for the stupid
questions but the docs say the 1007 is supported.
Yes I do have hplip-gui installed and it does try to look that the USB,
etc..

I really looks like that it is the problem with FC7, because I cannot
install a recent version of hplip, 1.7.4 is too low, it looks that that I
need a 2.8



Of course it could be a problem with F7.

poc




--
---
================================================== ========================
Patrick DUPRÉ | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: pd520@york.ac.uk
================================================== ========================--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-22-2008, 08:35 AM
"Steve Repo"
 
Default Hp P1005

>>> connected and powered-on.
>>>
>>> But it is here:
>>> Bus 007 Device 006: ID 03f0:3d17 Hewlett-Packard
>>
>> Are you using the GUI? Did you tell it to look for USB printers (hplip
>> supports parallel and network printers as well). Sorry for the stupid
>> questions but the docs say the 1007 is supported.
>
> Yes I do have hplip-gui installed and it does try to look that the USB,
> etc..
> I really looks like that it is the problem with FC7, because I cannot
> install a recent version of hplip, 1.7.4 is too low, it looks that that I
> need a 2.8
>


Get the latest drivers from here
http://sourceforge.net/forum/forum.php?forum_id=851608

And here is the changelog. P1005 was added around 2.8.2 I think,
http://hplip.sourceforge.net/release_notes.html

Good luck!

Steve

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-22-2008, 09:14 AM
Patrick Dupre
 
Default Hp P1005

But it is here:
Bus 007 Device 006: ID 03f0:3d17 Hewlett-Packard


Are you using the GUI? Did you tell it to look for USB printers (hplip
supports parallel and network printers as well). Sorry for the stupid
questions but the docs say the 1007 is supported.


Yes I do have hplip-gui installed and it does try to look that the USB,
etc..
I really looks like that it is the problem with FC7, because I cannot
install a recent version of hplip, 1.7.4 is too low, it looks that that I
need a 2.8




Get the latest drivers from here
http://sourceforge.net/forum/forum.php?forum_id=851608

And here is the changelog. P1005 was added around 2.8.2 I think,
http://hplip.sourceforge.net/release_notes.html


Thank for the advise.
This it what I did.
but after making make install. the hplip-1.7.4 (rpm) is this here
and I got the errors that I previously mention.
If I remove the rpm hplip.1.7.4 package, and make an install
of hplip.2.8.7, I lost also the hp-setup, etc... commands even after
I reinstall, so I have to reinstall the rpm hplip.1.7.4 !

I do not understand why I cannot get the hp- etc... commands
from hplip-2.8.7.tgz !

Regards
--
---
================================================== ========================
Patrick DUPRÃ? | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: pd520@york.ac.uk
================================================== ========================--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-22-2008, 01:35 PM
David Jansen
 
Default Hp P1005

On Fri, Aug 22, 2008 at 10:14:17AM +0100, Patrick Dupre wrote:
> >>>> But it is here:
> >>>> Bus 007 Device 006: ID 03f0:3d17 Hewlett-Packard
> >>>
> >>> Are you using the GUI? Did you tell it to look for USB printers (hplip
> >>> supports parallel and network printers as well). Sorry for the stupid
> >>> questions but the docs say the 1007 is supported.
> >>
> >> Yes I do have hplip-gui installed and it does try to look that the USB,
> >> etc..
> >> I really looks like that it is the problem with FC7, because I cannot
> >> install a recent version of hplip, 1.7.4 is too low, it looks that that I
> >> need a 2.8
> >>
> >
> >
> > Get the latest drivers from here
> > http://sourceforge.net/forum/forum.php?forum_id=851608
> >
> > And here is the changelog. P1005 was added around 2.8.2 I think,
> > http://hplip.sourceforge.net/release_notes.html
> >
> Thank for the advise.
> This it what I did.
> but after making make install. the hplip-1.7.4 (rpm) is this here
> and I got the errors that I previously mention.
> If I remove the rpm hplip.1.7.4 package, and make an install
> of hplip.2.8.7, I lost also the hp-setup, etc... commands even after
> I reinstall, so I have to reinstall the rpm hplip.1.7.4 !
>
> I do not understand why I cannot get the hp- etc... commands
> from hplip-2.8.7.tgz !

If you installed the new version from source, you may want to check were
it gets installed. Probably in /usr/local, which is a good location for
software that doesn't come from an rpm. But by default, it is not in
your path. Also, many administrative utilities usually end up in one of
the sbin directories (eg /usr/local/sbin), and those are by default only
in root's path (and fedora packages often set up consolehelper for users
to prompt them for the root password before running such applications.

So take a look in /usr/local/bin and /usr/local/sbin and if the tool is
there, you may try running it from there.

David Jansen

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 08-22-2008, 02:36 PM
Patrick Dupre
 
Default Hp P1005

On Fri, 22 Aug 2008, David Jansen wrote:


On Fri, Aug 22, 2008 at 10:14:17AM +0100, Patrick Dupre wrote:

But it is here:
Bus 007 Device 006: ID 03f0:3d17 Hewlett-Packard


Are you using the GUI? Did you tell it to look for USB printers (hplip
supports parallel and network printers as well). Sorry for the stupid
questions but the docs say the 1007 is supported.


Yes I do have hplip-gui installed and it does try to look that the USB,
etc..
I really looks like that it is the problem with FC7, because I cannot
install a recent version of hplip, 1.7.4 is too low, it looks that that I
need a 2.8




Get the latest drivers from here
http://sourceforge.net/forum/forum.php?forum_id=851608

And here is the changelog. P1005 was added around 2.8.2 I think,
http://hplip.sourceforge.net/release_notes.html


Thank for the advise.
This it what I did.
but after making make install. the hplip-1.7.4 (rpm) is this here
and I got the errors that I previously mention.
If I remove the rpm hplip.1.7.4 package, and make an install
of hplip.2.8.7, I lost also the hp-setup, etc... commands even after
I reinstall, so I have to reinstall the rpm hplip.1.7.4 !

I do not understand why I cannot get the hp- etc... commands
from hplip-2.8.7.tgz !


If you installed the new version from source, you may want to check were
it gets installed. Probably in /usr/local, which is a good location for
software that doesn't come from an rpm. But by default, it is not in
your path. Also, many administrative utilities usually end up in one of
the sbin directories (eg /usr/local/sbin), and those are by default only
in root's path (and fedora packages often set up consolehelper for users
to prompt them for the root password before running such applications.

So take a look in /usr/local/bin and /usr/local/sbin and if the tool is
there, you may try running it from there.


I made an updatedb and locate hp-setup after a make and make install,
but only the one installed by hplip-1.7.4.rpm is here !
Does it recognize that there is a rpm package and doed not reinstall
a hp-setup ?

--
---
================================================== ========================
Patrick DUPRÉ | |
Department of Chemistry | | Phone: (44)-(0)-1904-434384
The University of York | | Fax: (44)-(0)-1904-432516
Heslington | |
York YO10 5DD United Kingdom | | email: pd520@york.ac.uk
================================================== ========================--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 07:18 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org