FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 07-20-2008, 02:21 AM
Dan Thurman
 
Default F9: List of packages that has missing geko-libs v1.9

I get notifications constantly asking to update
the following list. Unfortunately, there is a
conflict and it is saying:

Error: Missing Dependency: gecko-libs = 1.9 is needed by package X
where X is the following:

devhelp
emerald
epiphany
epiphany-extensions
firefox
gnomesword
xulrunner
xulrunner-devel
yelp

The important one for me is firefox.

So what do I need to do to get these packages installed?

Thanks!
Dan

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 02:44 AM
"Kevin J. Cummings"
 
Default F9: List of packages that has missing geko-libs v1.9

Dan Thurman wrote:


I get notifications constantly asking to update
the following list. Unfortunately, there is a
conflict and it is saying:

Error: Missing Dependency: gecko-libs = 1.9 is needed by package X
where X is the following:

devhelp
emerald
epiphany
epiphany-extensions
firefox
gnomesword
xulrunner
xulrunner-devel
yelp

The important one for me is firefox.

So what do I need to do to get these packages installed?


From my investigation yesterday, gecko-libs is a capability that is
supplied by xulrunner RPM. I was able to update earlier this afternoon.
firefox, epiphany, yelp, and xulrunner were what was holding me up.
(I don't have any of your other RPMs installed on my system.)
When I was able to update, cpio and system-config-language were also a
part of the update. Try again when these are available to you.



Thanks!
Dan


--
Kevin J. Cummings
kjchome@rcn.com
cummings@kjchome.homeip.net
cummings@kjc386.framingham.ma.us
Registered Linux User #1232 (http://counter.li.org)

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 04:13 AM
Craig White
 
Default F9: List of packages that has missing geko-libs v1.9

On Sat, 2008-07-19 at 22:44 -0400, Kevin J. Cummings wrote:
> Dan Thurman wrote:
> >
> > I get notifications constantly asking to update
> > the following list. Unfortunately, there is a
> > conflict and it is saying:
> >
> > Error: Missing Dependency: gecko-libs = 1.9 is needed by package X
> > where X is the following:
> >
> > devhelp
> > emerald
> > epiphany
> > epiphany-extensions
> > firefox
> > gnomesword
> > xulrunner
> > xulrunner-devel
> > yelp
> >
> > The important one for me is firefox.
> >
> > So what do I need to do to get these packages installed?
>
> From my investigation yesterday, gecko-libs is a capability that is
> supplied by xulrunner RPM. I was able to update earlier this afternoon.
> firefox, epiphany, yelp, and xulrunner were what was holding me up.
> (I don't have any of your other RPMs installed on my system.)
> When I was able to update, cpio and system-config-language were also a
> part of the update. Try again when these are available to you.
----
fwiw...I'm still unable to update and have been unable to update F9-i386
for 2 days now because of the missing gecko-libs dependency.

# yum clean all
Loaded plugins: fastestmirror, priorities, refresh-packagekit
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@lin-workstation ~]# yum update
Loaded plugins: fastestmirror, priorities, refresh-packagekit
Determining fastest mirrors
* livna: mirrors.tummy.com
* fedora: ftp.uci.edu
* adobe-linux-i386: linuxdownload.adobe.com
* updates: ftp.uci.edu
livna
| 2.1 kB 00:00
primary.sqlite.bz2
| 214 kB 00:02
fedora
| 2.4 kB 00:00
primary.sqlite.bz2
| 6.1 MB 00:13
adobe-linux-i386
| 951 B 00:00
primary.xml.gz
| 10 kB 00:00
adobe-linux-i386 17/17
updates
| 2.3 kB 00:00
primary.sqlite.bz2
| 1.9 MB 00:02
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xscreensaver-gl-base.i386 1:5.06-1.fc9 set to be updated
---> Package firefox.i386 0:3.0.1-1.fc9 set to be updated
---> Package xulrunner.i386 0:1.9.0.1-1.fc9 set to be updated
---> Package seamonkey.i386 0:1.1.11-1.fc9 set to be updated
---> Package totem-mozplugin.i386 0:2.23.2-5.fc9 set to be updated
---> Package kpartx.i386 0:0.4.7-16.fc9 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-16.fc9 set to be
updated
---> Package xscreensaver-gl-extras.i386 1:5.06-1.fc9 set to be updated
---> Package nfs-utils-lib.i386 0:1.1.1-5.fc9 set to be updated
---> Package selinux-policy.noarch 0:3.3.1-78.fc9 set to be updated
---> Package selinux-policy-targeted.noarch 0:3.3.1-78.fc9 set to be
updated
---> Package devhelp.i386 0:0.19.1-3.fc9 set to be updated
---> Package totem.i386 0:2.23.2-5.fc9 set to be updated
---> Package nspluginwrapper.i386 0:1.1.0-3.fc9 set to be updated
---> Package cpio.i386 0:2.9-8.fc9 set to be updated
---> Package rsync.i386 0:3.0.3-0.fc9 set to be updated
---> Package system-config-language.noarch 0:1.3.1-2.fc9 set to be
updated
---> Package pilot-link.i386 2:0.12.3-14.fc9 set to be updated
---> Package xscreensaver-base.i386 1:5.06-1.fc9 set to be updated
---> Package dmraid.i386 0:1.0.0.rc14-8.fc9 set to be updated
---> Package xscreensaver-extras.i386 1:5.06-1.fc9 set to be updated
---> Package binutils.i386 0:2.18.50.0.6-4.fc9 set to be updated
---> Package yelp.i386 0:2.22.1-4.fc9 set to be updated
---> Package totem-nautilus.i386 0:2.23.2-5.fc9 set to be updated
--> Processing Dependency: gecko-libs = 1.9 for package: gxine
---> Package pilot-link-devel.i386 2:0.12.3-14.fc9 set to be updated
---> Package totem-gstreamer.i386 0:2.23.2-5.fc9 set to be updated
---> Package totem-xine.i386 0:2.23.2-5.fc9 set to be updated
---> Package binutils-devel.i386 0:2.18.50.0.6-4.fc9 set to be updated
--> Finished Dependency Resolution
gxine-0.5.11-17.fc9.i386 from installed has depsolving problems
--> Missing Dependency: gecko-libs = 1.9 is needed by package
gxine-0.5.11-17.fc9.i386 (installed)
Error: Missing Dependency: gecko-libs = 1.9 is needed by package
gxine-0.5.11-17.fc9.i386 (installed)

Craig

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 05:39 AM
"Kevin J. Cummings"
 
Default F9: List of packages that has missing geko-libs v1.9

Craig White wrote:

--> Finished Dependency Resolution
gxine-0.5.11-17.fc9.i386 from installed has depsolving problems
--> Missing Dependency: gecko-libs = 1.9 is needed by package
gxine-0.5.11-17.fc9.i386 (installed)
Error: Missing Dependency: gecko-libs = 1.9 is needed by package
gxine-0.5.11-17.fc9.i386 (installed)


From that output, I'm inclined to suggest that gxone is still broken?
I do not have that package installed on my system....
Trying to install it tries to bring in a whole bunch of obsolete i386
stuff. Has a bug been filed against it yet?



Craig


--
Kevin J. Cummings
kjchome@rcn.com
cummings@kjchome.homeip.net
cummings@kjc386.framingham.ma.us
Registered Linux User #1232 (http://counter.li.org)

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 05:45 AM
"Mike Burger"
 
Default F9: List of packages that has missing geko-libs v1.9

> Craig White wrote:
>> --> Finished Dependency Resolution
>> gxine-0.5.11-17.fc9.i386 from installed has depsolving problems
>> --> Missing Dependency: gecko-libs = 1.9 is needed by package
>> gxine-0.5.11-17.fc9.i386 (installed)
>> Error: Missing Dependency: gecko-libs = 1.9 is needed by package
>> gxine-0.5.11-17.fc9.i386 (installed)
>
> From that output, I'm inclined to suggest that gxone is still broken?
> I do not have that package installed on my system....
> Trying to install it tries to bring in a whole bunch of obsolete i386
> stuff. Has a bug been filed against it yet?

That was my conclusion, as well. I was seeing the same issue "gecko-libs".

I removed gxine and the system updated.

I'll check, every so often, to see if a fixed gxine comes out...I suggest
he do the same.

It's odd...never before have I run a Fedora release that had so many
broken dependencies from update to update...and I've run all of them
except for F7.

--
Mike Burger
http://www.bubbanfriends.org

Visit the Dog Pound II BBS
telnet://dogpound2.citadel.org or http://dogpound2.citadel.org

To be notified of updates to the web site, visit:

https://www.bubbanfriends.org/mailman/listinfo/site-update

or send a blank email message to:

site-update-subscribe@bubbanfriends.org

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 05:50 AM
"Kevin J. Cummings"
 
Default F9: List of packages that has missing geko-libs v1.9

Mike Burger wrote:

It's odd...never before have I run a Fedora release that had so many
broken dependencies from update to update...and I've run all of them
except for F7.


I agree, there is definitely something wrong with their "process". They
don't seem to have learned lessons I learned 25 years ago....


--
Kevin J. Cummings
kjchome@rcn.com
cummings@kjchome.homeip.net
cummings@kjc386.framingham.ma.us
Registered Linux User #1232 (http://counter.li.org)

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 12:37 PM
Michael Schwendt
 
Default F9: List of packages that has missing geko-libs v1.9

On Sun, 20 Jul 2008 01:39:50 -0400, Kevin J. Cummings wrote:

> Craig White wrote:
> > --> Finished Dependency Resolution
> > gxine-0.5.11-17.fc9.i386 from installed has depsolving problems
> > --> Missing Dependency: gecko-libs = 1.9 is needed by package
> > gxine-0.5.11-17.fc9.i386 (installed)
> > Error: Missing Dependency: gecko-libs = 1.9 is needed by package
> > gxine-0.5.11-17.fc9.i386 (installed)
>
> From that output, I'm inclined to suggest that gxone is still broken?
> I do not have that package installed on my system....
> Trying to install it tries to bring in a whole bunch of obsolete i386
> stuff. Has a bug been filed against it yet?

See fedora-devel-list for the related topic (broken deps report from
yesterday). An update for gxine is waiting to be pushed. Compare with what
the Fedora Updates System shows about it (=> "pending" category).

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 02:35 PM
"Paolo Galtieri"
 
Default F9: List of packages that has missing geko-libs v1.9

On Sun, Jul 20, 2008 at 5:37 AM, Michael Schwendt <mschwendt@gmail.com> wrote:

On Sun, 20 Jul 2008 01:39:50 -0400, Kevin J. Cummings wrote:



> Craig White wrote:

> > --> Finished Dependency Resolution

> > gxine-0.5.11-17.fc9.i386 from installed has depsolving problems

> > * --> Missing Dependency: gecko-libs = 1.9 is needed by package

> > gxine-0.5.11-17.fc9.i386 (installed)

> > Error: Missing Dependency: gecko-libs = 1.9 is needed by package

> > gxine-0.5.11-17.fc9.i386 (installed)

>

> *From that output, I'm inclined to suggest that gxone is still broken?

> I do not have that package installed on my system....

> Trying to install it tries to bring in a whole bunch of obsolete i386

> stuff. *Has a bug been filed against it yet?



See fedora-devel-list for the related topic (broken deps report from

yesterday). An update for gxine is waiting to be pushed. Compare with what

the Fedora Updates System shows about it (=> "pending" category).



--

fedora-list mailing list

fedora-list@redhat.com

To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


Well I hope they are not fixing things one package at a time.* Yesterday I reported 3 packages that also fail with the gecko-libs dependency

gtkmozembedmm.i386
gnome-python2-gtkmozembed

gtkmozembedmm.x86_64

As of this morning all 3 still fail to install due to the gecko-libs = 1.9 problem.* There seems to have been a fundamental failure somewhere in the update "process".* Maybe the Fedora folks need to take a look at the whole package interdependency scheme so they can avoid this sort of mess in the future?* I've run been running Fedora since FC5 and I have never seen an update problem like this before.


Paolo

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 03:27 PM
Michael Schwendt
 
Default F9: List of packages that has missing geko-libs v1.9

On Sun, 20 Jul 2008 07:35:27 -0700, Paolo Galtieri wrote:

> I've run been running Fedora since FC5 and I have never seen an
> update problem like this before.

Congratulations! ;o) This incident is just one of many. It has happened
before several times, with Firefox and with other packages. Firefox
affects almost everyone, though.

Interestingly, for Fedora 8 there was an attempt at rebuilding all
dependencies and publishing them at once, as a single update (see
https://admin.fedoraproject.org/updates/search/firefox ), and that has
been done before. For F8, only one pkg slipped through (evolution-rss).
For F9, only a few packages were rebuilt actually (as can be seen at above
url, too).

It's a workflow problem, a communication problem, a resource problem, and
a policy problem.

The firefox maintainer can't be blamed if other packages cause trouble
because they create a strict dependency on a specific firefox
version. Semi-automated rebuilds of dependencies might help, if the spec
files were specially crafted to not require any manual editing at all (and
in the case of a dependency on firefox would pick up the new firefox
version automatically). Currently, however, a new package is not available
in the builtroots unless it's pushed to the stable repo or release
engineers add it on demand).

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-20-2008, 05:01 PM
Craig White
 
Default F9: List of packages that has missing geko-libs v1.9

On Sun, 2008-07-20 at 14:37 +0200, Michael Schwendt wrote:
> On Sun, 20 Jul 2008 01:39:50 -0400, Kevin J. Cummings wrote:
>
> > Craig White wrote:
> > > --> Finished Dependency Resolution
> > > gxine-0.5.11-17.fc9.i386 from installed has depsolving problems
> > > --> Missing Dependency: gecko-libs = 1.9 is needed by package
> > > gxine-0.5.11-17.fc9.i386 (installed)
> > > Error: Missing Dependency: gecko-libs = 1.9 is needed by package
> > > gxine-0.5.11-17.fc9.i386 (installed)
> >
> > From that output, I'm inclined to suggest that gxone is still broken?
> > I do not have that package installed on my system....
> > Trying to install it tries to bring in a whole bunch of obsolete i386
> > stuff. Has a bug been filed against it yet?
>
> See fedora-devel-list for the related topic (broken deps report from
> yesterday). An update for gxine is waiting to be pushed. Compare with what
> the Fedora Updates System shows about it (=> "pending" category).
----
I wasn't griping - just noting that updates still weren't working for me
and yes, I recognized that I could remove gxine and get the updates
installed but am patient and will wait until it is all worked through.

Craig

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 08:04 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org