FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 07-17-2008, 07:29 PM
Jonathan Ryshpan
 
Default nspluginwrapper vs. flash-plugin and AdobeReader_enu

Both
AdobeReader_enu-8.1.2-1.i486
and
Adobe's flash-plugin-9.0.124.0-release.i386
are installed on my system, which runs firefox-3.0-1.fc9.x86_64. I am
attempting to get nspluginwrapper-1.1.0-2.fc9.x86_64 to allow firefox to
access these plugins, configuring them as follows:

# mozilla-plugin-config -r
# mozilla-plugin-config -6 -i

This doesn't work. Neither of them shows up when "aboutlugins" is
entered into firefox's URL box; and a test doesn't show them working.
What's wrong with the configuration?

Here's a list of what appears to be configured.

# mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:

File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.so
/usr/lib64/mozilla/plugins-wrapped/npwrapper.libflashplayer.so
Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
Wrapper version string: 0.9.91.5
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.so
/usr/lib64/mozilla/plugins-wrapped/npwrapper.libflashplayer.so
Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
Wrapper version string: 0.9.91.5
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.xpt




--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-17-2008, 07:45 PM
"Kevin J. Cummings"
 
Default nspluginwrapper vs. flash-plugin and AdobeReader_enu

Jonathan Ryshpan wrote:

Both
AdobeReader_enu-8.1.2-1.i486
and
Adobe's flash-plugin-9.0.124.0-release.i386

are installed on my system, which runs firefox-3.0-1.fc9.x86_64. I am
attempting to get nspluginwrapper-1.1.0-2.fc9.x86_64 to allow firefox to
access these plugins, configuring them as follows:

# mozilla-plugin-config -r
# mozilla-plugin-config -6 -i

This doesn't work. Neither of them shows up when "aboutlugins" is
entered into firefox's URL box; and a test doesn't show them working.
What's wrong with the configuration?


What versions of nspluginwrapper are installed? On my (working) system,
I have 2:



nspluginwrapper-0.9.91.5-27.fc9.i386
nspluginwrapper-0.9.91.5-27.fc9.x86_64


I believe that the FAQ states you must have both installed in order for
it to work correctly.



Here's a list of what appears to be configured.

# mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:


I have the following at the top of my list:


/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so
Original plugin:
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nppdf.so
Original plugin:
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so

/usr/lib64/mozilla/plugins-wrapped/nswrapper_32_64.libflashplayer.so
Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
Wrapper version string: 0.9.91.5


You don't....


File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.so
/usr/lib64/mozilla/plugins-wrapped/npwrapper.libflashplayer.so
Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
Wrapper version string: 0.9.91.5
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-wmp.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-complex-plugin.so
/usr/lib64/mozilla/plugins-wrapped/npwrapper.libflashplayer.so
Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
Wrapper version string: 0.9.91.5
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-rm.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib64/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-dvx.so
File/Link /usr/lib64/mozilla/plugins-wrapped/gecko-mediaplayer-qt.xpt


Good luck getting it fixed!

--
Kevin J. Cummings
kjchome@rcn.com
cummings@kjchome.homeip.net
cummings@kjc386.framingham.ma.us
Registered Linux User #1232 (http://counter.li.org)

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-19-2008, 08:59 PM
Jonathan Ryshpan
 
Default nspluginwrapper vs. flash-plugin and AdobeReader_enu

On Thu, 2008-07-17 at 15:45 -0400, Kevin J. Cummings wrote:
> Jonathan Ryshpan wrote:
> > Both
> > AdobeReader_enu-8.1.2-1.i486
> > and
> > Adobe's flash-plugin-9.0.124.0-release.i386
> > are installed on my system, which runs firefox-3.0-1.fc9.x86_64. I
> am
> > attempting to get nspluginwrapper-1.1.0-2.fc9.x86_64 to allow
> firefox to
> > access these plugins, configuring them as follows:
> >
> > # mozilla-plugin-config -r
> > # mozilla-plugin-config -6 -i
> >
> > This doesn't work. Neither of them shows up when "aboutlugins" is
> > entered into firefox's URL box; and a test doesn't show them
> working.
> > What's wrong with the configuration?
>
> What versions of nspluginwrapper are installed? On my (working)
> system,
> I have 2:
>
> > nspluginwrapper-0.9.91.5-27.fc9.i386
> > nspluginwrapper-0.9.91.5-27.fc9.x86_64
>
> I believe that the FAQ states you must have both installed in order
> for it to work correctly.

You are correct. nspluginwrapper for both i386 and x86_64 architectures
have to be installes for things to work properly. And they both have to
be the same version: I had
nspluginwrapper-1.1.0-3.fc9.x86_64
nspluginwrapper-0.9.91.5-27.fc9.i386
installed.

Also to get sound libflashpluginsupport has to be installed. Probably
this should be a dependency for Adobe's flash-plugin.*.rpm, which it
isn't.

BTW: Where is the FAQ you're writing about? I couldn't find it.

Thanks - jon

>

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 07-19-2008, 09:17 PM
"Kevin J. Cummings"
 
Default nspluginwrapper vs. flash-plugin and AdobeReader_enu

Jonathan Ryshpan wrote:

On Thu, 2008-07-17 at 15:45 -0400, Kevin J. Cummings wrote:

Jonathan Ryshpan wrote:

Both
AdobeReader_enu-8.1.2-1.i486
and
Adobe's flash-plugin-9.0.124.0-release.i386

are installed on my system, which runs firefox-3.0-1.fc9.x86_64. I

am

attempting to get nspluginwrapper-1.1.0-2.fc9.x86_64 to allow

firefox to

access these plugins, configuring them as follows:

# mozilla-plugin-config -r
# mozilla-plugin-config -6 -i

This doesn't work. Neither of them shows up when "aboutlugins" is
entered into firefox's URL box; and a test doesn't show them

working.

What's wrong with the configuration?

What versions of nspluginwrapper are installed? On my (working)
system,
I have 2:



nspluginwrapper-0.9.91.5-27.fc9.i386
nspluginwrapper-0.9.91.5-27.fc9.x86_64

I believe that the FAQ states you must have both installed in order
for it to work correctly.


You are correct. nspluginwrapper for both i386 and x86_64 architectures
have to be installes for things to work properly. And they both have to
be the same version: I had
nspluginwrapper-1.1.0-3.fc9.x86_64

nspluginwrapper-0.9.91.5-27.fc9.i386
installed.


Which probably happened during the last update with the bad
dependencies. If the correct version of the .i386 package had already
been installed, it wouldn't have been a problem. (It wasn't for me).
This last update brought in .i386 versions of sqlite, libidn, libcurl,
and nss for me which weren't there before.


Also to get sound libflashpluginsupport has to be installed. Probably
this should be a dependency for Adobe's flash-plugin.*.rpm, which it
isn't.


Fedora doesn't build Adobe's RPM, and its not clear if the same RPM from
Adobe is intended for multiple RPM based distributions or not, or if the
other distrubutions even *have* a libflashpluginsupport RPM.


BTW: Where is the FAQ you're writing about? I couldn't find it.


Fedora Release Notes. For F8, its section 10.3.1 and contains the line:


Users of Fedora x86_64 must install the nspluginwrapper.i386 package to enable the 32-bit Adobe Flash plugin in x86_64 Firefox and the pulseaudio-libs.i386 package to enable sound from the plugin..


I find that the Adobe Flash Plug-in works better for me than the
different open source alternatives.


Thanks - jon




--
Kevin J. Cummings
kjchome@rcn.com
cummings@kjchome.homeip.net
cummings@kjc386.framingham.ma.us
Registered Linux User #1232 (http://counter.li.org)

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 09:50 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org