FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 12-04-2007, 12:50 AM
Timothy Selivanow
 
Default Eclipse error/warning when starting new Java project.

When I start a new Java project in Eclipse, I get a warning/error down
at the bottom of the dialog window that says:

"The current workspace uses a 1.4 JRE with compiler compliance level
6.0. This is not recommended and either the JRE or the compiler level
should be changed."


I am using Icedtea/GCJ and have not installed any other JRE/JDKs (Livna
is the only 3rd party repo). I've done minimal configuration changes in
Preferences, as this is the first Java project that I have started (I
configured PyDev, and installed E-P-I-C, but that is all that I have
done in Eclipse so far).

Apparently, I either have something wrong or perhaps Icedtea is
identifying itself as a 1.4 JRE (which would be weird since it looks
like Eclipse thinks it is a 1.7 JRE in some other places).


__________________________________________________ ___
< If this is timesharing, give me my share right now. >
-----------------------------------------------------


/
( )
.( o ).

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-04-2007, 01:34 PM
Andrew Overholt
 
Default Eclipse error/warning when starting new Java project.

Timothy Selivanow wrote:

When I start a new Java project in Eclipse, I get a warning/error down
at the bottom of the dialog window that says:

"The current workspace uses a 1.4 JRE with compiler compliance level
6.0. This is not recommended and either the JRE or the compiler level
should be changed."


This is because 1.7 isn't really supported yet. Feel free to change
your workspace compliance settings or those for that project.


I'm curious, though: is it an error or a warning?

Andrew

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-04-2007, 05:32 PM
Timothy Selivanow
 
Default Eclipse error/warning when starting new Java project.

On Tue, 2007-12-04 at 09:34 -0500, Andrew Overholt wrote:
> Timothy Selivanow wrote:
> > When I start a new Java project in Eclipse, I get a warning/error down
> > at the bottom of the dialog window that says:
> >
> > "The current workspace uses a 1.4 JRE with compiler compliance level
> > 6.0. This is not recommended and either the JRE or the compiler level
> > should be changed."
>
> This is because 1.7 isn't really supported yet. Feel free to change
> your workspace compliance settings or those for that project.
>
> I'm curious, though: is it an error or a warning?
>
> Andrew

I suppose I'd classify it as a warning, as it allows you to continue
without modifying any settings.

If it is purely cosmetic (i.e. Icedtea will properly handle 5.0 and
6.0), I don't mind the message. It just may seem odd, and a bit
alarming, to someone who is new to Icedtea and Java in general (as I
am).


--Tim
__________________________________________________ __________________________
/ Acquaintance, n:
| A person whom we know well enough to borrow from but not well |
| enough to lend to. A degree of friendship called slight when the |
| object is poor or obscure, and intimate when he is rich or famous. |
-- Ambrose Bierce, "The Devil's Dictionary" /
----------------------------------------------------------------------------


/
( )
.( o ).

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-04-2007, 05:37 PM
Sudheer Satyanarayana
 
Default Eclipse error/warning when starting new Java project.

Andrew Overholt wrote:

Timothy Selivanow wrote:

When I start a new Java project in Eclipse, I get a warning/error down
at the bottom of the dialog window that says:

"The current workspace uses a 1.4 JRE with compiler compliance level
6.0. This is not recommended and either the JRE or the compiler level
should be changed."


This is because 1.7 isn't really supported yet. Feel free to change
your workspace compliance settings or those for that project.


I'm curious, though: is it an error or a warning?


It is a an error.

An error has occurred. See the log file
/home/sudheer/.eclipse/org.eclipse.platform_3.3.0_1543616141/configuration/1196793422104.log.

Andrew




--
Thanks and regards,

Sudheer Satyanarayana
http://binaryvibes.co.in


--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-04-2007, 05:40 PM
Andrew Overholt
 
Default Eclipse error/warning when starting new Java project.

Sudheer Satyanarayana wrote:

Sudheer Satyanarayana wrote:

Andrew Overholt wrote:

Timothy Selivanow wrote:

When I start a new Java project in Eclipse, I get a warning/error down
at the bottom of the dialog window that says:

"The current workspace uses a 1.4 JRE with compiler compliance level
6.0. This is not recommended and either the JRE or the compiler level
should be changed."


This is because 1.7 isn't really supported yet. Feel free to change
your workspace compliance settings or those for that project.


I'm curious, though: is it an error or a warning?


It is a an error.

An error has occurred. See the log file
/home/sudheer/.eclipse/org.eclipse.platform_3.3.0_1543616141/configuration/1196793422104.log.


Are you sure this is the same error that Timothy was talking about? I
don't think so as I see his warning message as well and can continue
just fine.



[sudheer@localhost ~]$ eclipse
*** glibc detected *** /usr/lib64/eclipse/eclipse: double free or
corruption (!prev): 0x000000000063cbc0 ***


I've never seen that. Please file a bug.

Andrew

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-04-2007, 05:42 PM
Sudheer Satyanarayana
 
Default Eclipse error/warning when starting new Java project.

Sudheer Satyanarayana wrote:

Andrew Overholt wrote:

Timothy Selivanow wrote:

When I start a new Java project in Eclipse, I get a warning/error down
at the bottom of the dialog window that says:

"The current workspace uses a 1.4 JRE with compiler compliance level
6.0. This is not recommended and either the JRE or the compiler level
should be changed."


This is because 1.7 isn't really supported yet. Feel free to change
your workspace compliance settings or those for that project.


I'm curious, though: is it an error or a warning?


It is a an error.

An error has occurred. See the log file
/home/sudheer/.eclipse/org.eclipse.platform_3.3.0_1543616141/configuration/1196793422104.log.


Andrew




Forgot to add more info. When I try to launch it from the terminal I see
this message:

[sudheer@localhost ~]$ eclipse
*** glibc detected *** /usr/lib64/eclipse/eclipse: double free or
corruption (!prev): 0x000000000063cbc0 ***


Also
[sudheer@localhost ~]$ for f in `rpm -qa | egrep "eclipse|swt"`; do echo
$f; rpm -qV $f; done

eclipse-rpm-editor-0.1.0-10.fc8
eclipse-pydev-1.3.9-1.fc8
eclipse-cvs-client-3.3.0-30.fc8
eclipse-phpeclipse-1.1.8-16.fc7
eclipse-mylyn-ide-2.0.0-9.fc8
eclipse-platform-3.3.0-30.fc8
Unsatisfied dependencies for eclipse-platform-3.3.0-30.fc8.x86_64:
ant-antlr, ant-apache-bcel, ant-apache-log4j, ant-apache-oro,
ant-apache-regexp, ant-apache-resolver, ant-commons-logging,
ant-javamail, ant-jdepend, ant-jsch, ant-junit, ant-nodeps, ant-swing,
ant-trax, jakarta-commons-beanutils, jakarta-commons-collections,
jakarta-commons-dbcp, jakarta-commons-digester, jakarta-commons-el >=
1.0-8jpp, jakarta-commons-fileupload, jakarta-commons-launcher,
jakarta-commons-modeler, jakarta-commons-pool, jetty, jsch >= 0.1.31,
lucene >= 1.9.1, lucene-contrib >= 1.9.1, tomcat5 >= 5.5.23-9jpp.4,
tomcat5-jasper-eclipse >= 5.5.23-9jpp.4

eclipse-changelog-2.5.1-2.fc8
eclipse-mylyn-bugzilla-2.0.0-9.fc8
libswt3-gtk2-3.3.0-30.fc8
eclipse-quickrex-3.5.0-5.fc8
eclipse-mylyn-2.0.0-9.fc8
eclipse-mylyn-java-2.0.0-9.fc8
eclipse-rcp-3.3.0-30.fc8
Unsatisfied dependencies for eclipse-rcp-3.3.0-30.fc8.x86_64:
icu4j-eclipse >= 3.6.1

eclipse-ecj-3.3.0-30.fc8
eclipse-jdt-3.3.0-30.fc8
eclipse-subclipse-1.2.4-5.fc8
eclipse-demos-0.0.1-2.fc8
eclipse-pde-runtime-3.3.0-30.fc8
eclipse-cdt-4.0.1-1.fc8
eclipse-pde-3.3.0-30.fc8
[sudheer@localhost ~]$


--
Thanks and regards,

Sudheer Satyanarayana
http://binaryvibes.co.in


--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-04-2007, 07:23 PM
Timothy Selivanow
 
Default Eclipse error/warning when starting new Java project.

On Tue, 2007-12-04 at 13:40 -0500, Andrew Overholt wrote:
> Sudheer Satyanarayana wrote:
> > Sudheer Satyanarayana wrote:
> >> Andrew Overholt wrote:
> >>> Timothy Selivanow wrote:
> >>>> When I start a new Java project in Eclipse, I get a warning/error down
> >>>> at the bottom of the dialog window that says:
> >>>>
> >>>> "The current workspace uses a 1.4 JRE with compiler compliance level
> >>>> 6.0. This is not recommended and either the JRE or the compiler level
> >>>> should be changed."
> >>>
> >>> This is because 1.7 isn't really supported yet. Feel free to change
> >>> your workspace compliance settings or those for that project.
> >>>
> >>> I'm curious, though: is it an error or a warning?
> >>>
> >> It is a an error.
> >>
> >> An error has occurred. See the log file
> >> /home/sudheer/.eclipse/org.eclipse.platform_3.3.0_1543616141/configuration/1196793422104.log.
>
> Are you sure this is the same error that Timothy was talking about? I
> don't think so as I see his warning message as well and can continue
> just fine.
>
> > [sudheer@localhost ~]$ eclipse
> > *** glibc detected *** /usr/lib64/eclipse/eclipse: double free or
> > corruption (!prev): 0x000000000063cbc0 ***
>
> I've never seen that. Please file a bug.
>
> Andrew

I'm also seeing issues when trying to do a "Run" or "Run As". I went
through the HelloWorld tutorial to make sure I'm not missing anything,
and at the end of the tutorial when it says:

To run your application, right-click on your class in the Package
Explorer and select Run As > Java Application. The Console view should
appear at the bottom and display the "Hello, world!" output.


There is only "Open Run Dialog..." when I right click on the class and
hover on "Run As". If I go through and add a configuration under "Java
Application" (and add HelloWorld as the class) or just click the run
button on the toolbar and choose "Java Application", I get the following
error:

Exception in thread "main" java.lang.NoSuchMethodError: main
Error: A JNI error has occurred, please check your installation and try
again


Should I take this thread over to the Fedora-Java list?



--Tim
______
< Huh? >
------


/
( )
.( o ).

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-04-2007, 07:30 PM
Andrew Overholt
 
Default Eclipse error/warning when starting new Java project.

Timothy Selivanow wrote:

Exception in thread "main" java.lang.NoSuchMethodError: main
Error: A JNI error has occurred, please check your installation and try
again


Should I take this thread over to the Fedora-Java list?


Sure. I've never seen this error you're seeing. fedora-devel-java-list
or bugzilla are fine with me.


Andrew

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 04:32 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org