Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   YUM: problems to update the system (http://www.linux-archive.org/fedora-user/114929-yum-problems-update-system.html)

"Aldo Foot" 06-27-2008 10:31 PM

YUM: problems to update the system
 
On Fri, Jun 27, 2008 at 3:15 PM, Fernando Tavares
<tavaresfernando@yahoo.com> wrote:
> I have tried the following problem when I try to bring up to date the system through yum:
>
>
> --> Running transaction check
> ---> Package muine.i386 0:0.8.8-3.fc8 set to be updated
> --> Processing Dependency: mono(glib-sharp) = 2.10.0.0 for package:
> muine
> --> Processing Dependency: mono(gdk-sharp) = 2.10.0.0 for package: muine
> --> Processing Dependency: mono(gtk-sharp) = 2.10.0.0 for package: muine
> ---> Package liferea.i386 0:1.4.15-6.fc9 set to be updated
> --> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package:
> liferea
> --> Processing Dependency: libgnutls.so.13 for package: liferea
> ---> Package wireshark-gnome.i386 0:1.0.0-2.fc9 set to be updated
> --> Processing Dependency: libgnutls.so.13 for package: wireshark-gnome
> ---> Package perl-DateManip.noarch 0:5.44-4.fc8 set to be updated
> --> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package:
> perl-DateManip
> ---> Package wireshark.i386 0:1.0.0-2.fc9 set to be updated
> --> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package:
> wireshark
> --> Processing Dependency: libgnutls.so.13 for package: wireshark
> --> Processing Conflict: syslog-ng conflicts rsyslog

syslog-ng and rsyslog have problem when running simultaneously.
test this: disable syslog-ng and try updating again.

~af

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Joe Mild 06-27-2008 10:42 PM

YUM: problems to update the system
 
Hi Fernando,

try rpm -e rsyslog and rum yum again.

cu Joe

On Fri, 2008-06-27 at 15:15 -0700, Fernando Tavares wrote:
> I have tried the following problem when I try to bring up to date the system through yum:
>
>
> --> Running transaction check
> ---> Package muine.i386 0:0.8.8-3.fc8 set to be updated
> --> Processing Dependency: mono(glib-sharp) = 2.10.0.0 for package:
> muine
> --> Processing Dependency: mono(gdk-sharp) = 2.10.0.0 for package: muine
> --> Processing Dependency: mono(gtk-sharp) = 2.10.0.0 for package: muine
> ---> Package liferea.i386 0:1.4.15-6.fc9 set to be updated
> --> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package:
> liferea
> --> Processing Dependency: libgnutls.so.13 for package: liferea
> ---> Package wireshark-gnome.i386 0:1.0.0-2.fc9 set to be updated
> --> Processing Dependency: libgnutls.so.13 for package: wireshark-gnome
> ---> Package perl-DateManip.noarch 0:5.44-4.fc8 set to be updated
> --> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package:
> perl-DateManip
> ---> Package wireshark.i386 0:1.0.0-2.fc9 set to be updated
> --> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package:
> wireshark
> --> Processing Dependency: libgnutls.so.13 for package: wireshark
> --> Processing Conflict: syslog-ng conflicts rsyslog
> --> Restarting Dependency Resolution with new changes.
> ...
> --> Running transaction check
> ...
>
> SYSTEM INFORMATION:
>
> [root@localhost ~]# uname -a
> Linux localhost.localdomain 2.6.24.5-85.fc8 #1 SMP Sat Apr 19 11:02:19 EDT 2008 i686 i686 i386 GNU/Linux
>
>
> Fedora release 8 (Werewolf)
> Kernel 2.6.24.5-85.fc8 on an i686
>
>
>
>
> Novos endereços, o Yahoo! que você conhece. Crie um email novo com a sua cara @ymail.com ou @rocketmail.com.
> http://br.new.mail.yahoo.com/addresses
>

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Fernando Tavares 06-27-2008 11:15 PM

YUM: problems to update the system
 
Hi and thanks, but...

the ploblem is libgnutls.so.13

After run "rpm -e rsyslog" the result is:
...
...
...

--> Finished Dependency Resolution
Error: Missing Dependency: libgnutls.so.13 is needed by package wireshark-gnome
Error: Missing Dependency: libgnutls.so.13 is needed by package wireshark
Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package muine
Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package muine
Error: Missing Dependency: libgnutls.so.13(GNUTLS_1_3) is needed by package wireshark
Error: Missing Dependency: libgnutls.so.13(GNUTLS_1_3) is needed by package liferea
Error: Missing Dependency: libgnutls.so.13 is needed by package liferea
Error: Missing Dependency: mono(gdk-sharp) = 2.10.0.0 is needed by package muine
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DateManip



>
> try rpm -e rsyslog and rum yum again.
>
> On Fri, 2008-06-27 at 15:15 -0700, Fernando Tavares wrote:
> > I have tried the following problem when I try to bring
> up to date the system through yum:
> >
> >
> > --> Running transaction check
> > ---> Package muine.i386 0:0.8.8-3.fc8 set to be
> updated
> > --> Processing Dependency: mono(glib-sharp) =
> 2.10.0.0 for package:
> > muine
> > --> Processing Dependency: mono(gdk-sharp) =
> 2.10.0.0 for package: muine
> > --> Processing Dependency: mono(gtk-sharp) =
> 2.10.0.0 for package: muine
> > ---> Package liferea.i386 0:1.4.15-6.fc9 set to be
> updated
> > --> Processing Dependency:
> libgnutls.so.13(GNUTLS_1_3) for package:
> > liferea
> > --> Processing Dependency: libgnutls.so.13 for
> package: liferea
> > ---> Package wireshark-gnome.i386 0:1.0.0-2.fc9 set
> to be updated
> > --> Processing Dependency: libgnutls.so.13 for
> package: wireshark-gnome
> > ---> Package perl-DateManip.noarch 0:5.44-4.fc8 set
> to be updated
> > --> Processing Dependency:
> perl(:MODULE_COMPAT_5.8.8) for package:
> > perl-DateManip
> > ---> Package wireshark.i386 0:1.0.0-2.fc9 set to be
> updated
> > --> Processing Dependency:
> libgnutls.so.13(GNUTLS_1_3) for package:
> > wireshark
> > --> Processing Dependency: libgnutls.so.13 for
> package: wireshark
> > --> Processing Conflict: syslog-ng conflicts
> rsyslog
> > --> Restarting Dependency Resolution with new
> changes.
> > ...
> > --> Running transaction check
> > ...
> >
> > SYSTEM INFORMATION:
> >
> > [root@localhost ~]# uname -a
> > Linux localhost.localdomain 2.6.24.5-85.fc8 #1 SMP Sat
> Apr 19 11:02:19 EDT 2008 i686 i686 i386 GNU/Linux
> >
> >
> > Fedora release 8 (Werewolf)
> > Kernel 2.6.24.5-85.fc8 on an i686
> >
> >
> >
> >
> > Novos endereços, o Yahoo! que você conhece.
> Crie um email novo com a sua cara @ymail.com ou
> @rocketmail.com.
> > http://br.new.mail.yahoo.com/addresses
> >


Novos endereços, o Yahoo! que você conhece. Crie um email novo com a sua cara @ymail.com ou @rocketmail.com.
http://br.new.mail.yahoo.com/addresses

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

"Aldo Foot" 06-28-2008 12:44 AM

YUM: problems to update the system
 
On Fri, Jun 27, 2008 at 4:15 PM, Fernando Tavares
<tavaresfernando@yahoo.com> wrote:
> Hi and thanks, but...
>
> the ploblem is libgnutls.so.13
>
> After run "rpm -e rsyslog" the result is:
> ...
> ...
> ...
>
> --> Finished Dependency Resolution
> Error: Missing Dependency: libgnutls.so.13 is needed by package wireshark-gnome
> Error: Missing Dependency: libgnutls.so.13 is needed by package wireshark
> Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package muine
> Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package muine
> Error: Missing Dependency: libgnutls.so.13(GNUTLS_1_3) is needed by package wireshark
> Error: Missing Dependency: libgnutls.so.13(GNUTLS_1_3) is needed by package liferea
> Error: Missing Dependency: libgnutls.so.13 is needed by package liferea
> Error: Missing Dependency: mono(gdk-sharp) = 2.10.0.0 is needed by package muine
> Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DateManip
>
>
>

Maybe you should read up on yum/rpm and syslog stuff before you
mess up your system. There is always the potential for trouble when things
are removed from your system.

~af

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Joe Mild 06-28-2008 07:50 AM

YUM: problems to update the system
 
Hi,

my suggestion is to remove with yum wireshark-gnome wireshark muine
liferea muine perl-DateManip. You can in install them after the update
again.

On Fri, 2008-06-27 at 17:44 -0700, Aldo Foot wrote:
> On Fri, Jun 27, 2008 at 4:15 PM, Fernando Tavares
> <tavaresfernando@yahoo.com> wrote:
> > Hi and thanks, but...
> >
> > the ploblem is libgnutls.so.13
> >
> > After run "rpm -e rsyslog" the result is:
> > ...
> > ...
> > ...
> >
> > --> Finished Dependency Resolution
> > Error: Missing Dependency: libgnutls.so.13 is needed by package wireshark-gnome
> > Error: Missing Dependency: libgnutls.so.13 is needed by package wireshark
> > Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package muine
> > Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package muine
> > Error: Missing Dependency: libgnutls.so.13(GNUTLS_1_3) is needed by package wireshark
> > Error: Missing Dependency: libgnutls.so.13(GNUTLS_1_3) is needed by package liferea
> > Error: Missing Dependency: libgnutls.so.13 is needed by package liferea
> > Error: Missing Dependency: mono(gdk-sharp) = 2.10.0.0 is needed by package muine
> > Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DateManip
> >
> >
> >
>
> Maybe you should read up on yum/rpm and syslog stuff before you
> mess up your system. There is always the potential for trouble when things
> are removed from your system.

Hmm maybe but not with rpm -e rsyslog... rpm would tell you if there is
a dependency with other...

@Fernando
Have yum done updates before or have you done a upgrade e.g Fedora8 ->
9 ?

cu Joe


--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Michael Schwendt 06-28-2008 08:13 AM

YUM: problems to update the system
 
On Fri, 27 Jun 2008 15:15:03 -0700 (PDT), Fernando Tavares wrote:

> I have tried the following problem when I try to bring up to date the system through yum:
>
>
> --> Running transaction check
> ---> Package muine.i386 0:0.8.8-3.fc8 set to be updated
> --> Processing Dependency: mono(glib-sharp) = 2.10.0.0 for package:
> muine
> --> Processing Dependency: mono(gdk-sharp) = 2.10.0.0 for package: muine
> --> Processing Dependency: mono(gtk-sharp) = 2.10.0.0 for package: muine
> ---> Package liferea.i386 0:1.4.15-6.fc9 set to be updated
> --> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package:
> liferea

What are you trying to do? Upgrade from F8 to F10 devel?

> Fedora release 8 (Werewolf)
> Kernel 2.6.24.5-85.fc8 on an i686

The dependency problems you quote are from F10 devel (compare with
the daily rawhide build report).

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Fernando Tavares 06-30-2008 02:04 AM

YUM: problems to update the system
 
How to exclude nfs (fc8)

after command:

yum -y -t --exclude=banshee --exclude=muine --exclude=nfs --exclude=nfs-utils --exclude=nfs-utils-lib --exclude=libldap-2.3.so.0 --exclude="libevent*" update

the final result is:

--> Finished Dependency Resolution
Error: Missing Dependency: libldap-2.3.so.0 is needed by package nfs-utils-lib
Error: Missing Dependency: libldap-2.3.so.0 is needed by package nfs-utils









Novos endereços, o Yahoo! que você conhece. Crie um email novo com a sua cara @ymail.com ou @rocketmail.com.
http://br.new.mail.yahoo.com/addresses

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

stan 06-30-2008 02:18 AM

YUM: problems to update the system
 
Fernando Tavares wrote:

How to exclude nfs (fc8)

after command:

yum -y -t --exclude=banshee --exclude=muine --exclude=nfs --exclude=nfs-utils --exclude=nfs-utils-lib --exclude=libldap-2.3.so.0 --exclude="libevent*" update

the final result is:

--> Finished Dependency Resolution
Error: Missing Dependency: libldap-2.3.so.0 is needed by package nfs-utils-lib
Error: Missing Dependency: libldap-2.3.so.0 is needed by package nfs-utils


The update you want to exclude isn't nfs but libldap. There is an
update for it, but nfs needs the earlier version, so won't let the
update occur. It means a package with a dependency on the latest
libldap hasn't been released for nfs-utils-lib and nfs-utils yet.



--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


All times are GMT. The time now is 10:21 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.