Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   F9 - sendmail won't send on startup? (http://www.linux-archive.org/fedora-user/111487-f9-sendmail-wont-send-startup.html)

Knute Johnson 06-22-2008 06:32 PM

F9 - sendmail won't send on startup?
 
Craig White wrote:

On Sun, 2008-06-22 at 11:17 -0700, Knute Johnson wrote:
I've got two installations of F9 running, one x86_64 and the other i386.
They both fail to send email initially but if I restart sendmail they
send fine after that. I'm using thunderbird and have it configured to
use the local sendmail for sending. The only thing I've modified in my
sendmail.mc file is the masquerading. Any ideas where to start looking?


Thanks,

knute...

Jun 22 11:09:54 localhost sendmail[2107]: alias database /etc/aliases
rebuilt by root
Jun 22 11:09:54 localhost sendmail[2107]: /etc/aliases: 77 aliases,
longest 10 bytes, 774 bytes total
Jun 22 11:09:54 localhost sendmail[2112]: starting daemon (8.14.2):
SMTP+queueing@01:00:00

Jun 22 11:09:54 localhost sendmail[2112]: STARTTLS: ServerCertFile missing
Jun 22 11:09:54 localhost sendmail[2112]: started as: /usr/sbin/sendmail
-bd -q1h
Jun 22 11:09:54 localhost sm-msp-queue[2121]: starting daemon (8.14.2):
queueing@01:00:00
Jun 22 11:10:43 localhost sendmail[2664]: NOQUEUE: connect from
localhost.localdomain [127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: AUTH: available mech=CRAM-MD5
PLAIN ANONYMOUS DIGEST-MD5 LOGIN, allowed mech=EXTERNAL GSSAPI
KERBEROS_V4 DIGEST-MD5 CRAM-MD5
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: Milter: no
active filter
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 220
localhost.localdomain ESMTP Sendmail 8.14.2/8.14.2; Sun, 22 Jun 2008
11:10:43 -0700
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- EHLO
[127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-localhost.localdomain Hello localhost.localdomain [127.0.0.1],
pleased to meet you
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-ENHANCEDSTATUSCODES

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-PIPELINING
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-8BITMIME
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-SIZE
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DSN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-ETRN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-AUTH
DIGEST-MD5 CRAM-MD5

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DELIVERBY
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250 HELP
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- MAIL
FROM:<linux@www.knutejohnson.com> SIZE=427
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 050
<linux@www.knutejohnson.com>... Transient parse error -- message queued
for future delivery
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451 4.1.8
Domain of sender address linux@www.knutejohnson.com does not resolve
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664:
ruleset=check_mail, arg1=<linux@www.knutejohnson.com>,
relay=localhost.localdomain [127.0.0.1], reject=451 4.1.8 Domain of
sender address linux@www.knutejohnson.com does not resolve

Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: <-- QUIT
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: --- 221 2.0.0
localhost.localdomain closing connection
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664:
from=<linux@www.knutejohnson.com>, size=427, class=0, nrcpts=0,
proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]

----
is sendmail set to start on boot?


Yes. That's why I included the log that shows the start of sendmail.


chkconfig --list sendmail # to review which runlevels it starts on
chkconfig sendmail on # to have it start on boot


The log above shows it is running but;

[root@knute knute]# /sbin/chkconfig --list | grep sendmail
sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off


it does appear that you've got a DNS issue too...'sender address of
www.knutejohnson.com does not resolve' is a problem as I see it.


When the computer first starts. After I restart sendmail it doesn't
have a problem any more. This mail was sent from one of the computers
with the problem.


--
Knute Johnson
linux@www.knutejohnson.com

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Craig White 06-22-2008 06:49 PM

F9 - sendmail won't send on startup?
 
On Sun, 2008-06-22 at 11:32 -0700, Knute Johnson wrote:
> Craig White wrote:
> > On Sun, 2008-06-22 at 11:17 -0700, Knute Johnson wrote:
> >> I've got two installations of F9 running, one x86_64 and the other i386.
> >> They both fail to send email initially but if I restart sendmail they
> >> send fine after that. I'm using thunderbird and have it configured to
> >> use the local sendmail for sending. The only thing I've modified in my
> >> sendmail.mc file is the masquerading. Any ideas where to start looking?
> >>
> >> Thanks,
> >>
> >> knute...
> >>
> >> Jun 22 11:09:54 localhost sendmail[2107]: alias database /etc/aliases
> >> rebuilt by root
> >> Jun 22 11:09:54 localhost sendmail[2107]: /etc/aliases: 77 aliases,
> >> longest 10 bytes, 774 bytes total
> >> Jun 22 11:09:54 localhost sendmail[2112]: starting daemon (8.14.2):
> >> SMTP+queueing@01:00:00
> >> Jun 22 11:09:54 localhost sendmail[2112]: STARTTLS: ServerCertFile missing
> >> Jun 22 11:09:54 localhost sendmail[2112]: started as: /usr/sbin/sendmail
> >> -bd -q1h
> >> Jun 22 11:09:54 localhost sm-msp-queue[2121]: starting daemon (8.14.2):
> >> queueing@01:00:00
> >> Jun 22 11:10:43 localhost sendmail[2664]: NOQUEUE: connect from
> >> localhost.localdomain [127.0.0.1]
> >> Jun 22 11:10:43 localhost sendmail[2664]: AUTH: available mech=CRAM-MD5
> >> PLAIN ANONYMOUS DIGEST-MD5 LOGIN, allowed mech=EXTERNAL GSSAPI
> >> KERBEROS_V4 DIGEST-MD5 CRAM-MD5
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: Milter: no
> >> active filter
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 220
> >> localhost.localdomain ESMTP Sendmail 8.14.2/8.14.2; Sun, 22 Jun 2008
> >> 11:10:43 -0700
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- EHLO
> >> [127.0.0.1]
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
> >> 250-localhost.localdomain Hello localhost.localdomain [127.0.0.1],
> >> pleased to meet you
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
> >> 250-ENHANCEDSTATUSCODES
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-PIPELINING
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-8BITMIME
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-SIZE
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DSN
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-ETRN
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-AUTH
> >> DIGEST-MD5 CRAM-MD5
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DELIVERBY
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250 HELP
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- MAIL
> >> FROM:<linux@www.knutejohnson.com> SIZE=427
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
> >> www.knutejohnson.com: Name server timeout
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 050
> >> <linux@www.knutejohnson.com>... Transient parse error -- message queued
> >> for future delivery
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
> >> www.knutejohnson.com: Name server timeout
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
> >> www.knutejohnson.com: Name server timeout
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
> >> www.knutejohnson.com: Name server timeout
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451 4.1.8
> >> Domain of sender address linux@www.knutejohnson.com does not resolve
> >> Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664:
> >> ruleset=check_mail, arg1=<linux@www.knutejohnson.com>,
> >> relay=localhost.localdomain [127.0.0.1], reject=451 4.1.8 Domain of
> >> sender address linux@www.knutejohnson.com does not resolve
> >> Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: <-- QUIT
> >> Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: --- 221 2.0.0
> >> localhost.localdomain closing connection
> >> Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664:
> >> from=<linux@www.knutejohnson.com>, size=427, class=0, nrcpts=0,
> >> proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
> > ----
> > is sendmail set to start on boot?
>
> Yes. That's why I included the log that shows the start of sendmail.
>
> > chkconfig --list sendmail # to review which runlevels it starts on
> > chkconfig sendmail on # to have it start on boot
>
> The log above shows it is running but;
>
> [root@knute knute]# /sbin/chkconfig --list | grep sendmail
> sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off
>
> > it does appear that you've got a DNS issue too...'sender address of
> > www.knutejohnson.com does not resolve' is a problem as I see it.
>
> When the computer first starts. After I restart sendmail it doesn't
> have a problem any more. This mail was sent from one of the computers
> with the problem.
----
I would think that sendmail starts after named starts but perhaps not.

Try setting a manual entry for www.knutejohnson.com in /etc/hosts

Craig

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Knute Johnson 06-22-2008 06:57 PM

F9 - sendmail won't send on startup?
 
Craig White wrote:

On Sun, 2008-06-22 at 11:32 -0700, Knute Johnson wrote:

Craig White wrote:

On Sun, 2008-06-22 at 11:17 -0700, Knute Johnson wrote:
I've got two installations of F9 running, one x86_64 and the other i386.
They both fail to send email initially but if I restart sendmail they
send fine after that. I'm using thunderbird and have it configured to
use the local sendmail for sending. The only thing I've modified in my
sendmail.mc file is the masquerading. Any ideas where to start looking?


Thanks,

knute...

Jun 22 11:09:54 localhost sendmail[2107]: alias database /etc/aliases
rebuilt by root
Jun 22 11:09:54 localhost sendmail[2107]: /etc/aliases: 77 aliases,
longest 10 bytes, 774 bytes total
Jun 22 11:09:54 localhost sendmail[2112]: starting daemon (8.14.2):
SMTP+queueing@01:00:00

Jun 22 11:09:54 localhost sendmail[2112]: STARTTLS: ServerCertFile missing
Jun 22 11:09:54 localhost sendmail[2112]: started as: /usr/sbin/sendmail
-bd -q1h
Jun 22 11:09:54 localhost sm-msp-queue[2121]: starting daemon (8.14.2):
queueing@01:00:00
Jun 22 11:10:43 localhost sendmail[2664]: NOQUEUE: connect from
localhost.localdomain [127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: AUTH: available mech=CRAM-MD5
PLAIN ANONYMOUS DIGEST-MD5 LOGIN, allowed mech=EXTERNAL GSSAPI
KERBEROS_V4 DIGEST-MD5 CRAM-MD5
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: Milter: no
active filter
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 220
localhost.localdomain ESMTP Sendmail 8.14.2/8.14.2; Sun, 22 Jun 2008
11:10:43 -0700
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- EHLO
[127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-localhost.localdomain Hello localhost.localdomain [127.0.0.1],
pleased to meet you
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-ENHANCEDSTATUSCODES

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-PIPELINING
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-8BITMIME
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-SIZE
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DSN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-ETRN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-AUTH
DIGEST-MD5 CRAM-MD5

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DELIVERBY
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250 HELP
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- MAIL
FROM:<linux@www.knutejohnson.com> SIZE=427
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 050
<linux@www.knutejohnson.com>... Transient parse error -- message queued
for future delivery
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451 4.1.8
Domain of sender address linux@www.knutejohnson.com does not resolve
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664:
ruleset=check_mail, arg1=<linux@www.knutejohnson.com>,
relay=localhost.localdomain [127.0.0.1], reject=451 4.1.8 Domain of
sender address linux@www.knutejohnson.com does not resolve

Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: <-- QUIT
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: --- 221 2.0.0
localhost.localdomain closing connection
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664:
from=<linux@www.knutejohnson.com>, size=427, class=0, nrcpts=0,
proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]

----
is sendmail set to start on boot?

Yes. That's why I included the log that shows the start of sendmail.


chkconfig --list sendmail # to review which runlevels it starts on
chkconfig sendmail on # to have it start on boot

The log above shows it is running but;

[root@knute knute]# /sbin/chkconfig --list | grep sendmail
sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off


it does appear that you've got a DNS issue too...'sender address of
www.knutejohnson.com does not resolve' is a problem as I see it.
When the computer first starts. After I restart sendmail it doesn't
have a problem any more. This mail was sent from one of the computers
with the problem.

----
I would think that sendmail starts after named starts but perhaps not.

Try setting a manual entry for www.knutejohnson.com in /etc/hosts

Craig



That didn't fix it. The mail got queued though which is another problem
that occurs sometimes along with this. As soon as I restart sendmail
these queued mails are sent immediately.


[root@knute knute]# mailq
/var/spool/mqueue (2 requests)
-----Q-ID----- --Size-- -----Q-Time-----
------------Sender/Recipient-----------

m5MItEsf002625 52 Sun Jun 22 11:55 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
m5MIrQFK002822 52 Sun Jun 22 11:53 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
Total requests: 2

--
Knute Johnson
linux@www.knutejohnson.com

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Knute Johnson 06-22-2008 06:57 PM

F9 - sendmail won't send on startup?
 
Craig White wrote:

On Sun, 2008-06-22 at 11:32 -0700, Knute Johnson wrote:

Craig White wrote:

On Sun, 2008-06-22 at 11:17 -0700, Knute Johnson wrote:
I've got two installations of F9 running, one x86_64 and the other i386.
They both fail to send email initially but if I restart sendmail they
send fine after that. I'm using thunderbird and have it configured to
use the local sendmail for sending. The only thing I've modified in my
sendmail.mc file is the masquerading. Any ideas where to start looking?


Thanks,

knute...

Jun 22 11:09:54 localhost sendmail[2107]: alias database /etc/aliases
rebuilt by root
Jun 22 11:09:54 localhost sendmail[2107]: /etc/aliases: 77 aliases,
longest 10 bytes, 774 bytes total
Jun 22 11:09:54 localhost sendmail[2112]: starting daemon (8.14.2):
SMTP+queueing@01:00:00

Jun 22 11:09:54 localhost sendmail[2112]: STARTTLS: ServerCertFile missing
Jun 22 11:09:54 localhost sendmail[2112]: started as: /usr/sbin/sendmail
-bd -q1h
Jun 22 11:09:54 localhost sm-msp-queue[2121]: starting daemon (8.14.2):
queueing@01:00:00
Jun 22 11:10:43 localhost sendmail[2664]: NOQUEUE: connect from
localhost.localdomain [127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: AUTH: available mech=CRAM-MD5
PLAIN ANONYMOUS DIGEST-MD5 LOGIN, allowed mech=EXTERNAL GSSAPI
KERBEROS_V4 DIGEST-MD5 CRAM-MD5
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: Milter: no
active filter
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 220
localhost.localdomain ESMTP Sendmail 8.14.2/8.14.2; Sun, 22 Jun 2008
11:10:43 -0700
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- EHLO
[127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-localhost.localdomain Hello localhost.localdomain [127.0.0.1],
pleased to meet you
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-ENHANCEDSTATUSCODES

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-PIPELINING
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-8BITMIME
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-SIZE
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DSN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-ETRN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-AUTH
DIGEST-MD5 CRAM-MD5

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DELIVERBY
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250 HELP
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- MAIL
FROM:<linux@www.knutejohnson.com> SIZE=427
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 050
<linux@www.knutejohnson.com>... Transient parse error -- message queued
for future delivery
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451 4.1.8
Domain of sender address linux@www.knutejohnson.com does not resolve
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664:
ruleset=check_mail, arg1=<linux@www.knutejohnson.com>,
relay=localhost.localdomain [127.0.0.1], reject=451 4.1.8 Domain of
sender address linux@www.knutejohnson.com does not resolve

Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: <-- QUIT
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: --- 221 2.0.0
localhost.localdomain closing connection
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664:
from=<linux@www.knutejohnson.com>, size=427, class=0, nrcpts=0,
proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]

----
is sendmail set to start on boot?

Yes. That's why I included the log that shows the start of sendmail.


chkconfig --list sendmail # to review which runlevels it starts on
chkconfig sendmail on # to have it start on boot

The log above shows it is running but;

[root@knute knute]# /sbin/chkconfig --list | grep sendmail
sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off


it does appear that you've got a DNS issue too...'sender address of
www.knutejohnson.com does not resolve' is a problem as I see it.
When the computer first starts. After I restart sendmail it doesn't
have a problem any more. This mail was sent from one of the computers
with the problem.

----
I would think that sendmail starts after named starts but perhaps not.

Try setting a manual entry for www.knutejohnson.com in /etc/hosts

Craig



That didn't fix it. The mail got queued though which is another problem
that occurs sometimes along with this. As soon as I restart sendmail
these queued mails are sent immediately.


[root@knute knute]# mailq
/var/spool/mqueue (2 requests)
-----Q-ID----- --Size-- -----Q-Time-----
------------Sender/Recipient-----------

m5MItEsf002625 52 Sun Jun 22 11:55 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
m5MIrQFK002822 52 Sun Jun 22 11:53 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
Total requests: 2

--
Knute Johnson
linux@www.knutejohnson.com

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Knute Johnson 06-22-2008 07:02 PM

F9 - sendmail won't send on startup?
 
Knute Johnson wrote:

Craig White wrote:

On Sun, 2008-06-22 at 11:32 -0700, Knute Johnson wrote:

Craig White wrote:

On Sun, 2008-06-22 at 11:17 -0700, Knute Johnson wrote:
I've got two installations of F9 running, one x86_64 and the other
i386. They both fail to send email initially but if I restart
sendmail they send fine after that. I'm using thunderbird and have
it configured to use the local sendmail for sending. The only
thing I've modified in my sendmail.mc file is the masquerading.
Any ideas where to start looking?


Thanks,

knute...

Jun 22 11:09:54 localhost sendmail[2107]: alias database
/etc/aliases rebuilt by root
Jun 22 11:09:54 localhost sendmail[2107]: /etc/aliases: 77 aliases,
longest 10 bytes, 774 bytes total
Jun 22 11:09:54 localhost sendmail[2112]: starting daemon (8.14.2):
SMTP+queueing@01:00:00
Jun 22 11:09:54 localhost sendmail[2112]: STARTTLS: ServerCertFile
missing
Jun 22 11:09:54 localhost sendmail[2112]: started as:
/usr/sbin/sendmail -bd -q1h
Jun 22 11:09:54 localhost sm-msp-queue[2121]: starting daemon
(8.14.2): queueing@01:00:00
Jun 22 11:10:43 localhost sendmail[2664]: NOQUEUE: connect from
localhost.localdomain [127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: AUTH: available
mech=CRAM-MD5 PLAIN ANONYMOUS DIGEST-MD5 LOGIN, allowed
mech=EXTERNAL GSSAPI KERBEROS_V4 DIGEST-MD5 CRAM-MD5
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: Milter:
no active filter
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 220
localhost.localdomain ESMTP Sendmail 8.14.2/8.14.2; Sun, 22 Jun
2008 11:10:43 -0700
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- EHLO
[127.0.0.1]
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-localhost.localdomain Hello localhost.localdomain [127.0.0.1],
pleased to meet you
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-ENHANCEDSTATUSCODES
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-PIPELINING
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-8BITMIME

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-SIZE
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-DSN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250-ETRN
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-AUTH DIGEST-MD5 CRAM-MD5
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: ---
250-DELIVERBY

Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 250 HELP
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: <-- MAIL
FROM:<linux@www.knutejohnson.com> SIZE=427
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 050
<linux@www.knutejohnson.com>... Transient parse error -- message
queued for future delivery
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
www.knutejohnson.com: Name server timeout
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664: --- 451
4.1.8 Domain of sender address linux@www.knutejohnson.com does not
resolve
Jun 22 11:10:43 localhost sendmail[2664]: m5MIAhEW002664:
ruleset=check_mail, arg1=<linux@www.knutejohnson.com>,
relay=localhost.localdomain [127.0.0.1], reject=451 4.1.8 Domain of
sender address linux@www.knutejohnson.com does not resolve

Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: <-- QUIT
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664: --- 221
2.0.0 localhost.localdomain closing connection
Jun 22 11:10:56 localhost sendmail[2664]: m5MIAhEW002664:
from=<linux@www.knutejohnson.com>, size=427, class=0, nrcpts=0,
proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]

----
is sendmail set to start on boot?

Yes. That's why I included the log that shows the start of sendmail.


chkconfig --list sendmail # to review which runlevels it starts on
chkconfig sendmail on # to have it start on boot

The log above shows it is running but;

[root@knute knute]# /sbin/chkconfig --list | grep sendmail
sendmail 0:off 1:off 2:on 3:on 4:on 5:on
6:off



it does appear that you've got a DNS issue too...'sender address of
www.knutejohnson.com does not resolve' is a problem as I see it.
When the computer first starts. After I restart sendmail it doesn't
have a problem any more. This mail was sent from one of the
computers with the problem.

----
I would think that sendmail starts after named starts but perhaps not.

Try setting a manual entry for www.knutejohnson.com in /etc/hosts

Craig



That didn't fix it. The mail got queued though which is another problem
that occurs sometimes along with this. As soon as I restart sendmail
these queued mails are sent immediately.


[root@knute knute]# mailq
/var/spool/mqueue (2 requests)
-----Q-ID----- --Size-- -----Q-Time-----
------------Sender/Recipient-----------

m5MItEsf002625 52 Sun Jun 22 11:55 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
m5MIrQFK002822 52 Sun Jun 22 11:53 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
Total requests: 2



These extra emails are problems with the mailq (I think).

--
Knute Johnson
linux@www.knutejohnson.com

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Craig White 06-22-2008 07:08 PM

F9 - sendmail won't send on startup?
 
On Sun, 2008-06-22 at 12:02 -0700, Knute Johnson wrote:
> Knute Johnson wrote:
> >
> > That didn't fix it. The mail got queued though which is another problem
> > that occurs sometimes along with this. As soon as I restart sendmail
> > these queued mails are sent immediately.
> >
> > [root@knute knute]# mailq
> > /var/spool/mqueue (2 requests)
> > -----Q-ID----- --Size-- -----Q-Time-----
> > ------------Sender/Recipient-----------
> > m5MItEsf002625 52 Sun Jun 22 11:55 <linux@www.knutejohnson.com>
> > (Deferred: Name server: www.knutejohnson.com.: host
> > name look)
> > <linux@www.knutejohnson.com>
> > m5MIrQFK002822 52 Sun Jun 22 11:53 <linux@www.knutejohnson.com>
> > (Deferred: Name server: www.knutejohnson.com.: host
> > name look)
> > <linux@www.knutejohnson.com>
> > Total requests: 2
> >
>
> These extra emails are problems with the mailq (I think).
----
I'm out...I abandoned sendmail for postfix years ago. A suggestion
though...set up a server on your lan to handle relaying all outbound
mail and use an smtp connection to that server instead of relying upon
the local /usr/bin/sendmail binary. That pretty much solves the issue of
configuring each workstation to handle mail deliveries.

Craig

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

Knute Johnson 06-22-2008 07:17 PM

F9 - sendmail won't send on startup?
 
Craig White wrote:

On Sun, 2008-06-22 at 12:02 -0700, Knute Johnson wrote:

Knute Johnson wrote:
That didn't fix it. The mail got queued though which is another problem
that occurs sometimes along with this. As soon as I restart sendmail
these queued mails are sent immediately.


[root@knute knute]# mailq
/var/spool/mqueue (2 requests)
-----Q-ID----- --Size-- -----Q-Time-----
------------Sender/Recipient-----------

m5MItEsf002625 52 Sun Jun 22 11:55 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
m5MIrQFK002822 52 Sun Jun 22 11:53 <linux@www.knutejohnson.com>
(Deferred: Name server: www.knutejohnson.com.: host
name look)

<linux@www.knutejohnson.com>
Total requests: 2


These extra emails are problems with the mailq (I think).

----
I'm out...I abandoned sendmail for postfix years ago. A suggestion
though...set up a server on your lan to handle relaying all outbound
mail and use an smtp connection to that server instead of relying upon
the local /usr/bin/sendmail binary. That pretty much solves the issue of
configuring each workstation to handle mail deliveries.

Craig



There are a million ways around the problem, but I'd really just like to
fix it.


Thanks for trying though.

--
Knute Johnson
linux@www.knutejohnson.com

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


All times are GMT. The time now is 02:32 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.