Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Fedora User (http://www.linux-archive.org/fedora-user/)
-   -   {Disarmed} problems w/ net (http) install (http://www.linux-archive.org/fedora-user/110641-disarmed-problems-w-net-http-install.html)

Craig White 06-20-2008 09:58 PM

{Disarmed} problems w/ net (http) install
 
I believe that using NFS, you would want to serve out the ISO and not
the individual files...I remember someone cluing me in on that a while
back.

It is beginning to sound like you have a problem with one or more of
your routers.

Anyway, there are a number of packages that provide a lot of utility for
Linux servers that aren't available for OS X server such as 'cobbler and
mrepo'

I heavily recommend mrepo (Dag package) that allows me to create a local
mirror for any repos that I want, uses the ISO to create the 'base' and
can also mirror the updates and also provides tftp package for
installation and http server base for installation. With mrepo, every
install I do is a kickstart.

Craig

On Fri, 2008-06-20 at 17:36 -0400, Matt Nicholson wrote:
> Craig,
>
> For your 4 points:
>
> NFS isn't strictly off the table, but the system hosting this install
> tree will need to be accessible from alot of system across a large
> number of subnets/VLAN's. I would rather have port 80 open to these
> nets/the world than NFS, but then again I can just make it an "ro"
> export. Something to try next week.
>
> I'm not mounting the iso's, but rather have full fledged, rsync'd
> copies of the install tree, local on disk.
>
> No energy saving on the Xserve. It doesn't powerdown/spin down at all,
> ever.
>
> The Xserve is running Leopard Server, MailScanner warning: numerical
> links are often malicious: 10.5.3. Unfortunatly, no erros in the logs.
> Everything looks normal.
>
> And Rick,
>
> Nope the packages aren't big ones, fairly standard, 1MB-ish packages,
> although the packages do change. The keep alive is set at 300 seconds,
> which = 5 minutes. The thing is, this is all happening while anaconda
> is preparing to install (ie, not when its acctually downloading and
> installing the rpms, the set jsut before that starts). It zips right
> though until it hits one of these files. If it wasn't interupted, the
> whole thing could finish in maybe 1 minute, if not less, so I don't
> think timeouts are an issue. I've even up'd the number of conenction
> Apache allows, and the nubmer of servers it spawns, jsut incase
> anaconda was hammering it with too many requests.
>
> Matt
>
> On Fri, Jun 20, 2008 at 4:36 PM, Craig White <craigwhite@azapple.com>
> wrote:
>
> I. On Fri, 2008-06-20 at 15:45 -0400, Matt Nicholson
> wrote:
> > Greetings everyone,
> >
> > So, I'm trying to setup a local server for some net-installs
> I hope to
> > do with a kickstart file. I am, however, running into an
> issue.
> >
> > I have a copy of the fedora 9 install media on the web
> server that the
> > install will be pulled from, and everything is in tip top
> shape. This
> > server is actually a fairly new Xserve, and I am using it
> simply
> > because it is available, has to disk-space and bandwidth,
> and is a
> > pretty fast system for multiple systems to kickstart aganst.
> I would
> > rather be doing this off a Fedora/RHEL server, but, this is
> what I
> > have for the time being.
> >
> > Anyways, I've rsync'd the install media to the server, and
> its
> > accessible, however, durring the install, I always get a
> file or two
> > (sometimes different, sometimes the same), that anaconda
> spits back at
> > me, saying it could not find/read the file, make sure its
> not
> > currupted, etc etc etc. I can reboot, or retry, and retry
> always
> > works, that is, until it hit the next file ti doesn't like.
> I get
> > about 3-4 of these per install, EVERY TIME. I've checked,
> the files
> > are there, they are the right size, I've even done an MD% of
> them and
> > they match their sources. I even re-rsync'd the whole thing
> a few
> > times.If this is a one time deal, I wouldn't mind, but I
> need to be
> > able to basically start an install (via kickstart) and walk
> away.
> >
> > Now, normally, I would just say forget it, and do it over
> FTP, but FTP
> > on this Xserver is very, very slow, and my installs, while
> succeeding
> > without error, are about 10 times longer with the same
> package set.
> > Also the network alyout means NFS is off the table as well.
> >
> > Any ideas? I would love any insight.
>
> ----
> I'd be curious about why the network layout means that NFS is
> off the
> table but HTTP is on the table.
>
> Anyway, are you 'loop' mounting the ISO files? Is there
> something that
> delays reading the files?
>
> Is Energy saving allowing the hard drive to spin down on the
> XServer?
> (Mac's sometimes default to sleep modes with hard drive spin
> down which
> would be a mistake for a server).
>
> What OS is on the X-Serve? Are there errors in the web server
> logs on
> the X-Serve?
>
> Craig
>
>
> --
> fedora-list mailing list
> fedora-list@redhat.com
> To unsubscribe:
> https://www.redhat.com/mailman/listinfo/fedora-list
>
>
> --
> fedora-list mailing list
> fedora-list@redhat.com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list


All times are GMT. The time now is 12:42 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.