FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Redhat > Fedora User

 
 
LinkBack Thread Tools
 
Old 12-03-2007, 06:56 AM
Jörn Rink
 
Default Problems with grub since Fedora 8

Hi,
since updating from 7 to 8, grub does not recognize my first two
partitions.

I have a T43 with onde HD and 6 Partitions, the first 2 are 2 seperated
XP Partitions:

title 1
hide (hd0,0)
unhide (hd0,1)
parttype (hd0,0) 0x83
parttype (hd0,1) 0x07
rootnoverify (hd0,1)
makeactive
chainloader +1

title 2
hide (hd0,1)
unhide (hd0,0)
parttype (hd0,0) 0x07
parttype (hd0,1) 0x83
rootnoverify (hd0,0)
makeactive
chainloader +1

The hide and parttype trick hinders the booted XP to see the other XP.

Since Fedora 8 i become error 22 8unknown partition. When i set the
parttype correct, i was able to boot the xp while deleting the first 4
lines in grub.conf.

Has the syntax in grub changed?

CU
Jörn Rink

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 
Old 12-05-2007, 05:21 AM
Jörn Rink
 
Default Problems with grub since Fedora 8

Am Mon, 3 Dec 2007 08:56:23 +0100
hat Jörn Rink <j.rink@freenet.de> (Jörn Rink) folgendes geschrieben:

> Hi,
> since updating from 7 to 8, grub does not recognize my first two
> partitions.
>
> I have a T43 with onde HD and 6 Partitions, the first 2 are 2
> seperated XP Partitions:
>
> title 1
> hide (hd0,0)
> unhide (hd0,1)
> parttype (hd0,0) 0x83
> parttype (hd0,1) 0x07
> rootnoverify (hd0,1)
> makeactive
> chainloader +1
>
> title 2
> hide (hd0,1)
> unhide (hd0,0)
> parttype (hd0,0) 0x07
> parttype (hd0,1) 0x83
> rootnoverify (hd0,0)
> makeactive
> chainloader +1
>
> The hide and parttype trick hinders the booted XP to see the other XP.
>
> Since Fedora 8 i become error 22 8unknown partition. When i set the
> parttype correct, i was able to boot the xp while deleting the first 4
> lines in grub.conf.
>
> Has the syntax in grub changed?

I reinstall grub from fedora 7, make a grub-install and all run
perfectly now.
googling around shows, that i am not the only one who has problems with
the hide (hd0,0) syntax.

So it seems to me, that the fedora 8 grub has a bug or a new feature ;-)

CU
Nine

--
Nine (not 9)
Never trust a hippie

--
fedora-list mailing list
fedora-list@redhat.com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
 

Thread Tools




All times are GMT. The time now is 09:48 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org